




<!-- hearst/article/article_main.tpl -->

            <!-- hearst/article/articleMain.tpl -->



    
        <!doctype html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#  article: http://ogp.me/ns/article#">
    <!-- hearst/article/headerMain.tpl -->
<head>
    <!-- eid:article.16193168 -->
    <!-- generated at 2021-05-21 03:39:56 on pwcm4 running vv11.7.7 -->
            <!-- hmb:jquery jQuery JS -->
        <script type="text/javascript" src="/js/core/libs/jquery-2.2.4.min.js"></script>
                <!-- hmb:treg TREG JS -->
        <script type="text/javascript" src="//treg.hearstnp.com/treg.js"></script>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
            <!-- hmb:taboola Sailthru  -->
        <!-- hearst/home/header_sailthru.tpl -->
<meta property="sailthru.title" content="NY Forecast" /><meta name="sailthru.date" content="2021-05-21 4:34:00 -0400" /><meta name="sailthru.author" content="" /><meta name="sailthru_uid" content="16193168" /><meta name="sailthru_pubname" content="associated-press" /><meta name="sailthru_siteid" content="79" /><meta name="sailthru.tags" content="jfk,massena,shirley,new-york,north-america-watertown,united-states,new-york-city,glens-falls,rome,rochester,saranac-lake,ithaca,jamestown,islip,binghamton,dunkirk,central-park,uv-index-albany,dansville,east-hampton,farmingdale,elmira,fort-drum,niagara-falls,newburgh,poughkeepsie,ogdensburg,plattsburgh,monticello,montgomery,montauk,syracuse,wellsville,white-plains,westhampton-beach,wsw,ap,mc-complete-state-national,sun,buffalo,lga,penn,ssw,accuweather,wnw,clouds,wind-speed,ny-forecast,precip,wsw,ap,mc-complete-state-national,sun,buffalo,lga,penn,ssw,accuweather,jfk,massena,shirley,new-york,north-america-watertown,united-states,new-york-city,glens-falls,rome,rochester,saranac-lake,ithaca,jamestown,islip,binghamton,dunkirk,central-park,uv-index-albany,dansville,east-hampton,farmingdale,elmira,fort-drum,niagara-falls,newburgh,poughkeepsie,ogdensburg,plattsburgh,monticello,montgomery,montauk,syracuse,wellsville,white-plains,westhampton-beach,wnw,clouds,wind-speed,ny-forecast,precip,2fnews-2fweather" /><meta name="sailthru.image.thumb" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg" />
<!-- e hearst/home/header_sailthru.tpl -->
    
            <title>NY Forecast</title>

        <script>
          if ( document.location.hostname.match(/\.$/) ) {
              document.location.replace(
                  document.location.protocol +
                  '//' +
                  document.location.hostname.replace(/\.+$/, '') +
                  ( undefined !== document.location.pathname ? document.location.pathname : '' ) +
                  ( undefined !== document.location.search ? document.location.search : '' )  +
                  ( undefined !== document.location.hash ? document.location.hash : '' )
              );
          }
        </script>

    <script>
                var HDN = HDN || {};
        HDN.t_firstbyte = Number(new Date());
        HDN.dataLayer = HDN.dataLayer || {};
        HDN.dataLayer.content = HDN.dataLayer.content || {};
                HDN.dataLayer.paywall = HDN.dataLayer.paywall || {};
        HDN.dataLayer.paywall.accessRule = "";
        HDN.dataLayer.paywall.mode = "";
        var Article = {
            "id": "16193168",
            "title": "NY Forecast",
            "url": "https://www.milfordmirror.com/weather/article/NY-Forecast-16193168.php",
            "slug": "https://www.milfordmirror.com/weather/article/NY-Forecast-16193168.php",
            "summary": "NY Forecast for Sunday, May 23, 2021",
            "image": "https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg",
            "keywords": "",
            "siteName": "Milford Mirror",
            "env": "pwcm4",
            "comments": true,
            "isSensitive": false,
            'version': "v11.7.7",
            "renderNLP": true,
            "timing": {
                "firstbyte": HDN.t_firstbyte,
                "ready": {}
            }
        };
        
        document.addEventListener('DOMContentLoaded', function () {
            Article.timing.ready = Number(new Date());
        }, false);
        
    </script>
        
    <!-- hearst/common/hdn_datalayer_header.tpl -->
<script type="text/javascript">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</script>
<!-- e hearst/common/hdn_datalayer_header.tpl -->
    <script type="text/javascript" src="/js/site.js?v11.7.7"></script>
            
            <!-- Hotfix Top Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.94216 -->
<!-- DO NOT REMOVE -->
<script src="https://projects.sfchronicle.com/shared/js/responsive-frame.js"></script>
<!-- e DO NOT REMOVE -->

<!-- ENG-6410 -->
<style>
    @media only screen and (max-width: 767px) {
        main.article { grid-template-columns: minmax(0, 1fr); }
    }
    .leaderboard--outer,
    .pageHeader  .adhesive--outer,
    main.contentChannel {
        overflow-x: hidden;
    }
    @media (min-width: 768px) {
        .leaderboard--outer,
        .pageHeader  .adhesive--outer,
        main.contentChannel {
            overflow-x: visible;
        }
    }
</style>
<!-- e ENG-6410 -->
<script>
    var HDN = HDN || {};
        HDN.dataLayer = HDN.dataLayer || {};
        HDN.dataLayer.content = HDN.dataLayer.content || {};
        HDN.dataLayer.ads = HDN.dataLayer.ads || {}
</script>
<style>
/* ENG-7164 */
@media (min-width: 928px) {
    .centerpiece .centerpiece-tab-primary:not(.density) .centerpiece-tab--main .badge {
        display: inline-block;
    }
    .centerpiece .centerpiece-non-tab + .centerpiece-tab-primary:not(.density) .centerpiece-tab--main .badge {
        display: inline-block;
    }
    .centerpiece .centerpiece-tab-primary:not(.density):not(.bigImage)>div:first-child .centerpiece-tab--main .badge::before {
        margin: 0;
    }
    .centerpiece .centerpiece-non-tab + .centerpiece-tab-primary:not(.density)>div:first-child .centerpiece-tab--main .badge::before {
        margin: auto;
    }
}
</style>
<!-- ENG-7192 -->
<script type="text/javascript">
(function () {
  if (navigator.userAgent.match(/Mac/) && navigator.maxTouchPoints && navigator.maxTouchPoints > 2) {
    function enableArrowsForTaboola() {
		const se = document.createElement('style');
		se.innerHTML = '.gallery--slider.force-nav .nav { display: block; }.gallery--slider.force-nav.end .nav.next { display: none; }';
  
		document.head.append(se);
  
		const callback = function(mutationsList, observer) {
		    for(const mutation of mutationsList) {
		        if (mutation.type === 'attributes' && mutation.attributeName == 'style' && mutation.target.style.visibility !== mutation.target.dataset.tbState) {
		            var parent = mutation.target.parentElement;
		            if (mutation.target.style.visibility == 'visible') {
						parent.classList.add('force-nav');
		            } else {
						parent.classList.remove('force-nav');
		            }
		            mutation.target.dataset.tbState = mutation.target.style.visibility;
		        }
		    }
		};
  
		const observer = new MutationObserver(callback);

  		let = tbSlides = Array.from(document.querySelectorAll('[data-slide-id^="taboola"]'));
		tbSlides.forEach(function (t) {
		    t.dataset.tbState = t.style.visibility
		    observer.observe(t, {attributes: true});
		});
	}
    if (document.readyState === "complete" || document.readyState === "interactive") {
        setTimeout(enableArrowsForTaboola, 1);
    } else {
        document.addEventListener("DOMContentLoaded", enableArrowsForTaboola);
    }
  }
}());
</script>
<!-- e ENG-7192 -->
        <!-- Hotfix Top Freeform (Local Dynamic Two-Column) -->
        
<!-- noGen: item_header_hotfix_top_dtc_ssl 79 dne  -->
        <link rel="stylesheet" href="/css/article.main.css?v11.7.7">
                        <!-- hmb:Polyfill  -->
        <script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=IntersectionObserver%2CIntersectionObserverEntry%2CPromise%2CCustomEvent%2CArray.prototype.forEach%2CArray.prototype.entries"></script>
                <!-- hmb:js_header Static JS Bundle  -->
        <script type="text/javascript" src="/js/article.main.js?v11.7.7"></script>
        <!-- hearst/article/common/meta_tags.tpl -->
<meta name="msvalidate.01" content="9451CA04ABC9D1D5C6419C73B4C4F7B7" />
<meta name="HandheldFriendly" content="true">
<meta name="twitter:dnt" content="on">
<meta name="apple-mobile-web-app-title" content="">
<meta name="environment" content="pwcm4">
<meta name="id" content="16193168">
<link rel="canonical" href="https://www.milfordmirror.com/weather/article/NY-Forecast-16193168.php" />
    <link rel="amphtml" href="https://www.milfordmirror.com/weather/amp/NY-Forecast-16193168.php" />
                                        <meta name="author" content="">
        <meta name="author.name" content="" />
        <meta name="author.title" content="" />
        <meta name="description" content="NY Forecast for Sunday, May 23, 2021"/>
    <meta name="date.release" content="2021-05-21 08:34:18" />
    <meta name="time.release" content="2021-05-21 08:34:18" />
    <meta name="sections" content="Weather" />
            <meta name="subject" content="Jfk, Massena, Shirley, New York, North America Watertown, United States, New York City, Glens Falls, Rome, Rochester, Saranac Lake, Ithaca, Jamestown, Islip, Binghamton, Dunkirk, Central Park, UV Index Albany, Dansville, East Hampton, Farmingdale, Elmira, Fort Drum, Niagara Falls, Newburgh, Poughkeepsie, Ogdensburg, Plattsburgh, Monticello, Montgomery, Montauk, Syracuse, Wellsville, White Plains, Westhampton Beach, WSW, AP, MC Complete - State & National, Sun, Buffalo, Lga, Penn, SSW, AccuWeather, WNW, Clouds, Wind Speed, NY Forecast, Precip" />
        <meta name="news_keywords" content="Jfk, Massena, Shirley, New York, North America Watertown, United States, New York City, Glens Falls, Rome, Rochester, Saranac Lake, Ithaca, Jamestown, Islip, Binghamton, Dunkirk, Central Park, UV Index Albany, Dansville, East Hampton, Farmingdale, Elmira, Fort Drum, Niagara Falls, Newburgh, Poughkeepsie, Ogdensburg, Plattsburgh, Monticello, Montgomery, Montauk, Syracuse, Wellsville, White Plains, Westhampton Beach, WSW, AP, MC Complete - State & National, Sun, Buffalo, Lga, Penn, SSW, AccuWeather, WNW, Clouds, Wind Speed, NY Forecast, Precip" />
                <meta name="nlpOrganization" content="WSW, AP, MC Complete - State & National, Sun, Sun, Buffalo, Lga, Penn, SSW, AccuWeather" />
                <meta name="nlpPerson" content="Jfk, Massena, Shirley" />
                <meta name="nlpLocation" content="New York, North America Watertown, United States, New York City, Glens Falls, Rome, Rochester, Saranac Lake, Ithaca, Jamestown, Islip, Binghamton, Dunkirk, Central Park, UV Index Albany, Dansville, East Hampton, Farmingdale, Elmira, Fort Drum, Niagara Falls, Newburgh, Poughkeepsie, Ogdensburg, Plattsburgh, Monticello, Montgomery, Montauk, Syracuse, Wellsville, White Plains, Westhampton Beach" />
                            <meta name="nlpOther" content="WNW, Clouds, Wind Speed, NY Forecast, Precip" />
                            <meta name="nlpCategories" content="%2FNews%2FWeather" />
    <!-- e hearst/article/common/meta_tags.tpl -->    <!-- hearst/article/common/opengraph.tpl -->
<meta property="fb:admins" content="100006394927810"/><meta property="fb:app_id" content="322056085100167"/><meta property="fb:pages" content="105702905593" /><meta property="fb:pages" content="307851324523" /><meta property="fb:pages" content="12852567813" /><meta property="fb:pages" content="480760515417232" /><meta property="fb:pages" content="288240529145" /><meta property="fb:pages" content="316774245761" /><meta property="fb:pages" content="984197758297116" /><meta property="fb:pages" content="7457442370" /><meta property="fb:pages" content="207033189701" /><meta property="fb:pages" content="207346283795" /><meta property="fb:pages" content="222959748728" /><meta property="fb:pages" content="207042068180" /><meta property="fb:pages" content="72983690774" /><meta property="fb:pages" content="339413234035" /><meta property="fb:pages" content="343689323559" /><meta property="fb:pages" content="345828366626" /><meta property="fb:pages" content="234821559861394" /><meta property="fb:pages" content="335699426867" /><meta property="fb:pages" content="10150105039485602" /><meta property="fb:pages" content="338983127562" /><meta property="fb:pages" content="364516539001" /><meta property="fb:pages" content="337922332042" /><meta property="fb:pages" content="115637335153191" /><meta property="fb:pages" content="372011535931" /><meta property="fb:pages" content="333376634908" /><meta property="fb:pages" content="127590790608884" /><meta property="fb:pages" content="141923885872653" /><meta property="fb:pages" content="655037391286291" /><meta property="fb:pages" content="320774811368833" /><meta property="fb:pages" content="1740489152861748" /><meta property="fb:pages" content="469700473093040" /><meta property="fb:pages" content="386754203367" /><meta property="fb:pages" content="556449374478585" /><meta property="fb:pages" content="340999853450" /><meta property="fb:pages" content="350771491032" /><meta property="fb:pages" content="1120648627959218" /><meta property="fb:pages" content="342017778245" /><meta property="fb:pages" content="338463361591" /><meta property="fb:pages" content="138772706196968" /><meta property="fb:pages" content="1641688532739111" /><meta property="fb:pages" content="326312697536" /><meta property="fb:pages" content="353120110016" /><meta property="fb:pages" content="343366744658" /><meta property="fb:pages" content="335009494554" /><meta property="fb:pages" content="347261603104" /><meta property="fb:pages" content="350924013892" /><meta property="fb:pages" content="257724773860" /><meta property="fb:pages" content="361203926417" /><meta property="fb:pages" content="367174215398" /><meta property="fb:pages" content="284154645394" /><meta property="fb:pages" content="334501182354" /><meta property="fb:pages" content="350279743224" /><meta property="fb:pages" content="154340691263654" /><meta property="fb:pages" content="147848678611852" /><meta property="fb:pages" content="361381078011" /><meta property="fb:pages" content="362831597677" /><meta property="fb:pages" content="10150095255780118" /><meta name="og:datePublished" content="2021-05-21 08:30:32"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="NY Forecast"/><meta property="og:description" content="NY Forecast for Sunday, May 23, 2021"/><meta property="og:url" content="https://www.milfordmirror.com/weather/article/NY-Forecast-16193168.php"/><meta property="og:site_name" content="Milford Mirror"/><meta property="og:image" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg"/><meta property="article:published_time" content="2021-05-21 08:30:32" /><meta property="article:modified_time" content="2021-05-21 08:34:19" /><meta property="article:author" content=""/><meta property="article:section" content="Weather" /><meta property="article:tag" content="Jfk" /><meta property="article:tag" content="Massena" /><meta property="article:tag" content="Shirley" /><meta property="article:tag" content="New York" /><meta property="article:tag" content="North America Watertown" /><meta property="article:tag" content="United States" /><meta property="article:tag" content="New York City" /><meta property="article:tag" content="Glens Falls" /><meta property="article:tag" content="Rome" /><meta property="article:tag" content="Rochester" /><meta property="article:tag" content="Saranac Lake" /><meta property="article:tag" content="Ithaca" /><meta property="article:tag" content="Jamestown" /><meta property="article:tag" content="Islip" /><meta property="article:tag" content="Binghamton" /><meta property="article:tag" content="Dunkirk" /><meta property="article:tag" content="Central Park" /><meta property="article:tag" content="UV Index Albany" /><meta property="article:tag" content="Dansville" /><meta property="article:tag" content="East Hampton" /><meta property="article:tag" content="Farmingdale" /><meta property="article:tag" content="Elmira" /><meta property="article:tag" content="Fort Drum" /><meta property="article:tag" content="Niagara Falls" /><meta property="article:tag" content="Newburgh" /><meta property="article:tag" content="Poughkeepsie" /><meta property="article:tag" content="Ogdensburg" /><meta property="article:tag" content="Plattsburgh" /><meta property="article:tag" content="Monticello" /><meta property="article:tag" content="Montgomery" /><meta property="article:tag" content="Montauk" /><meta property="article:tag" content="Syracuse" /><meta property="article:tag" content="Wellsville" /><meta property="article:tag" content="White Plains" /><meta property="article:tag" content="Westhampton Beach" /><meta property="article:tag" content="WSW" /><meta property="article:tag" content="AP" /><meta property="article:tag" content="MC Complete - State &amp; National" /><meta property="article:tag" content="Sun" /><meta property="article:tag" content="Buffalo" /><meta property="article:tag" content="Lga" /><meta property="article:tag" content="Penn" /><meta property="article:tag" content="SSW" /><meta property="article:tag" content="AccuWeather" /><meta property="article:tag" content="WNW" /><meta property="article:tag" content="Clouds" /><meta property="article:tag" content="Wind Speed" /><meta property="article:tag" content="NY Forecast" /><meta property="article:tag" content="Precip" />
<!-- e hearst/article/common/opengraph.tpl -->    <!-- hearst/article/common/twittercard.tpl -->

<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:image" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg"/>
<meta name="twitter:description" content="NY Forecast for Sunday, May 23, 2021"/>
<meta name="twitter:title" content="NY Forecast"/>
<meta name="twitter:site" content="@milfordmirror" />
<!-- e hearst/article/common/twittercard.tpl -->    <!-- hearst/article/common/analytics.tpl -->
<script>var omni_channelPath = "Weather";var omni_title = "NY Forecast";var omni_bizObjectId = "16193168";var omni_className = "article";var omni_publicationDate = "2021-05-21 08:30:32";var omni_sourceSite ="ap";var omni_authorName = "";var omni_authorTitle = "";var omni_premiumStatus = "free";var omni_premiumEndDate = "";var omni_originalSource = "AP";var omni_pageNumber = "0";var omni_breakingNewsFlag = "0";var omni_localNewsFlag = "0";var omni_isListView = "0";var omni_paywallSite = "0";var omni_displayTemplate = "dynamic_two_column";</script>
<!-- e hearst/article/common/analytics.tpl -->    <!-- hearst/article/common/schema_NewsArticle.tpl -->

<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://www.milfordmirror.com/weather/article/NY-Forecast-16193168.php"
        },
		"headline": "NY Forecast",
        "image": {
            "@type": "ImageObject",
            "url":   "https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg"
        },
        "datePublished": "2021-05-21 08:30:32",
        "dateModified": "2021-05-21 08:34:19",
        "author": [
                    {"@type": "Person",
            "name": "",
            "jobTitle": ""
            }                    ],
        "publisher": {
            "@type": "Organization",
            "name": "Associated Press",
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.MilfordMirror.com/img/ldjson_logo.png",
                "width": 600,
                "height": 60
            }
        },
        "description": "NY Forecast for Sunday, May 23, 2021"
            }
</script>
<!-- e hearst/article/common/schema_NewsArticle.tpl -->    <!-- hearst/article/common/schema_SearchAction.tpl -->

<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"url": "https://MilfordMirror.com",
		"potentialAction": {
			"@type": "SearchAction",
			"target": "https://www.milfordmirror.com/search/?action=search&sitelinks=1&searchindex=solr&query={search_term_string}",
			"query-input": "required name=search_term_string"
		}
	}
</script>
<!-- e hearst/article/common/schema_SearchAction.tpl -->    <!-- hearst/common/third_party_assets.tpl -->
                    <!-- hmb:juice Juice -->
        <script type="text/javascript" id="adPositionManagerScriptTag" src="https://aps.hearstnp.com/Scripts/loadAds.js"></script>
    
    <!-- hmb:ensighten Ensighten  -->
    <!-- hearst/ensighten/ensighten.tpl -->
<!-- hmb:ensighten Ensighten script -->
<!-- Hearst analytics: Ensighten -->
<script src="https://nexus.ensighten.com/hearst/news/Bootstrap.js"></script>
<!-- End Hearst analytics: Ensighten -->
<!-- e ensighten.tpl -->            <script src="https://cdn.blueconic.net/hearst.js"></script>
    
    <!-- hmb:taboola Taboola  -->
                            
                            
                <script type="text/javascript">
                    
                    (function () {
                        window._taboolaNetworkMode = true;
                        
                        window._taboola = window._taboola || [];
                        window._taboolaHDNPageLabel = window._taboolaHDNPageLabel || 'article';
                        var tobj = {};
                        tobj[window._taboolaHDNPageLabel] = 'auto';
                        window._taboola.push(tobj);
                        !function (e, f, u, i) {
                            if (!document.getElementById(i)){
                                e.async = 1;
                                e.src = u;
                                e.id = i;
                                f.parentNode.insertBefore(e, f);
                            }
                        }(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/hearstlocalnews-network/loader.js', 'tb_loader_script');
                        if(window.performance && typeof window.performance.mark == 'function') {
                            window.performance.mark('tbl_ic');
                        }
                    })();
                </script>
                
                                <!-- e hearst/common/third_party_assets.tpl -->
    <link rel="shortcut icon" href="/favicon.ico">
    <link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon.png">
    <link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
    <link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
    <link rel="apple-touch-icon-precomposed" sizes="128x128" href="/apple-touch-icon-128x128.png">
            <!-- Hotfix Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.93530 -->
<!-- ENG-3363 -->
<style>
  .thumbnailListAuthor.one .thumbnailListAuthor--wrapper { margin: 0; }
  @media (min-width: 768px) { .thumbnailListAuthor.two .thumbnailListAuthor--wrapper { margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--items { justify-content: space-between; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--item { flex: 0 0 48%; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--spacer { display: none; } }
  @media (min-width: 928px) { .thumbnailListAuthor.three .thumbnailListAuthor--wrapper { margin: 0; } }
</style>
<!-- ENG-3834 -->
<style>
  .alert{background-color:#000;bottom:0;box-sizing:border-box;color:#fff;font-family:Helvetica,sans-serif;font-size:16px;font-weight:600;left:50%;line-height:1.25;overflow:hidden;padding:10px;position:fixed;transform:translateX(-50%);width:100vw;z-index:5000000}.alert .close{border-radius:8px;color:#fff;display:block;position:absolute;right:10px;height:16px;overflow:hidden;top:10px;width:16px}.alert .close::after{background-color:#fff;content:'';display:block;height:2px;left:-6px;position:relative;top:4px;transform:rotate(-45deg);width:30px}.alert .close::before{background-color:#fff;content:'';display:block;height:2px;left:-5px;position:relative;top:9px;transform:rotate(45deg);width:30px}.alert>div{box-sizing:border-box;max-width:1200px;margin:0 auto;position:relative;padding-right:34px}
</style>
<script>
  document.addEventListener('DOMContentLoaded', function() {
    if (/MSIE \d|Trident.*rv:/.test(navigator.userAgent)) {var site=HDN.domain,name=site.charAt(0).toUpperCase()+site.slice(1),section=document.createElement("section"),close=document.createElement("a");close.className="close",close.href="#",close.addEventListener("click",function(e){e.stopPropagation(),e.preventDefault(),e.target.parentElement.style.display="none"});var HTML="<div>Thank you for visiting "+name+". You are using an older browser that may impact your reading experience. For the best experience, we recommend you use Chrome, Safari, Firefox, or Edge.</div>";section.className="alert",section.id="warning",section.innerHTML=HTML,section.appendChild(close),document.getElementsByTagName("body")[0].appendChild(section);}
  }, false);
</script>
<!-- e ENG-3834 -->
<!-- ENG-6817 -->
<style>
    .hide-sign-in { display: none !important; }
    .hide-right-border:after { display: none; }
</style>
<script>
document.addEventListener("DOMContentLoaded", function(event) { 
    var hostname = window.location.hostname;
    var sites = [
        "bigrapidsnews",
        "fairfieldcitizenonline",
        "lakecountystar",
        "manisteenews",
        "michigansthumb",
        "myjournalcourier",
        "myplainview",
        "newmilfordspectrum",
        "ourmidland",
        "recordpatriot",
        "theheraldreview",
        "theintelligencer",
        "thetelegraph",
        "westport-news",
        "yourconroenews",
    ];

    for(var i = 0; i < sites.length; i++) {
        if(hostname.indexOf(sites[i]) > 0) {
            if(document.getElementById("subscription")) { document.getElementById("subscription").classList.add('hide-right-border'); }
            document.getElementsByClassName("gigya_menu")[0].classList.add('hide-sign-in');
        }
    }
});
</script>
<!-- end ENG-6817 -->
<style>
/* ENG-6708 */
.factBox button {
    border: 1px solid #000;
    color: #000;
}
.factBox button:hover {
    border: 1px solid transparent;
    color: #fff;
}
.factBox button .more::after {
    background-image: url('data:image/svg+xml;charset=utf-8,%3Csvg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 9 6"%3E%3Cg stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"%3E%3Cg transform="translate(-1740.000000, -3192.000000)" fill="%23111" fill-rule="nonzero"%3E%3Cpath d="M1744.5,3195.43934 L1741.28033,3192.21967 C1740.98744,3191.92678 1740.51256,3191.92678 1740.21967,3192.21967 C1739.92678,3192.51256 1739.92678,3192.98744 1740.21967,3193.28033 L1743.96967,3197.03033 C1744.26256,3197.32322 1744.73744,3197.32322 1745.03033,3197.03033 L1748.78033,3193.28033 C1749.07322,3192.98744 1749.07322,3192.51256 1748.78033,3192.21967 C1748.48744,3191.92678 1748.01256,3191.92678 1747.71967,3192.21967 L1744.5,3195.43934 Z"%3E%3C/path%3E%3C/g%3E%3C/g%3E%3C/svg%3E');
}
.factBox button:hover .more::after {
    background-image: url('data:image/svg+xml;charset=utf-8,%3Csvg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 9 6"%3E%3Cg stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"%3E%3Cg transform="translate(-1740.000000, -3192.000000)" fill="%23fff" fill-rule="nonzero"%3E%3Cpath d="M1744.5,3195.43934 L1741.28033,3192.21967 C1740.98744,3191.92678 1740.51256,3191.92678 1740.21967,3192.21967 C1739.92678,3192.51256 1739.92678,3192.98744 1740.21967,3193.28033 L1743.96967,3197.03033 C1744.26256,3197.32322 1744.73744,3197.32322 1745.03033,3197.03033 L1748.78033,3193.28033 C1749.07322,3192.98744 1749.07322,3192.51256 1748.78033,3192.21967 C1748.48744,3191.92678 1748.01256,3191.92678 1747.71967,3192.21967 L1744.5,3195.43934 Z"%3E%3C/path%3E%3C/g%3E%3C/g%3E%3C/svg%3E');
}
.factBox button .less::after {
    background-image: url('data:image/svg+xml;charset=utf-8,%3Csvg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 9 6"%3E%3Cg stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"%3E%3Cg transform="translate(-1727.000000, -3193.000000)" fill="%23111" fill-rule="nonzero"%3E%3Cpath d="M1731.5,3196.43934 L1728.28033,3193.21967 C1727.98744,3192.92678 1727.51256,3192.92678 1727.21967,3193.21967 C1726.92678,3193.51256 1726.92678,3193.98744 1727.21967,3194.28033 L1730.96967,3198.03033 C1731.26256,3198.32322 1731.73744,3198.32322 1732.03033,3198.03033 L1735.78033,3194.28033 C1736.07322,3193.98744 1736.07322,3193.51256 1735.78033,3193.21967 C1735.48744,3192.92678 1735.01256,3192.92678 1734.71967,3193.21967 L1731.5,3196.43934 Z" transform="translate(1731.500000, 3195.625000) rotate(-180.000000) translate(-1731.500000, -3195.625000)"%3E%3C/path%3E%3C/g%3E%3C/g%3E%3C/svg%3E');
}
.factBox button:hover .less::after {
    background-image: url('data:image/svg+xml;charset=utf-8,%3Csvg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 9 6"%3E%3Cg stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"%3E%3Cg transform="translate(-1727.000000, -3193.000000)" fill="%23fff" fill-rule="nonzero"%3E%3Cpath d="M1731.5,3196.43934 L1728.28033,3193.21967 C1727.98744,3192.92678 1727.51256,3192.92678 1727.21967,3193.21967 C1726.92678,3193.51256 1726.92678,3193.98744 1727.21967,3194.28033 L1730.96967,3198.03033 C1731.26256,3198.32322 1731.73744,3198.32322 1732.03033,3198.03033 L1735.78033,3194.28033 C1736.07322,3193.98744 1736.07322,3193.51256 1735.78033,3193.21967 C1735.48744,3192.92678 1735.01256,3192.92678 1734.71967,3193.21967 L1731.5,3196.43934 Z" transform="translate(1731.500000, 3195.625000) rotate(-180.000000) translate(-1731.500000, -3195.625000)"%3E%3C/path%3E%3C/g%3E%3C/g%3E%3C/svg%3E');
}
</style>
<!-- ENG-7027 -->
<style>
.justNow--item-label {
    margin: 0 12px 0 0;
}
</style>
        <!-- Hotfix Freeform (Local Dynamic Two-Column) -->
        
<!-- noGen: item_header_hotfix_dtc_ssl -->
                    </head>
<!-- e hearst/article/headerMain.tpl -->    <body data-location="weather"   class="two-column">
                            <!-- design/article/dynamic_two_column.tpl -->
    <!-- hearst/article/types/dynamic_two_column.tpl -->


<!-- hearst/common/siteBranding.tpl -->
<header class="pageHeader standard" data-stage="0">
        <div class="pageHeader--progress"><div class="pageHeader--progress-bar" id="progress"></div></div>    <div class="pageHeader--skipLink-wrapper">
        <a href="#content" class="pageHeader--skipLink">Skip to main content</a>
    </div>
    <div class="pageHeader--wrapper lock">
        <div id="navToggle" class="pageHeader--menuButton navToggle" aria-expanded="false" aria-labelledby="navigation" tabindex="0"></div>                <a id="mastheadLogo" href="/"  class="pageHeader--logo mastheadLogo fade show hdn-analytics" role="img" aria-label="Homepage - Site Logo" data-hdn-analytics="visit|masthead|navigation|0"></a>
                    <div id="titleBar" class="pageHeader--titleBar titleBar fade show hidden">
                                    <div class="pageHeader--titleBar-subsection">Currently Reading</div>
                    <div class="pageHeader--titleBar-title">NY Forecast</div>
                            </div>
                            <div id="nextStory" class="pageHeader--nextStory nextStory fade show hidden"></div>
                            <ul class="pageHeader--links fade show">
                                                                                                                                        <li id="subscription" class="pageHeader--links-nonsub subscribeButton fade show hidden">
                                <a class="visible-xs-f subscribe" href="https://subscription.hearstmediact.com/checkout/507?siteid=CT_MM&origin=button&ipid=wcm">Subscribe</a>
                                <button type="button" class="hidden-xs" data-link="https://subscription.hearstmediact.com/checkout/507?siteid=CT_MM&origin=button&ipid=wcm">Subscribe</button>
                            </li>
                                                            <li id="eEdition" class="pageHeader--links-sub eEdition fade show hidden"><a href="/e-edition">e-edition</a></li>
                                                                                                        <!-- hearst/common/signin.tpl -->
<li class="treg-is-gigya gigya_menu ">
    <div class="gya-title expandable treg-conditional treg-not-logged-in">
        <a class="signIn" tabindex="0">Sign In</a>
    </div>
    <div class="gya-title expandable treg-conditional treg-logged-in"><span></span></div>
    <div class="gya-content expandable">
        <div class="treg-gya-login-widget"></div>
    </div>
</li>
<!-- e hearst/common/signin.tpl -->                <li class="pageHeader--searchButton searchToggle" aria-expanded="false" aria-labelledby="searchField-aria" tabindex="0"></li>            </ul>
                            <div class="pageHeader--search searchField" id="searchField-aria">
                
                <form class="pageHeader--search-form" action="/search/" method="get">
                    <input type="hidden" name="action" value="search" />
                    <input type="hidden" name="firstRequest" value="1" />
                    <input type="hidden" name="searchindex" value="solr" />
                    <div class="fieldset">
                        <input class="pageHeader--search-input" id="search" name="query" type="text" value="" placeholder="Search" />
                        <button class="searchButton btn" value="" name="search" type="submit"></button>
                    </div>
                </form>
            </div>
            </div>
                                    
        <!-- hearst/home/HNavigation.tpl -->
<!-- hearst/home/navigation.tpl -->
         <!-- hearst/common/siteNavigation.tpl -->
<nav id="navigation" class="navigation"><div class="navigation--wrapper lock"><div class="navigation--menu"><ul class="hidden-sm hidden-md hidden-lg hidden-xl"><li class="parent topLevel" data-length="6" data-index="0"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4941" data-hdn-analytics="visit|home|navigation-ard|1">home</a><span class="toggle navigation--item-glyph"></span></a><ul class="navigation--subMenu" data-collapsed="true" style="--n: 132px"><li class="child"><a  href="https://link.milfordmirror.com/join/signup-mm" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5806" data-hdn-analytics="visit|home-Sign Up for Newsletters|navigation-ard|1">Sign Up for Newsletters</a></li><li class="child"><a  href="https://hearstmediact.newsbank.com/home" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4949" data-hdn-analytics="visit|home-Print Archives|navigation-ard|2">Print Archives</a></li><li class="child"><a  href="https://subscription.hearstmediact.com/checkout/507?siteid=CT_MM&origin=hamburger" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4952" data-hdn-analytics="visit|home-Subscribe|navigation-ard|3">Subscribe</a></li><li class="child"><a  href="/news-submission-guidelines/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4944" data-hdn-analytics="visit|home-Submission Guidelines|navigation-ard|4">Submission Guidelines</a></li><li class="child"><a  href="/submissions/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4987" data-hdn-analytics="visit|home-Submissions|navigation-ard|5">Submissions</a></li></ul></span></li><li class="parent topLevel" data-length="8" data-index="1"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4997" data-hdn-analytics="visit|News|navigation-ard|2">News</a><span class="toggle navigation--item-glyph"></span></a><ul class="navigation--subMenu" data-collapsed="true" style="--n: 176px"><li class="child"><a  href="/politics-elections/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4990" data-hdn-analytics="visit|News-Politics & Elections|navigation-ard|1">Politics & Elections</a></li><li class="child"><a  href="/news/town-government/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4991" data-hdn-analytics="visit|News-Town Government|navigation-ard|2">Town Government</a></li><li class="child"><a  href="/news/community/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4992" data-hdn-analytics="visit|News-Community|navigation-ard|3">Community</a></li><li class="child"><a  href="/news/education/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4994" data-hdn-analytics="visit|News-Education|navigation-ard|4">Education</a></li><li class="child"><a  href="/news/police-fire/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4995" data-hdn-analytics="visit|News-Police & Fire|navigation-ard|5">Police & Fire</a></li><li class="child"><a  href="/news/connecticut/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4998" data-hdn-analytics="visit|News-Connecticut|navigation-ard|6">Connecticut</a></li><li class="child"><a  href="/opinion/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5812" data-hdn-analytics="visit|News-Opinion|navigation-ard|7">Opinion</a></li></ul></span></li><li class="single" data-length="1" data-index="2"><a href="/business/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4977" data-hdn-analytics="visit|Business|navigation-ard|3">Business</a></li><li class="single" data-length="1" data-index="3"><a href="https://www.legacy.com/obituaries/milfordmirror/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4979" data-hdn-analytics="visit|Obituaries|navigation-ard|4">Obituaries</a></li><li class="parent topLevel" data-length="3" data-index="4"><span role="heading" aria-level="2"><a  href="/sports/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4986" data-hdn-analytics="visit|Sports|navigation-ard|5">Sports</a><span class="toggle navigation--item-glyph"></span></a><ul class="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/uconn/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5833" data-hdn-analytics="visit|Sports-UConn|navigation-ard|1">UConn</a></li><li class="child"><a  href="/sports/high-school-sports/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4985" data-hdn-analytics="visit|Sports-High School Sports|navigation-ard|2">High School Sports</a></li></ul></span></li><li class="parent topLevel" data-length="3" data-index="5"><span role="heading" aria-level="2"><a  href="/living/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5799" data-hdn-analytics="visit|Living|navigation-ard|6">Living</a><span class="toggle navigation--item-glyph"></span></a><ul class="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/food/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5800" data-hdn-analytics="visit|Living-Food|navigation-ard|1">Food</a></li><li class="child"><a  href="/homegarden/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5354" data-hdn-analytics="visit|Living-Home and Garden|navigation-ard|2">Home and Garden</a></li></ul></span></li><li class="single" data-length="1" data-index="6"><a href="/entertainment/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4996" data-hdn-analytics="visit|Entertainment|navigation-ard|7">Entertainment</a></li><li class="parent topLevel" data-length="6" data-index="7"><span role="heading" aria-level="2"><a  href="/help/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4948" data-hdn-analytics="visit|Help|navigation-ard|8">Help</a><span class="toggle navigation--item-glyph"></span></a><ul class="navigation--subMenu" data-collapsed="true" style="--n: 132px"><li class="child"><a  href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CMM" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4947" data-hdn-analytics="visit|Help-Delivery Problems|navigation-ard|1">Delivery Problems</a></li><li class="child"><a  href="/about-us/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4945" data-hdn-analytics="visit|Help-About Us|navigation-ard|2">About Us</a></li><li class="child"><a  href="/contact-us/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4946" data-hdn-analytics="visit|Help-Contact Us|navigation-ard|3">Contact Us</a></li><li class="child"><a  href="/privacy/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4943" data-hdn-analytics="visit|Help-Privacy Notice|navigation-ard|4">Privacy Notice</a></li><li class="child"><a  href="/tos/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4942" data-hdn-analytics="visit|Help-Terms of Use|navigation-ard|5">Terms of Use</a></li></ul></span></li><li class="parent topLevel" data-length="5" data-index="8"><span role="heading" aria-level="2"><a  href="/sponsoredarticles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5716" data-hdn-analytics="visit|Partner Content|navigation-ard|9">Partner Content</a><span class="toggle navigation--item-glyph"></span></a><ul class="navigation--subMenu" data-collapsed="true" style="--n: 88px"><li class="child"><a  href="/healthyct/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5762" data-hdn-analytics="visit|Partner Content-HealthyCT|navigation-ard|1">HealthyCT</a></li><li class="child"><a  href="/the-legal-brief/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5857" data-hdn-analytics="visit|Partner Content-The Legal Brief|navigation-ard|2">The Legal Brief</a></li><li class="child"><a  href="https://storystudio.connecticutmag.com/ct-staycation/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5718" data-hdn-analytics="visit|Partner Content-Staycations|navigation-ard|3">Staycations</a></li><li class="child"><a  href="https://storystudio.connecticutmag.com/camp-guide-2020-2021/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5717" data-hdn-analytics="visit|Partner Content-Camp Guide|navigation-ard|4">Camp Guide</a></li></ul></span></li><li class="single" data-length="1" data-index="9"><a href="http://connecticut.ipublishmarketplace.com/connecticut-marketplace/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5002" data-hdn-analytics="visit|Classifieds|navigation-ard|1">Classifieds</a></li></ul></div></div><span class="rule"></span><div id="navToggle__page" class="navTogglePage"></div></nav>
<!-- e hearst/common/siteNavigation.tpl -->
<!-- e hearst/home/navigation.tpl --> <!-- e hearst/home/HNavigation.tpl -->    </header>

<!-- e hearst/common/siteBranding.tpl --><section id="topZone" class="zone topZone"><!-- src/business/widgets/hearst/collection/widget.tpl -->

    <div class="hide-rss-link hdnce-e hdnce-collection-111520-dynamic_ribbon_articles"><!-- hearst/collections/dynamic_ribbon_articles.tpl -->
<!-- collection.dynamic_ribbon_articles.111520 -->
    <!-- design/collection/dynamic_ribbon_articles/single_zone.tpl -->
                                                                                                                                                <div class="articleRibbon" data-component="collection" data-collection-type="ribbon" data-collection-id="111520" data-collection-title="D- MM Article Ribbon News" data-type="list">
        <button class="articleRibbon--nav-btn articleRibbon--nav-prev fade" data-delta="-1"></button>
        <div class="articleRibbon--wrapper">
            <ul class="articleRibbon--list">
                <div class="scrollSpacer"></div>
                                <div class="articleRibbon--list-wrapper" style="flex: 1 0 2200px;">
                    <span class="articleRibbon--list-title"><span class="articleRibbon--list-label"><!-- widgets/hearst/moduleHeader/widget.tpl -->
                                            Recommended
                        <!-- e widgets/hearst/moduleHeader/widget.tpl --></span></span>                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Milford-names-new-principal-at-The-Academy-16188953.php" data-hdn-analytics="visit-from-img|article-16188953|-111520|1">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/20/12/03/21012706/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/20/12/03/21012706/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/20/12/03/21012706/4/ratio1x1_100.jpg" alt="Danyelle Williams has been named the new principal at The Academy in Milford.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics "  href="/news/article/Milford-names-new-principal-at-The-Academy-16188953.php" data-hdn-analytics="visit|article-16188953|-111520|1" data-epe-inst="s:0;t:75" data-epe-title="1">Milford names new principal at The Academy alternative school</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Milford-mall-owners-present-master-plan-with-16186445.php" data-hdn-analytics="visit-from-img|article-16186445|-111520|2">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/20/10/73/21008111/3/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/20/10/73/21008111/3/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/20/10/73/21008111/3/ratio1x1_100.jpg" alt="An artist rendering of Centennial's master plan for the Connecticut Post Mall property, viewed from Boston Post Road.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics "  href="/news/article/Milford-mall-owners-present-master-plan-with-16186445.php" data-hdn-analytics="visit|article-16186445|-111520|2" data-epe-inst="s:0;t:75" data-epe-title="1">Mall owners present plan with apartments, offices, but no ‘mall’</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/400-Milford-students-vaccinated-at-COVID-19-16184645.php" data-hdn-analytics="visit-from-img|article-16184645|-111520|3">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/20/10/13/21005035/3/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/20/10/13/21005035/3/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/20/10/13/21005035/3/ratio1x1_100.jpg" alt="Alexander Pereira, 15, of Milford, receives the Pfizer Covid-19 vaccine from nurse Kaitlin Erickson at a Yale New Haven Health vaccination clinic at the Parsons Complex gymnasium in Milford on Monday.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics "  href="/news/article/400-Milford-students-vaccinated-at-COVID-19-16184645.php" data-hdn-analytics="visit|article-16184645|-111520|3" data-epe-inst="s:0;t:75" data-epe-title="1">400 Milford students vaccinated at COVID-19 clinic</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Panel-Milford-hospital-has-significant-16177274.php" data-hdn-analytics="visit-from-img|article-16177274|-111520|4">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/20/05/04/20992259/3/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/20/05/04/20992259/3/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/20/05/04/20992259/3/ratio1x1_100.jpg" alt="The Milford campus of Bridgeport Hospital">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics "  href="/news/article/Panel-Milford-hospital-has-significant-16177274.php" data-hdn-analytics="visit|article-16177274|-111520|4" data-epe-inst="s:0;t:75" data-epe-title="1">Panel: Milford hospital has ‘significant improvements’ since...</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Milford-will-drop-its-tax-rate-for-the-sixth-year-16167700.php" data-hdn-analytics="visit-from-img|article-16167700|-111520|5">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/20/00/55/20974435/3/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/20/00/55/20974435/3/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/20/00/55/20974435/3/ratio1x1_100.jpg" alt="Milford City Hall, Spring 2021">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics "  href="/news/article/Milford-will-drop-its-tax-rate-for-the-sixth-year-16167700.php" data-hdn-analytics="visit|article-16167700|-111520|5" data-epe-inst="s:0;t:75" data-epe-title="1">Milford will drop its tax rate for the sixth year in row</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Milford-PD-99-violations-cited-during-distracted-16165847.php" data-hdn-analytics="visit-from-img|article-16165847|-111520|6">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/11/46/54/19294980/17/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/11/46/54/19294980/17/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/11/46/54/19294980/17/ratio1x1_100.jpg" alt="A logo for the Milford Police Department.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics "  href="/news/article/Milford-PD-99-violations-cited-during-distracted-16165847.php" data-hdn-analytics="visit|article-16165847|-111520|6" data-epe-inst="s:0;t:75" data-epe-title="1">Milford PD: 99 violations cited during distracted driving enforcement event</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/coronavirus/article/With-less-COVID-restrictions-will-more-people-go-16163434.php" data-hdn-analytics="visit-from-img|article-16163434|-111520|7">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/17/77/10/20967941/3/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/17/77/10/20967941/3/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/17/77/10/20967941/3/ratio1x1_100.jpg" alt="From left, Andy Macri photographed with his daughter, Andromeda Macri, and grandson, Augie Campbell, 8 months, alongside a row of rhubarb at River Crest Farm in Milford on May 5, 2021.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics "  href="/news/coronavirus/article/With-less-COVID-restrictions-will-more-people-go-16163434.php" data-hdn-analytics="visit|article-16163434|-111520|7" data-epe-inst="s:0;t:75" data-epe-title="1">With fewer COVID rules, will more people go to farmers markets?</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Milford-officials-fighting-proposal-for-a-16160081.php" data-hdn-analytics="visit-from-img|article-16160081|-111520|8">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/17/75/42/20961455/3/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/17/75/42/20961455/3/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/17/75/42/20961455/3/ratio1x1_100.jpg" alt="The Connecticut Siting Council will hold a public hearing June 15 on a proposed cellular tower on the rear portion of the property at 1061 and 1063 Boston Post Road.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics "  href="/news/article/Milford-officials-fighting-proposal-for-a-16160081.php" data-hdn-analytics="visit|article-16160081|-111520|8" data-epe-inst="s:0;t:75" data-epe-title="1">Milford officials fighting proposal for a 115-foot cell tower</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Fashion-and-food-event-planned-for-downtown-16154913.php" data-hdn-analytics="visit-from-img|article-16154913|-111520|9">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/17/73/47/20953562/3/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/17/73/47/20953562/3/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/17/73/47/20953562/3/ratio1x1_100.jpg" alt="A sign on a bridge marking downtown Milford.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics "  href="/news/article/Fashion-and-food-event-planned-for-downtown-16154913.php" data-hdn-analytics="visit|article-16154913|-111520|9" data-epe-inst="s:0;t:75" data-epe-title="1">Fashion and food event planned for downtown Milford</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/news/article/Milford-Arts-Council-launches-outdoor-summer-arts-16153940.php" data-hdn-analytics="visit-from-img|article-16153940|-111520|10">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/17/73/17/20952023/3/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/17/73/17/20952023/3/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/17/73/17/20952023/3/ratio1x1_100.jpg" alt="DynaMojo guitarist John Nelson, left, and bassist Timothy &quot;Lucky&quot; Topalian perform at Milford Arts Council's MAC Musicfest fundraiser at Eisenhower Park in Milford, Conn., on Saturday Oct. 10, 2020.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics "  href="/news/article/Milford-Arts-Council-launches-outdoor-summer-arts-16153940.php" data-hdn-analytics="visit|article-16153940|-111520|10" data-epe-inst="s:0;t:75" data-epe-title="1">Milford Arts Council launches outdoor summer arts series</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                    </div>
                <div class="scrollSpacer"></div>
            </ul>
        </div>
        <button class="articleRibbon--nav-btn articleRibbon--nav-next fade show " data-delta="1"></button>
    </div>
        <script type="text/javascript">
        var nextStory = [
                                                            {
                    "id": 16188953,
                    "headline": "Milford names new principal at The Academy...",
                    "url": "/news/article/Milford-names-new-principal-at-The-Academy-16188953.php",
                    "image": "https://s.hdnux.com/photos/01/20/12/03/21012706/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 16186445,
                    "headline": "Mall owners present plan with apartments, offices,...",
                    "url": "/news/article/Milford-mall-owners-present-master-plan-with-16186445.php",
                    "image": "https://s.hdnux.com/photos/01/20/10/73/21008111/3/ratio3x2_100.jpg"
                },                                                            {
                    "id": 16184645,
                    "headline": "400 Milford students vaccinated at COVID-19 clinic",
                    "url": "/news/article/400-Milford-students-vaccinated-at-COVID-19-16184645.php",
                    "image": "https://s.hdnux.com/photos/01/20/10/13/21005035/3/ratio3x2_100.jpg"
                },                                                            {
                    "id": 16177274,
                    "headline": "Panel: Milford hospital has ‘significant...",
                    "url": "/news/article/Panel-Milford-hospital-has-significant-16177274.php",
                    "image": "https://s.hdnux.com/photos/01/20/05/04/20992259/3/ratio3x2_100.jpg"
                },                                                            {
                    "id": 16167700,
                    "headline": "Milford will drop its tax rate for the sixth year in...",
                    "url": "/news/article/Milford-will-drop-its-tax-rate-for-the-sixth-year-16167700.php",
                    "image": "https://s.hdnux.com/photos/01/20/00/55/20974435/3/ratio3x2_100.jpg"
                },                                                            {
                    "id": 16165847,
                    "headline": "Milford PD: 99 violations cited during distracted...",
                    "url": "/news/article/Milford-PD-99-violations-cited-during-distracted-16165847.php",
                    "image": "https://s.hdnux.com/photos/01/11/46/54/19294980/17/ratio3x2_100.jpg"
                },                                                            {
                    "id": 16163434,
                    "headline": "With fewer COVID rules, will more people go to...",
                    "url": "/news/coronavirus/article/With-less-COVID-restrictions-will-more-people-go-16163434.php",
                    "image": "https://s.hdnux.com/photos/01/17/77/10/20967941/3/ratio3x2_100.jpg"
                },                                                            {
                    "id": 16160081,
                    "headline": "Milford officials fighting proposal for a 115-foot...",
                    "url": "/news/article/Milford-officials-fighting-proposal-for-a-16160081.php",
                    "image": "https://s.hdnux.com/photos/01/17/75/42/20961455/3/ratio3x2_100.jpg"
                },                                                            {
                    "id": 16154913,
                    "headline": "Fashion and food event planned for downtown Milford",
                    "url": "/news/article/Fashion-and-food-event-planned-for-downtown-16154913.php",
                    "image": "https://s.hdnux.com/photos/01/17/73/47/20953562/3/ratio3x2_100.jpg"
                },                                                            {
                    "id": 16153940,
                    "headline": "Milford Arts Council launches outdoor summer arts...",
                    "url": "/news/article/Milford-Arts-Council-launches-outdoor-summer-arts-16153940.php",
                    "image": "https://s.hdnux.com/photos/01/17/73/17/20952023/3/ratio3x2_100.jpg"
                }                    ];
    </script>
<!-- e design/collection/dynamic_ribbon_articles/single_zone.tpl --><!-- e hearst/collections/dynamic_ribbon_articles.tpl -->
</div><!-- e src/business/widgets/hearst/collection/widget.tpl --></section><main id="content" class="article" data-type="dtc"><!-- hearst/article/articleHeader.tpl -->
        

<header class="article--header articleHeader"><div class="articleHeader--breadcrumbs"><a class="articleHeader--breadcrumbs-item" href="https://www.milfordmirror.com/weather/">Weather</a></div><h1 class="articleHeader--headline" aria-labelledby="">NY Forecast</h1><h3 class="articleHeader--deck"></h3><div class="articleHeader--subHead "><div class="articleHeader--byline"></div><div class="articleHeader--timestamp"><time class="articleHeader--timestamp-pubdate hasUpdate hidden-xs" datetime="2021-05-21 08:30:32">May 21, 2021</time><time class="articleHeader--timestamp-update" datetime="2021-05-21 08:34:19">Updated: May 21, 2021 4:34&nbsp;a.m.</time></div><div class="articleHeader--shareTools"><!-- hearst/common/shareTools.tpl -->
    
<div class="share-list comments">
    <a class="share-facebook" data-shareNetwork="facebook">Facebook</a>
    <a class="share-twitter" data-shareNetwork="twitter">Twitter</a>
    <a class="share-email" data-shareNetwork="email">Email</a>
            <div class="pipe"></div>
                    
                            <a class="share-comments" data-shareNetwork="comments" href="https://www.milfordmirror.com/weather/articleComments/NY-Forecast-16193168.php" onclick="document.location.href = document.location.href.replace('/article/','/articleComments/').replace('/slideshow/','/slideshowComments/'); return false;">Comments</a>
        <span class="share-count"></span>
    </div>
<!-- e hearst/common/shareTools.tpl --></div></div></header>
<!-- e hearst/article/articleHeader.tpl --><article class="article--content"><section id="articleTop" class="article--content-zone top"></section>
            <p>NY Forecast for Sunday, May 23, 2021</p>

    
            <p>_____</p>

    <div id="paywall" class="content-wrapper">
            <p>City/Town;Weather Condition;High Temp (F);Low Temp (F);Wind Direction;Wind Speed (MPH);Humidity (%);Chance of Precip. (%);UV Index</p>

    
            <p>Albany;A thunderstorm;85;65;WNW;8;58%;63%;6</p>

    
            <p>Binghamton;Clouds and sun;79;62;W;9;52%;44%;7</p>

    
            <p>Buffalo;A thunderstorm;72;63;WSW;12;69%;63%;5</p>

    
            <p>Central Park;Partly sunny;89;68;NW;3;38%;44%;8</p>

    
            <p>Dansville;A stray thunderstorm;83;64;W;9;49%;55%;9</p>

    
            <p>Dunkirk;A t-storm in spots;78;64;SW;10;61%;55%;6</p>

    
            <p>East Hampton;Clouds and sun;71;60;WNW;6;75%;44%;7</p>

    
            <p>Elmira;Clouds and sun;84;62;W;8;52%;44%;6</p>

    
            <p>Farmingdale;Partly sunny;83;67;W;7;45%;44%;8</p>

    
    <!-- hearst/article/content/zone.tpl -->
            <!-- hearst/article/content/embed.tpl -->
        <section class="article--content-embed  ">
            <div id="93066811-0534-4a7d-848c-7844b68ad1e1" class="hst-exco-player"></div><script>
function loadExcoPlayer (d, s, id) {
   var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s);
    js.id = 'exco';
    js.dataset.src = "https://player.ex.co/player/93066811-0534-4a7d-848c-7844b68ad1e1";
    fjs.parentNode.insertBefore(js, fjs);
}
if (typeof window.treg === 'object' && 'loaded' in window.treg && typeof window.treg.realm === 'object') {
    window.treg.cmd = window.treg.cmd || [];
    window.treg.cmd.push(function () {
        var treg = window.treg;
        treg.realm.events.registerReplayLast("realm.Oidc.refreshLogicComplete", function () {
            loadExcoPlayer(document, 'script', 'hst-exco-93066811-0534-4a7d-848c-7844b68ad1e1');
        });
    });
} else {
    loadExcoPlayer(document, 'script', 'hst-exco-93066811-0534-4a7d-848c-7844b68ad1e1');
}
</script><!-- amp-exco-9dfa517e-768d-4e35-98d0-e65b9084c85e -->

    </section>
<!-- e hearst/article/content/embed.tpl -->    <!-- e hearst/article/content/zone.tpl -->
            <p>Fort Drum;A thunderstorm;78;61;SW;10;57%;60%;3</p>

    
            <p>Fulton;A thunderstorm;81;59;W;9;54%;61%;6</p>

    
            <p>Glens Falls;A thunderstorm;82;62;WSW;6;54%;62%;5</p>

    
            <p>Islip;Clouds and sun;79;66;WNW;6;61%;18%;9</p>

    
    <!-- Missed: ad -->

            <p>Ithaca;A t-storm in spots;81;61;WNW;8;53%;56%;6</p>

    
            <p>Jamestown;A t-storm around;76;62;W;12;52%;56%;6</p>

    
            <p>Massena;A thunderstorm;78;63;WSW;9;55%;60%;2</p>

    
            <p>Montauk;Clouds and sun;71;61;W;6;65%;44%;7</p>

    
            <p>Montgomery;A t-storm around;85;62;WNW;7;47%;55%;8</p>

    
            <p>Monticello;A t-storm around;83;63;NW;8;54%;55%;7</p>

    
            <p>New York;Sun and clouds;89;68;NW;8;48%;44%;8</p>

    
            <p>New York Jfk;Warmer with some sun;82;66;W;9;49%;39%;7</p>

    
    <!-- Missed: ad -->

            <p>New York Lga;Sun and clouds;88;70;WNW;7;36%;44%;7</p>

    
            <p>Newburgh;A t-storm around;87;64;WNW;7;54%;55%;7</p>

    
            <p>Niagara Falls;A shower in the p.m.;78;64;SW;8;62%;64%;5</p>

    
            <p>Ogdensburg;A thunderstorm;80;63;SW;6;67%;60%;3</p>

    
            <p>Penn (Yan);Some sun, a t-storm;82;64;W;10;49%;63%;9</p>

    <aside class="article--content-inline"><aside class="zone">
    
<!-- hearst/home/mostPopular.tpl -->

    <div class="mostPopular">
        <div class="collectionHeader">Most Popular</div>
                                                <ol class="mostPopular--list">
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Milford-mall-owners-present-master-plan-with-16186445.php" title="Connecticut Post mall owners present master plan with apartments, offices, but no ‘mall’" data-hdn-analytics="visit|article-16186445|most_popular|0">Connecticut Post mall owners present master plan with apartments, offices, but no ‘mall’</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Milford-names-new-principal-at-The-Academy-16188953.php" title="Milford names new principal at The Academy alternative school" data-hdn-analytics="visit|article-16188953|most_popular|1">Milford names new principal at The Academy alternative school</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/sports/article/Law-softball-rallies-back-twice-to-defeat-Foran-16189679.php" title="Law softball rallies back twice to defeat Foran" data-hdn-analytics="visit|article-16189679|most_popular|2">Law softball rallies back twice to defeat Foran</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/sports/article/Gambardella-s-walk-off-hit-lifts-West-Haven-by-16189573.php" title="Gambardella’s walk-off hit lifts West Haven by Law baseball" data-hdn-analytics="visit|article-16189573|most_popular|3">Gambardella’s walk-off hit lifts West Haven by Law baseball</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/New-plan-for-Milford-mall-includes-public-space-16130902.php" title="New plan for Milford mall includes public space, apartments" data-hdn-analytics="visit|article-16130902|most_popular|4">New plan for Milford mall includes public space, apartments</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/sports/article/Law-finishes-unbeaten-seeded-first-in-Class-M-16190612.php" title="Law finishes unbeaten, seeded first in Class M boys tennis" data-hdn-analytics="visit|article-16190612|most_popular|5">Law finishes unbeaten, seeded first in Class M boys tennis</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/entertainment/article/Art-without-bounds-Immersive-art-show-at-Bruce-16189057.php" title="Art without bounds: Immersive art show at Bruce Museum to close soon" data-hdn-analytics="visit|article-16189057|most_popular|6">Art without bounds: Immersive art show at Bruce Museum to close soon</a>
                                                    </li>
                                    </ol>
                        </div>
<!--e hearst/home/mostPopular.tpl --></aside></aside>
            <p>Plattsburgh;A thunderstorm;78;63;W;7;53%;62%;3</p>

    
            <p>Poughkeepsie;A t-storm around;87;62;NW;5;45%;55%;7</p>

    
            <p>Rochester;A thunderstorm;84;65;W;10;54%;62%;6</p>

    
    <!-- Missed: ad -->

            <p>Rome;A thunderstorm;82;61;W;9;56%;63%;6</p>

    
            <p>Saranac Lake;A thunderstorm;76;58;W;7;58%;62%;3</p>

    
            <p>Shirley;Partly sunny;78;63;WNW;6;64%;22%;7</p>

    
            <p>Syracuse;A thunderstorm;85;64;W;10;47%;63%;6</p>

    
            <p>Watertown;A thunderstorm;75;59;SSW;10;64%;59%;4</p>

    
            <p>Wellsville;A t-storm around;79;63;WNW;9;55%;56%;7</p>

    
            <p>Westhampton Beach;Clouds and sun;76;58;WSW;8;55%;25%;7</p>

    
            <p>White Plains;Sun and clouds;85;65;NW;7;41%;40%;7</p>

    
            <p>_____</p>

    
            <p>Copyright 2021 AccuWeather</p>

    <section id="articleBottom" class="article--content-zone bottom"></section></div></article><!-- hearst/article/articleAside.tpl -->
<aside class="article--aside slideshow--aside">
    <aside id="zoneD" class="zone">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85203 -->
    <div class="hst-freeform hdnce-e hdnce-item-85203">
                <script type="text/javascript" id="taboola-right-rail-script-id">
(function () {
    window._taboolaRRI = window._taboolaRRI || 0;
    window._taboolaRRI++;
    var e = document.documentElement;
    var g = document.getElementsByTagName('body')[0];
    var w = window.innerWidth||e.clientWidth||g.clientWidth;
    if ( (w >= 768 && window._taboolaRRI === 1) || (w < 768 && window._taboolaRRI === 2) ){
        var c = 'taboola-right-rail-thumbnails';
        var p = 'Right Rail Thumbnails';
        var m = 'rr';
        try {
            if (window._taboolaNetworkMode) {
                c = c + '---redesign';
                p = p + ' - Redesign';
                if (HDN.dataLayer.content.objectType  === 'article') {
                    m = 'f';
                }
            }
        } catch (e) {}
        var d = document.createElement('div');
        d.id = c;
        var s = document.getElementById('taboola-right-rail-script-id');
        s.parentNode.insertBefore(d, s);
        window._taboola = window._taboola || [];
        _taboola.push({
            mode: 'thumbnails-' + m,
            container: c,
            placement: p,
            target_type: 'mix'
        });
    }
})();
</script>
    </div>
            </aside>
    <aside id="zoneC" class="zone">
    
<!-- hearst/home/mostPopular.tpl -->

    <div class="mostPopular">
        <div class="collectionHeader">Most Popular</div>
                                                <ol class="mostPopular--list">
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Milford-mall-owners-present-master-plan-with-16186445.php" title="Connecticut Post mall owners present master plan with apartments, offices, but no ‘mall’" data-hdn-analytics="visit|article-16186445|most_popular|0">Connecticut Post mall owners present master plan with apartments, offices, but no ‘mall’</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Milford-names-new-principal-at-The-Academy-16188953.php" title="Milford names new principal at The Academy alternative school" data-hdn-analytics="visit|article-16188953|most_popular|1">Milford names new principal at The Academy alternative school</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/sports/article/Law-softball-rallies-back-twice-to-defeat-Foran-16189679.php" title="Law softball rallies back twice to defeat Foran" data-hdn-analytics="visit|article-16189679|most_popular|2">Law softball rallies back twice to defeat Foran</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/sports/article/Gambardella-s-walk-off-hit-lifts-West-Haven-by-16189573.php" title="Gambardella’s walk-off hit lifts West Haven by Law baseball" data-hdn-analytics="visit|article-16189573|most_popular|3">Gambardella’s walk-off hit lifts West Haven by Law baseball</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/New-plan-for-Milford-mall-includes-public-space-16130902.php" title="New plan for Milford mall includes public space, apartments" data-hdn-analytics="visit|article-16130902|most_popular|4">New plan for Milford mall includes public space, apartments</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/sports/article/Law-finishes-unbeaten-seeded-first-in-Class-M-16190612.php" title="Law finishes unbeaten, seeded first in Class M boys tennis" data-hdn-analytics="visit|article-16190612|most_popular|5">Law finishes unbeaten, seeded first in Class M boys tennis</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/entertainment/article/Art-without-bounds-Immersive-art-show-at-Bruce-16189057.php" title="Art without bounds: Immersive art show at Bruce Museum to close soon" data-hdn-analytics="visit|article-16189057|most_popular|6">Art without bounds: Immersive art show at Bruce Museum to close soon</a>
                                                    </li>
                                    </ol>
                        </div>
<!--e hearst/home/mostPopular.tpl --></aside>
</aside>
<!-- e hearst/article/articleAside.tpl --><!-- hearst/article/articleFooter.tpl -->
<footer class="article--footer"><div class="content-wrapper"><div class="articleFooter"><div class="articleFooter--author noImage"><div class="articleFooter--author-label">Written By</div><div class="articleFooter--author-name"></div></div></div></div><section class="article--comments"><button id="commentsButton" data-link="https://www.milfordmirror.com/weather/articleComments/NY-Forecast-16193168.php" onclick="document.location.href = 'https://www.milfordmirror.com/weather/articleComments/NY-Forecast-16193168.php'; return false;">View Comments</button></section></footer>
<!-- e hearst/article/articleFooter.tpl --></main><section id="bottomZone" class="zone bottomZone lock">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85204 -->
    <div class="hst-freeform hdnce-e hdnce-item-85204">
                <script type="text/javascript" id="taboola-feed-script-id">
(function () {
    var c = 'taboola-below-article-thumbnails';
    var p = 'Below Article Thumbnails';
    try {
        if (window._taboolaNetworkMode) {
            var e = document.documentElement;
            var g = document.getElementsByTagName('body')[0];
            var w = window.innerWidth||e.clientWidth||g.clientWidth;
            if (w < 768) {
                c = 'taboola-mobile-below-article-feed---redesign';
                p = 'Mobile Below Article Feed - Redesign';
            } else {
                c = 'taboola-below-article-feed---redesign';
                p = 'Below Article Feed - Redesign';
            }
        }
    } catch (e) {}
    var d = document.createElement('div');
    d.id = c;
    var s = document.getElementById('taboola-feed-script-id');
    s.parentNode.insertBefore(d, s);
    window._taboola = window._taboola || [];
    window._taboola.push({
        mode: 'thumbnails-a',
        container: c,
        placement: p,
        target_type: 'mix'
    });
})();
</script>
    </div>
            <div class="taboola-skip-wrapper"><div id="taboola-skip"></div></div></section><!-- hearst/common/siteFooter.tpl -->
<footer class="pageFooter">
    <div class="lock">
        <div class="pageFooter--wrapper">
            <div class="pageFooter--left">
                <a href="/" class="pageFooter--left-logo"></a>
                <ul class="pageFooter--left-social">
                    <li class="facebook"><a href="http://facebook.com/milfordmirror" aria-label="facebook"></a></li>                    <li class="twitter"><a href="http://twitter.com/milfordmirror" aria-label="twitter"></a></li>                                                        </ul>
            </div>
            <div class="pageFooter--right">
                <div class="pageFooter--right-topLine">
                    <a href="#content" class="return"><span class="full">Return to</span> Top</a>
                </div>
                <div class="pageFooter--right-links">
                    
                    <!-- hearst/item/standalone.tpl -->
<div class="hdnce-e hdnce-item-97493"><!-- mid:freeform.97493 -->
<style>
@media (min-width: 768px) {
  .pageFooter--right-links .wrapper > li:nth-child(2) {
    box-sizing: border-box;
    padding-left: 50px;
  }
}
</style>
<ul class="wrapper">
  <li>
<div class="title">About</div>
    <ul class="section">
      <li><a href="/home/article/How-Hearst-Newspapers-is-delivering-information-15678014.php">Newspaper Delivery Safety Procedures</a></li>
      <li><a href="/privacy/">Privacy Notice / Notice at Collection</a></li>
      <li><a href="/privacy/#additionalinformationforcaliforniaresidents">Your California Privacy Rights</a></li>
      <li><a href="/privacy/#interestbasedads">Interest Based Ads</a></li>
      <li><a href="/tos/">Terms of Use</a></li>
      <li><a href="https://www.hearst.com/careers/">Careers</a></li>
      <li><a href="https://hearstmediact.com/">Advertising</a></li>
    </ul>
  </li>
  <li>
<div class="title">Contact</div>
    <ul class="section">
      <li><a href="/contact/">Contact Us</a></li>
      <li><a href="/help/">Help</a></li>
      <li><a href="https://subscription.hearstmediact.com/eEdition?siteID=CT_MM">E-Edition</a></li>
      <li><a href="/submissions/">Submissions</a></li>
    </ul>
  </li>
  <li>
<div class="title">Connect</div>
    <ul class="section">
      <li><a href="https://subscription.hearstmediact.com/checkout/507?siteid=CT_MM&amp;origin=footer">Subscribe Today</a></li>
      <li><a href="https://www.facebook.com/milfordmirror">Facebook</a></li>
      <li><a href="https://twitter.com/milfordmirror">Twitter</a></li>
    </ul>
  </li>
  <li>
</li>
</ul>
</div><!-- / hdnce-e -->                </div>
            </div>
        </div>
        <div class="pageFooter--branding">
            <img class="pageFooter--branding-logo" src="/img/core/hearst_newspapers_logo.svg" alt="HEARST newspapers logo" />
            <span class="pageFooter--branding-copyright">&copy;2021 Hearst</span>
        </div>
    </div>
                        <!-- hearst/common/spotImFooterJS.tpl -->
<script>
                                
        if ( document.readyState === "complete" || (document.readyState !== "loading" && !document.documentElement.doScroll)) {
            if (HDN && HDN.hasOwnProperty('spotim')) {
                HDN.spotim.commentCount(undefined,undefined,1);
            }
        } else {
            document.addEventListener("DOMContentLoaded", function() { 
                        if (HDN && HDN.hasOwnProperty('spotim')) {
                            HDN.spotim.commentCount(undefined,undefined,1);
                        }
                    });
        }
    
</script>
<!-- e hearst/common/spotImFooterJS.tpl -->
                            
                <script type="text/javascript">
                    window._taboola = window._taboola || [];
                    _taboola.push({flush: true});
                </script>
            
                    </footer>
<!-- e hearst/common/siteFooter.tpl -->
<!-- e hearst/article/types/dynamic_two_column.tpl --><!-- e design/article/dynamic_two_column.tpl -->                </body>
</html>
<!-- e hearst/article/articleMain.tpl --><!-- e hearst/article/article_main.tpl -->