




<!-- hearst/article/article_main.tpl -->

            <!-- hearst/article/articleMain.tpl -->



    
        <!doctype html>
<html class="no-js "  lang="en-US" prefix="og: http://ogp.me/ns#  article: http://ogp.me/ns/article#">
    <head>
<!-- hearst/article/headerMain.tpl -->

    <!-- Includes for HashTag Labs -->
    
    <!-- eid:article.17524667 -->
    <!-- generated at 2022-10-21 09:29:05 on pwcm7 running vv13.6.3 -->
            <!-- hmb:jquery jQuery JS -->
        <script type="text/javascript" src="/js/core/libs/jquery-2.2.4.min.js"></script>
                <!-- hmb:treg TREG JS -->
        <script type="text/javascript">window.tregEnabled = true;</script>
        <script type="text/javascript" src="//treg.hearstnp.com/treg.js"></script>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
            <!-- hmb:taboola Sailthru  -->
        <!-- hearst/home/header_sailthru.tpl -->
<meta property="sailthru.title" content="New York Giants" /><meta name="sailthru.date" content="2022-10-21 10:11:00 -0400" /><meta name="sailthru.author" content="" /><meta name="sailthru_uid" content="17524667" /><meta name="sailthru_pubname" content="associated-press" /><meta name="sailthru_siteid" content="79" /><meta name="sailthru.tags" content="barkley,brightwell,entertainment-figure-person,crowder-musician,bellinger-1,james-19,crowder-1-0,thibodeaux-1-0,breida,w-robinson,ward-1-0,johnson,pinnock,gillan,james-10,off,gano-0,james-1,taylor,thibodeaux-0,l-williams,united-states,new-york-new-york-city,north-america,belton,jackson,new-york-giants,toney-2,james-2,w-robinson-1,slayton-8,fc-yards-avg,brightwell-8,jones-2,bellinger-15,gillan-1-3-3-0,rec,tot,jones-47,jones-159,fga-fg-saf-tot,jones-2-0,recoveries-fum-rec,yards-avg,member-choice-sports-option,com-pct,comp,passing-att,generic-sports,yards-gain,rushing-att,myarick,yards-avg-avg,love-1-0,lawrence-4-0,ximines-2-0,fox-1-0,ojulari-1-0,sills,def,new-york-giants,toney-2,gano-0,james-2,w-robinson-1,slayton-8,fc-yards-avg,brightwell-8,jones-2,bellinger-15,gillan-1-3-3-0,rec,tot,barkley,brightwell,entertainment-figure-person,crowder-musician,bellinger-1,james-19,crowder-1-0,thibodeaux-1-0,breida,w-robinson,ward-1-0,johnson,pinnock,gillan,james-10,off,gano-0,james-1,taylor,thibodeaux-0,l-williams,united-states,new-york-new-york-city,north-america,belton,jackson,jones-47,jones-159,yards-avg,member-choice-sports-option,com-pct,comp,passing-att,generic-sports,yards-gain,rushing-att,myarick,yards-avg-avg,toney-2,love-1-0,lawrence-4-0,ximines-2-0,fox-1-0,ojulari-1-0,sills,def,2fsports-2fteam-sports-2famerican-football,2fnews-2fsports-news,2fsports-2ffantasy-sports" /><meta name="sailthru.image.thumb" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg" />
<!-- e hearst/home/header_sailthru.tpl -->
    
        <title>New York Giants</title>
    <!-- hearst/common/fonts.tpl -->
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-regular.woff" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-300.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-600.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<!-- e hearst/common/fonts.tpl -->

        <script>
          if ( document.location.hostname.match(/\.$/) ) {
              document.location.replace(
                  document.location.protocol +
                  '//' +
                  document.location.hostname.replace(/\.+$/, '') +
                  ( undefined !== document.location.pathname ? document.location.pathname : '' ) +
                  ( undefined !== document.location.search ? document.location.search : '' )  +
                  ( undefined !== document.location.hash ? document.location.hash : '' )
              );
          }
        </script>

    <script>
                var HDN = HDN || {};
        HDN.t_firstbyte = Number(new Date());
        HDN.dataLayer = HDN.dataLayer || {};
        HDN.dataLayer.content = HDN.dataLayer.content || {};
                HDN.dataLayer.paywall = HDN.dataLayer.paywall || {};
        HDN.dataLayer.paywall.accessRule = "";
        HDN.dataLayer.paywall.mode = "";
        var Article = {
            "id": "17524667",
            "title": "New York Giants",
            "url": "https://www.milfordmirror.com/sports/article/New-York-Giants-17524667.php",
            "slug": "https://www.milfordmirror.com/sports/article/New-York-Giants-17524667.php",
            "summary": "Statistics after 6 games",
            "image": "https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg",
            "keywords": "",
            "siteName": "Milford Mirror",
            "env": "pwcm7",
            "comments": true,
            "isSensitive": false,
            "version": "v13.6.3",
            "displayTemplate": "dynamic_two_column",
            "renderNLP": true,
            "timing": {
                "firstbyte": HDN.t_firstbyte,
                "ready": {}
            }
        };
        
        document.addEventListener('DOMContentLoaded', function () {
            Article.timing.ready = Number(new Date());
        }, false);
        
    </script>
        
    <!-- hearst/common/hdn_datalayer_header.tpl -->

                                                                      
<script type="text/javascript">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</script>
<!-- e hearst/common/hdn_datalayer_header.tpl -->
    <script type="text/javascript" src="/js/site.js?v13.6.3"></script>
            
            <!-- Hotfix Top Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.94216 -->
<!-- DO NOT REMOVE -->
<script src="https://projects.sfchronicle.com/shared/js/responsive-frame.js"></script>
<!-- e DO NOT REMOVE -->
        <!-- Hotfix Top Freeform (Local Dynamic Two-Column) -->
        
<!-- noGen: item_header_hotfix_top_dtc_ssl 79 dne  -->
                <link rel="stylesheet" href="/dist/article.min.css?v13.6.3">
                            <!-- hmb:Polyfill  -->
        <script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=IntersectionObserver%2CIntersectionObserverEntry%2CPromise%2CCustomEvent%2CArray.prototype.forEach%2CArray.prototype.entries"></script>
                <!-- hmb:js_header Static JS Bundle  -->
        <script type="text/javascript" src="/dist/hdn/article.min.js?v13.6.3"></script>
        <!-- hearst/article/common/meta_tags.tpl -->
<meta name="msvalidate.01" content="9451CA04ABC9D1D5C6419C73B4C4F7B7" />
<meta name="HandheldFriendly" content="true">
<meta name="twitter:dnt" content="on">
<meta name="apple-mobile-web-app-title" content="">
<meta name="environment" content="pwcm7">
<meta name="id" content="17524667">
<link rel="canonical" href="https://www.milfordmirror.com/sports/article/New-York-Giants-17524667.php" />
<meta name="robots" content="max-image-preview:large">
                                            <meta name="author" content="">
        <meta name="author.name" content="" />
        <meta name="author.title" content="" />
        <meta name="description" content="Statistics after 6 games"/>
    <meta name="date.release" content="2022-10-21 14:11:14" />
    <meta name="time.release" content="2022-10-21 14:11:14" />
    <meta name="sections" content="Sports" />
            <meta name="subject" content="Barkley, Brightwell, ENTERTAINMENT_FIGURE PERSON, Crowder MUSICIAN, Bellinger 1, James 19, Crowder 1.0, Thibodeaux 1.0, Breida, W.Robinson, Ward 1.0, Johnson, Pinnock, Gillan, James 10, OFF, Gano 0, James 1, Taylor, Thibodeaux 0, L.Williams, United States, New York New York City, North America, Belton, Jackson, New York Giants, Toney 2, James 2, W.Robinson 1, Slayton 8, FC YARDS AVG, Brightwell 8, Jones 2, Bellinger 15, Gillan 1 -3 -3.0, REC, TOT, Jones 47, Jones 159, FGA FG SAF TOT, Jones 2 0, RECOVERIES FUM REC, YARDS AVG, Member Choice Sports Option, COM PCT, COMP, PASSING ATT, Generic Sports, YARDS GAIN, RUSHING ATT, Myarick, YARDS AVG AVG, Love 1.0, Lawrence 4.0, Ximines 2.0, Fox 1.0, Ojulari 1.0, Sills, DEF" />
        <meta name="news_keywords" content="Barkley, Brightwell, ENTERTAINMENT_FIGURE PERSON, Crowder MUSICIAN, Bellinger 1, James 19, Crowder 1.0, Thibodeaux 1.0, Breida, W.Robinson, Ward 1.0, Johnson, Pinnock, Gillan, James 10, OFF, Gano 0, James 1, Taylor, Thibodeaux 0, L.Williams, United States, New York New York City, North America, Belton, Jackson, New York Giants, Toney 2, James 2, W.Robinson 1, Slayton 8, FC YARDS AVG, Brightwell 8, Jones 2, Bellinger 15, Gillan 1 -3 -3.0, REC, TOT, Jones 47, Jones 159, FGA FG SAF TOT, Jones 2 0, RECOVERIES FUM REC, YARDS AVG, Member Choice Sports Option, COM PCT, COMP, PASSING ATT, Generic Sports, YARDS GAIN, RUSHING ATT, Myarick, YARDS AVG AVG, Love 1.0, Lawrence 4.0, Ximines 2.0, Fox 1.0, Ojulari 1.0, Sills, DEF" />
                <meta name="nlpOrganization" content="New York Giants, Toney 2, Gano 0, James 2, W.Robinson 1, Slayton 8, FC YARDS AVG, Brightwell 8, Jones 2, Bellinger 15, Gillan 1 -3 -3.0, REC, TOT" />
                <meta name="nlpPerson" content="Barkley, Brightwell, ENTERTAINMENT_FIGURE PERSON, Crowder MUSICIAN, Bellinger 1, James 19, Crowder 1.0, Thibodeaux 1.0, Breida, W.Robinson, Ward 1.0, Johnson, Pinnock, Gillan, James 10, OFF, Gano 0, James 1, Taylor, Thibodeaux 0, L.Williams" />
                <meta name="nlpLocation" content="United States, New York New York City, North America, Belton, Jackson" />
                <meta name="nlpConsumerGood" content="FGA FG SAF TOT, Jones 2 0, RECOVERIES FUM REC" />
                <meta name="nlpWorkOfArt" content="Jones 47, Jones 159" />
                    <meta name="nlpOther" content="YARDS AVG, Member Choice Sports Option, COM PCT, COMP, PASSING ATT, Generic Sports, YARDS GAIN, RUSHING ATT, Myarick, YARDS AVG AVG, Toney 2, Love 1.0, Lawrence 4.0, Ximines 2.0, Fox 1.0, Ojulari 1.0, Sills, DEF" />
                            <meta name="nlpCategories" content="%2FSports%2FTeam+Sports%2FAmerican+Football,%2FNews%2FSports+News,%2FSports%2FFantasy+Sports" />
    <!-- e hearst/article/common/meta_tags.tpl -->    <!-- hearst/article/common/opengraph.tpl -->
<meta property="fb:admins" content="100006394927810"/><meta property="fb:app_id" content="322056085100167"/><meta property="fb:pages" content="105702905593" /><meta property="fb:pages" content="307851324523" /><meta property="fb:pages" content="12852567813" /><meta property="fb:pages" content="480760515417232" /><meta property="fb:pages" content="288240529145" /><meta property="fb:pages" content="316774245761" /><meta property="fb:pages" content="984197758297116" /><meta property="fb:pages" content="7457442370" /><meta property="fb:pages" content="207033189701" /><meta property="fb:pages" content="207346283795" /><meta property="fb:pages" content="222959748728" /><meta property="fb:pages" content="207042068180" /><meta property="fb:pages" content="72983690774" /><meta property="fb:pages" content="339413234035" /><meta property="fb:pages" content="343689323559" /><meta property="fb:pages" content="345828366626" /><meta property="fb:pages" content="234821559861394" /><meta property="fb:pages" content="335699426867" /><meta property="fb:pages" content="10150105039485602" /><meta property="fb:pages" content="338983127562" /><meta property="fb:pages" content="364516539001" /><meta property="fb:pages" content="337922332042" /><meta property="fb:pages" content="115637335153191" /><meta property="fb:pages" content="372011535931" /><meta property="fb:pages" content="333376634908" /><meta property="fb:pages" content="127590790608884" /><meta property="fb:pages" content="141923885872653" /><meta property="fb:pages" content="655037391286291" /><meta property="fb:pages" content="320774811368833" /><meta property="fb:pages" content="1740489152861748" /><meta property="fb:pages" content="469700473093040" /><meta property="fb:pages" content="386754203367" /><meta property="fb:pages" content="556449374478585" /><meta property="fb:pages" content="340999853450" /><meta property="fb:pages" content="350771491032" /><meta property="fb:pages" content="1120648627959218" /><meta property="fb:pages" content="342017778245" /><meta property="fb:pages" content="338463361591" /><meta property="fb:pages" content="138772706196968" /><meta property="fb:pages" content="1641688532739111" /><meta property="fb:pages" content="326312697536" /><meta property="fb:pages" content="353120110016" /><meta property="fb:pages" content="343366744658" /><meta property="fb:pages" content="335009494554" /><meta property="fb:pages" content="347261603104" /><meta property="fb:pages" content="350924013892" /><meta property="fb:pages" content="257724773860" /><meta property="fb:pages" content="361203926417" /><meta property="fb:pages" content="367174215398" /><meta property="fb:pages" content="284154645394" /><meta property="fb:pages" content="334501182354" /><meta property="fb:pages" content="350279743224" /><meta property="fb:pages" content="154340691263654" /><meta property="fb:pages" content="147848678611852" /><meta property="fb:pages" content="361381078011" /><meta property="fb:pages" content="362831597677" /><meta property="fb:pages" content="10150095255780118" /><meta name="og:datePublished" content="2022-10-21 14:09:08"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="New York Giants"/><meta property="og:description" content="Statistics after 6 games"/><meta property="og:url" content="https://www.milfordmirror.com/sports/article/New-York-Giants-17524667.php"/><meta property="og:site_name" content="Milford Mirror"/><meta property="og:image" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg"/><meta property="article:published_time" content="2022-10-21 14:09:08" /><meta property="article:modified_time" content="2022-10-21 14:11:14" /><meta property="article:author" content=""/><meta property="article:section" content="Sports" /><meta property="article:tag" content="Barkley" /><meta property="article:tag" content="Brightwell" /><meta property="article:tag" content="ENTERTAINMENT_FIGURE PERSON" /><meta property="article:tag" content="Crowder MUSICIAN" /><meta property="article:tag" content="Bellinger 1" /><meta property="article:tag" content="James 19" /><meta property="article:tag" content="Crowder 1.0" /><meta property="article:tag" content="Thibodeaux 1.0" /><meta property="article:tag" content="Breida" /><meta property="article:tag" content="W.Robinson" /><meta property="article:tag" content="Ward 1.0" /><meta property="article:tag" content="Johnson" /><meta property="article:tag" content="Pinnock" /><meta property="article:tag" content="Gillan" /><meta property="article:tag" content="James 10" /><meta property="article:tag" content="OFF" /><meta property="article:tag" content="Gano 0" /><meta property="article:tag" content="James 1" /><meta property="article:tag" content="Taylor" /><meta property="article:tag" content="Thibodeaux 0" /><meta property="article:tag" content="L.Williams" /><meta property="article:tag" content="United States" /><meta property="article:tag" content="New York New York City" /><meta property="article:tag" content="North America" /><meta property="article:tag" content="Belton" /><meta property="article:tag" content="Jackson" /><meta property="article:tag" content="New York Giants" /><meta property="article:tag" content="Toney 2" /><meta property="article:tag" content="James 2" /><meta property="article:tag" content="W.Robinson 1" /><meta property="article:tag" content="Slayton 8" /><meta property="article:tag" content="FC YARDS AVG" /><meta property="article:tag" content="Brightwell 8" /><meta property="article:tag" content="Jones 2" /><meta property="article:tag" content="Bellinger 15" /><meta property="article:tag" content="Gillan 1 -3 -3.0" /><meta property="article:tag" content="REC" /><meta property="article:tag" content="TOT" /><meta property="article:tag" content="Jones 47" /><meta property="article:tag" content="Jones 159" /><meta property="article:tag" content="FGA FG SAF TOT" /><meta property="article:tag" content="Jones 2 0" /><meta property="article:tag" content="RECOVERIES FUM REC" /><meta property="article:tag" content="YARDS AVG" /><meta property="article:tag" content="Member Choice Sports Option" /><meta property="article:tag" content="COM PCT" /><meta property="article:tag" content="COMP" /><meta property="article:tag" content="PASSING ATT" /><meta property="article:tag" content="Generic Sports" /><meta property="article:tag" content="YARDS GAIN" /><meta property="article:tag" content="RUSHING ATT" /><meta property="article:tag" content="Myarick" /><meta property="article:tag" content="YARDS AVG AVG" /><meta property="article:tag" content="Love 1.0" /><meta property="article:tag" content="Lawrence 4.0" /><meta property="article:tag" content="Ximines 2.0" /><meta property="article:tag" content="Fox 1.0" /><meta property="article:tag" content="Ojulari 1.0" /><meta property="article:tag" content="Sills" /><meta property="article:tag" content="DEF" />
<!-- e hearst/article/common/opengraph.tpl -->    <!-- hearst/article/common/twittercard.tpl -->

<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:image" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg"/>
<meta name="twitter:description" content="Statistics after 6 games"/>
<meta name="twitter:title" content="New York Giants"/>
<meta name="twitter:site" content="@milfordmirror" />
<!-- e hearst/article/common/twittercard.tpl -->    <!-- hearst/article/common/analytics.tpl -->
<script>var omni_channelPath = "Sports";var omni_title = "New York Giants";var omni_bizObjectId = "17524667";var omni_className = "article";var omni_publicationDate = "2022-10-21 14:09:08";var omni_sourceSite ="ap";var omni_authorName = "";var omni_authorTitle = "";var omni_premiumStatus = "free";var omni_premiumEndDate = "";var omni_originalSource = "AP";var omni_pageNumber = "0";var omni_breakingNewsFlag = "0";var omni_localNewsFlag = "0";var omni_isListView = "0";var omni_paywallSite = "0";var omni_displayTemplate = "dynamic_two_column";</script>
<!-- e hearst/article/common/analytics.tpl -->    <!-- hearst/article/common/schema_NewsArticle.tpl -->

<script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@id":"https:\/\/www.milfordmirror.com\/sports\/article\/New-York-Giants-17524667.php"},"headline":"New York Giants","articleBody":"Statistics after 6 games COMP AVG TD INT PASSING ATT. COM PCT YARDS GAIN TD PCT INT PCT LONG RATE Jones 159 107 67.3 1021 6.42 5 3.1 2 1.3 65t 90.2 Taylor 3 1 33.3 11 3.67 0 0.0 1 33.3 11 5.6 TEAM 162 108 66.7 926 6.37 5 3.1 3 1.9 65t 86.8 OPPONENTS 186 108 58.1 1167 6.62 7 3.8 1 0.5 56 88.4 RUSHING ATT. YARDS AVG LONG TD Barkley 119 616 5.2 68 4 Jones 47 236 5.0 21t 2 Breida 17 49 2.9 13 0 Taylor 3 30 10.0 13 0 Toney 2 23 11.5 19 0 Brightwell 4 19 4.8 14 1 James 2 6 3.0 4 0 Bellinger 1 2 2.0 2t 1 Gillan 1 -3 -3.0 -3 0 TEAM 196 978 5.0 68 8 OPPONENTS 155 869 5.6 49 2 RECEIVING NO. YARDS AVG LONG TD Barkley 21 155 7.4 41 0 James 19 189 9.9 16 0 Bellinger 15 139 9.3 20 2 Shepard 13 154 11.8 65t 1 Sills 9 82 9.1 24 0 Slayton 8 108 13.5 26 0 Johnson 5 60 12.0 18 0 Breida 4 30 7.5 15 0 W.Robinson 4 42 10.5 17 1 Hudson 3 40 13.3 18 0 Myarick 3 11 3.7 6 1 Golladay 2 22 11.0 15 0 Toney 2 0 0.0 2 0 TEAM 108 1032 9.6 65t 5 OPPONENTS 108 1232 11.4 56 7 INTERCEPTIONS NO. YARDS AVG LONG TD Love 1 27 27.0 27 0 TEAM 1 27 27.0 27 0 OPPONENTS 3 4 1.3 7 0 SACKS NO. Lawrence 4.0 Ximines 2.0 Crowder 1.0 Fox 1.0 Love 1.0 Ojulari 1.0 Thibodeaux 1.0 Ward 1.0 TEAM 13.0 OPPONENTS 19.0 GROSS NET IN PUNTING NO. YARDS AVG AVG 20 LONG BLK Gillan 25 1255 50.2 41.6 8 69 0 TEAM 25 1255 50.2 41.6 8 69 0 OPPONENTS 25 1215 48.6 43.7 13 66 0 PUNT RETURNS NO. FC YARDS AVG LONG TD James 10 0 76 7.6 22 0 Pinnock 1 0 0 0.0 0 0 TEAM 11 0 76 6.9 22 0 OPPONENTS 11 0 149 13.5 46 0 KICKOFF RETURNS NO. YARDS AVG LONG TD Brightwell 8 177 22.1 47 0 TEAM 8 177 22.1 47 0 OPPONENTS 11 229 20.8 36 0 OFF. DEF. FUMBLES\/RECOVERIES FUM REC. REC. Barkley 1 0 0 Belton 0 0 2 Brightwell 0 0 1 Jackson 0 0 1 James 1 0 0 Jones 2 0 0 Pinnock 1 0 1 Taylor 1 0 0 Thibodeaux 0 0 1 L.Williams 0 0 1 TEAM 6 0 7 OPPONENTS 15 7 3 SCORE BY QUARTERS 1 2 3 4 OT TOT TEAM 16 24 39 48 0 127 OPPONENTS 26 38 27 22 0 113 TOUCHDOWNS LONG SCORING TOT RUS REC RET XP XPA FG FGA FG SAF TOT Gano 0 0 0 0 11 11 12 14 56 0 47 Barkley 4 4 0 0 0 0 0 0 0 0 26 Bellinger 3 1 2 0 0 0 0 0 0 0 18 Jones 2 2 0 0 0 0 0 0 0 0 14 Brightwell 1 1 0 0 0 0 0 0 0 0 6 Myarick 1 0 1 0 0 0 0 0 0 0 6 W.Robinson 1 0 1 0 0 0 0 0 0 0 6 Shepard 1 0 1 0 0 0 0 0 0 0 6 TEAM 13 8 5 0 11 11 12 14 56 0 114 OPPONENTS 9 2 7 0 9 9 16 19 48 1 104 FIELD GOALS 1-19 20-29 30-39 40-49 50+ Gano 0\/ 0 0\/ 0 4\/ 5 4\/ 5 4\/ 4 TEAM 0\/ 0 0\/ 0 4\/ 5 4\/ 5 4\/ 4 OPPONENTS 0\/ 0 6\/ 6 5\/ 5 5\/ 6 0\/ 2","datePublished":"2022-10-21T14:09:08Z","dateModified":"2022-10-21T14:11:14Z","author":[{"@type":"Person","name":"","jobTitle":""}],"publisher":{"@type":"Organization","name":"Associated Press","logo":{"@type":"ImageObject","url":"https:\/\/www.MilfordMirror.com\/img\/ldjson_logo.png","width":600,"height":60},"sameAs":["http:\/\/facebook.com\/milfordmirror","http:\/\/twitter.com\/milfordmirror"]},"description":"Statistics after 6 games"}
</script>
<!-- e hearst/article/common/schema_NewsArticle.tpl -->        <!-- hearst/common/third_party_assets.tpl -->
                    <!-- hmb:juice Juice -->
        <script type="text/javascript">
            
                var startRevWorker = function() {
                    if (window.articleShowLISTQueue) {
                        while (window.articleShowLISTQueue.length > 0) {
                            var showListEntry = articleShowLISTQueue.shift();
                            window.aps.showLIST([showListEntry]);
                        }
                    }
                    if (window.placeAdQueue) {
                        while (window.placeAdQueue.length > 0) {
                            var placeAdEntry = placeAdQueue.shift();
                            window.aps.placeAd([placeAdEntry]);
                        }
                    }
                    if (window.slideshowShowLISTQueue) {
                        while (window.slideshowShowLISTQueue.length > 0) {
                            var ads = window.slideshowShowLISTQueue.shift();
                            window.aps.showLIST(ads);
                        }
                    }
                    window.juiceloaded = true;
                }
            
        </script>

        <!-- ENG-10074 If AB Test on Seattle we turn off Juice in order to use HTL code -->
                    <script  src="https://aps.hearstnp.com/Scripts/loadAds.js?v=1.3.3.5" type="text/javascript" id="adPositionManagerScriptTag"></script>
            
    <!-- hmb:ensighten Ensighten  -->
    <!-- hearst/ensighten/ensighten.tpl -->
<!-- hmb:ensighten Ensighten script -->
<!-- Hearst analytics: Ensighten -->
<script src="https://tm.hdmtools.com/hearst/news/Bootstrap.js"></script>
<!-- End Hearst analytics: Ensighten -->
<!-- e ensighten.tpl -->                    <!-- blueconic -->
        <script src="https://y752.milfordmirror.com/script.js" async></script>
            
    <!-- hmb:taboola Taboola  -->
                            
                            
                <script type="text/javascript">
                    
                    (function () {
                        window._taboolaNetworkMode = true;
                        
                        window._taboola = window._taboola || [];
                        window._taboolaHDNPageLabel = window._taboolaHDNPageLabel || 'article';
                        var tobj = {};
                        tobj[window._taboolaHDNPageLabel] = 'auto';
                        window._taboola.push(tobj);
                        !function (e, f, u, i) {
                            if (!document.getElementById(i)){
                                e.async = 1;
                                e.src = u;
                                e.id = i;
                                f.parentNode.insertBefore(e, f);
                            }
                        }(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/hearstlocalnews-network/loader.js', 'tb_loader_script');
                        if(window.performance && typeof window.performance.mark == 'function') {
                            window.performance.mark('tbl_ic');
                        }
                    })();
                </script>
                
                                <!-- e hearst/common/third_party_assets.tpl -->
    <link rel="shortcut icon" href="/favicon.ico">
    <link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon.png">
    <link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
    <link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
    <link rel="apple-touch-icon-precomposed" sizes="128x128" href="/apple-touch-icon-128x128.png">
            <!-- Hotfix Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.93530 -->
<!-- ENG-3363 -->
<style>
  .thumbnailListAuthor.one .thumbnailListAuthor--wrapper { margin: 0; }
  @media (min-width: 768px) { .thumbnailListAuthor.two .thumbnailListAuthor--wrapper { margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--items { justify-content: space-between; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--item { flex: 0 0 48%; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--spacer { display: none; } }
  @media (min-width: 928px) { .thumbnailListAuthor.three .thumbnailListAuthor--wrapper { margin: 0; } }
</style>
<!-- ENG-3834 -->
<style>
  .alert{background-color:#000;bottom:0;box-sizing:border-box;color:#fff;font-family:Helvetica,sans-serif;font-size:16px;font-weight:600;left:50%;line-height:1.25;overflow:hidden;padding:10px;position:fixed;transform:translateX(-50%);width:100vw;z-index:5000000}.alert .close{border-radius:8px;color:#fff;display:block;position:absolute;right:10px;height:16px;overflow:hidden;top:10px;width:16px}.alert .close::after{background-color:#fff;content:'';display:block;height:2px;left:-6px;position:relative;top:4px;transform:rotate(-45deg);width:30px}.alert .close::before{background-color:#fff;content:'';display:block;height:2px;left:-5px;position:relative;top:9px;transform:rotate(45deg);width:30px}.alert>div{box-sizing:border-box;max-width:1200px;margin:0 auto;position:relative;padding-right:34px}
</style>
<script>
  document.addEventListener('DOMContentLoaded', function() {
    if (/MSIE \d|Trident.*rv:/.test(navigator.userAgent)) {var site=HDN.domain,name=site.charAt(0).toUpperCase()+site.slice(1),section=document.createElement("section"),close=document.createElement("a");close.className="close",close.href="#",close.addEventListener("click",function(e){e.stopPropagation(),e.preventDefault(),e.target.parentElement.style.display="none"});var HTML="<div>Thank you for visiting "+name+". You are using an older browser that may impact your reading experience. For the best experience, we recommend you use Chrome, Safari, Firefox, or Edge.</div>";section.className="alert",section.id="warning",section.innerHTML=HTML,section.appendChild(close),document.getElementsByTagName("body")[0].appendChild(section);}
  }, false);
</script>
<!-- e ENG-3834 -->
<!--  Start ENG-8221 -->
<style>
@media (max-width:768px) {   
  .articleHeader:not(.heroleft):not(.herotextabove):not(.herocenter) .articleHeader--timestamp {     
    bottom: 0px !important;     
    margin-left: 0px !important;     
    position: relative;    
  }
}</style>
        <!-- Hotfix Freeform (Local Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.97469 -->
<!-- ENG-10491 -->
<style>
  .badge:not(.shopping):not(.sponsored-content):not(.paidad-content):before, 
  section.fourPack-breaking .fourPack--item .badge::before, 
  section.centerpiece .centerpiece-tab-primary.density>div:last-child .centerpiece-tab 
  .badge::before {
    display: none;
  }
  .thumbnail-list a.hideKicker, 
  .centerpiece div.hideKicker, 
  .dynamicSpotlight div.hideKicker, 
  .thumbnail-list div.hideKicker, 
  .thumbnail-list span.hideKicker,
  .dynamicSpotlight span.hideKicker {
    display: inherit;
  }
  .dynamicSpotlight div.hideKicker, 
  .dynamicSpotlight span.hideKicker {
    display: inline-block;
  }
  .centerpiece .badgeInline p.bullet span {
    display: none;
  }
  .centerpiece:not(.density) div.centerpiece-tab--main-kicker.hideKicker {
    display: block;
  }
  .thumbnail-list--item-header.badge.shopping .hideKicker > a, .thumbnail-list--item-header.badge.shopping .hideKicker > span {
    display: none;
  }
</style>
                    </head>
<!-- e hearst/article/headerMain.tpl -->    <body data-location="sports"  class="two-column">
                                                <!-- design/article/dynamic_two_column.tpl -->
    <!-- hearst/article/types/dynamic_two_column.tpl -->


<div id="zoneTop" class="zone full innerGrid" data-tb-region="zoneAboveMasthead"></div><!-- hearst/common/siteBranding.tpl -->
    <header class="pageHeader standard" data-stage="0">
        <div class="pageHeader--progress"><div class="pageHeader--progress-bar" id="progress"></div></div>    <div class="pageHeader--skipLink-wrapper">
        <a href="#content" class="pageHeader--skipLink" aria-label="Skip to main content">Skip to main content</a>
    </div>
    <div class="pageHeader--wrapper lock">
        <button id="navToggle" class="pageHeader--menuButton navToggle" role="button" tabindex="0" aria-expanded="false" aria-label="navigation"></button>                <a id="mastheadLogo" href="/" tabindex="0">Milford Mirror Homepage<span  class="pageHeader--logo mastheadLogo fade show hdn-analytics" role="img" aria-label="Milford Mirror Homepage - Site Logo" data-hdn-analytics="visit|masthead|navigation|0"></span></a>
                    <div id="titleBar" class="pageHeader--titleBar titleBar fade show hidden">
                                    <div class="pageHeader--titleBar-subsection">Currently Reading</div>
                    <div class="pageHeader--titleBar-title">New York Giants</div>
                            </div>
                            <div id="nextStory" class="pageHeader--nextStory nextStory fade show hidden"></div>
                            <ul class="pageHeader--links fade show">
                                                                                                                                        <li id="subscription" class="pageHeader--links-nonsub subscribeButton fade show hidden">
                                <a class="visible-xs-f subscribe" href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=button&ipid=wcm" target="_blank">Subscribe</a>
                                <a class="hidden-xs button" href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=button&ipid=wcm" target="_blank">Subscribe</a>
                            </li>
                                                                                                <li id="eEdition" class="pageHeader--links-sub eEdition fade show hidden"><a href="/e-edition">e-Edition</a></li>
                                                                                                                                        <!-- hearst/common/signin.tpl -->
<li class="treg-is-gigya gigya_menu ">
    <div class="gya-title expandable treg-conditional treg-not-logged-in">
        <a class="signIn featureSignIn" tabindex="0" role="button">Sign In</a>
    </div>
    <div class="gya-title expandable treg-conditional treg-logged-in" aria-controls="treg-login-widget" role="button"><span></span></div>
    <div class="gya-content expandable" id="treg-login-widget">
        <div class="treg-gya-login-widget"></div>
    </div>
</li>
<!-- e hearst/common/signin.tpl -->                <button class="pageHeader--searchButton searchToggle" aria-expanded="false" tabindex="0" aria-label="searchToggle" aria-controls="searchField-aria"></button>            </ul>
                            <div class="pageHeader--search searchField" id="searchField-aria">
                
                <form class="pageHeader--search-form" action="/search/" method="get">
                    <input type="hidden" name="action" value="search" />
                    <input type="hidden" name="firstRequest" value="1" />
                    <input type="hidden" name="searchindex" value="solr" />
                    <div class="fieldset">
                        <input class="pageHeader--search-input" id="search" name="query" type="text" value="" placeholder="Search" aria-label="search" />
                        <button class="searchButton btn" value="" name="search" type="submit" aria-label="search"></button>
                    </div>
                </form>
            </div>
            </div>
                                    
        <!-- hearst/home/HNavigation.tpl -->
<!-- hearst/home/navigation.tpl -->
         <!-- hearst/common/siteNavigation.tpl -->
<nav id="navigation" class="navigation"><div class="navigation--wrapper lock"><div class="navigation--menu"><ul class="hidden-sm hidden-md hidden-lg hidden-xl"><li class="single" data-length="1" data-index="1"><a href="/puzzles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="6062" data-hdn-analytics="visit|Puzzles|navigation-ard|1">Puzzles</a></li><li class="parent topLevel" data-length="6" data-index="0"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4941" data-hdn-analytics="visit|home|navigation-ard|2">home</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 132px"><li class="child"><a  href="https://link.milfordmirror.com/join/signup-mm" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5806" data-hdn-analytics="visit|home-Sign Up for Newsletters|navigation-ard|1">Sign Up for Newsletters</a></li><li class="child"><a  href="https://hearstmediact.newsbank.com/home" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4949" data-hdn-analytics="visit|home-Print Archives|navigation-ard|2">Print Archives</a></li><li class="child"><a  href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=hamburger&ipid=wcm" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4952" data-hdn-analytics="visit|home-Subscribe|navigation-ard|3">Subscribe</a></li><li class="child"><a  href="/news-submission-guidelines/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4944" data-hdn-analytics="visit|home-Submission Guidelines|navigation-ard|4">Submission Guidelines</a></li><li class="child"><a  href="/submissions/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4987" data-hdn-analytics="visit|home-Submissions|navigation-ard|5">Submissions</a></li></ul></li><li class="parent topLevel" data-length="9" data-index="2"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4997" data-hdn-analytics="visit|News|navigation-ard|3">News</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 176px"><li class="child"><a  href="/politics-elections/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4990" data-hdn-analytics="visit|News-Politics & Elections|navigation-ard|1">Politics & Elections</a></li><li class="child"><a  href="/news/town-government/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4991" data-hdn-analytics="visit|News-Town Government|navigation-ard|2">Town Government</a></li><li class="child"><a  href="/news/community/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4992" data-hdn-analytics="visit|News-Community|navigation-ard|3">Community</a></li><li class="child"><a  href="/news/education/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4994" data-hdn-analytics="visit|News-Education|navigation-ard|4">Education</a></li><li class="child"><a  href="/news/police-fire/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4995" data-hdn-analytics="visit|News-Police & Fire|navigation-ard|5">Police & Fire</a></li><li class="child"><a  href="/news/connecticut/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4998" data-hdn-analytics="visit|News-Connecticut|navigation-ard|6">Connecticut</a></li><li class="child"><a  href="/cannabis/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="6085" data-hdn-analytics="visit|News-Cannabis|navigation-ard|7">Cannabis</a></li><li class="child"><a  href="/opinion/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5812" data-hdn-analytics="visit|News-Opinion|navigation-ard|8">Opinion</a></li></ul></li><li class="single" data-length="1" data-index="3"><a href="/business/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4977" data-hdn-analytics="visit|Business|navigation-ard|4">Business</a></li><li class="single" data-length="1" data-index="4"><a href="https://www.legacy.com/obituaries/milfordmirror/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4979" data-hdn-analytics="visit|Obituaries|navigation-ard|5">Obituaries</a></li><li class="parent topLevel" data-length="3" data-index="5"><span role="heading" aria-level="2"><a  href="/sports/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4986" data-hdn-analytics="visit|Sports|navigation-ard|6">Sports</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/uconn/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5833" data-hdn-analytics="visit|Sports-UConn|navigation-ard|1">UConn</a></li><li class="child"><a  href="/sports/high-school-sports/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4985" data-hdn-analytics="visit|Sports-High School Sports|navigation-ard|2">High School Sports</a></li></ul></li><li class="parent topLevel" data-length="3" data-index="6"><span role="heading" aria-level="2"><a  href="/living/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5799" data-hdn-analytics="visit|Living|navigation-ard|7">Living</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/food/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5800" data-hdn-analytics="visit|Living-Food|navigation-ard|1">Food</a></li><li class="child"><a  href="/homegarden/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5354" data-hdn-analytics="visit|Living-Home and Garden|navigation-ard|2">Home and Garden</a></li></ul></li><li class="single" data-length="1" data-index="7"><a href="/entertainment/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4996" data-hdn-analytics="visit|Entertainment|navigation-ard|8">Entertainment</a></li><li class="parent topLevel" data-length="6" data-index="8"><span role="heading" aria-level="2"><a  href="/faq/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4948" data-hdn-analytics="visit|Help|navigation-ard|9">Help</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 132px"><li class="child"><a  href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CMM" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4947" data-hdn-analytics="visit|Help-Delivery Problems|navigation-ard|1">Delivery Problems</a></li><li class="child"><a  href="/about-us/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4945" data-hdn-analytics="visit|Help-About Us|navigation-ard|2">About Us</a></li><li class="child"><a  href="/contact/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4946" data-hdn-analytics="visit|Help-Contact Us|navigation-ard|3">Contact Us</a></li><li class="child"><a  href="/privacy/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4943" data-hdn-analytics="visit|Help-Privacy Notice|navigation-ard|4">Privacy Notice</a></li><li class="child"><a  href="/tos/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4942" data-hdn-analytics="visit|Help-Terms of Use|navigation-ard|5">Terms of Use</a></li></ul></li><li class="single" data-length="1" data-index="9"><a href="/shopping/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="6110" data-hdn-analytics="visit|Shopping|navigation-ard|10">Shopping</a></li><li class="parent topLevel" data-length="2" data-index="10"><span role="heading" aria-level="2"><a  href="/sponsoredarticles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5716" data-hdn-analytics="visit|Advertising Features|navigation-ard|11">Advertising Features</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/events-calendar/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="6007" data-hdn-analytics="visit|Advertising Features-Events|navigation-ard|1">Events</a></li></ul></li><li class="single" data-length="1" data-index="11"><a href="http://connecticut.ipublishmarketplace.com/connecticut-marketplace/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5002" data-hdn-analytics="visit|Classifieds|navigation-ard|1">Classifieds</a></li></ul></div></div><span class="rule"></span><div id="navToggle__page" class="navTogglePage"></div></nav>
<!-- e hearst/common/siteNavigation.tpl -->
<!-- e hearst/home/navigation.tpl --> <!-- e hearst/home/HNavigation.tpl -->    </header>

<!-- e hearst/common/siteBranding.tpl --> <main><section id="topZone" class="zone topZone"><!-- src/business/widgets/hearst/collection/widget.tpl -->

    <div class="hide-rss-link hdnce-e hdnce-collection-111519-dynamic_ribbon_articles"><!-- hearst/collections/dynamic_ribbon_articles.tpl -->
<!-- collection.dynamic_ribbon_articles.111519 -->
    <!-- design/collection/dynamic_ribbon_articles/single_zone.tpl -->
                                                                                                                                                <div class="articleRibbon" aria-label="carousel" role="region" data-component="collection" data-type="ribbon" data-collection-id="111519" data-collection-title="D- MM Article Ribbon Sports" data-type="list">
        <button class="articleRibbon--nav-btn articleRibbon--nav-prev fade" data-delta="-1" aria-label="Previous"></button>
        <div class="articleRibbon--wrapper">
            <ul class="articleRibbon--list">
                <div class="scrollSpacer"></div>
                                <div class="articleRibbon--list-wrapper" style="flex: 1 0 2200px;">
                    <span class="articleRibbon--list-title" role="heading" aria-level="2"><span class="articleRibbon--list-label"><!-- widgets/hearst/moduleHeader/widget.tpl -->
                                            <h2 role="heading" aria-level="2">Recommended</h2>
                        <!-- e widgets/hearst/moduleHeader/widget.tpl --></span></span>                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php" data-hdn-analytics="visit-from-img|article-17310688|-111519|1">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio1x1_100.jpg" alt="Members of the Milford Little League softball team celebrate after defeating Wallingford 9-4 Saturday for the program's fourth-straight state championship. Milford will represent Connecticut in the Little League World Series New England Regional at the A. Bartlett Giamatti Little League Leadership Training Center in Bristol. Milford opens play against Rhode Island Saturday at 4 p.m. on ESPN+.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php" data-hdn-analytics="visit|article-17310688|-111519|1" data-epe-inst="s:0;t:75" data-epe-title="1">Milford Little League softball wins 4th straight state title</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php" data-hdn-analytics="visit-from-img|article-17207808|-111519|2">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio1x1_100.jpg" alt="Lauren Vitti, Kelly Jones, Amanda Umbricht and Carys Cook broke the school record in the 4x800 at the SCC Championships.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php" data-hdn-analytics="visit|article-17207808|-111519|2" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton seventh at SCC track, relay sets record</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php" data-hdn-analytics="visit-from-img|article-17181447|-111519|3">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio1x1_100.jpg" alt="Katherine Baisley, Bria Colangelo, Emma Hoffman, Lauren Vitti, Katerina Koutouvides, Carys Cook and Kelly Jones medaled for Lauralton Hall at the SCC East Sectional meet.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php" data-hdn-analytics="visit|article-17181447|-111519|3" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton fifth at SCC East Sectional meet</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php" data-hdn-analytics="visit-from-img|article-17176456|-111519|4">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio1x1_100.jpg" alt="Foran improved to 9-8 with its win against previously unbeaten Amity.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php" data-hdn-analytics="visit|article-17176456|-111519|4" data-epe-inst="s:0;t:75" data-epe-title="1">HS update: Foran baseball upends No. 1 Amity</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php" data-hdn-analytics="visit-from-img|article-17172989|-111519|5">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio1x1_100.jpg" alt="Law’s Mike Merchant is safe at the plate as Hand catcher Connor Powell tags him too late.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php" data-hdn-analytics="visit|article-17172989|-111519|5" data-epe-inst="s:0;t:75" data-epe-title="1">Law edges Hand in high-scoring SCC tilt</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php" data-hdn-analytics="visit-from-img|article-17172988|-111519|6">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio1x1_100.jpg" alt="Lucia Pino is closing in on becoming the career wins leader at Law before going to Bryant University.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php" data-hdn-analytics="visit|article-17172988|-111519|6" data-epe-inst="s:0;t:75" data-epe-title="1">Lucia Pino closing in on Law record for wins</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php" data-hdn-analytics="visit-from-img|article-17170770|-111519|7">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio1x1_100.jpg" alt="Lauralton Hall's track team celebrates winning SCC Housatonic Division championship.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php" data-hdn-analytics="visit|article-17170770|-111519|7" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton track wins Housatonic Division</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php" data-hdn-analytics="visit-from-img|article-17162949|-111519|8">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio1x1_100.jpg" alt="Arezoo Ghazagh, Quincy Ercanbrack and Katharine Harrison captain the Foran girls track team.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php" data-hdn-analytics="visit|article-17162949|-111519|8" data-epe-inst="s:0;t:75" data-epe-title="1">Foran aided by newcomers, strong leadership</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php" data-hdn-analytics="visit-from-img|article-17147665|-111519|9">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio1x1_100.jpg" alt="McKenna Sharpe, Sydney Simpson, McKenzie Powers, Shelby Green and Lauren Davis captain Law girls track team.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php" data-hdn-analytics="visit|article-17147665|-111519|9" data-epe-inst="s:0;t:75" data-epe-title="1">Law track making its mark in early going of season</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php" data-hdn-analytics="visit-from-img|article-17128086|-111519|10">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio1x1_100.jpg" alt="Foran and Jonathan Law catchers and captains Kendall LaMorte and Nicolina Salanto have high hopes for their softball teams.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php" data-hdn-analytics="visit|article-17128086|-111519|10" data-epe-inst="s:0;t:75" data-epe-title="1">Foran, Law aiming to further success this postseason</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                    </div>
                <div class="scrollSpacer"></div>
            </ul>
        </div>
        <button class="articleRibbon--nav-btn articleRibbon--nav-next fade show " data-delta="1" aria-label="Next"></button>
    </div>
        <script type="text/javascript">
        var nextStory = [
                                                            {
                    "id": 17310688,
                    "headline": "Milford Little League softball wins 4th straight...",
                    "url": "/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php",
                    "image": "https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17207808,
                    "headline": "Lauralton seventh at SCC track, relay sets record",
                    "url": "/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php",
                    "image": "https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17181447,
                    "headline": "Lauralton fifth at SCC East Sectional meet",
                    "url": "/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php",
                    "image": "https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17176456,
                    "headline": "HS update: Foran baseball upends No. 1 Amity",
                    "url": "/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php",
                    "image": "https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17172989,
                    "headline": "Law edges Hand in high-scoring SCC tilt",
                    "url": "/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php",
                    "image": "https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17172988,
                    "headline": "Lucia Pino closing in on Law record for wins",
                    "url": "/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php",
                    "image": "https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17170770,
                    "headline": "Lauralton track wins Housatonic Division",
                    "url": "/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php",
                    "image": "https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17162949,
                    "headline": "Foran aided by newcomers, strong leadership",
                    "url": "/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php",
                    "image": "https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17147665,
                    "headline": "Law track making its mark in early going of season",
                    "url": "/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php",
                    "image": "https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17128086,
                    "headline": "Foran, Law aiming to further success this postseason",
                    "url": "/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php",
                    "image": "https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio3x2_100.jpg"
                }                    ];
    </script>
<!-- e design/collection/dynamic_ribbon_articles/single_zone.tpl --><!-- e hearst/collections/dynamic_ribbon_articles.tpl -->
</div><!-- e src/business/widgets/hearst/collection/widget.tpl --></section> <div class="belowMastheadWrapper"></div> <section id="content" class="article" data-type="dtc"><!-- hearst/article/articleHeader.tpl -->
            
    <header class="article--header articleHeader"><div class="articleHeader--breadcrumbs"><a class="articleHeader--breadcrumbs-item" href="https://www.milfordmirror.com/sports/">Sports</a></div><h1 class="articleHeader--headline" aria-labelledby="">New York Giants</h1><div class="articleHeader--subHead"><div class="articleHeader--byline"></div><div class="articleHeader--timestamp"><time class="articleHeader--timestamp-pubdate " datetime="2022-10-21 14:11:14">Oct. 21, 2022</time></div><div class="articleHeader--shareTools"><!-- hearst/common/shareTools.tpl -->
    
<div class="share-list comments">
    <a class="share-facebook" data-shareNetwork="facebook">Facebook</a>
    <a class="share-twitter" data-shareNetwork="twitter">Twitter</a>
    <a class="share-email" data-shareNetwork="email">Email</a>
            <div class="pipe"></div>
                    
                            <a class="share-comments" data-shareNetwork="comments" href="https://www.milfordmirror.com/sports/articleComments/New-York-Giants-17524667.php" onclick="document.location.href = document.location.href.replace('/article/','/articleComments/').replace('/slideshow/','/slideshowComments/'); return false;">Comments</a>
        <span class="share-count"></span>
    </div>
<!-- e hearst/common/shareTools.tpl --></div></div></header>
<!-- e hearst/article/articleHeader.tpl --><!-- hearst/common/chapterNavigation.tpl -->
        <!-- e hearst/common/chapterNavigation.tpl --><article class="article--content"><section id="articleTop" class="article--content-zone top"></section>            <p class="lead">Statistics after 6 games</p>
        <!-- hearst/article/content/relatedStories.tpl -->
    <section class="relatedStories" data-progressive="true"><div class="relatedStories--title articleModule"><div class="articleModule--title h4" role="heading" aria-level="2">More for you</div></div><ul class="relatedStories--list" data-total="2"><li class="relatedStories--item" data-number="1"><div class="slide" data-number="1"><a href="https://www.milfordmirror.com/sports/article/Yale-football-in-contention-for-Ivy-League-title-17523730.php" class="hdn-analytics"data-hdn-analytics="related_stories|article-17523730|article-17524667|1"><div class="slide--headline"><div class="slide--headline-title">Yale in contention for Ivy League title midway through s</div></div><div class="slide--image fullBleed"><picture class="deferred threeTwo" data-progressive="true" data-component="picture"><source data-srcset="https://s.hdnux.com/photos/01/27/73/37/23050183/5/ratio3x2_350.jpg 1x, https://s.hdnux.com/photos/01/27/73/37/23050183/5/ratio3x2_700.jpg 2x"><img data-src="https://s.hdnux.com/photos/01/27/73/37/23050183/5/ratio3x2_700.jpg" alt=""></picture></div></a></div></li><li class="relatedStories--item" data-number="2"><div class="slide" data-number="2"><a href="https://www.milfordmirror.com/college/article/Former-Enfield-star-Mary-Baskerville-Quinnipiac-17505838.php" class="hdn-analytics"data-hdn-analytics="related_stories|article-17505838|article-17524667|2"><div class="slide--headline"><div class="slide--headline-title">CT native thriving as transfer for Quinnipiac women's basketball</div></div><div class="slide--image fullBleed"><picture class="deferred threeTwo" data-progressive="true" data-component="picture"><source data-srcset="https://s.hdnux.com/photos/01/27/77/75/23068521/3/ratio3x2_350.jpg 1x, https://s.hdnux.com/photos/01/27/77/75/23068521/3/ratio3x2_700.jpg 2x"><img data-src="https://s.hdnux.com/photos/01/27/77/75/23068521/3/ratio3x2_700.jpg" alt=""></picture></div></a></div></li></ul></section>
     <!-- e hearst/article/content/relatedStories.tpl -->            <table xmlns="http://www.w3.org/2005/Atom" id="table-block-passing" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead>
<tr>
<th class="headline-col-name" colspan="1"></th>
<th class="headline-col-attempts" colspan="1"></th>
<th class="headline-col-completions" colspan="1"></th>
<th class="headline-col-completion-percentage" colspan="1">COMP</th>
<th class="headline-col-yards" colspan="1"></th>
<th class="headline-col-average-yards-gained" colspan="1">AVG</th>
<th class="headline-col-touchdowns" colspan="1"></th>
<th class="headline-col-touchdown-percentage" colspan="1">TD</th>
<th class="headline-col-interference" colspan="1"></th>
<th class="headline-col-interference-percentage" colspan="1">INT</th>
<th class="headline-col-interference-long" colspan="1"></th>
<th class="headline-col-rating" colspan="1"></th>
</tr>
<tr>
<th class="headline-col-name" colspan="1">PASSING</th>
<th class="headline-col-attempts" colspan="1">ATT.</th>
<th class="headline-col-completions" colspan="1">COM</th>
<th class="headline-col-completion-percentage" colspan="1">PCT</th>
<th class="headline-col-yards" colspan="1">YARDS</th>
<th class="headline-col-average-yards-gained" colspan="1">GAIN</th>
<th class="headline-col-touchdowns" colspan="1">TD</th>
<th class="headline-col-touchdown-percentage" colspan="1">PCT</th>
<th class="headline-col-interference" colspan="1">INT</th>
<th class="headline-col-interference-percentage" colspan="1">PCT</th>
<th class="headline-col-interference-long" colspan="1">LONG</th>
<th class="headline-col-rating" colspan="1">RATE</th>
</tr>
</thead>
<tbody>
<tr>
<td class="col-name">Jones</td>
<td class="col-attempts">159</td>
<td class="col-completions">107</td>
<td class="col-completion-percentage">67.3</td>
<td class="col-yards">1021</td>
<td class="col-average-yards-gained">6.42</td>
<td class="col-touchdowns">5</td>
<td class="col-touchdown-percentage">3.1</td>
<td class="col-interference">2</td>
<td class="col-interference-percentage">1.3</td>
<td class="col-interference-long">65t</td>
<td class="col-rating">90.2</td>
</tr>
<tr>
<td class="col-name">Taylor</td>
<td class="col-attempts">3</td>
<td class="col-completions">1</td>
<td class="col-completion-percentage">33.3</td>
<td class="col-yards">11</td>
<td class="col-average-yards-gained">3.67</td>
<td class="col-touchdowns">0</td>
<td class="col-touchdown-percentage">0.0</td>
<td class="col-interference">1</td>
<td class="col-interference-percentage">33.3</td>
<td class="col-interference-long">11</td>
<td class="col-rating">5.6</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-attempts">162</td>
<td class="col-completions">108</td>
<td class="col-completion-percentage">66.7</td>
<td class="col-yards">926</td>
<td class="col-average-yards-gained">6.37</td>
<td class="col-touchdowns">5</td>
<td class="col-touchdown-percentage">3.1</td>
<td class="col-interference">3</td>
<td class="col-interference-percentage">1.9</td>
<td class="col-interference-long">65t</td>
<td class="col-rating">86.8</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-attempts">186</td>
<td class="col-completions">108</td>
<td class="col-completion-percentage">58.1</td>
<td class="col-yards">1167</td>
<td class="col-average-yards-gained">6.62</td>
<td class="col-touchdowns">7</td>
<td class="col-touchdown-percentage">3.8</td>
<td class="col-interference">1</td>
<td class="col-interference-percentage">0.5</td>
<td class="col-interference-long">56</td>
<td class="col-rating">88.4</td>
</tr>
</tbody>
</table>
    <div id="paywall" class="content-wrapper">            <table xmlns="http://www.w3.org/2005/Atom" id="table-block-rushing" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead><tr>
<th class="headline-col-name" colspan="1">RUSHING</th>
<th class="headline-col-attempts" colspan="1">ATT.</th>
<th class="headline-col-yards" colspan="1">YARDS</th>
<th class="headline-col-average" colspan="1">AVG</th>
<th class="headline-col-long" colspan="1">LONG</th>
<th class="headline-col-touchdowns" colspan="1">TD</th>
</tr></thead>
<tbody>
<tr>
<td class="col-name">Barkley</td>
<td class="col-attempts">119</td>
<td class="col-yards">616</td>
<td class="col-average">5.2</td>
<td class="col-long">68</td>
<td class="col-touchdowns">4</td>
</tr>
<tr>
<td class="col-name">Jones</td>
<td class="col-attempts">47</td>
<td class="col-yards">236</td>
<td class="col-average">5.0</td>
<td class="col-long">21t</td>
<td class="col-touchdowns">2</td>
</tr>
<tr>
<td class="col-name">Breida</td>
<td class="col-attempts">17</td>
<td class="col-yards">49</td>
<td class="col-average">2.9</td>
<td class="col-long">13</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Taylor</td>
<td class="col-attempts">3</td>
<td class="col-yards">30</td>
<td class="col-average">10.0</td>
<td class="col-long">13</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Toney</td>
<td class="col-attempts">2</td>
<td class="col-yards">23</td>
<td class="col-average">11.5</td>
<td class="col-long">19</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Brightwell</td>
<td class="col-attempts">4</td>
<td class="col-yards">19</td>
<td class="col-average">4.8</td>
<td class="col-long">14</td>
<td class="col-touchdowns">1</td>
</tr>
<tr>
<td class="col-name">James</td>
<td class="col-attempts">2</td>
<td class="col-yards">6</td>
<td class="col-average">3.0</td>
<td class="col-long">4</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Bellinger</td>
<td class="col-attempts">1</td>
<td class="col-yards">2</td>
<td class="col-average">2.0</td>
<td class="col-long">2t</td>
<td class="col-touchdowns">1</td>
</tr>
<tr>
<td class="col-name">Gillan</td>
<td class="col-attempts">1</td>
<td class="col-yards">-3</td>
<td class="col-average">-3.0</td>
<td class="col-long">-3</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-attempts">196</td>
<td class="col-yards">978</td>
<td class="col-average">5.0</td>
<td class="col-long">68</td>
<td class="col-touchdowns">8</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-attempts">155</td>
<td class="col-yards">869</td>
<td class="col-average">5.6</td>
<td class="col-long">49</td>
<td class="col-touchdowns">2</td>
</tr>
</tbody>
</table>
        <!-- hearst/article/content/embed.tpl -->
        <section class="article--content-embed inline-iframe" data-eid="item-96892">
                        <div id="93066811-0534-4a7d-848c-7844b68ad1e1" class="hst-exco-player"></div><script>
(function (d, id) {
  var js, fjs = d.getElementsByTagName('script')[0];
  js = d.createElement('script');
  js.id = 'exco';
  js.dataset.src = 'https://player.ex.co/player/' + id;
  fjs.parentNode.insertBefore(js, fjs);
}(document, '93066811-0534-4a7d-848c-7844b68ad1e1'));
</script><!-- amp-exco-9dfa517e-768d-4e35-98d0-e65b9084c85e -->

            </section>
<!-- e hearst/article/content/embed.tpl -->            <table xmlns="http://www.w3.org/2005/Atom" id="table-block-receiving" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead><tr>
<th class="headline-col-name" colspan="1">RECEIVING</th>
<th class="headline-col-numbers" colspan="1">NO.</th>
<th class="headline-col-yards" colspan="1">YARDS</th>
<th class="headline-col-average" colspan="1">AVG</th>
<th class="headline-col-long" colspan="1">LONG</th>
<th class="headline-col-touchdowns" colspan="1">TD</th>
</tr></thead>
<tbody>
<tr>
<td class="col-name">Barkley</td>
<td class="col-numbers">21</td>
<td class="col-yards">155</td>
<td class="col-average">7.4</td>
<td class="col-long">41</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">James</td>
<td class="col-numbers">19</td>
<td class="col-yards">189</td>
<td class="col-average">9.9</td>
<td class="col-long">16</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Bellinger</td>
<td class="col-numbers">15</td>
<td class="col-yards">139</td>
<td class="col-average">9.3</td>
<td class="col-long">20</td>
<td class="col-touchdowns">2</td>
</tr>
<tr>
<td class="col-name">Shepard</td>
<td class="col-numbers">13</td>
<td class="col-yards">154</td>
<td class="col-average">11.8</td>
<td class="col-long">65t</td>
<td class="col-touchdowns">1</td>
</tr>
<tr>
<td class="col-name">Sills</td>
<td class="col-numbers">9</td>
<td class="col-yards">82</td>
<td class="col-average">9.1</td>
<td class="col-long">24</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Slayton</td>
<td class="col-numbers">8</td>
<td class="col-yards">108</td>
<td class="col-average">13.5</td>
<td class="col-long">26</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Johnson</td>
<td class="col-numbers">5</td>
<td class="col-yards">60</td>
<td class="col-average">12.0</td>
<td class="col-long">18</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Breida</td>
<td class="col-numbers">4</td>
<td class="col-yards">30</td>
<td class="col-average">7.5</td>
<td class="col-long">15</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">W.Robinson</td>
<td class="col-numbers">4</td>
<td class="col-yards">42</td>
<td class="col-average">10.5</td>
<td class="col-long">17</td>
<td class="col-touchdowns">1</td>
</tr>
<tr>
<td class="col-name">Hudson</td>
<td class="col-numbers">3</td>
<td class="col-yards">40</td>
<td class="col-average">13.3</td>
<td class="col-long">18</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Myarick</td>
<td class="col-numbers">3</td>
<td class="col-yards">11</td>
<td class="col-average">3.7</td>
<td class="col-long">6</td>
<td class="col-touchdowns">1</td>
</tr>
<tr>
<td class="col-name">Golladay</td>
<td class="col-numbers">2</td>
<td class="col-yards">22</td>
<td class="col-average">11.0</td>
<td class="col-long">15</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Toney</td>
<td class="col-numbers">2</td>
<td class="col-yards">0</td>
<td class="col-average">0.0</td>
<td class="col-long">2</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-numbers">108</td>
<td class="col-yards">1032</td>
<td class="col-average">9.6</td>
<td class="col-long">65t</td>
<td class="col-touchdowns">5</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-numbers">108</td>
<td class="col-yards">1232</td>
<td class="col-average">11.4</td>
<td class="col-long">56</td>
<td class="col-touchdowns">7</td>
</tr>
</tbody>
</table>
                <table xmlns="http://www.w3.org/2005/Atom" id="table-block-interceptions" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead><tr>
<th class="headline-col-name" colspan="1">INTERCEPTIONS</th>
<th class="headline-col-numbers" colspan="1">NO.</th>
<th class="headline-col-yards" colspan="1">YARDS</th>
<th class="headline-col-average" colspan="1">AVG</th>
<th class="headline-col-long" colspan="1">LONG</th>
<th class="headline-col-touchdowns" colspan="1">TD</th>
</tr></thead>
<tbody>
<tr>
<td class="col-name">Love</td>
<td class="col-numbers">1</td>
<td class="col-yards">27</td>
<td class="col-average">27.0</td>
<td class="col-long">27</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-numbers">1</td>
<td class="col-yards">27</td>
<td class="col-average">27.0</td>
<td class="col-long">27</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-numbers">3</td>
<td class="col-yards">4</td>
<td class="col-average">1.3</td>
<td class="col-long">7</td>
<td class="col-touchdowns">0</td>
</tr>
</tbody>
</table>
                <table xmlns="http://www.w3.org/2005/Atom" id="table-block-sacks" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead><tr>
<th class="headline-col-name" colspan="1">SACKS</th>
<th class="headline-col-numbers" colspan="1">NO.</th>
</tr></thead>
<tbody>
<tr>
<td class="col-name">Lawrence</td>
<td class="col-numbers">4.0</td>
</tr>
<tr>
<td class="col-name">Ximines</td>
<td class="col-numbers">2.0</td>
</tr>
<tr>
<td class="col-name">Crowder</td>
<td class="col-numbers">1.0</td>
</tr>
<tr>
<td class="col-name">Fox</td>
<td class="col-numbers">1.0</td>
</tr>
<tr>
<td class="col-name">Love</td>
<td class="col-numbers">1.0</td>
</tr>
<tr>
<td class="col-name">Ojulari</td>
<td class="col-numbers">1.0</td>
</tr>
<tr>
<td class="col-name">Thibodeaux</td>
<td class="col-numbers">1.0</td>
</tr>
<tr>
<td class="col-name">Ward</td>
<td class="col-numbers">1.0</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-numbers">13.0</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-numbers">19.0</td>
</tr>
</tbody>
</table>
                <table xmlns="http://www.w3.org/2005/Atom" id="table-block-punting" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead>
<tr>
<th class="headline-col-name" colspan="1"></th>
<th class="headline-col-numbers" colspan="1"></th>
<th class="headline-col-yards" colspan="1"></th>
<th class="headline-col-average" colspan="1">GROSS</th>
<th class="headline-col-average-net-yards" colspan="1">NET</th>
<th class="headline-col-past-in-20-yards" colspan="1">IN</th>
<th class="headline-col-long" colspan="1"></th>
<th class="headline-col-blocked" colspan="1"></th>
</tr>
<tr>
<th class="headline-col-name" colspan="1">PUNTING</th>
<th class="headline-col-numbers" colspan="1">NO.</th>
<th class="headline-col-yards" colspan="1">YARDS</th>
<th class="headline-col-average" colspan="1">AVG</th>
<th class="headline-col-average-net-yards" colspan="1">AVG</th>
<th class="headline-col-past-in-20-yards" colspan="1">20</th>
<th class="headline-col-long" colspan="1">LONG</th>
<th class="headline-col-blocked" colspan="1">BLK</th>
</tr>
</thead>
<tbody>
<tr>
<td class="col-name">Gillan</td>
<td class="col-numbers">25</td>
<td class="col-yards">1255</td>
<td class="col-average">50.2</td>
<td class="col-average-net-yards">41.6</td>
<td class="col-past-in-20-yards">8</td>
<td class="col-long">69</td>
<td class="col-blocked">0</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-numbers">25</td>
<td class="col-yards">1255</td>
<td class="col-average">50.2</td>
<td class="col-average-net-yards">41.6</td>
<td class="col-past-in-20-yards">8</td>
<td class="col-long">69</td>
<td class="col-blocked">0</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-numbers">25</td>
<td class="col-yards">1215</td>
<td class="col-average">48.6</td>
<td class="col-average-net-yards">43.7</td>
<td class="col-past-in-20-yards">13</td>
<td class="col-long">66</td>
<td class="col-blocked">0</td>
</tr>
</tbody>
</table>
                <table xmlns="http://www.w3.org/2005/Atom" id="table-block-punt-returns" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead><tr>
<th class="headline-col-name" colspan="1">PUNT RETURNS</th>
<th class="headline-col-numbers" colspan="1">NO.</th>
<th class="headline-col-fair-catches" colspan="1">FC</th>
<th class="headline-col-yards" colspan="1">YARDS</th>
<th class="headline-col-average" colspan="1">AVG</th>
<th class="headline-col-long" colspan="1">LONG</th>
<th class="headline-col-touchdowns" colspan="1">TD</th>
</tr></thead>
<tbody>
<tr>
<td class="col-name">James</td>
<td class="col-numbers">10</td>
<td class="col-fair-catches">0</td>
<td class="col-yards">76</td>
<td class="col-average">7.6</td>
<td class="col-long">22</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">Pinnock</td>
<td class="col-numbers">1</td>
<td class="col-fair-catches">0</td>
<td class="col-yards">0</td>
<td class="col-average">0.0</td>
<td class="col-long">0</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-numbers">11</td>
<td class="col-fair-catches">0</td>
<td class="col-yards">76</td>
<td class="col-average">6.9</td>
<td class="col-long">22</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-numbers">11</td>
<td class="col-fair-catches">0</td>
<td class="col-yards">149</td>
<td class="col-average">13.5</td>
<td class="col-long">46</td>
<td class="col-touchdowns">0</td>
</tr>
</tbody>
</table>
                <table xmlns="http://www.w3.org/2005/Atom" id="table-block-kickoff-returns" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead><tr>
<th class="headline-col-name" colspan="1">KICKOFF RETURNS</th>
<th class="headline-col-numbers" colspan="1">NO.</th>
<th class="headline-col-yards" colspan="1">YARDS</th>
<th class="headline-col-average" colspan="1">AVG</th>
<th class="headline-col-long" colspan="1">LONG</th>
<th class="headline-col-touchdowns" colspan="1">TD</th>
</tr></thead>
<tbody>
<tr>
<td class="col-name">Brightwell</td>
<td class="col-numbers">8</td>
<td class="col-yards">177</td>
<td class="col-average">22.1</td>
<td class="col-long">47</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-numbers">8</td>
<td class="col-yards">177</td>
<td class="col-average">22.1</td>
<td class="col-long">47</td>
<td class="col-touchdowns">0</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-numbers">11</td>
<td class="col-yards">229</td>
<td class="col-average">20.8</td>
<td class="col-long">36</td>
<td class="col-touchdowns">0</td>
</tr>
</tbody>
</table>
    <aside class="article--content-inline"><aside class="zone">
    
<!-- hearst/home/mostPopular.tpl -->

    <div class="mostPopular">
        <h2 class="collectionHeader" role="heading" aria-level="2">Most Popular</h2>
                                                <ol class="mostPopular--list">
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Bs-Twisted-Eats-Express-Milford-17519967.php" title="New eatery offers Milford a different take on takeout" data-hdn-analytics="visit|article-17519967|most_popular|0">New eatery offers Milford a different take on takeout</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/CT-state-police-audit-found-widespread-17506259.php" title="CT state police audit found widespread discrepancies with trooper ticket data" data-hdn-analytics="visit|article-17506259|most_popular|1">CT state police audit found widespread discrepancies with trooper ticket data</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Cop-killer-played-football-at-Bristol-Central-17515432.php" title="Nicholas Brutcher played football at Bristol Central with Aaron Hernandez and another accused killer" data-hdn-analytics="visit|article-17515432|most_popular|2">Nicholas Brutcher played football at Bristol Central with Aaron Hernandez and another accused killer</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/food/restaurants/article/Dennys-closings-in-CT-17516914.php" title="Denny's closes four Connecticut locations in less than two months" data-hdn-analytics="visit|article-17516914|most_popular|3">Denny's closes four Connecticut locations in less than two months</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Simone-family-Christmas-tree-Sundae-House-Milford-17509282.php" title="Milford Christmas tree sale tradition will continue" data-hdn-analytics="visit|article-17509282|most_popular|4">Milford Christmas tree sale tradition will continue</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Crash-killed-guardsman-days-before-wedding-17522251.php" title="CT guardsman, 19, killed in Waterbury crash days before wedding, general says" data-hdn-analytics="visit|article-17522251|most_popular|5">CT guardsman, 19, killed in Waterbury crash days before wedding, general says</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Route-8-northbound-closed-serious-crash-pedestrian-17520852.php" title="Torrington woman, 26, killed changing tire on Route 8 in Thomaston, police say" data-hdn-analytics="visit|article-17520852|most_popular|6">Torrington woman, 26, killed changing tire on Route 8 in Thomaston, police say</a>
                                                    </li>
                                    </ol>
                        </div>
<!--e hearst/home/mostPopular.tpl --></aside></aside>            <table xmlns="http://www.w3.org/2005/Atom" id="table-block-fumbles" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead>
<tr>
<th class="headline-col-name" colspan="1"></th>
<th class="headline-col-fumbles" colspan="1"></th>
<th class="headline-col-offensive-recovered" colspan="1">OFF.</th>
<th class="headline-col-defensive-recovered" colspan="1">DEF.</th>
</tr>
<tr>
<th class="headline-col-name" colspan="1">FUMBLES/RECOVERIES</th>
<th class="headline-col-fumbles" colspan="1">FUM</th>
<th class="headline-col-offensive-recovered" colspan="1">REC.</th>
<th class="headline-col-defensive-recovered" colspan="1">REC.</th>
</tr>
</thead>
<tbody>
<tr>
<td class="col-name">Barkley</td>
<td class="col-fumbles">1</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">0</td>
</tr>
<tr>
<td class="col-name">Belton</td>
<td class="col-fumbles">0</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">2</td>
</tr>
<tr>
<td class="col-name">Brightwell</td>
<td class="col-fumbles">0</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">1</td>
</tr>
<tr>
<td class="col-name">Jackson</td>
<td class="col-fumbles">0</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">1</td>
</tr>
<tr>
<td class="col-name">James</td>
<td class="col-fumbles">1</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">0</td>
</tr>
<tr>
<td class="col-name">Jones</td>
<td class="col-fumbles">2</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">0</td>
</tr>
<tr>
<td class="col-name">Pinnock</td>
<td class="col-fumbles">1</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">1</td>
</tr>
<tr>
<td class="col-name">Taylor</td>
<td class="col-fumbles">1</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">0</td>
</tr>
<tr>
<td class="col-name">Thibodeaux</td>
<td class="col-fumbles">0</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">1</td>
</tr>
<tr>
<td class="col-name">L.Williams</td>
<td class="col-fumbles">0</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">1</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-fumbles">6</td>
<td class="col-offensive-recovered">0</td>
<td class="col-defensive-recovered">7</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-fumbles">15</td>
<td class="col-offensive-recovered">7</td>
<td class="col-defensive-recovered">3</td>
</tr>
</tbody>
</table>
                <table xmlns="http://www.w3.org/2005/Atom" id="table-block-score-by-quarters" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead><tr>
<th class="headline-col-name" colspan="1">SCORE BY QUARTERS</th>
<th class="headline-col-quarter-1" colspan="1">1</th>
<th class="headline-col-quarter-2" colspan="1">2</th>
<th class="headline-col-quarter-3" colspan="1">3</th>
<th class="headline-col-quarter-4" colspan="1">4</th>
<th class="headline-col-quarter-overtime" colspan="1">OT</th>
<th class="headline-col-total" colspan="1">TOT</th>
</tr></thead>
<tbody>
<tr>
<td class="col-name">TEAM</td>
<td class="col-quarter-1">16</td>
<td class="col-quarter-2">24</td>
<td class="col-quarter-3">39</td>
<td class="col-quarter-4">48</td>
<td class="col-quarter-overtime">0</td>
<td class="col-total">127</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-quarter-1">26</td>
<td class="col-quarter-2">38</td>
<td class="col-quarter-3">27</td>
<td class="col-quarter-4">22</td>
<td class="col-quarter-overtime">0</td>
<td class="col-total">113</td>
</tr>
</tbody>
</table>
                <table xmlns="http://www.w3.org/2005/Atom" id="table-block-scoring" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead>
<tr>
<th class="headline-col-name" colspan="1"></th>
<th class="headline-col-touchdowns-total" colspan="1">TOUCHDOWNS</th>
<th class="headline-col-rushing-touchdowns" colspan="1"></th>
<th class="headline-col-receiving-touchdowns" colspan="1"></th>
<th class="headline-col-returns" colspan="1"></th>
<th class="headline-col-extra-points" colspan="1"></th>
<th class="headline-col-extra-points-opponent" colspan="1"></th>
<th class="headline-col-field-goals-made" colspan="1"></th>
<th class="headline-col-field-goals-opponent" colspan="1"></th>
<th class="headline-col-longest-field-goal" colspan="1">LONG</th>
<th class="headline-col-safteys" colspan="1"></th>
<th class="headline-col-points" colspan="1"></th>
</tr>
<tr>
<th class="headline-col-name" colspan="1">SCORING</th>
<th class="headline-col-touchdowns-total" colspan="1">TOT</th>
<th class="headline-col-rushing-touchdowns" colspan="1">RUS</th>
<th class="headline-col-receiving-touchdowns" colspan="1">REC</th>
<th class="headline-col-returns" colspan="1">RET</th>
<th class="headline-col-extra-points" colspan="1">XP</th>
<th class="headline-col-extra-points-opponent" colspan="1">XPA</th>
<th class="headline-col-field-goals-made" colspan="1">FG</th>
<th class="headline-col-field-goals-opponent" colspan="1">FGA</th>
<th class="headline-col-longest-field-goal" colspan="1">FG</th>
<th class="headline-col-safteys" colspan="1">SAF</th>
<th class="headline-col-points" colspan="1">TOT</th>
</tr>
</thead>
<tbody>
<tr>
<td class="col-name">Gano</td>
<td class="col-touchdowns-total">0</td>
<td class="col-rushing-touchdowns">0</td>
<td class="col-receiving-touchdowns">0</td>
<td class="col-returns">0</td>
<td class="col-extra-points">11</td>
<td class="col-extra-points-opponent">11</td>
<td class="col-field-goals-made">12</td>
<td class="col-field-goals-opponent">14</td>
<td class="col-longest-field-goal">56</td>
<td class="col-safteys">0</td>
<td class="col-points">47</td>
</tr>
<tr>
<td class="col-name">Barkley</td>
<td class="col-touchdowns-total">4</td>
<td class="col-rushing-touchdowns">4</td>
<td class="col-receiving-touchdowns">0</td>
<td class="col-returns">0</td>
<td class="col-extra-points">0</td>
<td class="col-extra-points-opponent">0</td>
<td class="col-field-goals-made">0</td>
<td class="col-field-goals-opponent">0</td>
<td class="col-longest-field-goal">0</td>
<td class="col-safteys">0</td>
<td class="col-points">26</td>
</tr>
<tr>
<td class="col-name">Bellinger</td>
<td class="col-touchdowns-total">3</td>
<td class="col-rushing-touchdowns">1</td>
<td class="col-receiving-touchdowns">2</td>
<td class="col-returns">0</td>
<td class="col-extra-points">0</td>
<td class="col-extra-points-opponent">0</td>
<td class="col-field-goals-made">0</td>
<td class="col-field-goals-opponent">0</td>
<td class="col-longest-field-goal">0</td>
<td class="col-safteys">0</td>
<td class="col-points">18</td>
</tr>
<tr>
<td class="col-name">Jones</td>
<td class="col-touchdowns-total">2</td>
<td class="col-rushing-touchdowns">2</td>
<td class="col-receiving-touchdowns">0</td>
<td class="col-returns">0</td>
<td class="col-extra-points">0</td>
<td class="col-extra-points-opponent">0</td>
<td class="col-field-goals-made">0</td>
<td class="col-field-goals-opponent">0</td>
<td class="col-longest-field-goal">0</td>
<td class="col-safteys">0</td>
<td class="col-points">14</td>
</tr>
<tr>
<td class="col-name">Brightwell</td>
<td class="col-touchdowns-total">1</td>
<td class="col-rushing-touchdowns">1</td>
<td class="col-receiving-touchdowns">0</td>
<td class="col-returns">0</td>
<td class="col-extra-points">0</td>
<td class="col-extra-points-opponent">0</td>
<td class="col-field-goals-made">0</td>
<td class="col-field-goals-opponent">0</td>
<td class="col-longest-field-goal">0</td>
<td class="col-safteys">0</td>
<td class="col-points">6</td>
</tr>
<tr>
<td class="col-name">Myarick</td>
<td class="col-touchdowns-total">1</td>
<td class="col-rushing-touchdowns">0</td>
<td class="col-receiving-touchdowns">1</td>
<td class="col-returns">0</td>
<td class="col-extra-points">0</td>
<td class="col-extra-points-opponent">0</td>
<td class="col-field-goals-made">0</td>
<td class="col-field-goals-opponent">0</td>
<td class="col-longest-field-goal">0</td>
<td class="col-safteys">0</td>
<td class="col-points">6</td>
</tr>
<tr>
<td class="col-name">W.Robinson</td>
<td class="col-touchdowns-total">1</td>
<td class="col-rushing-touchdowns">0</td>
<td class="col-receiving-touchdowns">1</td>
<td class="col-returns">0</td>
<td class="col-extra-points">0</td>
<td class="col-extra-points-opponent">0</td>
<td class="col-field-goals-made">0</td>
<td class="col-field-goals-opponent">0</td>
<td class="col-longest-field-goal">0</td>
<td class="col-safteys">0</td>
<td class="col-points">6</td>
</tr>
<tr>
<td class="col-name">Shepard</td>
<td class="col-touchdowns-total">1</td>
<td class="col-rushing-touchdowns">0</td>
<td class="col-receiving-touchdowns">1</td>
<td class="col-returns">0</td>
<td class="col-extra-points">0</td>
<td class="col-extra-points-opponent">0</td>
<td class="col-field-goals-made">0</td>
<td class="col-field-goals-opponent">0</td>
<td class="col-longest-field-goal">0</td>
<td class="col-safteys">0</td>
<td class="col-points">6</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-touchdowns-total">13</td>
<td class="col-rushing-touchdowns">8</td>
<td class="col-receiving-touchdowns">5</td>
<td class="col-returns">0</td>
<td class="col-extra-points">11</td>
<td class="col-extra-points-opponent">11</td>
<td class="col-field-goals-made">12</td>
<td class="col-field-goals-opponent">14</td>
<td class="col-longest-field-goal">56</td>
<td class="col-safteys">0</td>
<td class="col-points">114</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-touchdowns-total">9</td>
<td class="col-rushing-touchdowns">2</td>
<td class="col-receiving-touchdowns">7</td>
<td class="col-returns">0</td>
<td class="col-extra-points">9</td>
<td class="col-extra-points-opponent">9</td>
<td class="col-field-goals-made">16</td>
<td class="col-field-goals-opponent">19</td>
<td class="col-longest-field-goal">48</td>
<td class="col-safteys">1</td>
<td class="col-points">104</td>
</tr>
</tbody>
</table>
                <table xmlns="http://www.w3.org/2005/Atom" id="table-block-field-goals" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead><tr>
<th class="headline-col-name" colspan="1">FIELD GOALS</th>
<th class="headline-col-1-19-yards-attempted-made" colspan="2">1-19</th>
<th class="headline-col-20-29-yards-attempted-made" colspan="2">20-29</th>
<th class="headline-col-30-39-yards-attempted-made" colspan="2">30-39</th>
<th class="headline-col-40-49-yards-attempted-made" colspan="2">40-49</th>
<th class="headline-col-50-pluss-yards-attempted-made" colspan="2">50+</th>
</tr></thead>
<tbody>
<tr>
<td class="col-name">Gano</td>
<td class="col-1-19-yards-made">0/</td>
<td class="col-1-19-yards-attempted">0</td>
<td class="col-20-29-yards-made">0/</td>
<td class="col-20-29-yards-attempted">0</td>
<td class="col-30-39-yards-made">4/</td>
<td class="col-30-39-yards-attempted">5</td>
<td class="col-40-49-yards-made">4/</td>
<td class="col-40-49-yards-attempted">5</td>
<td class="col-50-pluss-yards-made">4/</td>
<td class="col-50-pluss-yards-attempted">4</td>
</tr>
<tr>
<td class="col-name">TEAM</td>
<td class="col-1-19-yards-made">0/</td>
<td class="col-1-19-yards-attempted">0</td>
<td class="col-20-29-yards-made">0/</td>
<td class="col-20-29-yards-attempted">0</td>
<td class="col-30-39-yards-made">4/</td>
<td class="col-30-39-yards-attempted">5</td>
<td class="col-40-49-yards-made">4/</td>
<td class="col-40-49-yards-attempted">5</td>
<td class="col-50-pluss-yards-made">4/</td>
<td class="col-50-pluss-yards-attempted">4</td>
</tr>
<tr>
<td class="col-name">OPPONENTS</td>
<td class="col-1-19-yards-made">0/</td>
<td class="col-1-19-yards-attempted">0</td>
<td class="col-20-29-yards-made">6/</td>
<td class="col-20-29-yards-attempted">6</td>
<td class="col-30-39-yards-made">5/</td>
<td class="col-30-39-yards-attempted">5</td>
<td class="col-40-49-yards-made">5/</td>
<td class="col-40-49-yards-attempted">6</td>
<td class="col-50-pluss-yards-made">0/</td>
<td class="col-50-pluss-yards-attempted">2</td>
</tr>
</tbody>
</table>
    <section id="articleBottom" class="article--content-zone bottom"></section></div></article><!-- hearst/article/articleAside.tpl -->
<aside class="article--aside slideshow--aside">
    <aside id="zoneD" class="zone">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85203 -->
    <div class="hst-freeform hdnce-e hdnce-item-85203">
                <script type="text/javascript" id="taboola-right-rail-script-id">
(function () {
    window._taboolaRRI = window._taboolaRRI || 0;
    window._taboolaRRI++;
    var e = document.documentElement;
    var g = document.getElementsByTagName('body')[0];
    var w = window.innerWidth||e.clientWidth||g.clientWidth;
    if ( (w >= 768 && window._taboolaRRI === 1) || (w < 768 && window._taboolaRRI === 2) ){
        var c = 'taboola-right-rail-thumbnails';
        var p = 'Right Rail Thumbnails';
        var m = 'rr';
        try {
            if (window._taboolaNetworkMode) {
                c = c + '---redesign';
                p = p + ' - Redesign';
                if (HDN.dataLayer.content.objectType  === 'article') {
                    m = 'f';
                if (HDN.dataLayer.presentation.infiniteScrollEnabled && (window.infiniteScroll && window.infiniteScroll.length > 0) && HDN.dataLayer.content.objectId && window.Article.isSensitive !== true && (Object.hasOwnProperty.call(HDN, 'activeABTest') && HDN.activeABTest === 'ENG9746')) {
                    p = 'Right Rail Thumbnails';
                    m = '1x8-rr';
                }
                }
            }
        } catch (e) {}
        var d = document.createElement('div');
        d.id = c;
        var s = document.getElementById('taboola-right-rail-script-id');
        s.parentNode.insertBefore(d, s);
        window._taboola = window._taboola || [];
        _taboola.push({
            mode: 'thumbnails-' + m,
            container: c,
            placement: p,
            target_type: 'mix'
        });
    }
})();
</script>
    </div>
            </aside>
    <aside id="zoneC" class="zone">
    
<!-- hearst/home/mostPopular.tpl -->

    <div class="mostPopular">
        <h2 class="collectionHeader" role="heading" aria-level="2">Most Popular</h2>
                                                <ol class="mostPopular--list">
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Bs-Twisted-Eats-Express-Milford-17519967.php" title="New eatery offers Milford a different take on takeout" data-hdn-analytics="visit|article-17519967|most_popular|0">New eatery offers Milford a different take on takeout</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/CT-state-police-audit-found-widespread-17506259.php" title="CT state police audit found widespread discrepancies with trooper ticket data" data-hdn-analytics="visit|article-17506259|most_popular|1">CT state police audit found widespread discrepancies with trooper ticket data</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Cop-killer-played-football-at-Bristol-Central-17515432.php" title="Nicholas Brutcher played football at Bristol Central with Aaron Hernandez and another accused killer" data-hdn-analytics="visit|article-17515432|most_popular|2">Nicholas Brutcher played football at Bristol Central with Aaron Hernandez and another accused killer</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/food/restaurants/article/Dennys-closings-in-CT-17516914.php" title="Denny's closes four Connecticut locations in less than two months" data-hdn-analytics="visit|article-17516914|most_popular|3">Denny's closes four Connecticut locations in less than two months</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Simone-family-Christmas-tree-Sundae-House-Milford-17509282.php" title="Milford Christmas tree sale tradition will continue" data-hdn-analytics="visit|article-17509282|most_popular|4">Milford Christmas tree sale tradition will continue</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Crash-killed-guardsman-days-before-wedding-17522251.php" title="CT guardsman, 19, killed in Waterbury crash days before wedding, general says" data-hdn-analytics="visit|article-17522251|most_popular|5">CT guardsman, 19, killed in Waterbury crash days before wedding, general says</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Route-8-northbound-closed-serious-crash-pedestrian-17520852.php" title="Torrington woman, 26, killed changing tire on Route 8 in Thomaston, police say" data-hdn-analytics="visit|article-17520852|most_popular|6">Torrington woman, 26, killed changing tire on Route 8 in Thomaston, police say</a>
                                                    </li>
                                    </ol>
                        </div>
<!--e hearst/home/mostPopular.tpl --></aside>
</aside>
<!-- e hearst/article/articleAside.tpl --><!-- hearst/article/articleFooter.tpl -->
<footer class="article--footer"><!-- hearst/common/author_body.tpl -->
     
        <div class="articleFooter">
                                <div class="articleFooter--author noImage">
                <div class="articleFooter--author-label">Written By </div>                    <div class="articleFooter--author-name"></div>
                </div>
                    </div>
<!-- e hearst/common/author_body.tpl --><section class="article--comments"><button id="commentsButton" data-link="https://www.milfordmirror.com/sports/articleComments/New-York-Giants-17524667.php" onclick="document.location.href = 'https://www.milfordmirror.com/sports/articleComments/New-York-Giants-17524667.php'; return false;">View Comments</button></section></footer>
<!-- e hearst/article/articleFooter.tpl --></section><section id="bottomZone" class="zone bottomZone lock">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85204 -->
    <div class="hst-freeform hdnce-e hdnce-item-85204">
                <script type="text/javascript" id="taboola-feed-script-id">
(function () {
    var c = 'taboola-below-article-thumbnails';
    var p = 'Below Article Thumbnails';
    try {
        if (window._taboolaNetworkMode) {
            var e = document.documentElement;
            var g = document.getElementsByTagName('body')[0];
            var w = window.innerWidth||e.clientWidth||g.clientWidth;
            if (w < 768) {
                c = 'taboola-mobile-below-article-feed---redesign';
                p = 'Mobile Below Article Feed - Redesign';
            } else {
                c = 'taboola-below-article-feed---redesign';
                p = 'Below Article Feed - Redesign';
            }
        }
    } catch (e) {}
    var d = document.createElement('div');
    d.id = c;
    var s = document.getElementById('taboola-feed-script-id');
    s.parentNode.insertBefore(d, s);
    window._taboola = window._taboola || [];
    window._taboola.push({
        mode: 'thumbnails-a',
        container: c,
        placement: p,
        target_type: 'mix'
    });
})();
</script>
    </div>
            <div class="taboola-skip-wrapper"><div id="taboola-skip"></div></div></section></main><!-- hearst/common/siteFooter.tpl -->
    <footer class="pageFooter">
    <div class="lock">
        <div class="pageFooter--wrapper">
            <div class="pageFooter--left">
                <a href="/">
                    <img class="pageFooter--left-logo" src="/img/logos/black/logo.svg" alt="Milford Mirror Homepage - Site Logo">
                </a>
                <ul class="pageFooter--left-social">
                    <li class="facebook"><a href="http://facebook.com/milfordmirror" aria-label="facebook"></a></li>                    <li class="twitter"><a href="http://twitter.com/milfordmirror" aria-label="twitter"></a></li>                                                        </ul>
            </div>
            <div class="pageFooter--right">
                <div class="pageFooter--right-topLine">
                    <a href="#content" class="return"><span class="full">Return to</span> Top</a>
                </div>
                <div class="pageFooter--right-links">
                    
                    <!-- hearst/item/standalone.tpl -->
<div class="hdnce-e hdnce-item-97493"><!-- mid:freeform.97493 -->
<style>
@media (min-width: 768px) {
  .pageFooter--right-links .wrapper > li:nth-child(2) {
    box-sizing: border-box;
    padding-left: 50px;
  }
}
</style>
<ul class="wrapper" role="presentation">
  <li>
<div class="title" role="heading" aria-level="2">About</div>
    <ul class="section" role="presentation">
      <li><a href="/home/article/How-Hearst-Newspapers-is-delivering-information-15678014.php">Newspaper Delivery Safety Procedures</a></li>
      <li><a href="/privacy/">Privacy Notice</a></li>
      <li><a href="/privacy/#additionalinformationforcaliforniaresidents">Your California Privacy Rights</a></li>
      <li><a href="/privacy/#interestbasedads">Interest Based Ads</a></li>
      <li><a href="/tos/">Terms of Use</a></li>
      <li><a href="https://eevd.fa.us6.oraclecloud.com/hcmUI/CandidateExperience/en/sites/CX_11004">Careers</a></li>
      <li><a href="https://hearstmediact.com/">Advertising</a></li>
    </ul>
  </li>
  <li>
<div class="title" role="heading" aria-level="2">Contact</div>
    <ul class="section" role="presentation">
      <li><a href="/contact/">Contact Us</a></li>
      <li><a href="/help/">FAQ's</a></li>
      <li><a href="https://subscription.hearstmediact.com/eEdition?siteID=CT_MM">E-Edition</a></li>
      <li><a href="/submissions/">Submissions</a></li>
    </ul>
  </li>
  <li>
<div class="title" role="heading" aria-level="2">Connect</div>
    <ul class="section" role="presentation">
      <li><a href="https://subscription.hearstmediact.com/checkout/700/1482?siteid=CT_MM&amp;origin=subserv&amp;ipid=footer">Subscribe Today</a></li>
      <li><a href="https://www.facebook.com/milfordmirror">Facebook</a></li>
      <li><a href="https://twitter.com/milfordmirror">Twitter</a></li>
    </ul>
  </li>
  <li>
</li>
</ul>
</div><!-- / hdnce-e -->                </div>
            </div>
        </div>
        <div class="pageFooter--branding">
            <img class="pageFooter--branding-logo" src="/img/core/hearst_newspapers_logo.svg" alt="HEARST newspapers logo" />
            <span class="pageFooter--branding-copyright">&copy;2022 Hearst</span>
        </div>
    </div>
                        <!-- hearst/common/spotImFooterJS.tpl -->
<script>
                                
        if ( document.readyState === "complete" || (document.readyState !== "loading" && !document.documentElement.doScroll)) {
            if (HDN && HDN.hasOwnProperty('spotim')) {
                HDN.spotim.commentCount(undefined,undefined,1);
            }
        } else {
            document.addEventListener("DOMContentLoaded", function() { 
                        if (HDN && HDN.hasOwnProperty('spotim')) {
                            HDN.spotim.commentCount(undefined,undefined,1);
                        }
                    });
        }
    
</script>
<!-- e hearst/common/spotImFooterJS.tpl -->
                            
                <script type="text/javascript">
                    window._taboola = window._taboola || [];
                    _taboola.push({flush: true});
                </script>
            
                    </footer>
<!-- e hearst/common/siteFooter.tpl -->
<!-- e hearst/article/types/dynamic_two_column.tpl --><!-- e design/article/dynamic_two_column.tpl -->                            </body>
</html>
<!-- e hearst/article/articleMain.tpl --><!-- e hearst/article/article_main.tpl -->