




<!-- hearst/article/article_main.tpl -->

            <!-- hearst/article/articleMain.tpl -->



    
        <!doctype html>
<html class="no-js "  lang="en-US" prefix="og: http://ogp.me/ns#  article: http://ogp.me/ns/article#">
    <head>

    <!-- Includes for HashTag Labs -->
    
    <!-- eid:article.17392499 -->
    <!-- generated at 2022-08-23 14:10:06 on pwcm6 running vv13.4.6 -->
    <!-- hearst/article/headerMain.tpl -->
            <!-- hmb:jquery jQuery JS -->
        <script type="text/javascript" src="/js/core/libs/jquery-2.2.4.min.js"></script>
                <!-- hmb:treg TREG JS -->
        <script type="text/javascript">window.tregEnabled = true;</script>
        <script type="text/javascript" src="//treg.hearstnp.com/treg.js"></script>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
            <!-- hmb:taboola Sailthru  -->
        <!-- hearst/home/header_sailthru.tpl -->
<meta property="sailthru.title" content="Angels owner Arte Moreno explores selling franchise" /><meta name="sailthru.date" content="2022-08-23 14:53:00 -0400" /><meta name="sailthru.author" content="" /><meta name="sailthru_uid" content="17392499" /><meta name="sailthru_pubname" content="associated-press" /><meta name="sailthru_siteid" content="79" /><meta name="sailthru.tags" content="arte-moreno,shohei-ohtani-professional-athlete-sports-figure-person,mike-trout-professional-athlete-sports-figure,shohei-ohtani,josh-hamilton,albert-pujols,al-mvps,mexican-american,los-angeles,california,north-america,united-states,anaheim,arizona,japan,washington,ap,galatioto-sports-partners,los-angeles-angels,major-league-baseball,washington-nationals,angels-moreno-sale,world-series,news-sports-stories,top-news,member-choice-z-sports-option,member-choice-sports-option,choice-plus,professional-athlete-sports-figure,california-z-sports-only,mike-trout,california-sports,https-twitter-com-ap-sports,ap,galatioto-sports-partners,los-angeles-angels,major-league-baseball,washington-nationals,arte-moreno,shohei-ohtani-professional-athlete-sports-figure-person,mike-trout-professional-athlete-sports-figure,shohei-ohtani,josh-hamilton,albert-pujols,al-mvps,mexican-american,los-angeles,california,north-america,united-states,anaheim,arizona,japan,washington,news-sports-stories,angels-moreno-sale,world-series,member-choice-z-sports-option,member-choice-sports-option,choice-plus,professional-athlete-sports-figure,california-z-sports-only,mike-trout,california-sports,https-twitter-com-ap-sports,2fsports-2fteam-sports-2fbaseball,2fnews-2fsports-news" /><meta name="sailthru.image.thumb" content="https://s.hdnux.com/photos/01/27/10/07/22839798/3/sailthruImage.jpg" />
<!-- e hearst/home/header_sailthru.tpl -->
    
            <title>Angels owner Arte Moreno explores selling franchise</title>
    <!-- hearst/common/fonts.tpl -->
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-regular.woff" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-300.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-600.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<!-- e hearst/common/fonts.tpl -->

        <script>
          if ( document.location.hostname.match(/\.$/) ) {
              document.location.replace(
                  document.location.protocol +
                  '//' +
                  document.location.hostname.replace(/\.+$/, '') +
                  ( undefined !== document.location.pathname ? document.location.pathname : '' ) +
                  ( undefined !== document.location.search ? document.location.search : '' )  +
                  ( undefined !== document.location.hash ? document.location.hash : '' )
              );
          }
        </script>

    <script>
                var HDN = HDN || {};
        HDN.t_firstbyte = Number(new Date());
        HDN.dataLayer = HDN.dataLayer || {};
        HDN.dataLayer.content = HDN.dataLayer.content || {};
                HDN.dataLayer.paywall = HDN.dataLayer.paywall || {};
        HDN.dataLayer.paywall.accessRule = "";
        HDN.dataLayer.paywall.mode = "";
        var Article = {
            "id": "17392499",
            "title": "Angels owner Arte Moreno explores selling franchise",
            "url": "https://www.milfordmirror.com/sports/article/Angels-owner-Arte-Moreno-explores-selling-17392499.php",
            "slug": "https://www.milfordmirror.com/sports/article/Angels-owner-Arte-Moreno-explores-selling-17392499.php",
            "summary": "ANAHEIM, Calif. (AP) — Los Angeles Angels owner Arte Moreno says he is exploring the...",
            "image": "https://s.hdnux.com/photos/01/27/10/07/22839798/3/rawImage.jpg",
            "keywords": "",
            "siteName": "Milford Mirror",
            "env": "pwcm6",
            "comments": true,
            "isSensitive": false,
            "version": "v13.4.6",
            "displayTemplate": "dynamic_two_column",
            "renderNLP": true,
            "timing": {
                "firstbyte": HDN.t_firstbyte,
                "ready": {}
            }
        };
        
        document.addEventListener('DOMContentLoaded', function () {
            Article.timing.ready = Number(new Date());
        }, false);
        
    </script>
        
    <!-- hearst/common/hdn_datalayer_header.tpl -->

                                                                
<script type="text/javascript">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</script>
<!-- e hearst/common/hdn_datalayer_header.tpl -->
    <script type="text/javascript" src="/js/site.js?v13.4.6"></script>
            
            <!-- Hotfix Top Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.94216 -->
<!-- DO NOT REMOVE -->
<script src="https://projects.sfchronicle.com/shared/js/responsive-frame.js"></script>
<!-- e DO NOT REMOVE -->
        <!-- Hotfix Top Freeform (Local Dynamic Two-Column) -->
        
<!-- noGen: item_header_hotfix_top_dtc_ssl 79 dne  -->
                <link rel="stylesheet" href="/dist/article.min.css?v13.4.6">
                            <!-- hmb:Polyfill  -->
        <script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=IntersectionObserver%2CIntersectionObserverEntry%2CPromise%2CCustomEvent%2CArray.prototype.forEach%2CArray.prototype.entries"></script>
                <!-- hmb:js_header Static JS Bundle  -->
        <script type="text/javascript" src="/dist/hdn/article.min.js?v13.4.6"></script>
        <!-- hearst/article/common/meta_tags.tpl -->
<meta name="msvalidate.01" content="9451CA04ABC9D1D5C6419C73B4C4F7B7" />
<meta name="HandheldFriendly" content="true">
<meta name="twitter:dnt" content="on">
<meta name="apple-mobile-web-app-title" content="">
<meta name="environment" content="pwcm6">
<meta name="id" content="17392499">
<link rel="canonical" href="https://www.milfordmirror.com/sports/article/Angels-owner-Arte-Moreno-explores-selling-17392499.php" />
                                        <meta name="author" content="">
        <meta name="author.name" content="" />
        <meta name="author.title" content="" />
        <meta name="description" content="ANAHEIM, Calif. (AP) — Los Angeles Angels owner Arte Moreno says he is exploring the..."/>
    <meta name="date.release" content="2022-08-23 18:08:54" />
    <meta name="time.release" content="2022-08-23 18:08:54" />
    <meta name="sections" content="Sports" />
            <meta name="robots" content="max-image-preview:large">
                <meta name="subject" content="Arte Moreno, Shohei Ohtani PROFESSIONAL_ATHLETE SPORTS_FIGURE PERSON, Mike Trout PROFESSIONAL_ATHLETE SPORTS_FIGURE, Shohei Ohtani, Josh Hamilton, Albert Pujols, AL MVPs, Mexican-American, Los Angeles, California, North America, United States, ANAHEIM, Arizona, Japan, Washington, AP, Galatioto Sports Partners, Los Angeles Angels, Major League Baseball, Washington Nationals, Angels-Moreno Sale, World Series, News - Sports - Stories, Top News, Member Choice Z Sports Option, Member Choice Sports Option, Choice Plus, PROFESSIONAL_ATHLETE SPORTS_FIGURE, California - Z Sports Only, Mike Trout, California - Sports, https://twitter.com/AP_Sports" />
        <meta name="news_keywords" content="Arte Moreno, Shohei Ohtani PROFESSIONAL_ATHLETE SPORTS_FIGURE PERSON, Mike Trout PROFESSIONAL_ATHLETE SPORTS_FIGURE, Shohei Ohtani, Josh Hamilton, Albert Pujols, AL MVPs, Mexican-American, Los Angeles, California, North America, United States, ANAHEIM, Arizona, Japan, Washington, AP, Galatioto Sports Partners, Los Angeles Angels, Major League Baseball, Washington Nationals, Angels-Moreno Sale, World Series, News - Sports - Stories, Top News, Member Choice Z Sports Option, Member Choice Sports Option, Choice Plus, PROFESSIONAL_ATHLETE SPORTS_FIGURE, California - Z Sports Only, Mike Trout, California - Sports, https://twitter.com/AP_Sports" />
                <meta name="nlpOrganization" content="AP, Galatioto Sports Partners, Los Angeles Angels, Major League Baseball, Washington Nationals" />
                <meta name="nlpPerson" content="Arte Moreno, Shohei Ohtani PROFESSIONAL_ATHLETE SPORTS_FIGURE PERSON, Mike Trout PROFESSIONAL_ATHLETE SPORTS_FIGURE, Shohei Ohtani, Josh Hamilton, Albert Pujols, AL MVPs, Mexican-American" />
                <meta name="nlpLocation" content="Los Angeles, California, North America, United States, ANAHEIM, Arizona, Japan, Washington" />
                <meta name="nlpConsumerGood" content="Top News" />
                <meta name="nlpWorkOfArt" content="News - Sports - Stories" />
                <meta name="nlpEvent" content="Angels-Moreno Sale, World Series" />
                <meta name="nlpOther" content="Member Choice Z Sports Option, Member Choice Sports Option, Choice Plus, PROFESSIONAL_ATHLETE SPORTS_FIGURE, California - Z Sports Only, Mike Trout, California - Sports, https://twitter.com/AP_Sports" />
                            <meta name="nlpCategories" content="%2FSports%2FTeam+Sports%2FBaseball,%2FNews%2FSports+News" />
                    <!-- e hearst/article/common/meta_tags.tpl -->    <!-- hearst/article/common/opengraph.tpl -->
<meta property="fb:admins" content="100006394927810"/><meta property="fb:app_id" content="322056085100167"/><meta property="fb:pages" content="105702905593" /><meta property="fb:pages" content="307851324523" /><meta property="fb:pages" content="12852567813" /><meta property="fb:pages" content="480760515417232" /><meta property="fb:pages" content="288240529145" /><meta property="fb:pages" content="316774245761" /><meta property="fb:pages" content="984197758297116" /><meta property="fb:pages" content="7457442370" /><meta property="fb:pages" content="207033189701" /><meta property="fb:pages" content="207346283795" /><meta property="fb:pages" content="222959748728" /><meta property="fb:pages" content="207042068180" /><meta property="fb:pages" content="72983690774" /><meta property="fb:pages" content="339413234035" /><meta property="fb:pages" content="343689323559" /><meta property="fb:pages" content="345828366626" /><meta property="fb:pages" content="234821559861394" /><meta property="fb:pages" content="335699426867" /><meta property="fb:pages" content="10150105039485602" /><meta property="fb:pages" content="338983127562" /><meta property="fb:pages" content="364516539001" /><meta property="fb:pages" content="337922332042" /><meta property="fb:pages" content="115637335153191" /><meta property="fb:pages" content="372011535931" /><meta property="fb:pages" content="333376634908" /><meta property="fb:pages" content="127590790608884" /><meta property="fb:pages" content="141923885872653" /><meta property="fb:pages" content="655037391286291" /><meta property="fb:pages" content="320774811368833" /><meta property="fb:pages" content="1740489152861748" /><meta property="fb:pages" content="469700473093040" /><meta property="fb:pages" content="386754203367" /><meta property="fb:pages" content="556449374478585" /><meta property="fb:pages" content="340999853450" /><meta property="fb:pages" content="350771491032" /><meta property="fb:pages" content="1120648627959218" /><meta property="fb:pages" content="342017778245" /><meta property="fb:pages" content="338463361591" /><meta property="fb:pages" content="138772706196968" /><meta property="fb:pages" content="1641688532739111" /><meta property="fb:pages" content="326312697536" /><meta property="fb:pages" content="353120110016" /><meta property="fb:pages" content="343366744658" /><meta property="fb:pages" content="335009494554" /><meta property="fb:pages" content="347261603104" /><meta property="fb:pages" content="350924013892" /><meta property="fb:pages" content="257724773860" /><meta property="fb:pages" content="361203926417" /><meta property="fb:pages" content="367174215398" /><meta property="fb:pages" content="284154645394" /><meta property="fb:pages" content="334501182354" /><meta property="fb:pages" content="350279743224" /><meta property="fb:pages" content="154340691263654" /><meta property="fb:pages" content="147848678611852" /><meta property="fb:pages" content="361381078011" /><meta property="fb:pages" content="362831597677" /><meta property="fb:pages" content="10150095255780118" /><meta name="og:datePublished" content="2022-08-23 18:49:37"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="Angels owner Arte Moreno explores selling franchise"/><meta property="og:description" content="ANAHEIM, Calif. (AP) — Los Angeles Angels owner Arte Moreno says he is exploring the..."/><meta property="og:url" content="https://www.milfordmirror.com/sports/article/Angels-owner-Arte-Moreno-explores-selling-17392499.php"/><meta property="og:site_name" content="Milford Mirror"/><meta property="og:image" content="https://s.hdnux.com/photos/01/27/10/07/22839798/3/rawImage.jpg"/><meta property="article:published_time" content="2022-08-23 18:49:37" /><meta property="article:modified_time" content="2022-08-23 18:53:03" /><meta property="article:author" content=""/><meta property="article:section" content="Sports" /><meta property="article:tag" content="Arte Moreno" /><meta property="article:tag" content="Shohei Ohtani PROFESSIONAL_ATHLETE SPORTS_FIGURE PERSON" /><meta property="article:tag" content="Mike Trout PROFESSIONAL_ATHLETE SPORTS_FIGURE" /><meta property="article:tag" content="Shohei Ohtani" /><meta property="article:tag" content="Josh Hamilton" /><meta property="article:tag" content="Albert Pujols" /><meta property="article:tag" content="AL MVPs" /><meta property="article:tag" content="Mexican-American" /><meta property="article:tag" content="Los Angeles" /><meta property="article:tag" content="California" /><meta property="article:tag" content="North America" /><meta property="article:tag" content="United States" /><meta property="article:tag" content="ANAHEIM" /><meta property="article:tag" content="Arizona" /><meta property="article:tag" content="Japan" /><meta property="article:tag" content="Washington" /><meta property="article:tag" content="AP" /><meta property="article:tag" content="Galatioto Sports Partners" /><meta property="article:tag" content="Los Angeles Angels" /><meta property="article:tag" content="Major League Baseball" /><meta property="article:tag" content="Washington Nationals" /><meta property="article:tag" content="Angels-Moreno Sale" /><meta property="article:tag" content="World Series" /><meta property="article:tag" content="News - Sports - Stories" /><meta property="article:tag" content="Top News" /><meta property="article:tag" content="Member Choice Z Sports Option" /><meta property="article:tag" content="Member Choice Sports Option" /><meta property="article:tag" content="Choice Plus" /><meta property="article:tag" content="PROFESSIONAL_ATHLETE SPORTS_FIGURE" /><meta property="article:tag" content="California - Z Sports Only" /><meta property="article:tag" content="Mike Trout" /><meta property="article:tag" content="California - Sports" /><meta property="article:tag" content="https://twitter.com/AP_Sports" />
<!-- e hearst/article/common/opengraph.tpl -->    <!-- hearst/article/common/twittercard.tpl -->

<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:image" content="https://s.hdnux.com/photos/01/27/10/07/22839798/3/rawImage.jpg"/>
<meta name="twitter:description" content="ANAHEIM, Calif. (AP) — Los Angeles Angels owner Arte Moreno says he is exploring the..."/>
<meta name="twitter:title" content="Angels owner Arte Moreno explores selling franchise"/>
<meta name="twitter:site" content="@milfordmirror" />
<!-- e hearst/article/common/twittercard.tpl -->    <!-- hearst/article/common/analytics.tpl -->
<script>var omni_channelPath = "Sports";var omni_title = "Angels owner Arte Moreno explores selling franchise";var omni_bizObjectId = "17392499";var omni_className = "article";var omni_publicationDate = "2022-08-23 18:49:37";var omni_sourceSite ="ap";var omni_authorName = "";var omni_authorTitle = "";var omni_premiumStatus = "free";var omni_premiumEndDate = "";var omni_originalSource = "AP";var omni_pageNumber = "0";var omni_breakingNewsFlag = "0";var omni_localNewsFlag = "0";var omni_isListView = "0";var omni_paywallSite = "0";var omni_displayTemplate = "dynamic_two_column";</script>
<!-- e hearst/article/common/analytics.tpl -->    <!-- hearst/article/common/schema_NewsArticle.tpl -->

<script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@id":"https:\/\/www.milfordmirror.com\/sports\/article\/Angels-owner-Arte-Moreno-explores-selling-17392499.php"},"headline":"Angels owner Arte Moreno explores selling franchise","image":["https:\/\/s.hdnux.com\/photos\/01\/27\/10\/07\/22839798\/3\/ratio3x2_1800.jpg","https:\/\/s.hdnux.com\/photos\/01\/27\/10\/07\/22839798\/3\/ratio3x2_700.jpg","https:\/\/s.hdnux.com\/photos\/01\/27\/10\/07\/22839798\/3\/square_small.jpg"],"articleBody":"ANAHEIM, Calif. (AP) \u2014 Los Angeles Angels owner Arte Moreno says he is exploring the possibility of selling the franchise. Moreno purchased the Angels in 2003, a year after they won the World Series. He has spent aggressively on aging free agent stars like Albert Pujols and Josh Hamilton, but the club hasn't been back to the Fall Classic since he became owner. Los Angeles is set to miss the postseason for the eighth straight year despite featuring AL MVPs Mike Trout and Shohei Ohtani. \u201cIt has been a great honor and privilege to own the Angels for 20 seasons,\" Moreno said in a statement. \u201cAlthough this difficult decision was entirely our choice and deserved a great deal of thoughtful consideration, my family and I have ultimately come to the conclusion that now is the time.\u201d Moreno's announcement comes at a critical moment for the franchise, with Ohtani set to be a free agent after the 2024 season. Ohtani, a two-way sensation who left Japan and joined the Angels in 2018, has made it clear he wants to play for a contending team. If the franchise can't sign Ohtani to a long-term deal, it may decide to trade him before he has a chance to leave as a free agent. Trout, a three-time MVP, is signed through the 2030 season on a $426.5 million, 12-year deal. He's appeared in just three postseason games with the Angels, all in 2014, despite having been the best player in baseball for most of the last decade. The team has retained Galatioto Sports Partners as financial advisor for the process and said it will not have any additional comment. Moreno, a Mexican-American born in Arizona, is the only non-white controlling owner in Major League Baseball. The Angels are the second MLB team currently for sale, joining the Washington Nationals. ___ More AP MLB: https:\/\/apnews.com\/hub\/mlb and https:\/\/twitter.com\/AP_Sports","datePublished":"2022-08-23T18:49:37Z","dateModified":"2022-08-23T18:53:03Z","author":[{"@type":"Person","name":"","jobTitle":""}],"publisher":{"@type":"Organization","name":"Associated Press","logo":{"@type":"ImageObject","url":"https:\/\/www.MilfordMirror.com\/img\/ldjson_logo.png","width":600,"height":60},"sameAs":["http:\/\/facebook.com\/milfordmirror","http:\/\/twitter.com\/milfordmirror"]},"description":"ANAHEIM, Calif. (AP) \u2014 Los Angeles Angels owner Arte Moreno says he is exploring the..."}
</script>
<!-- e hearst/article/common/schema_NewsArticle.tpl -->    <!-- hearst/common/third_party_assets.tpl -->
                    <!-- hmb:juice Juice -->
        <script type="text/javascript">
            
                var startRevWorker = function() {
                    if (window.articleShowLISTQueue) {
                        while (window.articleShowLISTQueue.length > 0) {
                            var showListEntry = articleShowLISTQueue.shift();
                            window.aps.showLIST([showListEntry]);
                        }
                    }
                    if (window.placeAdQueue) {
                        while (window.placeAdQueue.length > 0) {
                            var placeAdEntry = placeAdQueue.shift();
                            window.aps.placeAd([placeAdEntry]);
                        }
                    }
                    if (window.slideshowShowLISTQueue) {
                        while (window.slideshowShowLISTQueue.length > 0) {
                            var ads = window.slideshowShowLISTQueue.shift();
                            window.aps.showLIST(ads);
                        }
                    }
                    window.juiceloaded = true;
                }
            
        </script>

        <!-- ENG-10074 If AB Test on Seattle we turn off Juice in order to use HTL code -->
                    <script  src="https://aps.hearstnp.com/Scripts/loadAds.js?v=1.3.3.5" type="text/javascript" id="adPositionManagerScriptTag"></script>
            
    <!-- hmb:ensighten Ensighten  -->
    <!-- hearst/ensighten/ensighten.tpl -->
<!-- hmb:ensighten Ensighten script -->
<!-- Hearst analytics: Ensighten -->
<script src="https://tm.hdmtools.com/hearst/news/Bootstrap.js"></script>
<!-- End Hearst analytics: Ensighten -->
<!-- e ensighten.tpl -->                    <!-- blueconic -->
        <script src="https://y752.milfordmirror.com/script.js" async></script>
            
    <!-- hmb:taboola Taboola  -->
                            
                            
                <script type="text/javascript">
                    
                    (function () {
                        window._taboolaNetworkMode = true;
                        
                        window._taboola = window._taboola || [];
                        window._taboolaHDNPageLabel = window._taboolaHDNPageLabel || 'article';
                        var tobj = {};
                        tobj[window._taboolaHDNPageLabel] = 'auto';
                        window._taboola.push(tobj);
                        !function (e, f, u, i) {
                            if (!document.getElementById(i)){
                                e.async = 1;
                                e.src = u;
                                e.id = i;
                                f.parentNode.insertBefore(e, f);
                            }
                        }(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/hearstlocalnews-network/loader.js', 'tb_loader_script');
                        if(window.performance && typeof window.performance.mark == 'function') {
                            window.performance.mark('tbl_ic');
                        }
                    })();
                </script>
                
                                <!-- e hearst/common/third_party_assets.tpl -->
    <link rel="shortcut icon" href="/favicon.ico">
    <link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon.png">
    <link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
    <link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
    <link rel="apple-touch-icon-precomposed" sizes="128x128" href="/apple-touch-icon-128x128.png">
            <!-- Hotfix Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.93530 -->
<!-- ENG-3363 -->
<style>
  .thumbnailListAuthor.one .thumbnailListAuthor--wrapper { margin: 0; }
  @media (min-width: 768px) { .thumbnailListAuthor.two .thumbnailListAuthor--wrapper { margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--items { justify-content: space-between; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--item { flex: 0 0 48%; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--spacer { display: none; } }
  @media (min-width: 928px) { .thumbnailListAuthor.three .thumbnailListAuthor--wrapper { margin: 0; } }
</style>
<!-- ENG-3834 -->
<style>
  .alert{background-color:#000;bottom:0;box-sizing:border-box;color:#fff;font-family:Helvetica,sans-serif;font-size:16px;font-weight:600;left:50%;line-height:1.25;overflow:hidden;padding:10px;position:fixed;transform:translateX(-50%);width:100vw;z-index:5000000}.alert .close{border-radius:8px;color:#fff;display:block;position:absolute;right:10px;height:16px;overflow:hidden;top:10px;width:16px}.alert .close::after{background-color:#fff;content:'';display:block;height:2px;left:-6px;position:relative;top:4px;transform:rotate(-45deg);width:30px}.alert .close::before{background-color:#fff;content:'';display:block;height:2px;left:-5px;position:relative;top:9px;transform:rotate(45deg);width:30px}.alert>div{box-sizing:border-box;max-width:1200px;margin:0 auto;position:relative;padding-right:34px}
</style>
<script>
  document.addEventListener('DOMContentLoaded', function() {
    if (/MSIE \d|Trident.*rv:/.test(navigator.userAgent)) {var site=HDN.domain,name=site.charAt(0).toUpperCase()+site.slice(1),section=document.createElement("section"),close=document.createElement("a");close.className="close",close.href="#",close.addEventListener("click",function(e){e.stopPropagation(),e.preventDefault(),e.target.parentElement.style.display="none"});var HTML="<div>Thank you for visiting "+name+". You are using an older browser that may impact your reading experience. For the best experience, we recommend you use Chrome, Safari, Firefox, or Edge.</div>";section.className="alert",section.id="warning",section.innerHTML=HTML,section.appendChild(close),document.getElementsByTagName("body")[0].appendChild(section);}
  }, false);
</script>
<!-- e ENG-3834 -->
<!--  Start ENG-8221 -->
<style>
@media (max-width:768px) {   
  .articleHeader:not(.heroleft):not(.herotextabove):not(.herocenter) .articleHeader--timestamp {     
    bottom: 0px !important;     
    margin-left: 0px !important;     
    position: relative;    
  }
}</style>
        <!-- Hotfix Freeform (Local Dynamic Two-Column) -->
        
<!-- noGen: item_header_hotfix_dtc_ssl 79 -->
                    </head>
<!-- e hearst/article/headerMain.tpl -->    <body data-location="sports"  class="two-column">
                            <!-- design/article/dynamic_two_column.tpl -->
    <!-- hearst/article/types/dynamic_two_column.tpl -->


<div id="zoneTop" class="zone full innerGrid" data-tb-region="zoneAboveMasthead"></div><!-- hearst/common/siteBranding.tpl -->
    <header class="pageHeader standard" data-stage="0">
        <div class="pageHeader--progress"><div class="pageHeader--progress-bar" id="progress"></div></div>    <div class="pageHeader--skipLink-wrapper">
        <a href="#content" class="pageHeader--skipLink" aria-label="Skip to main content">Skip to main content</a>
    </div>
    <div class="pageHeader--wrapper lock">
        <button id="navToggle" class="pageHeader--menuButton navToggle" role="button" tabindex="0" aria-expanded="false" aria-label="navigation"></button>                <a id="mastheadLogo" href="/" tabindex="0">Milford Mirror Homepage<span  class="pageHeader--logo mastheadLogo fade show hdn-analytics" role="img" aria-label="Milford Mirror Homepage - Site Logo" data-hdn-analytics="visit|masthead|navigation|0"></span></a>
                    <div id="titleBar" class="pageHeader--titleBar titleBar fade show hidden">
                                    <div class="pageHeader--titleBar-subsection">Currently Reading</div>
                    <div class="pageHeader--titleBar-title">Angels owner Arte Moreno explores selling franchise</div>
                            </div>
                            <div id="nextStory" class="pageHeader--nextStory nextStory fade show hidden"></div>
                            <ul class="pageHeader--links fade show">
                                                                                                                                        <li id="subscription" class="pageHeader--links-nonsub subscribeButton fade show hidden">
                                <a class="visible-xs-f subscribe" href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=button&ipid=wcm" target="_blank">Subscribe</a>
                                <a class="hidden-xs button" href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=button&ipid=wcm" target="_blank">Subscribe</a>
                            </li>
                                                                                                <li id="eEdition" class="pageHeader--links-sub eEdition fade show hidden"><a href="/e-edition">e-Edition</a></li>
                                                                                                                                        <!-- hearst/common/signin.tpl -->
<li class="treg-is-gigya gigya_menu ">
    <div class="gya-title expandable treg-conditional treg-not-logged-in">
        <a class="signIn featureSignIn" tabindex="0" role="button">Sign In</a>
    </div>
    <div class="gya-title expandable treg-conditional treg-logged-in" aria-controls="treg-login-widget" role="button"><span></span></div>
    <div class="gya-content expandable" id="treg-login-widget">
        <div class="treg-gya-login-widget"></div>
    </div>
</li>
<!-- e hearst/common/signin.tpl -->                <button class="pageHeader--searchButton searchToggle" aria-expanded="false" tabindex="0" aria-label="searchToggle" aria-controls="searchField-aria"></button>            </ul>
                            <div class="pageHeader--search searchField" id="searchField-aria">
                
                <form class="pageHeader--search-form" action="/search/" method="get">
                    <input type="hidden" name="action" value="search" />
                    <input type="hidden" name="firstRequest" value="1" />
                    <input type="hidden" name="searchindex" value="solr" />
                    <div class="fieldset">
                        <input class="pageHeader--search-input" id="search" name="query" type="text" value="" placeholder="Search" aria-label="search" />
                        <button class="searchButton btn" value="" name="search" type="submit" aria-label="search"></button>
                    </div>
                </form>
            </div>
            </div>
                                    
        <!-- hearst/home/HNavigation.tpl -->
<!-- hearst/home/navigation.tpl -->
         <!-- hearst/common/siteNavigation.tpl -->
<nav id="navigation" class="navigation"><div class="navigation--wrapper lock"><div class="navigation--menu"><ul class="hidden-sm hidden-md hidden-lg hidden-xl"><li class="single" data-length="1" data-index="1"><a href="/puzzles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="6062" data-hdn-analytics="visit|Puzzles|navigation-ard|1">Puzzles</a></li><li class="parent topLevel" data-length="6" data-index="0"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4941" data-hdn-analytics="visit|home|navigation-ard|2">home</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 132px"><li class="child"><a  href="https://link.milfordmirror.com/join/signup-mm" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5806" data-hdn-analytics="visit|home-Sign Up for Newsletters|navigation-ard|1">Sign Up for Newsletters</a></li><li class="child"><a  href="https://hearstmediact.newsbank.com/home" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4949" data-hdn-analytics="visit|home-Print Archives|navigation-ard|2">Print Archives</a></li><li class="child"><a  href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=hamburger&ipid=wcm" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4952" data-hdn-analytics="visit|home-Subscribe|navigation-ard|3">Subscribe</a></li><li class="child"><a  href="/news-submission-guidelines/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4944" data-hdn-analytics="visit|home-Submission Guidelines|navigation-ard|4">Submission Guidelines</a></li><li class="child"><a  href="/submissions/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4987" data-hdn-analytics="visit|home-Submissions|navigation-ard|5">Submissions</a></li></ul></li><li class="parent topLevel" data-length="9" data-index="2"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4997" data-hdn-analytics="visit|News|navigation-ard|3">News</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 176px"><li class="child"><a  href="/politics-elections/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4990" data-hdn-analytics="visit|News-Politics & Elections|navigation-ard|1">Politics & Elections</a></li><li class="child"><a  href="/news/town-government/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4991" data-hdn-analytics="visit|News-Town Government|navigation-ard|2">Town Government</a></li><li class="child"><a  href="/news/community/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4992" data-hdn-analytics="visit|News-Community|navigation-ard|3">Community</a></li><li class="child"><a  href="/news/education/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4994" data-hdn-analytics="visit|News-Education|navigation-ard|4">Education</a></li><li class="child"><a  href="/news/police-fire/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4995" data-hdn-analytics="visit|News-Police & Fire|navigation-ard|5">Police & Fire</a></li><li class="child"><a  href="/news/connecticut/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4998" data-hdn-analytics="visit|News-Connecticut|navigation-ard|6">Connecticut</a></li><li class="child"><a  href="/cannabis/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="6085" data-hdn-analytics="visit|News-Cannabis|navigation-ard|7">Cannabis</a></li><li class="child"><a  href="/opinion/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5812" data-hdn-analytics="visit|News-Opinion|navigation-ard|8">Opinion</a></li></ul></li><li class="single" data-length="1" data-index="3"><a href="/business/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4977" data-hdn-analytics="visit|Business|navigation-ard|4">Business</a></li><li class="single" data-length="1" data-index="4"><a href="https://www.legacy.com/obituaries/milfordmirror/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4979" data-hdn-analytics="visit|Obituaries|navigation-ard|5">Obituaries</a></li><li class="parent topLevel" data-length="3" data-index="5"><span role="heading" aria-level="2"><a  href="/sports/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4986" data-hdn-analytics="visit|Sports|navigation-ard|6">Sports</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/uconn/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5833" data-hdn-analytics="visit|Sports-UConn|navigation-ard|1">UConn</a></li><li class="child"><a  href="/sports/high-school-sports/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4985" data-hdn-analytics="visit|Sports-High School Sports|navigation-ard|2">High School Sports</a></li></ul></li><li class="parent topLevel" data-length="3" data-index="6"><span role="heading" aria-level="2"><a  href="/living/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5799" data-hdn-analytics="visit|Living|navigation-ard|7">Living</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/food/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5800" data-hdn-analytics="visit|Living-Food|navigation-ard|1">Food</a></li><li class="child"><a  href="/homegarden/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5354" data-hdn-analytics="visit|Living-Home and Garden|navigation-ard|2">Home and Garden</a></li></ul></li><li class="single" data-length="1" data-index="7"><a href="/entertainment/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4996" data-hdn-analytics="visit|Entertainment|navigation-ard|8">Entertainment</a></li><li class="parent topLevel" data-length="6" data-index="8"><span role="heading" aria-level="2"><a  href="/faq/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4948" data-hdn-analytics="visit|Help|navigation-ard|9">Help</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 132px"><li class="child"><a  href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CMM" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4947" data-hdn-analytics="visit|Help-Delivery Problems|navigation-ard|1">Delivery Problems</a></li><li class="child"><a  href="/about-us/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4945" data-hdn-analytics="visit|Help-About Us|navigation-ard|2">About Us</a></li><li class="child"><a  href="/contact/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4946" data-hdn-analytics="visit|Help-Contact Us|navigation-ard|3">Contact Us</a></li><li class="child"><a  href="/privacy/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4943" data-hdn-analytics="visit|Help-Privacy Notice|navigation-ard|4">Privacy Notice</a></li><li class="child"><a  href="/tos/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4942" data-hdn-analytics="visit|Help-Terms of Use|navigation-ard|5">Terms of Use</a></li></ul></li><li class="single" data-length="1" data-index="9"><a href="/shopping/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="6110" data-hdn-analytics="visit|Shopping|navigation-ard|10">Shopping</a></li><li class="parent topLevel" data-length="2" data-index="10"><span role="heading" aria-level="2"><a  href="/sponsoredarticles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5716" data-hdn-analytics="visit|Advertising Features|navigation-ard|11">Advertising Features</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/events-calendar/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="6007" data-hdn-analytics="visit|Advertising Features-Events|navigation-ard|1">Events</a></li></ul></li><li class="single" data-length="1" data-index="11"><a href="http://connecticut.ipublishmarketplace.com/connecticut-marketplace/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5002" data-hdn-analytics="visit|Classifieds|navigation-ard|1">Classifieds</a></li></ul></div></div><span class="rule"></span><div id="navToggle__page" class="navTogglePage"></div></nav>
<!-- e hearst/common/siteNavigation.tpl -->
<!-- e hearst/home/navigation.tpl --> <!-- e hearst/home/HNavigation.tpl -->    </header>

<!-- e hearst/common/siteBranding.tpl --> <main><section id="topZone" class="zone topZone"><!-- src/business/widgets/hearst/collection/widget.tpl -->

    <div class="hide-rss-link hdnce-e hdnce-collection-111519-dynamic_ribbon_articles"><!-- hearst/collections/dynamic_ribbon_articles.tpl -->
<!-- collection.dynamic_ribbon_articles.111519 -->
    <!-- design/collection/dynamic_ribbon_articles/single_zone.tpl -->
                                                                                                                                                <div class="articleRibbon" aria-label="carousel" role="region" data-component="collection" data-type="ribbon" data-collection-id="111519" data-collection-title="D- MM Article Ribbon Sports" data-type="list">
        <button class="articleRibbon--nav-btn articleRibbon--nav-prev fade" data-delta="-1" aria-label="Previous"></button>
        <div class="articleRibbon--wrapper">
            <ul class="articleRibbon--list">
                <div class="scrollSpacer"></div>
                                <div class="articleRibbon--list-wrapper" style="flex: 1 0 2200px;">
                    <span class="articleRibbon--list-title" role="heading" aria-level="2"><span class="articleRibbon--list-label"><!-- widgets/hearst/moduleHeader/widget.tpl -->
                                            <h2 role="heading" aria-level="2">Recommended</h2>
                        <!-- e widgets/hearst/moduleHeader/widget.tpl --></span></span>                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php" data-hdn-analytics="visit-from-img|article-17310688|-111519|1">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/26/50/44/22710538/3/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/26/50/44/22710538/3/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/26/50/44/22710538/3/ratio1x1_100.jpg" alt="Members of the Milford Little League softball team celebrate after defeating Wallingford 9-4 Saturday for the program's fourth-straight state championship. Milford will represent Connecticut in the Little League World Series New England Regional at the A. Bartlett Giamatti Little League Leadership Training Center in Bristol. Milford opens play against Rhode Island Saturday at 4 p.m. on ESPN+.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php" data-hdn-analytics="visit|article-17310688|-111519|1" data-epe-inst="s:0;t:75" data-epe-title="1">Milford Little League softball wins 4th straight state title</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php" data-hdn-analytics="visit-from-img|article-17207808|-111519|2">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/76/70/22539802/7/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/76/70/22539802/7/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/76/70/22539802/7/ratio1x1_100.jpg" alt="Lauren Vitti, Kelly Jones, Amanda Umbricht and Carys Cook broke the school record in the 4x800 at the SCC Championships.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php" data-hdn-analytics="visit|article-17207808|-111519|2" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton seventh at SCC track, relay sets record</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php" data-hdn-analytics="visit-from-img|article-17181447|-111519|3">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/63/07/22491618/7/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/63/07/22491618/7/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/63/07/22491618/7/ratio1x1_100.jpg" alt="Katherine Baisley, Bria Colangelo, Emma Hoffman, Lauren Vitti, Katerina Koutouvides, Carys Cook and Kelly Jones medaled for Lauralton Hall at the SCC East Sectional meet.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php" data-hdn-analytics="visit|article-17181447|-111519|3" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton fifth at SCC East Sectional meet</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php" data-hdn-analytics="visit-from-img|article-17176456|-111519|4">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/61/15/22483835/7/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/61/15/22483835/7/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/61/15/22483835/7/ratio1x1_100.jpg" alt="Foran improved to 9-8 with its win against previously unbeaten Amity.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php" data-hdn-analytics="visit|article-17176456|-111519|4" data-epe-inst="s:0;t:75" data-epe-title="1">HS update: Foran baseball upends No. 1 Amity</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php" data-hdn-analytics="visit-from-img|article-17172989|-111519|5">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/57/37/22476761/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/57/37/22476761/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/57/37/22476761/4/ratio1x1_100.jpg" alt="Law’s Mike Merchant is safe at the plate as Hand catcher Connor Powell tags him too late.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php" data-hdn-analytics="visit|article-17172989|-111519|5" data-epe-inst="s:0;t:75" data-epe-title="1">Law edges Hand in high-scoring SCC tilt</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php" data-hdn-analytics="visit-from-img|article-17172988|-111519|6">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/57/37/22476760/7/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/57/37/22476760/7/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/57/37/22476760/7/ratio1x1_100.jpg" alt="Lucia Pino is closing in on becoming the career wins leader at Law before going to Bryant University.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php" data-hdn-analytics="visit|article-17172988|-111519|6" data-epe-inst="s:0;t:75" data-epe-title="1">Lucia Pino closing in on Law record for wins</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php" data-hdn-analytics="visit-from-img|article-17170770|-111519|7">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/56/54/22473489/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/56/54/22473489/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/56/54/22473489/4/ratio1x1_100.jpg" alt="Lauralton Hall's track team celebrates winning SCC Housatonic Division championship.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php" data-hdn-analytics="visit|article-17170770|-111519|7" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton track wins Housatonic Division</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php" data-hdn-analytics="visit-from-img|article-17162949|-111519|8">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/53/53/22461156/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/53/53/22461156/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/53/53/22461156/4/ratio1x1_100.jpg" alt="Arezoo Ghazagh, Quincy Ercanbrack and Katharine Harrison captain the Foran girls track team.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php" data-hdn-analytics="visit|article-17162949|-111519|8" data-epe-inst="s:0;t:75" data-epe-title="1">Foran aided by newcomers, strong leadership</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php" data-hdn-analytics="visit-from-img|article-17147665|-111519|9">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/45/66/22437278/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/45/66/22437278/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/45/66/22437278/4/ratio1x1_100.jpg" alt="McKenna Sharpe, Sydney Simpson, McKenzie Powers, Shelby Green and Lauren Davis captain Law girls track team.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php" data-hdn-analytics="visit|article-17147665|-111519|9" data-epe-inst="s:0;t:75" data-epe-title="1">Law track making its mark in early going of season</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php" data-hdn-analytics="visit-from-img|article-17128086|-111519|10">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/36/52/22407860/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/36/52/22407860/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/36/52/22407860/4/ratio1x1_100.jpg" alt="Foran and Jonathan Law catchers and captains Kendall LaMorte and Nicolina Salanto have high hopes for their softball teams.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php" data-hdn-analytics="visit|article-17128086|-111519|10" data-epe-inst="s:0;t:75" data-epe-title="1">Foran, Law aiming to further success this postseason</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                    </div>
                <div class="scrollSpacer"></div>
            </ul>
        </div>
        <button class="articleRibbon--nav-btn articleRibbon--nav-next fade show " data-delta="1" aria-label="Next"></button>
    </div>
        <script type="text/javascript">
        var nextStory = [
                                                            {
                    "id": 17310688,
                    "headline": "Milford Little League softball wins 4th straight...",
                    "url": "/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php",
                    "image": "https://s.hdnux.com/photos/01/26/50/44/22710538/3/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17207808,
                    "headline": "Lauralton seventh at SCC track, relay sets record",
                    "url": "/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php",
                    "image": "https://s.hdnux.com/photos/01/25/76/70/22539802/7/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17181447,
                    "headline": "Lauralton fifth at SCC East Sectional meet",
                    "url": "/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php",
                    "image": "https://s.hdnux.com/photos/01/25/63/07/22491618/7/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17176456,
                    "headline": "HS update: Foran baseball upends No. 1 Amity",
                    "url": "/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php",
                    "image": "https://s.hdnux.com/photos/01/25/61/15/22483835/7/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17172989,
                    "headline": "Law edges Hand in high-scoring SCC tilt",
                    "url": "/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php",
                    "image": "https://s.hdnux.com/photos/01/25/57/37/22476761/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17172988,
                    "headline": "Lucia Pino closing in on Law record for wins",
                    "url": "/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php",
                    "image": "https://s.hdnux.com/photos/01/25/57/37/22476760/7/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17170770,
                    "headline": "Lauralton track wins Housatonic Division",
                    "url": "/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php",
                    "image": "https://s.hdnux.com/photos/01/25/56/54/22473489/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17162949,
                    "headline": "Foran aided by newcomers, strong leadership",
                    "url": "/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php",
                    "image": "https://s.hdnux.com/photos/01/25/53/53/22461156/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17147665,
                    "headline": "Law track making its mark in early going of season",
                    "url": "/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php",
                    "image": "https://s.hdnux.com/photos/01/25/45/66/22437278/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17128086,
                    "headline": "Foran, Law aiming to further success this postseason",
                    "url": "/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php",
                    "image": "https://s.hdnux.com/photos/01/25/36/52/22407860/4/ratio3x2_100.jpg"
                }                    ];
    </script>
<!-- e design/collection/dynamic_ribbon_articles/single_zone.tpl --><!-- e hearst/collections/dynamic_ribbon_articles.tpl -->
</div><!-- e src/business/widgets/hearst/collection/widget.tpl --></section> <div class="belowMastheadWrapper"></div> <section id="content" class="article" data-type="dtc"><!-- hearst/article/articleHeader.tpl -->
            
            
    <header class="article--header articleHeader"><div class="articleHeader--breadcrumbs"><a class="articleHeader--breadcrumbs-item" href="https://www.milfordmirror.com/sports/">Sports</a></div><h1 class="articleHeader--headline" aria-labelledby="">Angels owner Arte Moreno explores selling franchise</h1><div class="articleHeader--subHead"><div class="articleHeader--byline"></div><div class="articleHeader--timestamp"><time class="articleHeader--timestamp-pubdate hasUpdate hidden-xs" datetime="2022-08-23 18:08:54">Aug. 23, 2022</time><time class="articleHeader--timestamp-update" datetime="2022-08-23 18:08:54">Updated: Aug. 23, 2022 2:53&nbsp;p.m.</time></div><div class="articleHeader--shareTools"><!-- hearst/common/shareTools.tpl -->
    
<div class="share-list comments">
    <a class="share-facebook" data-shareNetwork="facebook">Facebook</a>
    <a class="share-twitter" data-shareNetwork="twitter">Twitter</a>
    <a class="share-email" data-shareNetwork="email">Email</a>
            <div class="pipe"></div>
                    
                            <a class="share-comments" data-shareNetwork="comments" href="https://www.milfordmirror.com/sports/articleComments/Angels-owner-Arte-Moreno-explores-selling-17392499.php" onclick="document.location.href = document.location.href.replace('/article/','/articleComments/').replace('/slideshow/','/slideshowComments/'); return false;">Comments</a>
        <span class="share-count"></span>
    </div>
<!-- e hearst/common/shareTools.tpl --></div></div></header>
<!-- e hearst/article/articleHeader.tpl --><!-- hearst/common/chapterNavigation.tpl -->
        <!-- e hearst/common/chapterNavigation.tpl --><article class="article--content"><section id="articleTop" class="article--content-zone top"></section>
    <!-- hearst/article/content/photo.tpl -->

<figure class=" extendFromGrid fXS fSM fMD fLG fXL">




























            
    <picture class="image" data-width="2048" data-height="1365"  style="padding-top: 67%;"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/1200x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/2400x0.jpg 2x" media="(min-width: 1292px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/1150x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/2300x0.jpg 2x" media="(min-width: 1230px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/1100x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/2200x0.jpg 2x" media="(min-width: 1168px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/1050x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/2100x0.jpg 2x" media="(min-width: 1106px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/1000x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/2000x0.jpg 2x" media="(min-width: 1044px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/950x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/1900x0.jpg 2x" media="(min-width: 982px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/900x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/1800x0.jpg 2x" media="(min-width: 920px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/850x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/1700x0.jpg 2x" media="(min-width: 858px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/800x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/1600x0.jpg 2x" media="(min-width: 796px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/750x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/1500x0.jpg 2x" media="(min-width: 734px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/700x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/1400x0.jpg 2x" media="(min-width: 672px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/650x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/1300x0.jpg 2x" media="(min-width: 610px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/600x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/1200x0.jpg 2x" media="(min-width: 548px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/550x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/1100x0.jpg 2x" media="(min-width: 486px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/500x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/1000x0.jpg 2x" media="(min-width: 424px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/450x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/900x0.jpg 2x" media="(min-width: 362px)"><source srcset="https://s.hdnux.com/photos/01/27/10/07/22839798/3/400x0.jpg 1x, https://s.hdnux.com/photos/01/27/10/07/22839798/3/800x0.jpg 2x" media="(min-width: 300px)"><img class="landscape" src="https://s.hdnux.com/photos/01/27/10/07/22839798/3/1200x0.jpg" alt="FILE - Los Angeles Angels owner Arte Moreno, right, talks with Angels manager Joe Maddon prior to a baseball game against the Cleveland Guardians on Tuesday, April 26, 2022, in Anaheim, Calif. Moreno says he is exploring the possibility of selling the franchise."></picture><figcaption><span class="caption">FILE - Los Angeles Angels owner Arte Moreno, right, talks with Angels manager Joe Maddon prior to a baseball game against the Cleveland Guardians on Tuesday, April 26, 2022, in Anaheim, Calif. Moreno says he is exploring the possibility of selling the franchise.</span><span class="credits">Mark J. Terrill/AP</span></figcaption></figure>
<!-- e hearst/article/content/photo.tpl -->


            <p>ANAHEIM, Calif. (AP) — Los Angeles Angels owner Arte Moreno says he is exploring the possibility of selling the franchise.</p>
    
            <p>Moreno purchased the Angels in 2003, a year after they won the World Series. He has spent aggressively on aging free agent stars like Albert Pujols and Josh Hamilton, but the club hasn't been back to the Fall Classic since he became owner.</p>
    <div id="paywall" class="content-wrapper">
            <p>Los Angeles is set to miss the postseason for the eighth straight year despite featuring AL MVPs Mike Trout and Shohei Ohtani.</p>
    
    <!-- hearst/article/content/embed.tpl -->
        <section class="article--content-embed inline-iframe" data-eid="item-96892">
                        <div id="93066811-0534-4a7d-848c-7844b68ad1e1" class="hst-exco-player"></div><script>
(function (d, id) {
  var js, fjs = d.getElementsByTagName('script')[0];
  js = d.createElement('script');
  js.id = 'exco';
  js.dataset.src = 'https://player.ex.co/player/' + id;
  fjs.parentNode.insertBefore(js, fjs);
}(document, '93066811-0534-4a7d-848c-7844b68ad1e1'));
</script><!-- amp-exco-9dfa517e-768d-4e35-98d0-e65b9084c85e -->

            </section>
<!-- e hearst/article/content/embed.tpl -->
            <p>“It has been a great honor and privilege to own the Angels for 20 seasons," Moreno said in a statement. “Although this difficult decision was entirely our choice and deserved a great deal of thoughtful consideration, my family and I have ultimately come to the conclusion that now is the time.”</p>
    
    <!-- Missed: ad -->

            <p>Moreno's announcement comes at a critical moment for the franchise, with Ohtani set to be a free agent after the 2024 season. Ohtani, a two-way sensation who left Japan and joined the Angels in 2018, has made it clear he wants to play for a contending team. If the franchise can't sign Ohtani to a long-term deal, it may decide to trade him before he has a chance to leave as a free agent.</p>
    
    <!-- Missed: ad -->

            <p>Trout, a three-time MVP, is signed through the 2030 season on a $426.5 million, 12-year deal. He's appeared in just three postseason games with the Angels, all in 2014, despite having been the best player in baseball for most of the last decade.</p>
    
    <!-- hearst/article/content/relatedStories.tpl -->
    <section class="relatedStories" data-progressive="true"><div class="relatedStories--title articleModule"><div class="articleModule--title h4" role="heading" aria-level="2">More for you</div></div><ul class="relatedStories--list" data-total="2"><li class="relatedStories--item" data-number="1"><div class="slide" data-number="1"><a href="https://www.milfordmirror.com/uconn/article/Former-UConn-linebacker-Darrian-Beavers-of-Giants-17390115.php" class="hdn-analytics"data-hdn-analytics="related_stories|article-17390115|article-17392499|1"><div class="slide--headline"><div class="slide--headline-title">Former UConn LB tears ACL, will miss rookie season with Giants</div></div><div class="slide--image fullBleed"><picture class="deferred threeTwo" data-progressive="true" data-component="picture"><source data-srcset="https://s.hdnux.com/photos/01/27/06/71/22834803/3/ratio3x2_350.jpg 1x, https://s.hdnux.com/photos/01/27/06/71/22834803/3/ratio3x2_700.jpg 2x"><img data-src="https://s.hdnux.com/photos/01/27/06/71/22834803/3/ratio3x2_700.jpg" alt=""></picture></div></a></div></li><li class="relatedStories--item" data-number="2"><div class="slide" data-number="2"><a href="https://www.milfordmirror.com/sports/article/Hartford-Athletic-names-National-Soccer-Hall-of-17389558.php" class="hdn-analytics"data-hdn-analytics="related_stories|article-17389558|article-17392499|2"><div class="slide--headline"><div class="slide--headline-title">Hartford Athletic names Hall of Famer Tab Ramos as head coach</div></div><div class="slide--image fullBleed"><picture class="deferred threeTwo" data-progressive="true" data-component="picture"><source data-srcset="https://s.hdnux.com/photos/01/27/06/50/22833719/6/ratio3x2_350.jpg 1x, https://s.hdnux.com/photos/01/27/06/50/22833719/6/ratio3x2_700.jpg 2x"><img data-src="https://s.hdnux.com/photos/01/27/06/50/22833719/6/ratio3x2_700.jpg" alt=""></picture></div></a></div></li></ul></section>
     <!-- e hearst/article/content/relatedStories.tpl -->
            <p>The team has retained Galatioto Sports Partners as financial advisor for the process and said it will not have any additional comment.</p>
    <aside class="article--content-inline"><aside class="zone">
    
<!-- hearst/home/mostPopular.tpl -->

    <div class="mostPopular">
        <h2 class="collectionHeader" role="heading" aria-level="2">Most Popular</h2>
                                                <ol class="mostPopular--list">
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Waterbury-mall-to-get-first-tenant-under-new-owner-17390428.php" title="Brass Mill Center to get axe throwing business" data-hdn-analytics="visit|article-17390428|most_popular|0">Brass Mill Center to get axe throwing business</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Milford-car-dealer-faces-delays-from-glass-17389839.php" title="Milford car dealer faces delays from glass shortage, cell tower build" data-hdn-analytics="visit|article-17389839|most_popular|1">Milford car dealer faces delays from glass shortage, cell tower build</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Milford-rejects-plan-for-digital-billboards-17385650.php" title="Milford rejects plan for digital billboards" data-hdn-analytics="visit|article-17385650|most_popular|2">Milford rejects plan for digital billboards</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/hartford/article/DCF-worker-arrested-after-sneaking-female-client-17372081.php" title="Police: DCF social worker arrested after sneaking client and child out of building to avoid arrest" data-hdn-analytics="visit|article-17372081|most_popular|3">Police: DCF social worker arrested after sneaking client and child out of building to avoid arrest</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/policereports/article/Police-Man-who-assaulted-mother-of-his-child-in-17390805.php" title="Warrant: Bridgeport man fired gun, assaulted a woman in front of her child in a school parking lot" data-hdn-analytics="visit|article-17390805|most_popular|4">Warrant: Bridgeport man fired gun, assaulted a woman in front of her child in a school parking lot</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Electric-vehicle-showroom-planned-for-former-17383001.php" title="Electric vehicle showroom planned for former Milford Hooters site" data-hdn-analytics="visit|article-17383001|most_popular|5">Electric vehicle showroom planned for former Milford Hooters site</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Leora-Levy-claims-victory-in-U-S-Senate-primary-17363307.php" title="Leora Levy wins U.S. Senate primary over Themis Klarides, set to challenge Sen. Richard Blumenthal" data-hdn-analytics="visit|article-17363307|most_popular|6">Leora Levy wins U.S. Senate primary over Themis Klarides, set to challenge Sen. Richard Blumenthal</a>
                                                    </li>
                                    </ol>
                        </div>
<!--e hearst/home/mostPopular.tpl --></aside></aside>
    <!-- Missed: ad -->

            <p>Moreno, a Mexican-American born in Arizona, is the only non-white controlling owner in Major League Baseball. The Angels are the second MLB team currently for sale, joining the Washington Nationals.</p>
    
            <p>___</p>
    
            <p>More AP MLB: <a href="https://apnews.com/hub/mlb" target="_blank">https://apnews.com/hub/mlb</a> and <a href="https://twitter.com/AP_Sports" target="_blank">https://twitter.com/AP_Sports</a></p>
    <section id="articleBottom" class="article--content-zone bottom"></section></div></article><!-- hearst/article/articleAside.tpl -->
<aside class="article--aside slideshow--aside">
    <aside id="zoneD" class="zone">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85203 -->
    <div class="hst-freeform hdnce-e hdnce-item-85203">
                <script type="text/javascript" id="taboola-right-rail-script-id">
(function () {
    window._taboolaRRI = window._taboolaRRI || 0;
    window._taboolaRRI++;
    var e = document.documentElement;
    var g = document.getElementsByTagName('body')[0];
    var w = window.innerWidth||e.clientWidth||g.clientWidth;
    if ( (w >= 768 && window._taboolaRRI === 1) || (w < 768 && window._taboolaRRI === 2) ){
        var c = 'taboola-right-rail-thumbnails';
        var p = 'Right Rail Thumbnails';
        var m = 'rr';
        try {
            if (window._taboolaNetworkMode) {
                c = c + '---redesign';
                p = p + ' - Redesign';
                if (HDN.dataLayer.content.objectType  === 'article') {
                    m = 'f';
                if (HDN.dataLayer.presentation.infiniteScrollEnabled && (window.infiniteScroll && window.infiniteScroll.length > 0) && HDN.dataLayer.content.objectId && window.Article.isSensitive !== true && (Object.hasOwnProperty.call(HDN, 'activeABTest') && HDN.activeABTest === 'ENG9746')) {
                    p = 'Right Rail Thumbnails';
                    m = '1x8-rr';
                }
                }
            }
        } catch (e) {}
        var d = document.createElement('div');
        d.id = c;
        var s = document.getElementById('taboola-right-rail-script-id');
        s.parentNode.insertBefore(d, s);
        window._taboola = window._taboola || [];
        _taboola.push({
            mode: 'thumbnails-' + m,
            container: c,
            placement: p,
            target_type: 'mix'
        });
    }
})();
</script>
    </div>
            </aside>
    <aside id="zoneC" class="zone">
    
<!-- hearst/home/mostPopular.tpl -->

    <div class="mostPopular">
        <h2 class="collectionHeader" role="heading" aria-level="2">Most Popular</h2>
                                                <ol class="mostPopular--list">
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Waterbury-mall-to-get-first-tenant-under-new-owner-17390428.php" title="Brass Mill Center to get axe throwing business" data-hdn-analytics="visit|article-17390428|most_popular|0">Brass Mill Center to get axe throwing business</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Milford-car-dealer-faces-delays-from-glass-17389839.php" title="Milford car dealer faces delays from glass shortage, cell tower build" data-hdn-analytics="visit|article-17389839|most_popular|1">Milford car dealer faces delays from glass shortage, cell tower build</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Milford-rejects-plan-for-digital-billboards-17385650.php" title="Milford rejects plan for digital billboards" data-hdn-analytics="visit|article-17385650|most_popular|2">Milford rejects plan for digital billboards</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/hartford/article/DCF-worker-arrested-after-sneaking-female-client-17372081.php" title="Police: DCF social worker arrested after sneaking client and child out of building to avoid arrest" data-hdn-analytics="visit|article-17372081|most_popular|3">Police: DCF social worker arrested after sneaking client and child out of building to avoid arrest</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/policereports/article/Police-Man-who-assaulted-mother-of-his-child-in-17390805.php" title="Warrant: Bridgeport man fired gun, assaulted a woman in front of her child in a school parking lot" data-hdn-analytics="visit|article-17390805|most_popular|4">Warrant: Bridgeport man fired gun, assaulted a woman in front of her child in a school parking lot</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Electric-vehicle-showroom-planned-for-former-17383001.php" title="Electric vehicle showroom planned for former Milford Hooters site" data-hdn-analytics="visit|article-17383001|most_popular|5">Electric vehicle showroom planned for former Milford Hooters site</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Leora-Levy-claims-victory-in-U-S-Senate-primary-17363307.php" title="Leora Levy wins U.S. Senate primary over Themis Klarides, set to challenge Sen. Richard Blumenthal" data-hdn-analytics="visit|article-17363307|most_popular|6">Leora Levy wins U.S. Senate primary over Themis Klarides, set to challenge Sen. Richard Blumenthal</a>
                                                    </li>
                                    </ol>
                        </div>
<!--e hearst/home/mostPopular.tpl --></aside>
</aside>
<!-- e hearst/article/articleAside.tpl --><!-- hearst/article/articleFooter.tpl -->
<footer class="article--footer"><!-- hearst/common/author_body.tpl -->
     
        <div class="articleFooter">
                                <div class="articleFooter--author noImage">
                <div class="articleFooter--author-label">Written By </div>                    <div class="articleFooter--author-name"></div>
                </div>
                    </div>
<!-- e hearst/common/author_body.tpl --><section class="article--comments"><button id="commentsButton" data-link="https://www.milfordmirror.com/sports/articleComments/Angels-owner-Arte-Moreno-explores-selling-17392499.php" onclick="document.location.href = 'https://www.milfordmirror.com/sports/articleComments/Angels-owner-Arte-Moreno-explores-selling-17392499.php'; return false;">View Comments</button></section></footer>
<!-- e hearst/article/articleFooter.tpl --></section><section id="bottomZone" class="zone bottomZone lock">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85204 -->
    <div class="hst-freeform hdnce-e hdnce-item-85204">
                <script type="text/javascript" id="taboola-feed-script-id">
(function () {
    var c = 'taboola-below-article-thumbnails';
    var p = 'Below Article Thumbnails';
    try {
        if (window._taboolaNetworkMode) {
            var e = document.documentElement;
            var g = document.getElementsByTagName('body')[0];
            var w = window.innerWidth||e.clientWidth||g.clientWidth;
            if (w < 768) {
                c = 'taboola-mobile-below-article-feed---redesign';
                p = 'Mobile Below Article Feed - Redesign';
            } else {
                c = 'taboola-below-article-feed---redesign';
                p = 'Below Article Feed - Redesign';
            }
        }
    } catch (e) {}
    var d = document.createElement('div');
    d.id = c;
    var s = document.getElementById('taboola-feed-script-id');
    s.parentNode.insertBefore(d, s);
    window._taboola = window._taboola || [];
    window._taboola.push({
        mode: 'thumbnails-a',
        container: c,
        placement: p,
        target_type: 'mix'
    });
})();
</script>
    </div>
            <div class="taboola-skip-wrapper"><div id="taboola-skip"></div></div></section></main><!-- hearst/common/siteFooter.tpl -->
    <footer class="pageFooter">
    <div class="lock">
        <div class="pageFooter--wrapper">
            <div class="pageFooter--left">
                <a href="/">
                    <img class="pageFooter--left-logo" src="/img/logos/black/logo.svg" alt="Milford Mirror Homepage - Site Logo">
                </a>
                <ul class="pageFooter--left-social">
                    <li class="facebook"><a href="http://facebook.com/milfordmirror" aria-label="facebook"></a></li>                    <li class="twitter"><a href="http://twitter.com/milfordmirror" aria-label="twitter"></a></li>                                                        </ul>
            </div>
            <div class="pageFooter--right">
                <div class="pageFooter--right-topLine">
                    <a href="#content" class="return"><span class="full">Return to</span> Top</a>
                </div>
                <div class="pageFooter--right-links">
                    
                    <!-- hearst/item/standalone.tpl -->
<div class="hdnce-e hdnce-item-97493"><!-- mid:freeform.97493 -->
<style>
@media (min-width: 768px) {
  .pageFooter--right-links .wrapper > li:nth-child(2) {
    box-sizing: border-box;
    padding-left: 50px;
  }
}
</style>
<ul class="wrapper" role="presentation">
  <li>
<div class="title" role="heading" aria-level="2">About</div>
    <ul class="section" role="presentation">
      <li><a href="/home/article/How-Hearst-Newspapers-is-delivering-information-15678014.php">Newspaper Delivery Safety Procedures</a></li>
      <li><a href="/privacy/">Privacy Notice</a></li>
      <li><a href="/privacy/#additionalinformationforcaliforniaresidents">Your California Privacy Rights</a></li>
      <li><a href="/privacy/#interestbasedads">Interest Based Ads</a></li>
      <li><a href="/tos/">Terms of Use</a></li>
      <li><a href="https://eevd.fa.us6.oraclecloud.com/hcmUI/CandidateExperience/en/sites/CX_11004">Careers</a></li>
      <li><a href="https://hearstmediact.com/">Advertising</a></li>
    </ul>
  </li>
  <li>
<div class="title" role="heading" aria-level="2">Contact</div>
    <ul class="section" role="presentation">
      <li><a href="/contact/">Contact Us</a></li>
      <li><a href="/help/">FAQ's</a></li>
      <li><a href="https://subscription.hearstmediact.com/eEdition?siteID=CT_MM">E-Edition</a></li>
      <li><a href="/submissions/">Submissions</a></li>
    </ul>
  </li>
  <li>
<div class="title" role="heading" aria-level="2">Connect</div>
    <ul class="section" role="presentation">
      <li><a href="https://subscription.hearstmediact.com/checkout/700/1482?siteid=CT_MM&amp;origin=subserv&amp;ipid=footer">Subscribe Today</a></li>
      <li><a href="https://www.facebook.com/milfordmirror">Facebook</a></li>
      <li><a href="https://twitter.com/milfordmirror">Twitter</a></li>
    </ul>
  </li>
  <li>
</li>
</ul>
</div><!-- / hdnce-e -->                </div>
            </div>
        </div>
        <div class="pageFooter--branding">
            <img class="pageFooter--branding-logo" src="/img/core/hearst_newspapers_logo.svg" alt="HEARST newspapers logo" />
            <span class="pageFooter--branding-copyright">&copy;2022 Hearst</span>
        </div>
    </div>
                        <!-- hearst/common/spotImFooterJS.tpl -->
<script>
                                
        if ( document.readyState === "complete" || (document.readyState !== "loading" && !document.documentElement.doScroll)) {
            if (HDN && HDN.hasOwnProperty('spotim')) {
                HDN.spotim.commentCount(undefined,undefined,1);
            }
        } else {
            document.addEventListener("DOMContentLoaded", function() { 
                        if (HDN && HDN.hasOwnProperty('spotim')) {
                            HDN.spotim.commentCount(undefined,undefined,1);
                        }
                    });
        }
    
</script>
<!-- e hearst/common/spotImFooterJS.tpl -->
                            
                <script type="text/javascript">
                    window._taboola = window._taboola || [];
                    _taboola.push({flush: true});
                </script>
            
                    </footer>
<!-- e hearst/common/siteFooter.tpl -->
<!-- e hearst/article/types/dynamic_two_column.tpl --><!-- e design/article/dynamic_two_column.tpl -->            </body>
</html>
<!-- e hearst/article/articleMain.tpl --><!-- e hearst/article/article_main.tpl -->