




<!-- hearst/article/article_main.tpl -->

            <!-- hearst/article/articleMain.tpl -->



    
        <!doctype html>
<html class="no-js "  lang="en-US" prefix="og: http://ogp.me/ns#  article: http://ogp.me/ns/article#">
    <head>
<!-- hearst/article/headerMain.tpl -->

    <!-- Includes for HashTag Labs -->
    
    <!-- eid:article.17675782 -->
    <!-- generated at 2022-12-24 09:35:44 on pwcm5 running vv13.7.7 -->
            <!-- hmb:jquery jQuery JS -->
        <script type="text/javascript" src="/js/core/libs/jquery-2.2.4.min.js"></script>
                <!-- hmb:treg TREG JS -->
        <script type="text/javascript">window.tregEnabled = true;</script>
        <script type="text/javascript" src="//treg.hearstnp.com/treg.js"></script>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
            <!-- hmb:taboola Sailthru  -->
        <!-- hearst/home/header_sailthru.tpl -->
<meta property="sailthru.title" content="2022 New Orleans Saints Roster" /><meta name="sailthru.date" content="2022-12-24 10:09:00 -0500" /><meta name="sailthru.author" content="" /><meta name="sailthru_uid" content="17675782" /><meta name="sailthru_pubname" content="associated-press" /><meta name="sailthru_siteid" content="79" /><meta name="sailthru.tags" content="dennis-allen,jameis-winston,wil-lutz-k,jarvis-landry-wr,chris-olave-wr,marcus-maye-saf,jake-luton-qb,m,pete-werner-lb,andrew-dowell-lb,d-marco-jackson-lb,zack-baun-lb,ty-summers-lb,kaden-elliss-lb,isaac-yiadom-cb,blake-gillikin-p,marshon-lattimore-cb,taysom-hill,tre-quan-smith-wr,deonte-harty-wr,michael-thomas,andy-dalton,kevin-white,niko-lalos-de-6,daniel-sorensen-db,keith-kirkwood,dwayne-washington,david-johnson,justin-evans,eno-benjamin-rb,tyrann-mathieu-fs,kirk-merritt-wr,alvin-kamara-rb,derrick-gore,chris-harris-jr,bradley-roby,mark-ingram-ii-rb,adam-trautman-te,juwan-johnson-te,lucas-krull-te,zach-wood-ls,rashid-shaheed-wr,tanoh-kpassagnon-de-6,david-onyemata-dt,cameron-jordan-de-6,albert-huggins-dt,carl-granderson-de-6,malcolm-roach-dt,payton-turner-de-6,ryan-ramczyk-t,ethan-greenidge,demario-davis-lb,derrick-kelly-ii-ol,marcus-davenport,emili-dt,jabari-zuniga-de-6,josh-andrews-g,trevor-penning-t,tennessee,roster,florida,wisconsin,northern-iowa,michigan,can,utah,south-carolina,washington,oregon,auburn,west-virginia,kansas,alabama,dartmouth,pittsburgh,north-carolina,missouri,villanova,dayton,texas,manitoba,california,clemson,wyoming,houston,pennsylvania,kentucky,idaho,windsor,florida-state,ohio-state,georgia-state,new-orleans-saints,oregon-state,marquez-callaway-wr,penn-state,arkansas-state,byu,tcu,arizona-state,mississippi-state,michigan-state,appalachian-state,lsu,stanford,texas-a-amp,chase-hansen-lb,nephi-sewell-lb,paulson-adebo-cb,cesar-ruiz-ol,ucf,williams-cb,alontae-taylor-cb,saf,vincent-gray-db,boston-college,james-hurst-ol,andrus-peat-ol,calvin-throckmorton-ol,erik-mccoy-ol,weber-state,north-carolina-state,temple,holtz-te,louisiana-monroe,adam-prentice-fb,smu,yasir-durant-g,shy-tuttle-dt,montana-state,lewis-kidd-ol,utsa,jordan-jackson-dt,air-force,landon-young-t,member-choice-sports-option,generic-sports,gray-db,kentavius-street-dt,drew-desjarlais-g,florida-state,ohio-state,georgia-state,new-orleans-saints,oregon-state,marquez-callaway-wr,penn-state,arkansas-state,byu,tcu,arizona-state,mississippi-state,michigan-state,appalachian-state,lsu,stanford,texas-a-amp,chase-hansen-lb,nephi-sewell-lb,paulson-adebo-cb,cesar-ruiz-ol,ucf,williams-cb,alontae-taylor-cb,saf,vincent-gray-db,boston-college,james-hurst-ol,andrus-peat-ol,calvin-throckmorton-ol,erik-mccoy-ol,weber-state,north-carolina-state,temple,holtz-te,louisiana-monroe,adam-prentice-fb,smu,yasir-durant-g,shy-tuttle-dt,montana-state,lewis-kidd-ol,utsa,jordan-jackson-dt,air-force,dennis-allen,jameis-winston,wil-lutz-k,jarvis-landry-wr,chris-olave-wr,marcus-maye-saf,jake-luton-qb,m,pete-werner-lb,andrew-dowell-lb,d-marco-jackson-lb,zack-baun-lb,ty-summers-lb,kaden-elliss-lb,isaac-yiadom-cb,blake-gillikin-p,marshon-lattimore-cb,taysom-hill,tre-quan-smith-wr,deonte-harty-wr,michael-thomas,andy-dalton,kevin-white,niko-lalos-de-6,daniel-sorensen-db,keith-kirkwood,dwayne-washington,david-johnson,justin-evans,eno-benjamin-rb,tyrann-mathieu-fs,kirk-merritt-wr,alvin-kamara-rb,derrick-gore,chris-harris-jr,bradley-roby,mark-ingram-ii-rb,adam-trautman-te,juwan-johnson-te,lucas-krull-te,zach-wood-ls,rashid-shaheed-wr,tanoh-kpassagnon-de-6,david-onyemata-dt,cameron-jordan-de-6,albert-huggins-dt,carl-granderson-de-6,malcolm-roach-dt,payton-turner-de-6,ryan-ramczyk-t,ethan-greenidge,demario-davis-lb,derrick-kelly-ii-ol,marcus-davenport,emili-dt,jabari-zuniga-de-6,josh-andrews-g,trevor-penning-t,tennessee,roster,florida,wisconsin,northern-iowa,michigan,can,utah,south-carolina,washington,oregon,auburn,west-virginia,kansas,alabama,dartmouth,pittsburgh,north-carolina,missouri,villanova,dayton,texas,manitoba,california,clemson,wyoming,houston,pennsylvania,kentucky,idaho,windsor,member-choice-sports-option,generic-sports,gray-db,kentavius-street-dt,drew-desjarlais-g,2fsports-2fteam-sports-2famerican-football,2fnews-2fsports-news" /><meta name="sailthru.image.thumb" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg" />
<!-- e hearst/home/header_sailthru.tpl -->
    
        <title>2022 New Orleans Saints Roster</title>
    <!-- hearst/common/fonts.tpl -->
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-regular.woff" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-300.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-600.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<!-- e hearst/common/fonts.tpl -->

        <script>
          if ( document.location.hostname.match(/\.$/) ) {
              document.location.replace(
                  document.location.protocol +
                  '//' +
                  document.location.hostname.replace(/\.+$/, '') +
                  ( undefined !== document.location.pathname ? document.location.pathname : '' ) +
                  ( undefined !== document.location.search ? document.location.search : '' )  +
                  ( undefined !== document.location.hash ? document.location.hash : '' )
              );
          }
        </script>

    <script>
                var HDN = HDN || {};
        HDN.t_firstbyte = Number(new Date());
        HDN.dataLayer = HDN.dataLayer || {};
        HDN.dataLayer.content = HDN.dataLayer.content || {};
                HDN.dataLayer.paywall = HDN.dataLayer.paywall || {};
        HDN.dataLayer.paywall.accessRule = "";
        HDN.dataLayer.paywall.mode = "";
        var Article = {
            "id": "17675782",
            "title": "2022 New Orleans Saints Roster",
            "url": "https://www.milfordmirror.com/sports/article/2022-New-Orleans-Saints-Roster-17675782.php",
            "slug": "https://www.milfordmirror.com/sports/article/2022-New-Orleans-Saints-Roster-17675782.php",
            "summary": "Head Coach: Dennis Allen. . . . .. . .. . . . . . ... . . . . . . . . . . ....",
            "image": "https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg",
            "keywords": "",
            "siteName": "Milford Mirror",
            "env": "pwcm5",
            "comments": true,
            "isSensitive": false,
            "version": "v13.7.7",
            "displayTemplate": "dynamic_two_column",
            "renderNLP": true,
            "timing": {
                "firstbyte": HDN.t_firstbyte,
                "ready": {}
            }
        };
        
        document.addEventListener('DOMContentLoaded', function () {
            Article.timing.ready = Number(new Date());
        }, false);
        
    </script>
        
    <!-- hearst/common/hdn_datalayer_header.tpl -->

                                                                      
<script type="text/javascript">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</script>
<!-- e hearst/common/hdn_datalayer_header.tpl -->
    <script type="text/javascript" src="/js/site.js?v13.7.7"></script>
            
            <!-- Hotfix Top Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.94216 -->
<!-- DO NOT REMOVE -->
<script src="https://projects.sfchronicle.com/shared/js/responsive-frame.js"></script>
<!-- e DO NOT REMOVE -->
        <!-- Hotfix Top Freeform (Local Dynamic Two-Column) -->
        
<!-- noGen: item_header_hotfix_top_dtc_ssl 79 dne  -->
                <link rel="stylesheet" href="/dist/article.min.css?v13.7.7">
                            <!-- hmb:Polyfill  -->
        <script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=IntersectionObserver%2CIntersectionObserverEntry%2CPromise%2CCustomEvent%2CArray.prototype.forEach%2CArray.prototype.entries"></script>
                <!-- hmb:js_header Static JS Bundle  -->
        <script type="text/javascript" src="/dist/hdn/article.min.js?v13.7.7"></script>
        <!-- hearst/article/common/meta_tags.tpl -->
<meta name="msvalidate.01" content="9451CA04ABC9D1D5C6419C73B4C4F7B7" />
<meta name="HandheldFriendly" content="true">
<meta name="twitter:dnt" content="on">
<meta name="apple-mobile-web-app-title" content="">
<meta name="environment" content="pwcm5">
<meta name="id" content="17675782">
<link rel="canonical" href="https://www.milfordmirror.com/sports/article/2022-New-Orleans-Saints-Roster-17675782.php" />
<meta name="robots" content="max-image-preview:large">
                                            <meta name="author" content="">
        <meta name="author.name" content="" />
        <meta name="author.title" content="" />
        <meta name="description" content="Head Coach: Dennis Allen. . . . .. . .. . . . . . ... . . . . . . . . . . ...."/>
    <meta name="date.release" content="2022-12-24 15:09:09" />
    <meta name="time.release" content="2022-12-24 15:09:09" />
    <meta name="sections" content="Sports" />
            <meta name="subject" content="Dennis Allen, Jameis Winston, Wil Lutz K, Jarvis Landry WR, Chris Olave WR, Marcus Maye SAF, Jake Luton QB, M, Pete Werner LB, Andrew Dowell LB, D'Marco Jackson LB, Zack Baun LB, Ty Summers LB, Kaden Elliss LB, Isaac Yiadom CB, Blake Gillikin P, Marshon Lattimore CB, Taysom Hill, Tre'Quan Smith WR, Deonte Harty WR, Michael Thomas, Andy Dalton, Kevin White, Niko Lalos DE 6, Daniel Sorensen DB, Keith Kirkwood, Dwayne Washington, David Johnson, Justin Evans, Eno Benjamin RB, Tyrann Mathieu FS, Kirk Merritt WR, Alvin Kamara RB, Derrick Gore, Chris Harris Jr, Bradley Roby, Mark Ingram II RB, Adam Trautman TE, Juwan Johnson TE, Lucas Krull TE, Zach Wood LS, Rashid Shaheed WR, Tanoh Kpassagnon DE 6, David Onyemata DT, Cameron Jordan DE 6, Albert Huggins DT, Carl Granderson DE 6, Malcolm Roach DT, Payton Turner DE 6, Ryan Ramczyk T, Ethan Greenidge, Demario Davis LB, Derrick Kelly II OL, Marcus Davenport, Emili DT, Jabari Zuniga DE 6, Josh Andrews G, Trevor Penning T, Tennessee, Roster., Florida, Wisconsin, Northern Iowa, Michigan, CAN, Utah, South Carolina, Washington, Oregon, Auburn, West Virginia, Kansas, Alabama, Dartmouth, Pittsburgh, North Carolina, Missouri, Villanova, Dayton, Texas, Manitoba, California, Clemson, Wyoming, Houston, Pennsylvania, Kentucky, Idaho, Windsor, Florida State, Ohio State, Georgia State, New Orleans Saints, Oregon State, Marquez Callaway WR, Penn State, Arkansas State, BYU, TCU, Arizona State, Mississippi State, Michigan State, Appalachian State, LSU, Stanford, Texas A&amp, Chase Hansen LB, Nephi Sewell LB, Paulson Adebo CB, Cesar Ruiz OL, UCF, Williams CB, Alontae Taylor CB, SAF, Vincent Gray DB, Boston College, James Hurst OL, Andrus Peat OL, Calvin Throckmorton OL, Erik McCoy OL, Weber State, North Carolina State, Temple, Holtz TE, Louisiana-Monroe, Adam Prentice FB, SMU, Yasir Durant G, Shy Tuttle DT, Montana State, Lewis Kidd OL, UTSA, Jordan Jackson DT, Air Force, Landon Young T, Member Choice Sports Option, Generic Sports, Gray DB, Kentavius Street DT, Drew Desjarlais G" />
        <meta name="news_keywords" content="Dennis Allen, Jameis Winston, Wil Lutz K, Jarvis Landry WR, Chris Olave WR, Marcus Maye SAF, Jake Luton QB, M, Pete Werner LB, Andrew Dowell LB, D'Marco Jackson LB, Zack Baun LB, Ty Summers LB, Kaden Elliss LB, Isaac Yiadom CB, Blake Gillikin P, Marshon Lattimore CB, Taysom Hill, Tre'Quan Smith WR, Deonte Harty WR, Michael Thomas, Andy Dalton, Kevin White, Niko Lalos DE 6, Daniel Sorensen DB, Keith Kirkwood, Dwayne Washington, David Johnson, Justin Evans, Eno Benjamin RB, Tyrann Mathieu FS, Kirk Merritt WR, Alvin Kamara RB, Derrick Gore, Chris Harris Jr, Bradley Roby, Mark Ingram II RB, Adam Trautman TE, Juwan Johnson TE, Lucas Krull TE, Zach Wood LS, Rashid Shaheed WR, Tanoh Kpassagnon DE 6, David Onyemata DT, Cameron Jordan DE 6, Albert Huggins DT, Carl Granderson DE 6, Malcolm Roach DT, Payton Turner DE 6, Ryan Ramczyk T, Ethan Greenidge, Demario Davis LB, Derrick Kelly II OL, Marcus Davenport, Emili DT, Jabari Zuniga DE 6, Josh Andrews G, Trevor Penning T, Tennessee, Roster., Florida, Wisconsin, Northern Iowa, Michigan, CAN, Utah, South Carolina, Washington, Oregon, Auburn, West Virginia, Kansas, Alabama, Dartmouth, Pittsburgh, North Carolina, Missouri, Villanova, Dayton, Texas, Manitoba, California, Clemson, Wyoming, Houston, Pennsylvania, Kentucky, Idaho, Windsor, Florida State, Ohio State, Georgia State, New Orleans Saints, Oregon State, Marquez Callaway WR, Penn State, Arkansas State, BYU, TCU, Arizona State, Mississippi State, Michigan State, Appalachian State, LSU, Stanford, Texas A&amp, Chase Hansen LB, Nephi Sewell LB, Paulson Adebo CB, Cesar Ruiz OL, UCF, Williams CB, Alontae Taylor CB, SAF, Vincent Gray DB, Boston College, James Hurst OL, Andrus Peat OL, Calvin Throckmorton OL, Erik McCoy OL, Weber State, North Carolina State, Temple, Holtz TE, Louisiana-Monroe, Adam Prentice FB, SMU, Yasir Durant G, Shy Tuttle DT, Montana State, Lewis Kidd OL, UTSA, Jordan Jackson DT, Air Force, Landon Young T, Member Choice Sports Option, Generic Sports, Gray DB, Kentavius Street DT, Drew Desjarlais G" />
                <meta name="nlpOrganization" content="Florida State, Ohio State, Georgia State, New Orleans Saints, Oregon State, Marquez Callaway WR, Penn State, Arkansas State, BYU, TCU, Arizona State, Mississippi State, Michigan State, Appalachian State, LSU, Stanford, Texas A&amp, Chase Hansen LB, Nephi Sewell LB, Paulson Adebo CB, Cesar Ruiz OL, UCF, Williams CB, Alontae Taylor CB, SAF, Vincent Gray DB, Boston College, James Hurst OL, Andrus Peat OL, Calvin Throckmorton OL, Erik McCoy OL, Weber State, North Carolina State, Temple, Holtz TE, Louisiana-Monroe, Adam Prentice FB, SMU, Yasir Durant G, Shy Tuttle DT, Montana State, Lewis Kidd OL, UTSA, Jordan Jackson DT, Air Force" />
                <meta name="nlpPerson" content="Dennis Allen, Jameis Winston, Wil Lutz K, Jarvis Landry WR, Chris Olave WR, Marcus Maye SAF, Jake Luton QB, M, Pete Werner LB, Andrew Dowell LB, D'Marco Jackson LB, Zack Baun LB, Ty Summers LB, Kaden Elliss LB, Isaac Yiadom CB, Blake Gillikin P, Marshon Lattimore CB, Taysom Hill, Tre'Quan Smith WR, Deonte Harty WR, Michael Thomas, Andy Dalton, Kevin White, Niko Lalos DE 6, Daniel Sorensen DB, Keith Kirkwood, Dwayne Washington, David Johnson, Justin Evans, Eno Benjamin RB, Tyrann Mathieu FS, Kirk Merritt WR, Alvin Kamara RB, Derrick Gore, Chris Harris Jr, Bradley Roby, Mark Ingram II RB, Adam Trautman TE, Juwan Johnson TE, Lucas Krull TE, Zach Wood LS, Rashid Shaheed WR, Tanoh Kpassagnon DE 6, David Onyemata DT, Cameron Jordan DE 6, Albert Huggins DT, Carl Granderson DE 6, Malcolm Roach DT, Payton Turner DE 6, Ryan Ramczyk T, Ethan Greenidge, Demario Davis LB, Derrick Kelly II OL, Marcus Davenport, Emili DT, Jabari Zuniga DE 6, Josh Andrews G, Trevor Penning T" />
                <meta name="nlpLocation" content="Tennessee, Roster., Florida, Wisconsin, Northern Iowa, Michigan, CAN, Utah, South Carolina, Washington, Oregon, Auburn, West Virginia, Kansas, Alabama, Dartmouth, Pittsburgh, North Carolina, Missouri, Villanova, Dayton, Texas, Manitoba, California, Clemson, Wyoming, Houston, Pennsylvania, Kentucky, Idaho, Windsor" />
                <meta name="nlpConsumerGood" content="Landon Young T" />
                        <meta name="nlpOther" content="Member Choice Sports Option, Generic Sports, Gray DB, Kentavius Street DT, Drew Desjarlais G" />
                            <meta name="nlpCategories" content="%2FSports%2FTeam+Sports%2FAmerican+Football,%2FNews%2FSports+News" />
    <!-- e hearst/article/common/meta_tags.tpl -->    <!-- hearst/article/common/opengraph.tpl -->
<meta property="fb:admins" content="100006394927810"/><meta property="fb:app_id" content="322056085100167"/><meta property="fb:pages" content="105702905593" /><meta property="fb:pages" content="307851324523" /><meta property="fb:pages" content="12852567813" /><meta property="fb:pages" content="480760515417232" /><meta property="fb:pages" content="288240529145" /><meta property="fb:pages" content="316774245761" /><meta property="fb:pages" content="984197758297116" /><meta property="fb:pages" content="7457442370" /><meta property="fb:pages" content="207033189701" /><meta property="fb:pages" content="207346283795" /><meta property="fb:pages" content="222959748728" /><meta property="fb:pages" content="207042068180" /><meta property="fb:pages" content="72983690774" /><meta property="fb:pages" content="339413234035" /><meta property="fb:pages" content="343689323559" /><meta property="fb:pages" content="345828366626" /><meta property="fb:pages" content="234821559861394" /><meta property="fb:pages" content="335699426867" /><meta property="fb:pages" content="10150105039485602" /><meta property="fb:pages" content="338983127562" /><meta property="fb:pages" content="364516539001" /><meta property="fb:pages" content="337922332042" /><meta property="fb:pages" content="115637335153191" /><meta property="fb:pages" content="372011535931" /><meta property="fb:pages" content="333376634908" /><meta property="fb:pages" content="127590790608884" /><meta property="fb:pages" content="141923885872653" /><meta property="fb:pages" content="655037391286291" /><meta property="fb:pages" content="320774811368833" /><meta property="fb:pages" content="1740489152861748" /><meta property="fb:pages" content="469700473093040" /><meta property="fb:pages" content="386754203367" /><meta property="fb:pages" content="556449374478585" /><meta property="fb:pages" content="340999853450" /><meta property="fb:pages" content="350771491032" /><meta property="fb:pages" content="1120648627959218" /><meta property="fb:pages" content="342017778245" /><meta property="fb:pages" content="338463361591" /><meta property="fb:pages" content="138772706196968" /><meta property="fb:pages" content="1641688532739111" /><meta property="fb:pages" content="326312697536" /><meta property="fb:pages" content="353120110016" /><meta property="fb:pages" content="343366744658" /><meta property="fb:pages" content="335009494554" /><meta property="fb:pages" content="347261603104" /><meta property="fb:pages" content="350924013892" /><meta property="fb:pages" content="257724773860" /><meta property="fb:pages" content="361203926417" /><meta property="fb:pages" content="367174215398" /><meta property="fb:pages" content="284154645394" /><meta property="fb:pages" content="334501182354" /><meta property="fb:pages" content="350279743224" /><meta property="fb:pages" content="154340691263654" /><meta property="fb:pages" content="147848678611852" /><meta property="fb:pages" content="361381078011" /><meta property="fb:pages" content="362831597677" /><meta property="fb:pages" content="10150095255780118" /><meta name="og:datePublished" content="2022-12-24 15:06:26"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="2022 New Orleans Saints Roster"/><meta property="og:description" content="Head Coach: Dennis Allen. . . . .. . .. . . . . . ... . . . . . . . . . . ...."/><meta property="og:url" content="https://www.milfordmirror.com/sports/article/2022-New-Orleans-Saints-Roster-17675782.php"/><meta property="og:site_name" content="Milford Mirror"/><meta property="og:image" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg"/><meta property="article:published_time" content="2022-12-24 15:06:26" /><meta property="article:modified_time" content="2022-12-24 15:09:10" /><meta property="article:author" content=""/><meta property="article:section" content="Sports" /><meta property="article:tag" content="Dennis Allen" /><meta property="article:tag" content="Jameis Winston" /><meta property="article:tag" content="Wil Lutz K" /><meta property="article:tag" content="Jarvis Landry WR" /><meta property="article:tag" content="Chris Olave WR" /><meta property="article:tag" content="Marcus Maye SAF" /><meta property="article:tag" content="Jake Luton QB" /><meta property="article:tag" content="M" /><meta property="article:tag" content="Pete Werner LB" /><meta property="article:tag" content="Andrew Dowell LB" /><meta property="article:tag" content="D&#039;Marco Jackson LB" /><meta property="article:tag" content="Zack Baun LB" /><meta property="article:tag" content="Ty Summers LB" /><meta property="article:tag" content="Kaden Elliss LB" /><meta property="article:tag" content="Isaac Yiadom CB" /><meta property="article:tag" content="Blake Gillikin P" /><meta property="article:tag" content="Marshon Lattimore CB" /><meta property="article:tag" content="Taysom Hill" /><meta property="article:tag" content="Tre&#039;Quan Smith WR" /><meta property="article:tag" content="Deonte Harty WR" /><meta property="article:tag" content="Michael Thomas" /><meta property="article:tag" content="Andy Dalton" /><meta property="article:tag" content="Kevin White" /><meta property="article:tag" content="Niko Lalos DE 6" /><meta property="article:tag" content="Daniel Sorensen DB" /><meta property="article:tag" content="Keith Kirkwood" /><meta property="article:tag" content="Dwayne Washington" /><meta property="article:tag" content="David Johnson" /><meta property="article:tag" content="Justin Evans" /><meta property="article:tag" content="Eno Benjamin RB" /><meta property="article:tag" content="Tyrann Mathieu FS" /><meta property="article:tag" content="Kirk Merritt WR" /><meta property="article:tag" content="Alvin Kamara RB" /><meta property="article:tag" content="Derrick Gore" /><meta property="article:tag" content="Chris Harris Jr" /><meta property="article:tag" content="Bradley Roby" /><meta property="article:tag" content="Mark Ingram II RB" /><meta property="article:tag" content="Adam Trautman TE" /><meta property="article:tag" content="Juwan Johnson TE" /><meta property="article:tag" content="Lucas Krull TE" /><meta property="article:tag" content="Zach Wood LS" /><meta property="article:tag" content="Rashid Shaheed WR" /><meta property="article:tag" content="Tanoh Kpassagnon DE 6" /><meta property="article:tag" content="David Onyemata DT" /><meta property="article:tag" content="Cameron Jordan DE 6" /><meta property="article:tag" content="Albert Huggins DT" /><meta property="article:tag" content="Carl Granderson DE 6" /><meta property="article:tag" content="Malcolm Roach DT" /><meta property="article:tag" content="Payton Turner DE 6" /><meta property="article:tag" content="Ryan Ramczyk T" /><meta property="article:tag" content="Ethan Greenidge" /><meta property="article:tag" content="Demario Davis LB" /><meta property="article:tag" content="Derrick Kelly II OL" /><meta property="article:tag" content="Marcus Davenport" /><meta property="article:tag" content="Emili DT" /><meta property="article:tag" content="Jabari Zuniga DE 6" /><meta property="article:tag" content="Josh Andrews G" /><meta property="article:tag" content="Trevor Penning T" /><meta property="article:tag" content="Tennessee" /><meta property="article:tag" content="Roster." /><meta property="article:tag" content="Florida" /><meta property="article:tag" content="Wisconsin" /><meta property="article:tag" content="Northern Iowa" /><meta property="article:tag" content="Michigan" /><meta property="article:tag" content="CAN" /><meta property="article:tag" content="Utah" /><meta property="article:tag" content="South Carolina" /><meta property="article:tag" content="Washington" /><meta property="article:tag" content="Oregon" /><meta property="article:tag" content="Auburn" /><meta property="article:tag" content="West Virginia" /><meta property="article:tag" content="Kansas" /><meta property="article:tag" content="Alabama" /><meta property="article:tag" content="Dartmouth" /><meta property="article:tag" content="Pittsburgh" /><meta property="article:tag" content="North Carolina" /><meta property="article:tag" content="Missouri" /><meta property="article:tag" content="Villanova" /><meta property="article:tag" content="Dayton" /><meta property="article:tag" content="Texas" /><meta property="article:tag" content="Manitoba" /><meta property="article:tag" content="California" /><meta property="article:tag" content="Clemson" /><meta property="article:tag" content="Wyoming" /><meta property="article:tag" content="Houston" /><meta property="article:tag" content="Pennsylvania" /><meta property="article:tag" content="Kentucky" /><meta property="article:tag" content="Idaho" /><meta property="article:tag" content="Windsor" /><meta property="article:tag" content="Florida State" /><meta property="article:tag" content="Ohio State" /><meta property="article:tag" content="Georgia State" /><meta property="article:tag" content="New Orleans Saints" /><meta property="article:tag" content="Oregon State" /><meta property="article:tag" content="Marquez Callaway WR" /><meta property="article:tag" content="Penn State" /><meta property="article:tag" content="Arkansas State" /><meta property="article:tag" content="BYU" /><meta property="article:tag" content="TCU" /><meta property="article:tag" content="Arizona State" /><meta property="article:tag" content="Mississippi State" /><meta property="article:tag" content="Michigan State" /><meta property="article:tag" content="Appalachian State" /><meta property="article:tag" content="LSU" /><meta property="article:tag" content="Stanford" /><meta property="article:tag" content="Texas A&amp;amp" /><meta property="article:tag" content="Chase Hansen LB" /><meta property="article:tag" content="Nephi Sewell LB" /><meta property="article:tag" content="Paulson Adebo CB" /><meta property="article:tag" content="Cesar Ruiz OL" /><meta property="article:tag" content="UCF" /><meta property="article:tag" content="Williams CB" /><meta property="article:tag" content="Alontae Taylor CB" /><meta property="article:tag" content="SAF" /><meta property="article:tag" content="Vincent Gray DB" /><meta property="article:tag" content="Boston College" /><meta property="article:tag" content="James Hurst OL" /><meta property="article:tag" content="Andrus Peat OL" /><meta property="article:tag" content="Calvin Throckmorton OL" /><meta property="article:tag" content="Erik McCoy OL" /><meta property="article:tag" content="Weber State" /><meta property="article:tag" content="North Carolina State" /><meta property="article:tag" content="Temple" /><meta property="article:tag" content="Holtz TE" /><meta property="article:tag" content="Louisiana-Monroe" /><meta property="article:tag" content="Adam Prentice FB" /><meta property="article:tag" content="SMU" /><meta property="article:tag" content="Yasir Durant G" /><meta property="article:tag" content="Shy Tuttle DT" /><meta property="article:tag" content="Montana State" /><meta property="article:tag" content="Lewis Kidd OL" /><meta property="article:tag" content="UTSA" /><meta property="article:tag" content="Jordan Jackson DT" /><meta property="article:tag" content="Air Force" /><meta property="article:tag" content="Landon Young T" /><meta property="article:tag" content="Member Choice Sports Option" /><meta property="article:tag" content="Generic Sports" /><meta property="article:tag" content="Gray DB" /><meta property="article:tag" content="Kentavius Street DT" /><meta property="article:tag" content="Drew Desjarlais G" />
<!-- e hearst/article/common/opengraph.tpl -->    <!-- hearst/article/common/twittercard.tpl -->

<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:image" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg"/>
<meta name="twitter:description" content="Head Coach: Dennis Allen. . . . .. . .. . . . . . ... . . . . . . . . . . ...."/>
<meta name="twitter:title" content="2022 New Orleans Saints Roster"/>
<meta name="twitter:site" content="@milfordmirror" />
<!-- e hearst/article/common/twittercard.tpl -->    <!-- hearst/article/common/analytics.tpl -->
<script>var omni_channelPath = "Sports";var omni_title = "2022 New Orleans Saints Roster";var omni_bizObjectId = "17675782";var omni_className = "article";var omni_publicationDate = "2022-12-24 15:06:26";var omni_sourceSite ="ap";var omni_authorName = "";var omni_authorTitle = "";var omni_premiumStatus = "free";var omni_premiumEndDate = "";var omni_originalSource = "AP";var omni_pageNumber = "0";var omni_breakingNewsFlag = "0";var omni_localNewsFlag = "0";var omni_isListView = "0";var omni_paywallSite = "0";var omni_displayTemplate = "dynamic_two_column";</script>
<!-- e hearst/article/common/analytics.tpl -->    <!-- hearst/article/common/schema_NewsArticle.tpl -->

<script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@id":"https:\/\/www.milfordmirror.com\/sports\/article\/2022-New-Orleans-Saints-Roster-17675782.php"},"headline":"2022 New Orleans Saints Roster","articleBody":"No. Player Pos Ht Wt Born Exp College 1 Marquez Callaway WR 6-2 204 03-27-1998 2 Tennessee 2 Jameis Winston QB 6-4 231 01-06-1994 7 Florida State 3 Wil Lutz K 5-11 184 07-07-1994 6 Georgia State 4 Blake Gillikin P 6-2 196 01-21-1998 2 Penn State 5 Jarvis Landry WR 5-11 202 11-28-1992 8 LSU 6 Marcus Maye SAF 5-11 207 03-09-1993 5 Florida 7 Taysom Hill TE 6-2 221 08-23-1990 5 BYU 10 Tre'Quan Smith WR 6-2 210 01-07-1996 4 UCF 11 Deonte Harty WR 5-6 170 12-04-1997 3 Assumption 12 Chris Olave WR 6-1 189 06-27-2000 0 Ohio State 13 Michael Thomas WR 6-3 212 03-03-1993 6 Ohio State 14 Andy Dalton QB 6-2 220 10-29-1987 11 TCU 16 Jake Luton QB 6-6 224 04-11-1996 2 Oregon State 17 Kevin White WR 6-3 216 06-25-1992 7 West Virginia 18 Keith Kirkwood WR 6-3 210 12-26-1994 4 Temple 19 Chris Harris Jr. SAF 5-10 190 06-18-1989 11 Kansas 20 Pete Werner LB 6-3 242 06-05-1999 1 Ohio State 21 Bradley Roby CB 5-11 194 05-01-1992 8 Ohio State 22 Mark Ingram II RB 5-9 215 12-21-1989 11 Alabama 23 Marshon Lattimore CB 6-0 192 05-19-1996 5 Ohio State 24 Dwayne Washington RB 6-1 223 04-24-1994 6 Washington 25 Daniel Sorensen DB 6-1 208 03-05-1990 8 BYU 26 P.J. Williams CB 6-0 196 06-01-1993 7 Florida State 27 Alontae Taylor CB 6-0 195 12-03-1998 0 Tennessee 28 David Johnson RB 6-1 224 12-16-1991 7 Northern Iowa 29 Paulson Adebo CB 6-1 192 07-03-1999 1 Stanford 30 Justin Evans SAF 6-0 199 08-26-1995 5 Texas A&M 31 Eno Benjamin RB 5-9 207 04-13-1999 2 Arizona State 32 Tyrann Mathieu FS 5-9 190 05-13-1992 9 LSU 33 Kirk Merritt WR 6-0 208 01-05-1997 2 Arkansas State 35 Vincent Gray DB 6-2 192 12-28-1999 0 Michigan 36 Isaac Yiadom CB 6-1 190 02-20-1996 4 Boston College 38 Smoke Monday SAF 6-3 199 02-19-2000 0 Auburn 41 Alvin Kamara RB 5-10 215 07-25-1995 5 Tennessee 42 Chase Hansen LB 6-3 222 05-20-1993 3 Utah 44 Derrick Gore RB 5-10 212 12-13-1994 3 Louisiana-Monroe 45 Nephi Sewell LB 6-0 228 12-19-1998 0 Utah 46 Adam Prentice FB 6-0 245 01-16-1997 1 South Carolina 48 J.T. Gray DB 6-0 202 01-18-1996 4 Mississippi State 49 Zach Wood LS 6-3 255 01-10-1993 6 SMU 50 Andrew Dowell LB 6-1 225 11-16-1996 3 Michigan State 51 Cesar Ruiz OL 6-4 316 06-14-1999 2 Michigan 52 D'Marco Jackson LB 6-1 230 07-20-1998 0 Appalachian State 53 Zack Baun LB 6-3 225 12-30-1996 2 Wisconsin 54 Ty Summers LB 6-1 241 12-31-1995 3 TCU 54 Niko Lalos DE 6-5 269 06-25-1997 2 Dartmouth 55 Kaden Elliss LB 6-3 238 07-10-1995 3 Idaho 56 Demario Davis LB 6-2 248 01-11-1989 10 Arkansas State 57 Prince Emili DT 6-2 300 09-18-1998 0 Pennsylvania 59 Jordan Jackson DT 6-5 285 01-30-1998 0 Air Force 61 Drew Desjarlais G 6-2 313 04-24-1997 0 Windsor (CAN) 62 Derrick Kelly II OL 6-5 320 08-23-1995 3 Florida State 66 Lewis Kidd OL 6-6 311 09-15-1997 0 Montana State 67 Landon Young T 6-7 321 08-21-1997 1 Kentucky 68 Josh Andrews G 6-2 298 06-21-1991 8 Oregon State 69 Jabari Zuniga DE 6-3 264 08-14-1997 2 Florida 70 Trevor Penning T 6-7 332 05-15-1999 0 Northern Iowa 71 Ryan Ramczyk T 6-6 314 04-22-1994 5 Wisconsin 73 Ethan Greenidge OL 6-4 335 09-10-1997 3 Villanova 74 James Hurst OL 6-5 310 12-17-1991 8 North Carolina 75 Andrus Peat OL 6-7 316 11-04-1993 7 Stanford 76 Calvin Throckmorton OL 6-5 309 08-16-1996 2 Oregon 78 Erik McCoy OL 6-4 303 08-27-1997 3 Texas A&M 79 Yasir Durant G 6-7 330 05-21-1998 2 Missouri 82 Adam Trautman TE 6-5 253 02-05-1997 2 Dayton 83 Juwan Johnson TE 6-4 231 09-13-1996 2 Oregon 87 Lucas Krull TE 6-6 260 07-11-1998 0 Pittsburgh 88 J.P. Holtz TE 6-3 240 08-28-1993 6 Pittsburgh 89 Rashid Shaheed WR 6-0 180 08-31-1998 0 Weber State 90 Tanoh Kpassagnon DE 6-7 289 06-14-1994 5 Villanova 91 Kentavius Street DT 6-2 287 05-08-1996 4 North Carolina State 92 Marcus Davenport DE 6-6 265 09-04-1996 4 UTSA 93 David Onyemata DT 6-4 300 11-13-1992 6 Manitoba (CAN) 94 Cameron Jordan DE 6-4 287 07-10-1989 11 California 95 Albert Huggins DT 6-3 305 06-27-1997 3 Clemson 96 Carl Granderson DE 6-5 261 12-18-1996 3 Wyoming 97 Malcolm Roach DT 6-3 290 06-09-1998 2 Texas 98 Payton Turner DE 6-6 270 01-07-1999 1 Houston 99 Shy Tuttle DT 6-3 300 10-20-1995 3 Tennessee","datePublished":"2022-12-24T15:06:26Z","dateModified":"2022-12-24T15:09:10Z","author":[{"@type":"Person","name":"","jobTitle":""}],"publisher":{"@type":"Organization","name":"Associated Press","logo":{"@type":"ImageObject","url":"https:\/\/www.MilfordMirror.com\/img\/ldjson_logo.png","width":600,"height":60},"sameAs":["http:\/\/facebook.com\/milfordmirror","http:\/\/twitter.com\/milfordmirror"]},"description":"Head Coach: Dennis Allen. . . . .. . .. . . . . . ... . . . . . . . . . . ...."}
</script>
<!-- e hearst/article/common/schema_NewsArticle.tpl -->        <!-- hearst/common/third_party_assets.tpl -->
                    <!-- hmb:juice Juice -->
        <script type="text/javascript">
            
                var startRevWorker = function() {
                    if (window.articleShowLISTQueue) {
                        while (window.articleShowLISTQueue.length > 0) {
                            var showListEntry = articleShowLISTQueue.shift();
                            window.aps.showLIST([showListEntry]);
                        }
                    }
                    if (window.placeAdQueue) {
                        while (window.placeAdQueue.length > 0) {
                            var placeAdEntry = placeAdQueue.shift();
                            window.aps.placeAd([placeAdEntry]);
                        }
                    }
                    if (window.slideshowShowLISTQueue) {
                        while (window.slideshowShowLISTQueue.length > 0) {
                            var ads = window.slideshowShowLISTQueue.shift();
                            window.aps.showLIST(ads);
                        }
                    }
                    window.juiceloaded = true;
                }
            
        </script>

        <!-- ENG-10074 If AB Test on Seattle we turn off Juice in order to use HTL code -->
                    <script  src="https://aps.hearstnp.com/Scripts/loadAds.js?v=1.3.3.5" type="text/javascript" id="adPositionManagerScriptTag"></script>
            
    <!-- hmb:ensighten Ensighten  -->
    <!-- hearst/ensighten/ensighten.tpl -->
<!-- hmb:ensighten Ensighten script -->
<!-- Hearst analytics: Ensighten -->
<script src="https://tm.hdmtools.com/hearst/news/Bootstrap.js"></script>
<!-- End Hearst analytics: Ensighten -->
<!-- e ensighten.tpl -->                    <!-- blueconic -->
        <script src="https://y752.milfordmirror.com/script.js" async></script>
            
    <!-- hmb:taboola Taboola  -->
                            
                            
                <script type="text/javascript">
                    
                    (function () {
                        window._taboolaNetworkMode = true;
                        
                        window._taboola = window._taboola || [];
                        window._taboolaHDNPageLabel = window._taboolaHDNPageLabel || 'article';
                        var tobj = {};
                        tobj[window._taboolaHDNPageLabel] = 'auto';
                        window._taboola.push(tobj);
                        !function (e, f, u, i) {
                            if (!document.getElementById(i)){
                                e.async = 1;
                                e.src = u;
                                e.id = i;
                                f.parentNode.insertBefore(e, f);
                            }
                        }(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/hearstlocalnews-network/loader.js', 'tb_loader_script');
                        if(window.performance && typeof window.performance.mark == 'function') {
                            window.performance.mark('tbl_ic');
                        }
                    })();
                </script>
                
                                <!-- e hearst/common/third_party_assets.tpl -->
    <link rel="shortcut icon" href="/favicon.ico">
    <link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon.png">
    <link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
    <link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
    <link rel="apple-touch-icon-precomposed" sizes="128x128" href="/apple-touch-icon-128x128.png">
            <!-- Hotfix Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.93530 -->
<!-- ENG-3363 -->
<style>
  .thumbnailListAuthor.one .thumbnailListAuthor--wrapper { margin: 0; }
  @media (min-width: 768px) { .thumbnailListAuthor.two .thumbnailListAuthor--wrapper { margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--items { justify-content: space-between; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--item { flex: 0 0 48%; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--spacer { display: none; } }
  @media (min-width: 928px) { .thumbnailListAuthor.three .thumbnailListAuthor--wrapper { margin: 0; } }
</style>
<!-- ENG-3834 -->
<style>
  .alert{background-color:#000;bottom:0;box-sizing:border-box;color:#fff;font-family:Helvetica,sans-serif;font-size:16px;font-weight:600;left:50%;line-height:1.25;overflow:hidden;padding:10px;position:fixed;transform:translateX(-50%);width:100vw;z-index:5000000}.alert .close{border-radius:8px;color:#fff;display:block;position:absolute;right:10px;height:16px;overflow:hidden;top:10px;width:16px}.alert .close::after{background-color:#fff;content:'';display:block;height:2px;left:-6px;position:relative;top:4px;transform:rotate(-45deg);width:30px}.alert .close::before{background-color:#fff;content:'';display:block;height:2px;left:-5px;position:relative;top:9px;transform:rotate(45deg);width:30px}.alert>div{box-sizing:border-box;max-width:1200px;margin:0 auto;position:relative;padding-right:34px}
</style>
<script>
  document.addEventListener('DOMContentLoaded', function() {
    if (/MSIE \d|Trident.*rv:/.test(navigator.userAgent)) {var site=HDN.domain,name=site.charAt(0).toUpperCase()+site.slice(1),section=document.createElement("section"),close=document.createElement("a");close.className="close",close.href="#",close.addEventListener("click",function(e){e.stopPropagation(),e.preventDefault(),e.target.parentElement.style.display="none"});var HTML="<div>Thank you for visiting "+name+". You are using an older browser that may impact your reading experience. For the best experience, we recommend you use Chrome, Safari, Firefox, or Edge.</div>";section.className="alert",section.id="warning",section.innerHTML=HTML,section.appendChild(close),document.getElementsByTagName("body")[0].appendChild(section);}
  }, false);
</script>
<!-- e ENG-3834 -->
<!--  Start ENG-8221 -->
<style>
@media (max-width:768px) {   
  .articleHeader:not(.heroleft):not(.herotextabove):not(.herocenter) .articleHeader--timestamp {     
    bottom: 0px !important;     
    margin-left: 0px !important;     
    position: relative;    
  }
}</style>
        <!-- Hotfix Freeform (Local Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.97469 -->
<!-- ENG-10491 -->
<style>
  .badge:not(.shopping):not(.sponsored-content):not(.paidad-content):before, 
  section.fourPack-breaking .fourPack--item .badge::before, 
  section.centerpiece .centerpiece-tab-primary.density>div:last-child .centerpiece-tab 
  .badge::before {
    display: none;
  }
  .thumbnail-list a.hideKicker, 
  .centerpiece div.hideKicker, 
  .dynamicSpotlight div.hideKicker, 
  .thumbnail-list div.hideKicker, 
  .thumbnail-list span.hideKicker,
  .dynamicSpotlight span.hideKicker {
    display: inherit;
  }
  .dynamicSpotlight div.hideKicker, 
  .dynamicSpotlight span.hideKicker {
    display: inline-block;
  }
  .centerpiece .badgeInline p.bullet span {
    display: none;
  }
  .centerpiece:not(.density) div.centerpiece-tab--main-kicker.hideKicker {
    display: block;
  }
  .thumbnail-list--item-header.badge.shopping .hideKicker > a, .thumbnail-list--item-header.badge.shopping .hideKicker > span {
    display: none;
  }
</style>
                    </head>
<!-- e hearst/article/headerMain.tpl -->    <body data-location="sports"  class="two-column">
                                                <!-- design/article/dynamic_two_column.tpl -->
    <!-- hearst/article/types/dynamic_two_column.tpl -->


<div id="zoneTop" class="zone full innerGrid" data-tb-region="zoneAboveMasthead"></div><!-- hearst/common/siteBranding.tpl -->
    <header class="pageHeader standard" data-stage="0">
        <div class="pageHeader--progress"><div class="pageHeader--progress-bar" id="progress"></div></div>    <div class="pageHeader--skipLink-wrapper">
        <a href="#content" class="pageHeader--skipLink" aria-label="Skip to main content">Skip to main content</a>
    </div>
    <div class="pageHeader--wrapper lock">
        <button id="navToggle" class="pageHeader--menuButton navToggle" role="button" tabindex="0" aria-expanded="false" aria-label="navigation"></button>                <a id="mastheadLogo" href="/" tabindex="0">Milford Mirror Homepage<span  class="pageHeader--logo mastheadLogo fade show hdn-analytics" role="img" aria-label="Milford Mirror Homepage - Site Logo" data-hdn-analytics="visit|masthead|navigation|0"></span></a>
                    <div id="titleBar" class="pageHeader--titleBar titleBar fade show hidden">
                                    <div class="pageHeader--titleBar-subsection">Currently Reading</div>
                    <div class="pageHeader--titleBar-title">2022 New Orleans Saints Roster</div>
                            </div>
                            <div id="nextStory" class="pageHeader--nextStory nextStory fade show hidden"></div>
                            <ul class="pageHeader--links fade show">
                                                                                                                                        <li id="subscription" class="pageHeader--links-nonsub subscribeButton fade show hidden">
                                <a class="visible-xs-f subscribe" href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=button&ipid=wcm" target="_blank">Subscribe</a>
                                <a class="hidden-xs button" href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=button&ipid=wcm" target="_blank">Subscribe</a>
                            </li>
                                                                                                <li id="eEdition" class="pageHeader--links-sub eEdition fade show hidden"><a href="/e-edition">e-Edition</a></li>
                                                                                                                                        <!-- hearst/common/signin.tpl -->
<li class="treg-is-gigya gigya_menu ">
    <div class="gya-title expandable treg-conditional treg-not-logged-in">
        <a class="signIn featureSignIn" tabindex="0" role="button">Sign In</a>
    </div>
    <div class="gya-title expandable treg-conditional treg-logged-in" aria-controls="treg-login-widget" role="button"><span></span></div>
    <div class="gya-content expandable" id="treg-login-widget">
        <div class="treg-gya-login-widget"></div>
    </div>
</li>
<!-- e hearst/common/signin.tpl -->                <button class="pageHeader--searchButton searchToggle" aria-expanded="false" tabindex="0" aria-label="searchToggle" aria-controls="searchField-aria"></button>            </ul>
                            <div class="pageHeader--search searchField" id="searchField-aria">
                
                <form class="pageHeader--search-form" action="/search/" method="get">
                    <input type="hidden" name="action" value="search" />
                    <input type="hidden" name="firstRequest" value="1" />
                    <input type="hidden" name="searchindex" value="solr" />
                    <div class="fieldset">
                        <input class="pageHeader--search-input" id="search" name="query" type="text" value="" placeholder="Search" aria-label="search" />
                        <button class="searchButton btn" value="" name="search" type="submit" aria-label="search"></button>
                    </div>
                </form>
            </div>
            </div>
                                    
        <!-- hearst/home/HNavigation.tpl -->
<!-- hearst/home/navigation.tpl -->
         <!-- hearst/common/siteNavigation.tpl -->
<nav id="navigation" class="navigation"><div class="navigation--wrapper lock"><div class="navigation--menu"><ul class="hidden-sm hidden-md hidden-lg hidden-xl"><li class="single" data-length="1" data-index="1"><a href="/puzzles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="6062" data-hdn-analytics="visit|Puzzles|navigation-ard|1">Puzzles</a></li><li class="parent topLevel" data-length="6" data-index="0"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4941" data-hdn-analytics="visit|home|navigation-ard|2">home</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 132px"><li class="child"><a  href="https://link.milfordmirror.com/join/signup-mm" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5806" data-hdn-analytics="visit|home-Sign Up for Newsletters|navigation-ard|1">Sign Up for Newsletters</a></li><li class="child"><a  href="https://hearstmediact.newsbank.com/home" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4949" data-hdn-analytics="visit|home-Print Archives|navigation-ard|2">Print Archives</a></li><li class="child"><a  href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=hamburger&ipid=wcm" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4952" data-hdn-analytics="visit|home-Subscribe|navigation-ard|3">Subscribe</a></li><li class="child"><a  href="/news-submission-guidelines/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4944" data-hdn-analytics="visit|home-Submission Guidelines|navigation-ard|4">Submission Guidelines</a></li><li class="child"><a  href="/submissions/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4987" data-hdn-analytics="visit|home-Submissions|navigation-ard|5">Submissions</a></li></ul></li><li class="parent topLevel" data-length="9" data-index="2"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4997" data-hdn-analytics="visit|News|navigation-ard|3">News</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 176px"><li class="child"><a  href="/politics-elections/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4990" data-hdn-analytics="visit|News-Politics & Elections|navigation-ard|1">Politics & Elections</a></li><li class="child"><a  href="/news/town-government/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4991" data-hdn-analytics="visit|News-Town Government|navigation-ard|2">Town Government</a></li><li class="child"><a  href="/news/community/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4992" data-hdn-analytics="visit|News-Community|navigation-ard|3">Community</a></li><li class="child"><a  href="/news/education/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4994" data-hdn-analytics="visit|News-Education|navigation-ard|4">Education</a></li><li class="child"><a  href="/news/police-fire/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4995" data-hdn-analytics="visit|News-Police & Fire|navigation-ard|5">Police & Fire</a></li><li class="child"><a  href="/news/connecticut/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4998" data-hdn-analytics="visit|News-Connecticut|navigation-ard|6">Connecticut</a></li><li class="child"><a  href="/cannabis/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="6085" data-hdn-analytics="visit|News-Cannabis|navigation-ard|7">Cannabis</a></li><li class="child"><a  href="/opinion/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5812" data-hdn-analytics="visit|News-Opinion|navigation-ard|8">Opinion</a></li></ul></li><li class="single" data-length="1" data-index="3"><a href="/business/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4977" data-hdn-analytics="visit|Business|navigation-ard|4">Business</a></li><li class="single" data-length="1" data-index="4"><a href="https://www.legacy.com/obituaries/milfordmirror/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4979" data-hdn-analytics="visit|Obituaries|navigation-ard|5">Obituaries</a></li><li class="parent topLevel" data-length="3" data-index="5"><span role="heading" aria-level="2"><a  href="/sports/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4986" data-hdn-analytics="visit|Sports|navigation-ard|6">Sports</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/uconn/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5833" data-hdn-analytics="visit|Sports-UConn|navigation-ard|1">UConn</a></li><li class="child"><a  href="/sports/high-school-sports/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4985" data-hdn-analytics="visit|Sports-High School Sports|navigation-ard|2">High School Sports</a></li></ul></li><li class="parent topLevel" data-length="3" data-index="6"><span role="heading" aria-level="2"><a  href="/living/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5799" data-hdn-analytics="visit|Living|navigation-ard|7">Living</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/food/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5800" data-hdn-analytics="visit|Living-Food|navigation-ard|1">Food</a></li><li class="child"><a  href="/homegarden/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5354" data-hdn-analytics="visit|Living-Home and Garden|navigation-ard|2">Home and Garden</a></li></ul></li><li class="single" data-length="1" data-index="7"><a href="/entertainment/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4996" data-hdn-analytics="visit|Entertainment|navigation-ard|8">Entertainment</a></li><li class="parent topLevel" data-length="6" data-index="8"><span role="heading" aria-level="2"><a  href="/faq/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4948" data-hdn-analytics="visit|Help|navigation-ard|9">Help</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 132px"><li class="child"><a  href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CMM" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4947" data-hdn-analytics="visit|Help-Delivery Problems|navigation-ard|1">Delivery Problems</a></li><li class="child"><a  href="/about-us/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4945" data-hdn-analytics="visit|Help-About Us|navigation-ard|2">About Us</a></li><li class="child"><a  href="/contact/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4946" data-hdn-analytics="visit|Help-Contact Us|navigation-ard|3">Contact Us</a></li><li class="child"><a  href="/privacy/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4943" data-hdn-analytics="visit|Help-Privacy Notice|navigation-ard|4">Privacy Notice</a></li><li class="child"><a  href="/tos/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4942" data-hdn-analytics="visit|Help-Terms of Use|navigation-ard|5">Terms of Use</a></li></ul></li><li class="single" data-length="1" data-index="9"><a href="/shopping/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="6110" data-hdn-analytics="visit|Shopping|navigation-ard|10">Shopping</a></li><li class="parent topLevel" data-length="2" data-index="10"><span role="heading" aria-level="2"><a  href="/sponsoredarticles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5716" data-hdn-analytics="visit|Advertising Features|navigation-ard|11">Advertising Features</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/events-calendar/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="6007" data-hdn-analytics="visit|Advertising Features-Events|navigation-ard|1">Events</a></li></ul></li><li class="single" data-length="1" data-index="11"><a href="http://connecticut.ipublishmarketplace.com/connecticut-marketplace/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5002" data-hdn-analytics="visit|Classifieds|navigation-ard|1">Classifieds</a></li></ul></div></div><span class="rule"></span><div id="navToggle__page" class="navTogglePage"></div></nav>
<!-- e hearst/common/siteNavigation.tpl -->
<!-- e hearst/home/navigation.tpl --> <!-- e hearst/home/HNavigation.tpl -->    </header>

<!-- e hearst/common/siteBranding.tpl --> <main><section id="topZone" class="zone topZone"><!-- src/business/widgets/hearst/collection/widget.tpl -->

    <div class="hide-rss-link hdnce-e hdnce-collection-111519-dynamic_ribbon_articles"><!-- hearst/collections/dynamic_ribbon_articles.tpl -->
<!-- collection.dynamic_ribbon_articles.111519 -->
    <!-- design/collection/dynamic_ribbon_articles/single_zone.tpl -->
                                                                                                                                                <div class="articleRibbon" aria-label="carousel" role="region" data-component="collection" data-type="ribbon" data-collection-id="111519" data-collection-title="D- MM Article Ribbon Sports" data-type="list">
        <button class="articleRibbon--nav-btn articleRibbon--nav-prev fade" data-delta="-1" aria-label="Previous"></button>
        <div class="articleRibbon--wrapper">
            <ul class="articleRibbon--list">
                <div class="scrollSpacer"></div>
                                <div class="articleRibbon--list-wrapper" style="flex: 1 0 2200px;">
                    <span class="articleRibbon--list-title" role="heading" aria-level="2"><span class="articleRibbon--list-label"><!-- widgets/hearst/moduleHeader/widget.tpl -->
                                            <h2 role="heading" aria-level="2">Recommended</h2>
                        <!-- e widgets/hearst/moduleHeader/widget.tpl --></span></span>                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php" data-hdn-analytics="visit-from-img|article-17310688|-111519|1">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio1x1_100.jpg" alt="Members of the Milford Little League softball team celebrate after defeating Wallingford 9-4 Saturday for the program's fourth-straight state championship. Milford will represent Connecticut in the Little League World Series New England Regional at the A. Bartlett Giamatti Little League Leadership Training Center in Bristol. Milford opens play against Rhode Island Saturday at 4 p.m. on ESPN+.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php" data-hdn-analytics="visit|article-17310688|-111519|1" data-epe-inst="s:0;t:75" data-epe-title="1">Milford Little League softball wins 4th straight state title</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php" data-hdn-analytics="visit-from-img|article-17207808|-111519|2">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio1x1_100.jpg" alt="Lauren Vitti, Kelly Jones, Amanda Umbricht and Carys Cook broke the school record in the 4x800 at the SCC Championships.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php" data-hdn-analytics="visit|article-17207808|-111519|2" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton seventh at SCC track, relay sets record</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php" data-hdn-analytics="visit-from-img|article-17181447|-111519|3">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio1x1_100.jpg" alt="Katherine Baisley, Bria Colangelo, Emma Hoffman, Lauren Vitti, Katerina Koutouvides, Carys Cook and Kelly Jones medaled for Lauralton Hall at the SCC East Sectional meet.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php" data-hdn-analytics="visit|article-17181447|-111519|3" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton fifth at SCC East Sectional meet</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php" data-hdn-analytics="visit-from-img|article-17176456|-111519|4">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio1x1_100.jpg" alt="Foran improved to 9-8 with its win against previously unbeaten Amity.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php" data-hdn-analytics="visit|article-17176456|-111519|4" data-epe-inst="s:0;t:75" data-epe-title="1">HS update: Foran baseball upends No. 1 Amity</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php" data-hdn-analytics="visit-from-img|article-17172989|-111519|5">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio1x1_100.jpg" alt="Law’s Mike Merchant is safe at the plate as Hand catcher Connor Powell tags him too late.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php" data-hdn-analytics="visit|article-17172989|-111519|5" data-epe-inst="s:0;t:75" data-epe-title="1">Law edges Hand in high-scoring SCC tilt</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php" data-hdn-analytics="visit-from-img|article-17172988|-111519|6">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio1x1_100.jpg" alt="Lucia Pino is closing in on becoming the career wins leader at Law before going to Bryant University.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php" data-hdn-analytics="visit|article-17172988|-111519|6" data-epe-inst="s:0;t:75" data-epe-title="1">Lucia Pino closing in on Law record for wins</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php" data-hdn-analytics="visit-from-img|article-17170770|-111519|7">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio1x1_100.jpg" alt="Lauralton Hall's track team celebrates winning SCC Housatonic Division championship.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php" data-hdn-analytics="visit|article-17170770|-111519|7" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton track wins Housatonic Division</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php" data-hdn-analytics="visit-from-img|article-17162949|-111519|8">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio1x1_100.jpg" alt="Arezoo Ghazagh, Quincy Ercanbrack and Katharine Harrison captain the Foran girls track team.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php" data-hdn-analytics="visit|article-17162949|-111519|8" data-epe-inst="s:0;t:75" data-epe-title="1">Foran aided by newcomers, strong leadership</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php" data-hdn-analytics="visit-from-img|article-17147665|-111519|9">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio1x1_100.jpg" alt="McKenna Sharpe, Sydney Simpson, McKenzie Powers, Shelby Green and Lauren Davis captain Law girls track team.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php" data-hdn-analytics="visit|article-17147665|-111519|9" data-epe-inst="s:0;t:75" data-epe-title="1">Law track making its mark in early going of season</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php" data-hdn-analytics="visit-from-img|article-17128086|-111519|10">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio1x1_100.jpg" alt="Foran and Jonathan Law catchers and captains Kendall LaMorte and Nicolina Salanto have high hopes for their softball teams.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php" data-hdn-analytics="visit|article-17128086|-111519|10" data-epe-inst="s:0;t:75" data-epe-title="1">Foran, Law aiming to further success this postseason</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                    </div>
                <div class="scrollSpacer"></div>
            </ul>
        </div>
        <button class="articleRibbon--nav-btn articleRibbon--nav-next fade show " data-delta="1" aria-label="Next"></button>
    </div>
        <script type="text/javascript">
        var nextStory = [
                                                            {
                    "id": 17310688,
                    "headline": "Milford Little League softball wins 4th straight...",
                    "url": "/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php",
                    "image": "https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17207808,
                    "headline": "Lauralton seventh at SCC track, relay sets record",
                    "url": "/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php",
                    "image": "https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17181447,
                    "headline": "Lauralton fifth at SCC East Sectional meet",
                    "url": "/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php",
                    "image": "https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17176456,
                    "headline": "HS update: Foran baseball upends No. 1 Amity",
                    "url": "/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php",
                    "image": "https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17172989,
                    "headline": "Law edges Hand in high-scoring SCC tilt",
                    "url": "/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php",
                    "image": "https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17172988,
                    "headline": "Lucia Pino closing in on Law record for wins",
                    "url": "/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php",
                    "image": "https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17170770,
                    "headline": "Lauralton track wins Housatonic Division",
                    "url": "/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php",
                    "image": "https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17162949,
                    "headline": "Foran aided by newcomers, strong leadership",
                    "url": "/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php",
                    "image": "https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17147665,
                    "headline": "Law track making its mark in early going of season",
                    "url": "/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php",
                    "image": "https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17128086,
                    "headline": "Foran, Law aiming to further success this postseason",
                    "url": "/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php",
                    "image": "https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio3x2_100.jpg"
                }                    ];
    </script>
<!-- e design/collection/dynamic_ribbon_articles/single_zone.tpl --><!-- e hearst/collections/dynamic_ribbon_articles.tpl -->
</div><!-- e src/business/widgets/hearst/collection/widget.tpl --></section> <div class="belowMastheadWrapper"></div> <section id="content" class="article" data-type="dtc"><!-- hearst/article/articleHeader.tpl -->
            
    <header class="article--header articleHeader"><div class="articleHeader--breadcrumbs"><a class="articleHeader--breadcrumbs-item" href="https://www.milfordmirror.com/sports/">Sports</a></div><h1 class="articleHeader--headline" aria-labelledby="">2022 New Orleans Saints Roster</h1><div class="articleHeader--subHead"><div class="articleHeader--byline"></div><div class="articleHeader--timestamp"><time class="articleHeader--timestamp-pubdate " datetime="2022-12-24 15:09:09">Dec. 24, 2022</time></div><div class="articleHeader--shareTools"><!-- hearst/common/shareTools.tpl -->
    
<div class="share-list comments">
    <a class="share-facebook" data-shareNetwork="facebook">Facebook</a>
    <a class="share-twitter" data-shareNetwork="twitter">Twitter</a>
    <a class="share-email" data-shareNetwork="email">Email</a>
            <div class="pipe"></div>
                    
                            <a class="share-comments" data-shareNetwork="comments" href="https://www.milfordmirror.com/sports/articleComments/2022-New-Orleans-Saints-Roster-17675782.php" onclick="document.location.href = document.location.href.replace('/article/','/articleComments/').replace('/slideshow/','/slideshowComments/'); return false;">Comments</a>
        <span class="share-count"></span>
    </div>
<!-- e hearst/common/shareTools.tpl --></div></div></header>
<!-- e hearst/article/articleHeader.tpl --><!-- hearst/common/chapterNavigation.tpl -->
        <!-- e hearst/common/chapterNavigation.tpl --><article class="article--content"><section id="articleTop" class="article--content-zone top"></section>            <table xmlns="http://www.w3.org/2005/Atom" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead><tr>
<th class="headline-col-jersey-number">No.</th>
<th class="headline-col-name">Player</th>
<th class="headline-col-position">Pos</th>
<th class="headline-col-height">Ht</th>
<th class="headline-col-weight">Wt</th>
<th class="headline-col-born">Born</th>
<th class="headline-col-experience">Exp</th>
<th class="headline-col-college">College</th>
</tr></thead>
<tbody>
<tr>
<td class="col-jersey-number">1</td>
<td class="col-name">Marquez Callaway</td>
<td class="col-position">WR</td>
<td class="col-height">6-2</td>
<td class="col-weight">204</td>
<td class="col-born">03-27-1998</td>
<td class="col-experience">2</td>
<td class="col-college">Tennessee</td>
</tr>
<tr>
<td class="col-jersey-number">2</td>
<td class="col-name">Jameis Winston</td>
<td class="col-position">QB</td>
<td class="col-height">6-4</td>
<td class="col-weight">231</td>
<td class="col-born">01-06-1994</td>
<td class="col-experience">7</td>
<td class="col-college">Florida State</td>
</tr>
<tr>
<td class="col-jersey-number">3</td>
<td class="col-name">Wil Lutz</td>
<td class="col-position">K</td>
<td class="col-height">5-11</td>
<td class="col-weight">184</td>
<td class="col-born">07-07-1994</td>
<td class="col-experience">6</td>
<td class="col-college">Georgia State</td>
</tr>
<tr>
<td class="col-jersey-number">4</td>
<td class="col-name">Blake Gillikin</td>
<td class="col-position">P</td>
<td class="col-height">6-2</td>
<td class="col-weight">196</td>
<td class="col-born">01-21-1998</td>
<td class="col-experience">2</td>
<td class="col-college">Penn State</td>
</tr>
<tr>
<td class="col-jersey-number">5</td>
<td class="col-name">Jarvis Landry</td>
<td class="col-position">WR</td>
<td class="col-height">5-11</td>
<td class="col-weight">202</td>
<td class="col-born">11-28-1992</td>
<td class="col-experience">8</td>
<td class="col-college">LSU</td>
</tr>
<tr>
<td class="col-jersey-number">6</td>
<td class="col-name">Marcus Maye</td>
<td class="col-position">SAF</td>
<td class="col-height">5-11</td>
<td class="col-weight">207</td>
<td class="col-born">03-09-1993</td>
<td class="col-experience">5</td>
<td class="col-college">Florida</td>
</tr>
<tr>
<td class="col-jersey-number">7</td>
<td class="col-name">Taysom Hill</td>
<td class="col-position">TE</td>
<td class="col-height">6-2</td>
<td class="col-weight">221</td>
<td class="col-born">08-23-1990</td>
<td class="col-experience">5</td>
<td class="col-college">BYU</td>
</tr>
<tr>
<td class="col-jersey-number">10</td>
<td class="col-name">Tre'Quan Smith</td>
<td class="col-position">WR</td>
<td class="col-height">6-2</td>
<td class="col-weight">210</td>
<td class="col-born">01-07-1996</td>
<td class="col-experience">4</td>
<td class="col-college">UCF</td>
</tr>
<tr>
<td class="col-jersey-number">11</td>
<td class="col-name">Deonte Harty</td>
<td class="col-position">WR</td>
<td class="col-height">5-6</td>
<td class="col-weight">170</td>
<td class="col-born">12-04-1997</td>
<td class="col-experience">3</td>
<td class="col-college">Assumption</td>
</tr>
<tr>
<td class="col-jersey-number">12</td>
<td class="col-name">Chris Olave</td>
<td class="col-position">WR</td>
<td class="col-height">6-1</td>
<td class="col-weight">189</td>
<td class="col-born">06-27-2000</td>
<td class="col-experience">0</td>
<td class="col-college">Ohio State</td>
</tr>
<tr>
<td class="col-jersey-number">13</td>
<td class="col-name">Michael Thomas</td>
<td class="col-position">WR</td>
<td class="col-height">6-3</td>
<td class="col-weight">212</td>
<td class="col-born">03-03-1993</td>
<td class="col-experience">6</td>
<td class="col-college">Ohio State</td>
</tr>
<tr>
<td class="col-jersey-number">14</td>
<td class="col-name">Andy Dalton</td>
<td class="col-position">QB</td>
<td class="col-height">6-2</td>
<td class="col-weight">220</td>
<td class="col-born">10-29-1987</td>
<td class="col-experience">11</td>
<td class="col-college">TCU</td>
</tr>
<tr>
<td class="col-jersey-number">16</td>
<td class="col-name">Jake Luton</td>
<td class="col-position">QB</td>
<td class="col-height">6-6</td>
<td class="col-weight">224</td>
<td class="col-born">04-11-1996</td>
<td class="col-experience">2</td>
<td class="col-college">Oregon State</td>
</tr>
<tr>
<td class="col-jersey-number">17</td>
<td class="col-name">Kevin White</td>
<td class="col-position">WR</td>
<td class="col-height">6-3</td>
<td class="col-weight">216</td>
<td class="col-born">06-25-1992</td>
<td class="col-experience">7</td>
<td class="col-college">West Virginia</td>
</tr>
<tr>
<td class="col-jersey-number">18</td>
<td class="col-name">Keith Kirkwood</td>
<td class="col-position">WR</td>
<td class="col-height">6-3</td>
<td class="col-weight">210</td>
<td class="col-born">12-26-1994</td>
<td class="col-experience">4</td>
<td class="col-college">Temple</td>
</tr>
<tr>
<td class="col-jersey-number">19</td>
<td class="col-name">Chris Harris Jr.</td>
<td class="col-position">SAF</td>
<td class="col-height">5-10</td>
<td class="col-weight">190</td>
<td class="col-born">06-18-1989</td>
<td class="col-experience">11</td>
<td class="col-college">Kansas</td>
</tr>
<tr>
<td class="col-jersey-number">20</td>
<td class="col-name">Pete Werner</td>
<td class="col-position">LB</td>
<td class="col-height">6-3</td>
<td class="col-weight">242</td>
<td class="col-born">06-05-1999</td>
<td class="col-experience">1</td>
<td class="col-college">Ohio State</td>
</tr>
<tr>
<td class="col-jersey-number">21</td>
<td class="col-name">Bradley Roby</td>
<td class="col-position">CB</td>
<td class="col-height">5-11</td>
<td class="col-weight">194</td>
<td class="col-born">05-01-1992</td>
<td class="col-experience">8</td>
<td class="col-college">Ohio State</td>
</tr>
<tr>
<td class="col-jersey-number">22</td>
<td class="col-name">Mark Ingram II</td>
<td class="col-position">RB</td>
<td class="col-height">5-9</td>
<td class="col-weight">215</td>
<td class="col-born">12-21-1989</td>
<td class="col-experience">11</td>
<td class="col-college">Alabama</td>
</tr>
<tr>
<td class="col-jersey-number">23</td>
<td class="col-name">Marshon Lattimore</td>
<td class="col-position">CB</td>
<td class="col-height">6-0</td>
<td class="col-weight">192</td>
<td class="col-born">05-19-1996</td>
<td class="col-experience">5</td>
<td class="col-college">Ohio State</td>
</tr>
<tr>
<td class="col-jersey-number">24</td>
<td class="col-name">Dwayne Washington</td>
<td class="col-position">RB</td>
<td class="col-height">6-1</td>
<td class="col-weight">223</td>
<td class="col-born">04-24-1994</td>
<td class="col-experience">6</td>
<td class="col-college">Washington</td>
</tr>
<tr>
<td class="col-jersey-number">25</td>
<td class="col-name">Daniel Sorensen</td>
<td class="col-position">DB</td>
<td class="col-height">6-1</td>
<td class="col-weight">208</td>
<td class="col-born">03-05-1990</td>
<td class="col-experience">8</td>
<td class="col-college">BYU</td>
</tr>
<tr>
<td class="col-jersey-number">26</td>
<td class="col-name">P.J. Williams</td>
<td class="col-position">CB</td>
<td class="col-height">6-0</td>
<td class="col-weight">196</td>
<td class="col-born">06-01-1993</td>
<td class="col-experience">7</td>
<td class="col-college">Florida State</td>
</tr>
<tr>
<td class="col-jersey-number">27</td>
<td class="col-name">Alontae Taylor</td>
<td class="col-position">CB</td>
<td class="col-height">6-0</td>
<td class="col-weight">195</td>
<td class="col-born">12-03-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Tennessee</td>
</tr>
<tr>
<td class="col-jersey-number">28</td>
<td class="col-name">David Johnson</td>
<td class="col-position">RB</td>
<td class="col-height">6-1</td>
<td class="col-weight">224</td>
<td class="col-born">12-16-1991</td>
<td class="col-experience">7</td>
<td class="col-college">Northern Iowa</td>
</tr>
<tr>
<td class="col-jersey-number">29</td>
<td class="col-name">Paulson Adebo</td>
<td class="col-position">CB</td>
<td class="col-height">6-1</td>
<td class="col-weight">192</td>
<td class="col-born">07-03-1999</td>
<td class="col-experience">1</td>
<td class="col-college">Stanford</td>
</tr>
<tr>
<td class="col-jersey-number">30</td>
<td class="col-name">Justin Evans</td>
<td class="col-position">SAF</td>
<td class="col-height">6-0</td>
<td class="col-weight">199</td>
<td class="col-born">08-26-1995</td>
<td class="col-experience">5</td>
<td class="col-college">Texas A&amp;M</td>
</tr>
<tr>
<td class="col-jersey-number">31</td>
<td class="col-name">Eno Benjamin</td>
<td class="col-position">RB</td>
<td class="col-height">5-9</td>
<td class="col-weight">207</td>
<td class="col-born">04-13-1999</td>
<td class="col-experience">2</td>
<td class="col-college">Arizona State</td>
</tr>
<tr>
<td class="col-jersey-number">32</td>
<td class="col-name">Tyrann Mathieu</td>
<td class="col-position">FS</td>
<td class="col-height">5-9</td>
<td class="col-weight">190</td>
<td class="col-born">05-13-1992</td>
<td class="col-experience">9</td>
<td class="col-college">LSU</td>
</tr>
<tr>
<td class="col-jersey-number">33</td>
<td class="col-name">Kirk Merritt</td>
<td class="col-position">WR</td>
<td class="col-height">6-0</td>
<td class="col-weight">208</td>
<td class="col-born">01-05-1997</td>
<td class="col-experience">2</td>
<td class="col-college">Arkansas State</td>
</tr>
<tr>
<td class="col-jersey-number">35</td>
<td class="col-name">Vincent Gray</td>
<td class="col-position">DB</td>
<td class="col-height">6-2</td>
<td class="col-weight">192</td>
<td class="col-born">12-28-1999</td>
<td class="col-experience">0</td>
<td class="col-college">Michigan</td>
</tr>
<tr>
<td class="col-jersey-number">36</td>
<td class="col-name">Isaac Yiadom</td>
<td class="col-position">CB</td>
<td class="col-height">6-1</td>
<td class="col-weight">190</td>
<td class="col-born">02-20-1996</td>
<td class="col-experience">4</td>
<td class="col-college">Boston College</td>
</tr>
<tr>
<td class="col-jersey-number">38</td>
<td class="col-name">Smoke Monday</td>
<td class="col-position">SAF</td>
<td class="col-height">6-3</td>
<td class="col-weight">199</td>
<td class="col-born">02-19-2000</td>
<td class="col-experience">0</td>
<td class="col-college">Auburn</td>
</tr>
<tr>
<td class="col-jersey-number">41</td>
<td class="col-name">Alvin Kamara</td>
<td class="col-position">RB</td>
<td class="col-height">5-10</td>
<td class="col-weight">215</td>
<td class="col-born">07-25-1995</td>
<td class="col-experience">5</td>
<td class="col-college">Tennessee</td>
</tr>
<tr>
<td class="col-jersey-number">42</td>
<td class="col-name">Chase Hansen</td>
<td class="col-position">LB</td>
<td class="col-height">6-3</td>
<td class="col-weight">222</td>
<td class="col-born">05-20-1993</td>
<td class="col-experience">3</td>
<td class="col-college">Utah</td>
</tr>
<tr>
<td class="col-jersey-number">44</td>
<td class="col-name">Derrick Gore</td>
<td class="col-position">RB</td>
<td class="col-height">5-10</td>
<td class="col-weight">212</td>
<td class="col-born">12-13-1994</td>
<td class="col-experience">3</td>
<td class="col-college">Louisiana-Monroe</td>
</tr>
<tr>
<td class="col-jersey-number">45</td>
<td class="col-name">Nephi Sewell</td>
<td class="col-position">LB</td>
<td class="col-height">6-0</td>
<td class="col-weight">228</td>
<td class="col-born">12-19-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Utah</td>
</tr>
<tr>
<td class="col-jersey-number">46</td>
<td class="col-name">Adam Prentice</td>
<td class="col-position">FB</td>
<td class="col-height">6-0</td>
<td class="col-weight">245</td>
<td class="col-born">01-16-1997</td>
<td class="col-experience">1</td>
<td class="col-college">South Carolina</td>
</tr>
<tr>
<td class="col-jersey-number">48</td>
<td class="col-name">J.T. Gray</td>
<td class="col-position">DB</td>
<td class="col-height">6-0</td>
<td class="col-weight">202</td>
<td class="col-born">01-18-1996</td>
<td class="col-experience">4</td>
<td class="col-college">Mississippi State</td>
</tr>
<tr>
<td class="col-jersey-number">49</td>
<td class="col-name">Zach Wood</td>
<td class="col-position">LS</td>
<td class="col-height">6-3</td>
<td class="col-weight">255</td>
<td class="col-born">01-10-1993</td>
<td class="col-experience">6</td>
<td class="col-college">SMU</td>
</tr>
<tr>
<td class="col-jersey-number">50</td>
<td class="col-name">Andrew Dowell</td>
<td class="col-position">LB</td>
<td class="col-height">6-1</td>
<td class="col-weight">225</td>
<td class="col-born">11-16-1996</td>
<td class="col-experience">3</td>
<td class="col-college">Michigan State</td>
</tr>
<tr>
<td class="col-jersey-number">51</td>
<td class="col-name">Cesar Ruiz</td>
<td class="col-position">OL</td>
<td class="col-height">6-4</td>
<td class="col-weight">316</td>
<td class="col-born">06-14-1999</td>
<td class="col-experience">2</td>
<td class="col-college">Michigan</td>
</tr>
<tr>
<td class="col-jersey-number">52</td>
<td class="col-name">D'Marco Jackson</td>
<td class="col-position">LB</td>
<td class="col-height">6-1</td>
<td class="col-weight">230</td>
<td class="col-born">07-20-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Appalachian State</td>
</tr>
<tr>
<td class="col-jersey-number">53</td>
<td class="col-name">Zack Baun</td>
<td class="col-position">LB</td>
<td class="col-height">6-3</td>
<td class="col-weight">225</td>
<td class="col-born">12-30-1996</td>
<td class="col-experience">2</td>
<td class="col-college">Wisconsin</td>
</tr>
<tr>
<td class="col-jersey-number">54</td>
<td class="col-name">Ty Summers</td>
<td class="col-position">LB</td>
<td class="col-height">6-1</td>
<td class="col-weight">241</td>
<td class="col-born">12-31-1995</td>
<td class="col-experience">3</td>
<td class="col-college">TCU</td>
</tr>
<tr>
<td class="col-jersey-number">54</td>
<td class="col-name">Niko Lalos</td>
<td class="col-position">DE</td>
<td class="col-height">6-5</td>
<td class="col-weight">269</td>
<td class="col-born">06-25-1997</td>
<td class="col-experience">2</td>
<td class="col-college">Dartmouth</td>
</tr>
<tr>
<td class="col-jersey-number">55</td>
<td class="col-name">Kaden Elliss</td>
<td class="col-position">LB</td>
<td class="col-height">6-3</td>
<td class="col-weight">238</td>
<td class="col-born">07-10-1995</td>
<td class="col-experience">3</td>
<td class="col-college">Idaho</td>
</tr>
<tr>
<td class="col-jersey-number">56</td>
<td class="col-name">Demario Davis</td>
<td class="col-position">LB</td>
<td class="col-height">6-2</td>
<td class="col-weight">248</td>
<td class="col-born">01-11-1989</td>
<td class="col-experience">10</td>
<td class="col-college">Arkansas State</td>
</tr>
<tr>
<td class="col-jersey-number">57</td>
<td class="col-name">Prince Emili</td>
<td class="col-position">DT</td>
<td class="col-height">6-2</td>
<td class="col-weight">300</td>
<td class="col-born">09-18-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Pennsylvania</td>
</tr>
<tr>
<td class="col-jersey-number">59</td>
<td class="col-name">Jordan Jackson</td>
<td class="col-position">DT</td>
<td class="col-height">6-5</td>
<td class="col-weight">285</td>
<td class="col-born">01-30-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Air Force</td>
</tr>
<tr>
<td class="col-jersey-number">61</td>
<td class="col-name">Drew Desjarlais</td>
<td class="col-position">G</td>
<td class="col-height">6-2</td>
<td class="col-weight">313</td>
<td class="col-born">04-24-1997</td>
<td class="col-experience">0</td>
<td class="col-college">Windsor (CAN)</td>
</tr>
<tr>
<td class="col-jersey-number">62</td>
<td class="col-name">Derrick Kelly II</td>
<td class="col-position">OL</td>
<td class="col-height">6-5</td>
<td class="col-weight">320</td>
<td class="col-born">08-23-1995</td>
<td class="col-experience">3</td>
<td class="col-college">Florida State</td>
</tr>
<tr>
<td class="col-jersey-number">66</td>
<td class="col-name">Lewis Kidd</td>
<td class="col-position">OL</td>
<td class="col-height">6-6</td>
<td class="col-weight">311</td>
<td class="col-born">09-15-1997</td>
<td class="col-experience">0</td>
<td class="col-college">Montana State</td>
</tr>
<tr>
<td class="col-jersey-number">67</td>
<td class="col-name">Landon Young</td>
<td class="col-position">T</td>
<td class="col-height">6-7</td>
<td class="col-weight">321</td>
<td class="col-born">08-21-1997</td>
<td class="col-experience">1</td>
<td class="col-college">Kentucky</td>
</tr>
<tr>
<td class="col-jersey-number">68</td>
<td class="col-name">Josh Andrews</td>
<td class="col-position">G</td>
<td class="col-height">6-2</td>
<td class="col-weight">298</td>
<td class="col-born">06-21-1991</td>
<td class="col-experience">8</td>
<td class="col-college">Oregon State</td>
</tr>
<tr>
<td class="col-jersey-number">69</td>
<td class="col-name">Jabari Zuniga</td>
<td class="col-position">DE</td>
<td class="col-height">6-3</td>
<td class="col-weight">264</td>
<td class="col-born">08-14-1997</td>
<td class="col-experience">2</td>
<td class="col-college">Florida</td>
</tr>
<tr>
<td class="col-jersey-number">70</td>
<td class="col-name">Trevor Penning</td>
<td class="col-position">T</td>
<td class="col-height">6-7</td>
<td class="col-weight">332</td>
<td class="col-born">05-15-1999</td>
<td class="col-experience">0</td>
<td class="col-college">Northern Iowa</td>
</tr>
<tr>
<td class="col-jersey-number">71</td>
<td class="col-name">Ryan Ramczyk</td>
<td class="col-position">T</td>
<td class="col-height">6-6</td>
<td class="col-weight">314</td>
<td class="col-born">04-22-1994</td>
<td class="col-experience">5</td>
<td class="col-college">Wisconsin</td>
</tr>
<tr>
<td class="col-jersey-number">73</td>
<td class="col-name">Ethan Greenidge</td>
<td class="col-position">OL</td>
<td class="col-height">6-4</td>
<td class="col-weight">335</td>
<td class="col-born">09-10-1997</td>
<td class="col-experience">3</td>
<td class="col-college">Villanova</td>
</tr>
<tr>
<td class="col-jersey-number">74</td>
<td class="col-name">James Hurst</td>
<td class="col-position">OL</td>
<td class="col-height">6-5</td>
<td class="col-weight">310</td>
<td class="col-born">12-17-1991</td>
<td class="col-experience">8</td>
<td class="col-college">North Carolina</td>
</tr>
<tr>
<td class="col-jersey-number">75</td>
<td class="col-name">Andrus Peat</td>
<td class="col-position">OL</td>
<td class="col-height">6-7</td>
<td class="col-weight">316</td>
<td class="col-born">11-04-1993</td>
<td class="col-experience">7</td>
<td class="col-college">Stanford</td>
</tr>
<tr>
<td class="col-jersey-number">76</td>
<td class="col-name">Calvin Throckmorton</td>
<td class="col-position">OL</td>
<td class="col-height">6-5</td>
<td class="col-weight">309</td>
<td class="col-born">08-16-1996</td>
<td class="col-experience">2</td>
<td class="col-college">Oregon</td>
</tr>
<tr>
<td class="col-jersey-number">78</td>
<td class="col-name">Erik McCoy</td>
<td class="col-position">OL</td>
<td class="col-height">6-4</td>
<td class="col-weight">303</td>
<td class="col-born">08-27-1997</td>
<td class="col-experience">3</td>
<td class="col-college">Texas A&amp;M</td>
</tr>
<tr>
<td class="col-jersey-number">79</td>
<td class="col-name">Yasir Durant</td>
<td class="col-position">G</td>
<td class="col-height">6-7</td>
<td class="col-weight">330</td>
<td class="col-born">05-21-1998</td>
<td class="col-experience">2</td>
<td class="col-college">Missouri</td>
</tr>
<tr>
<td class="col-jersey-number">82</td>
<td class="col-name">Adam Trautman</td>
<td class="col-position">TE</td>
<td class="col-height">6-5</td>
<td class="col-weight">253</td>
<td class="col-born">02-05-1997</td>
<td class="col-experience">2</td>
<td class="col-college">Dayton</td>
</tr>
<tr>
<td class="col-jersey-number">83</td>
<td class="col-name">Juwan Johnson</td>
<td class="col-position">TE</td>
<td class="col-height">6-4</td>
<td class="col-weight">231</td>
<td class="col-born">09-13-1996</td>
<td class="col-experience">2</td>
<td class="col-college">Oregon</td>
</tr>
<tr>
<td class="col-jersey-number">87</td>
<td class="col-name">Lucas Krull</td>
<td class="col-position">TE</td>
<td class="col-height">6-6</td>
<td class="col-weight">260</td>
<td class="col-born">07-11-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Pittsburgh</td>
</tr>
<tr>
<td class="col-jersey-number">88</td>
<td class="col-name">J.P. Holtz</td>
<td class="col-position">TE</td>
<td class="col-height">6-3</td>
<td class="col-weight">240</td>
<td class="col-born">08-28-1993</td>
<td class="col-experience">6</td>
<td class="col-college">Pittsburgh</td>
</tr>
<tr>
<td class="col-jersey-number">89</td>
<td class="col-name">Rashid Shaheed</td>
<td class="col-position">WR</td>
<td class="col-height">6-0</td>
<td class="col-weight">180</td>
<td class="col-born">08-31-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Weber State</td>
</tr>
<tr>
<td class="col-jersey-number">90</td>
<td class="col-name">Tanoh Kpassagnon</td>
<td class="col-position">DE</td>
<td class="col-height">6-7</td>
<td class="col-weight">289</td>
<td class="col-born">06-14-1994</td>
<td class="col-experience">5</td>
<td class="col-college">Villanova</td>
</tr>
<tr>
<td class="col-jersey-number">91</td>
<td class="col-name">Kentavius Street</td>
<td class="col-position">DT</td>
<td class="col-height">6-2</td>
<td class="col-weight">287</td>
<td class="col-born">05-08-1996</td>
<td class="col-experience">4</td>
<td class="col-college">North Carolina State</td>
</tr>
<tr>
<td class="col-jersey-number">92</td>
<td class="col-name">Marcus Davenport</td>
<td class="col-position">DE</td>
<td class="col-height">6-6</td>
<td class="col-weight">265</td>
<td class="col-born">09-04-1996</td>
<td class="col-experience">4</td>
<td class="col-college">UTSA</td>
</tr>
<tr>
<td class="col-jersey-number">93</td>
<td class="col-name">David Onyemata</td>
<td class="col-position">DT</td>
<td class="col-height">6-4</td>
<td class="col-weight">300</td>
<td class="col-born">11-13-1992</td>
<td class="col-experience">6</td>
<td class="col-college">Manitoba (CAN)</td>
</tr>
<tr>
<td class="col-jersey-number">94</td>
<td class="col-name">Cameron Jordan</td>
<td class="col-position">DE</td>
<td class="col-height">6-4</td>
<td class="col-weight">287</td>
<td class="col-born">07-10-1989</td>
<td class="col-experience">11</td>
<td class="col-college">California</td>
</tr>
<tr>
<td class="col-jersey-number">95</td>
<td class="col-name">Albert Huggins</td>
<td class="col-position">DT</td>
<td class="col-height">6-3</td>
<td class="col-weight">305</td>
<td class="col-born">06-27-1997</td>
<td class="col-experience">3</td>
<td class="col-college">Clemson</td>
</tr>
<tr>
<td class="col-jersey-number">96</td>
<td class="col-name">Carl Granderson</td>
<td class="col-position">DE</td>
<td class="col-height">6-5</td>
<td class="col-weight">261</td>
<td class="col-born">12-18-1996</td>
<td class="col-experience">3</td>
<td class="col-college">Wyoming</td>
</tr>
<tr>
<td class="col-jersey-number">97</td>
<td class="col-name">Malcolm Roach</td>
<td class="col-position">DT</td>
<td class="col-height">6-3</td>
<td class="col-weight">290</td>
<td class="col-born">06-09-1998</td>
<td class="col-experience">2</td>
<td class="col-college">Texas</td>
</tr>
<tr>
<td class="col-jersey-number">98</td>
<td class="col-name">Payton Turner</td>
<td class="col-position">DE</td>
<td class="col-height">6-6</td>
<td class="col-weight">270</td>
<td class="col-born">01-07-1999</td>
<td class="col-experience">1</td>
<td class="col-college">Houston</td>
</tr>
<tr>
<td class="col-jersey-number">99</td>
<td class="col-name">Shy Tuttle</td>
<td class="col-position">DT</td>
<td class="col-height">6-3</td>
<td class="col-weight">300</td>
<td class="col-born">10-20-1995</td>
<td class="col-experience">3</td>
<td class="col-college">Tennessee</td>
</tr>
</tbody>
</table>
        <!-- hearst/article/content/relatedStories.tpl -->
    <section class="relatedStories" data-progressive="true"><div class="relatedStories--title articleModule"><div class="articleModule--title h4" role="heading" aria-level="2">More for you</div></div><ul class="relatedStories--list" data-total="2"><li class="relatedStories--item" data-number="1"><div class="slide" data-number="1"><a href="https://www.milfordmirror.com/gametimect/article/Jeff-Jacobs-Ode-to-Rocky-therapy-dog-17674211.php" class="hdn-analytics"data-hdn-analytics="related_stories|article-17674211|article-17675782|1"><div class="slide--headline"><div class="slide--headline-title">Jeff Jacobs: A Christmas ode to Rocky, our dream come true</div></div><div class="slide--image fullBleed"><picture class="deferred threeTwo" data-progressive="true" data-component="picture"><source data-srcset="https://s.hdnux.com/photos/01/30/71/74/23306046/3/ratio3x2_350.jpg 1x, https://s.hdnux.com/photos/01/30/71/74/23306046/3/ratio3x2_700.jpg 2x"><img data-src="https://s.hdnux.com/photos/01/30/71/74/23306046/3/ratio3x2_700.jpg" alt=""></picture></div></a></div></li><li class="relatedStories--item" data-number="2"><div class="slide" data-number="2"><a href="https://www.milfordmirror.com/sports/uconn-womens-basketball/article/Nika-Muhl-UConn-women-s-basketball-17672056.php" class="hdn-analytics"data-hdn-analytics="related_stories|article-17672056|article-17675782|2"><div class="slide--headline"><div class="slide--headline-title">How UConn's Nika Mühl became an elite point guard</div></div><div class="slide--image fullBleed"><picture class="deferred threeTwo" data-progressive="true" data-component="picture"><source data-srcset="https://s.hdnux.com/photos/01/30/67/71/23297601/3/ratio3x2_350.jpg 1x, https://s.hdnux.com/photos/01/30/67/71/23297601/3/ratio3x2_700.jpg 2x"><img data-src="https://s.hdnux.com/photos/01/30/67/71/23297601/3/ratio3x2_700.jpg" alt=""></picture></div></a></div></li></ul></section>
     <!-- e hearst/article/content/relatedStories.tpl -->    <!-- hearst/article/content/embed.tpl -->
<section class="article--content-embed inline-iframe" data-eid="item-96892">
                        <script id="hst-exco-player-code">

  // Set article player ID as default
  var playerId = '93066811-0534-4a7d-848c-7844b68ad1e1';

  if (!HDN || !HDN.dataLayer || !HDN.dataLayer.content || HDN.dataLayer.content.objectType !== 'article') {
    // This is not an article, set non-article player ID
    playerId = 'b9b6399a-2338-4244-bd61-744cfa75ecac';
  }

  (function (d, id) {

    var div = document.createElement('div');
    div.id = id;
    div.classList.add('hst-exco-player');
    var script = document.getElementById('hst-exco-player-code');
    script.parentElement.insertBefore(div, script);

    var js, fjs = d.getElementsByTagName('script')[0];
    js = d.createElement('script');
    js.id = 'exco';
    js.dataset.src = 'https://player.ex.co/player/' + id;
    fjs.parentNode.insertBefore(js, fjs);
  }(document, playerId));
</script>

            </section>
<!-- e hearst/article/content/embed.tpl --><section id="articleBottom" class="article--content-zone bottom"></section></article><!-- hearst/article/articleAside.tpl -->
<aside class="article--aside slideshow--aside">
    <aside id="zoneD" class="zone">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85203 -->
    <div class="hst-freeform hdnce-e hdnce-item-85203">
                <script type="text/javascript" id="taboola-right-rail-script-id">
(function () {
    window._taboolaRRI = window._taboolaRRI || 0;
    window._taboolaRRI++;
    var e = document.documentElement;
    var g = document.getElementsByTagName('body')[0];
    var w = window.innerWidth||e.clientWidth||g.clientWidth;
    if ( (w >= 768 && window._taboolaRRI === 1) || (w < 768 && window._taboolaRRI === 2) ){
        var c = 'taboola-right-rail-thumbnails';
        var p = 'Right Rail Thumbnails';
        var m = 'rr';
        try {
            if (window._taboolaNetworkMode) {
                c = c + '---redesign';
                p = p + ' - Redesign';
                if (HDN.dataLayer.content.objectType  === 'article') {
                    m = 'f';
                if (HDN.dataLayer.presentation.infiniteScrollEnabled && (window.infiniteScroll && window.infiniteScroll.length > 0) && HDN.dataLayer.content.objectId && window.Article.isSensitive !== true && (Object.hasOwnProperty.call(HDN, 'activeABTest') && HDN.activeABTest === 'ENG9746')) {
                    p = 'Right Rail Thumbnails';
                    m = '1x8-rr';
                }
                }
            }
        } catch (e) {}
        var d = document.createElement('div');
        d.id = c;
        var s = document.getElementById('taboola-right-rail-script-id');
        s.parentNode.insertBefore(d, s);
        window._taboola = window._taboola || [];
        _taboola.push({
            mode: 'thumbnails-' + m,
            container: c,
            placement: p,
            target_type: 'mix'
        });
    }
})();
</script>
    </div>
            </aside>
    <aside id="zoneC" class="zone">
    
<!-- hearst/home/mostPopular.tpl -->

    <div class="mostPopular">
        <h2 class="collectionHeader" role="heading" aria-level="2">Most Popular</h2>
                                                <ol class="mostPopular--list">
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Beach-Access-a-topic-of-discussion-17673739.php" title="Public or private? Milford zoning board talks beach access points" data-hdn-analytics="visit|article-17673739|most_popular|0">Public or private? Milford zoning board talks beach access points</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Many-factors-can-dictate-the-price-of-used-car-17658400.php" title="'Strength in numbers' helps Milford used car dealers thrive" data-hdn-analytics="visit|article-17658400|most_popular|1">'Strength in numbers' helps Milford used car dealers thrive</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Storm-causes-serious-flooding-in-Milford-13891805.php" title="Storm causes serious flooding in Milford" data-hdn-analytics="visit|article-13891805|most_popular|2">Storm causes serious flooding in Milford</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/weather/article/WA-WFO-PORTLAND-Warnings-Watches-and-Advisories-17673837.php" title="WA WFO PORTLAND Warnings, Watches, and Advisories" data-hdn-analytics="visit|article-17673837|most_popular|3">WA WFO PORTLAND Warnings, Watches, and Advisories</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Beaver-Brook-Apartment-project-17665036.php" title="Milford commission approves downsizing apartment plan" data-hdn-analytics="visit|article-17665036|most_popular|4">Milford commission approves downsizing apartment plan</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/weather/article/WA-WFO-PORTLAND-Warnings-Watches-and-Advisories-17675560.php" title="WA WFO PORTLAND Warnings, Watches, and Advisories" data-hdn-analytics="visit|article-17675560|most_popular|5">WA WFO PORTLAND Warnings, Watches, and Advisories</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Hazard-Mitigation-flooding-Milford-trees-17575281.php" title="Milford seeking input on trees, flooding and more in new survey" data-hdn-analytics="visit|article-17575281|most_popular|6">Milford seeking input on trees, flooding and more in new survey</a>
                                                    </li>
                                    </ol>
                        </div>
<!--e hearst/home/mostPopular.tpl --></aside>
</aside>
<!-- e hearst/article/articleAside.tpl --><!-- hearst/article/articleFooter.tpl -->
<footer class="article--footer"><!-- hearst/common/author_body.tpl -->
     
        <div class="articleFooter">
                                <div class="articleFooter--author noImage">
                <div class="articleFooter--author-label">Written By </div>                    <div class="articleFooter--author-name"></div>
                </div>
                    </div>
<!-- e hearst/common/author_body.tpl --><section class="article--comments"><button id="commentsButton" data-link="https://www.milfordmirror.com/sports/articleComments/2022-New-Orleans-Saints-Roster-17675782.php" onclick="document.location.href = 'https://www.milfordmirror.com/sports/articleComments/2022-New-Orleans-Saints-Roster-17675782.php'; return false;">View Comments</button></section></footer>
<!-- e hearst/article/articleFooter.tpl --></section><section id="bottomZone" class="zone bottomZone lock">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85204 -->
    <div class="hst-freeform hdnce-e hdnce-item-85204">
                <script type="text/javascript" id="taboola-feed-script-id">
(function () {
    var c = 'taboola-below-article-thumbnails';
    var p = 'Below Article Thumbnails';
    try {
        if (window._taboolaNetworkMode) {
            var e = document.documentElement;
            var g = document.getElementsByTagName('body')[0];
            var w = window.innerWidth||e.clientWidth||g.clientWidth;
            if (w < 768) {
                c = 'taboola-mobile-below-article-feed---redesign';
                p = 'Mobile Below Article Feed - Redesign';
            } else {
                c = 'taboola-below-article-feed---redesign';
                p = 'Below Article Feed - Redesign';
            }
        }
    } catch (e) {}
    var d = document.createElement('div');
    d.id = c;
    var s = document.getElementById('taboola-feed-script-id');
    s.parentNode.insertBefore(d, s);
    window._taboola = window._taboola || [];
    window._taboola.push({
        mode: 'thumbnails-a',
        container: c,
        placement: p,
        target_type: 'mix'
    });
})();
</script>
    </div>
            <div class="taboola-skip-wrapper"><div id="taboola-skip"></div></div></section></main><!-- hearst/common/siteFooter.tpl -->
    <footer class="pageFooter">
    <div class="lock">
        <div class="pageFooter--wrapper">
            <div class="pageFooter--left">
                <a href="/">
                    <img class="pageFooter--left-logo" src="/img/logos/black/logo.svg" alt="Milford Mirror Homepage - Site Logo">
                </a>
                <ul class="pageFooter--left-social">
                    <li class="facebook"><a href="http://facebook.com/milfordmirror" aria-label="facebook"></a></li>                    <li class="twitter"><a href="http://twitter.com/milfordmirror" aria-label="twitter"></a></li>                                                        </ul>
            </div>
            <div class="pageFooter--right">
                <div class="pageFooter--right-topLine">
                    <a href="#content" class="return"><span class="full">Return to</span> Top</a>
                </div>
                <div class="pageFooter--right-links">
                    
                    <!-- hearst/item/standalone.tpl -->
<div class="hdnce-e hdnce-item-97493"><!-- mid:freeform.97493 -->
<style>
@media (min-width: 768px) {
  .pageFooter--right-links .wrapper > li:nth-child(2) {
    box-sizing: border-box;
    padding-left: 50px;
  }
}
</style>
<ul class="wrapper" role="presentation">
  <li>
<div class="title" role="heading" aria-level="2">About</div>
    <ul class="section" role="presentation">
      <li><a href="/home/article/How-Hearst-Newspapers-is-delivering-information-15678014.php">Newspaper Delivery Safety Procedures</a></li>
      <li><a href="/privacy/">Privacy Notice</a></li>
      <li><a href="/privacy/#additionalinformationforcaliforniaresidents">Your California Privacy Rights</a></li>
      <li><a href="/privacy/#interestbasedads">Interest Based Ads</a></li>
      <li><a href="/tos/">Terms of Use</a></li>
      <li><a href="https://eevd.fa.us6.oraclecloud.com/hcmUI/CandidateExperience/en/sites/CX_11004">Careers</a></li>
      <li><a href="https://hearstmediact.com/">Advertising</a></li>
    </ul>
  </li>
  <li>
<div class="title" role="heading" aria-level="2">Contact</div>
    <ul class="section" role="presentation">
      <li><a href="/contact/">Contact Us</a></li>
      <li><a href="/help/">FAQ's</a></li>
      <li><a href="https://subscription.hearstmediact.com/eEdition?siteID=CT_MM">E-Edition</a></li>
      <li><a href="/submissions/">Submissions</a></li>
    </ul>
  </li>
  <li>
<div class="title" role="heading" aria-level="2">Connect</div>
    <ul class="section" role="presentation">
      <li><a href="https://subscription.hearstmediact.com/checkout/700/1482?siteid=CT_MM&amp;origin=subserv&amp;ipid=footer">Subscribe Today</a></li>
      <li><a href="https://www.facebook.com/milfordmirror">Facebook</a></li>
      <li><a href="https://twitter.com/milfordmirror">Twitter</a></li>
    </ul>
  </li>
  <li>
</li>
</ul>
</div><!-- / hdnce-e -->                </div>
            </div>
        </div>
        <div class="pageFooter--branding">
            <img class="pageFooter--branding-logo" src="/img/core/hearst_newspapers_logo.svg" alt="HEARST newspapers logo" />
            <span class="pageFooter--branding-copyright">&copy;2022 Hearst</span>
        </div>
    </div>
                        <!-- hearst/common/spotImFooterJS.tpl -->
<script>
                                
        if ( document.readyState === "complete" || (document.readyState !== "loading" && !document.documentElement.doScroll)) {
            if (HDN && HDN.hasOwnProperty('spotim')) {
                HDN.spotim.commentCount(undefined,undefined,1);
            }
        } else {
            document.addEventListener("DOMContentLoaded", function() { 
                        if (HDN && HDN.hasOwnProperty('spotim')) {
                            HDN.spotim.commentCount(undefined,undefined,1);
                        }
                    });
        }
    
</script>
<!-- e hearst/common/spotImFooterJS.tpl -->
                            
                <script type="text/javascript">
                    window._taboola = window._taboola || [];
                    _taboola.push({flush: true});
                </script>
            
                    </footer>
<!-- e hearst/common/siteFooter.tpl -->
<!-- e hearst/article/types/dynamic_two_column.tpl --><!-- e design/article/dynamic_two_column.tpl -->                            </body>
</html>
<!-- e hearst/article/articleMain.tpl --><!-- e hearst/article/article_main.tpl -->