



<!-- hearst/article/article_main.tpl -->

            <!-- hearst/article/articleMain.tpl -->



    
        <!doctype html>
<html class="no-js "  lang="en-US" prefix="og: http://ogp.me/ns#  article: http://ogp.me/ns/article#">
    <head>
<!-- hearst/article/headerMain.tpl -->

    <!-- Includes for HashTag Labs -->
    
    <!-- eid:article.17615441 -->
    <!-- generated at 2022-11-28 09:28:27 on pwcm7 running vv13.7.4 -->
            <!-- hmb:jquery jQuery JS -->
        <script type="text/javascript" src="/js/core/libs/jquery-2.2.4.min.js"></script>
                <!-- hmb:treg TREG JS -->
        <script type="text/javascript">window.tregEnabled = true;</script>
        <script type="text/javascript" src="//treg.hearstnp.com/treg.js"></script>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
            <!-- hmb:taboola Sailthru  -->
        <!-- hearst/home/header_sailthru.tpl -->
<meta property="sailthru.title" content="2022 Green Bay Packers Roster" /><meta name="sailthru.date" content="2022-11-28 10:12:00 -0500" /><meta name="sailthru.author" content="" /><meta name="sailthru_uid" content="17615441" /><meta name="sailthru_pubname" content="associated-press" /><meta name="sailthru_siteid" content="79" /><meta name="sailthru.tags" content="matt-lafleur,aaron-rodgers,randall-cobb-wr,justin-hollins-lb,jordan-love-qb,ramiz-ahmed-k,danny-etling-qb,thomas-lb,rashan-gary-lb,jonathan-garvin-lb,isaiah-mcduffie-lb,christian-watson-wr,micah-abernathy-saf,johnathan-abram-saf,rudy-ford-saf,adrian-amos-saf,corey-ballentine-cb,kiondre-thomas-cb,eric-stokes-cb,shemar-jean-charles-cb,jaire-alexander-cb,rasul-douglas-cb,sammy-watkins,pat-o-donnell-p,zach-tom-ol,samori-toure-wr,aaron-jones-rb,washburn,tyler-goodson-rb,eric-wilson,patrick-taylor,aj-dillon-rb,luke-tenuta-t,josiah-deguara-te,robert-tonyan-te,krys-barnes,jack-coco-ls,tim-ward,jon-runyan-g,dede-westbrook,travis-fulgham-wr,juwann-winfree-wr,jarran-reed-dt,devonte-wyatt-dt,jack-heflin-dt,chris-slayton-dt,jonathan-ford,preston-smith,dean-lowry-de-6,kenny-clark,david-bakhtiari-t,sean-rhyan-t,caleb-jones-t-6,colorado,georgia,miami,fl,nevada,iowa,michigan,old-dominion,south-carolina,cincinnati,clemson,california,kentucky,tennessee,west-virginia,auburn,louisville,maryland,memphis,oregon,wake-forest,north-texas,oklahoma,nebraska,romeo-doubs,alabama,t-j,syracuse,indiana,minnesota,utah-state,green-bay-packers,quay-walker-lb,dallin-leavitt-saf,mason-crosby-k,mississippi-state,ucla,georgia-tech,north-dakota-state,iowa-state,penn-state,tipa-galeai-lb,kansas-state,appalachian-state,innis-gaines-saf,tariq-carpenter-saf,darnell-savage-saf,virginia-tech,allen-lazard,lsu,boston-college,indiana-state,utep,tcu,tyler-davis-te,kingsley-enagbare,slaton-dt,marcedes-lewis-te,northwestern,ohio-state,dl,rasheed-walker-ol,ole-miss,royce-newman-ol,josh-myers-ol,elgton-jenkins-g,jake-hanson-c,nijman-t,member-choice-sports-option,generic-sports,christian-watson-wr,hamilton-lb,keisean-nixon-cb,utah-state,green-bay-packers,quay-walker-lb,dallin-leavitt-saf,mason-crosby-k,mississippi-state,ucla,georgia-tech,north-dakota-state,iowa-state,penn-state,tipa-galeai-lb,kansas-state,appalachian-state,innis-gaines-saf,tariq-carpenter-saf,darnell-savage-saf,virginia-tech,allen-lazard,lsu,boston-college,indiana-state,utep,tcu,tyler-davis-te,kingsley-enagbare,slaton-dt,marcedes-lewis-te,northwestern,ohio-state,dl,rasheed-walker-ol,ole-miss,royce-newman-ol,josh-myers-ol,elgton-jenkins-g,jake-hanson-c,matt-lafleur,aaron-rodgers,randall-cobb-wr,justin-hollins-lb,jordan-love-qb,ramiz-ahmed-k,danny-etling-qb,thomas-lb,rashan-gary-lb,jonathan-garvin-lb,isaiah-mcduffie-lb,christian-watson-wr,micah-abernathy-saf,johnathan-abram-saf,rudy-ford-saf,adrian-amos-saf,corey-ballentine-cb,kiondre-thomas-cb,eric-stokes-cb,shemar-jean-charles-cb,jaire-alexander-cb,rasul-douglas-cb,sammy-watkins,pat-o-donnell-p,zach-tom-ol,samori-toure-wr,aaron-jones-rb,washburn,tyler-goodson-rb,eric-wilson,patrick-taylor,aj-dillon-rb,luke-tenuta-t,josiah-deguara-te,robert-tonyan-te,krys-barnes,jack-coco-ls,tim-ward,jon-runyan-g,dede-westbrook,travis-fulgham-wr,juwann-winfree-wr,jarran-reed-dt,devonte-wyatt-dt,jack-heflin-dt,chris-slayton-dt,jonathan-ford,preston-smith,dean-lowry-de-6,kenny-clark,david-bakhtiari-t,sean-rhyan-t,caleb-jones-t-6,colorado,georgia,miami,fl,nevada,iowa,michigan,old-dominion,south-carolina,cincinnati,clemson,california,kentucky,tennessee,west-virginia,auburn,louisville,maryland,memphis,oregon,wake-forest,north-texas,oklahoma,nebraska,romeo-doubs,alabama,t-j,syracuse,indiana,minnesota,member-choice-sports-option,generic-sports,christian-watson-wr,hamilton-lb,keisean-nixon-cb,2fsports-2fteam-sports-2famerican-football,2fnews-2fsports-news" /><meta name="sailthru.image.thumb" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg" />
<!-- e hearst/home/header_sailthru.tpl -->
    
        <title>2022 Green Bay Packers Roster</title>
    <!-- hearst/common/fonts.tpl -->
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-regular.woff" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/lora/lora-v12-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-300.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-600.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-700.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-italic.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/css/core/fonts/sourcesans/source-sans-pro-v11-latin-regular.woff2" as="font" type="font/woff2" crossorigin>
<!-- e hearst/common/fonts.tpl -->

        <script>
          if ( document.location.hostname.match(/\.$/) ) {
              document.location.replace(
                  document.location.protocol +
                  '//' +
                  document.location.hostname.replace(/\.+$/, '') +
                  ( undefined !== document.location.pathname ? document.location.pathname : '' ) +
                  ( undefined !== document.location.search ? document.location.search : '' )  +
                  ( undefined !== document.location.hash ? document.location.hash : '' )
              );
          }
        </script>

    <script>
                var HDN = HDN || {};
        HDN.t_firstbyte = Number(new Date());
        HDN.dataLayer = HDN.dataLayer || {};
        HDN.dataLayer.content = HDN.dataLayer.content || {};
                HDN.dataLayer.paywall = HDN.dataLayer.paywall || {};
        HDN.dataLayer.paywall.accessRule = "";
        HDN.dataLayer.paywall.mode = "";
        var Article = {
            "id": "17615441",
            "title": "2022 Green Bay Packers Roster",
            "url": "https://www.milfordmirror.com/sports/article/2022-Green-Bay-Packers-Roster-17615441.php",
            "slug": "https://www.milfordmirror.com/sports/article/2022-Green-Bay-Packers-Roster-17615441.php",
            "summary": "Head Coach: Matt LaFleur . . . . . . . . . . . . . . . . ... . . . . . ....",
            "image": "https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg",
            "keywords": "",
            "siteName": "Milford Mirror",
            "env": "pwcm7",
            "comments": true,
            "isSensitive": false,
            "version": "v13.7.4",
            "displayTemplate": "dynamic_two_column",
            "renderNLP": true,
            "timing": {
                "firstbyte": HDN.t_firstbyte,
                "ready": {}
            }
        };
        
        document.addEventListener('DOMContentLoaded', function () {
            Article.timing.ready = Number(new Date());
        }, false);
        
    </script>
        
    <!-- hearst/common/hdn_datalayer_header.tpl -->

                                                                      
<script type="text/javascript">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</script>
<!-- e hearst/common/hdn_datalayer_header.tpl -->
    <script type="text/javascript" src="/js/site.js?v13.7.4"></script>
            
            <!-- Hotfix Top Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.94216 -->
<!-- DO NOT REMOVE -->
<script src="https://projects.sfchronicle.com/shared/js/responsive-frame.js"></script>
<!-- e DO NOT REMOVE -->
        <!-- Hotfix Top Freeform (Local Dynamic Two-Column) -->
        
<!-- noGen: item_header_hotfix_top_dtc_ssl 79 dne  -->
                <link rel="stylesheet" href="/dist/article.min.css?v13.7.4">
                            <!-- hmb:Polyfill  -->
        <script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=IntersectionObserver%2CIntersectionObserverEntry%2CPromise%2CCustomEvent%2CArray.prototype.forEach%2CArray.prototype.entries"></script>
                <!-- hmb:js_header Static JS Bundle  -->
        <script type="text/javascript" src="/dist/hdn/article.min.js?v13.7.4"></script>
        <!-- hearst/article/common/meta_tags.tpl -->
<meta name="msvalidate.01" content="9451CA04ABC9D1D5C6419C73B4C4F7B7" />
<meta name="HandheldFriendly" content="true">
<meta name="twitter:dnt" content="on">
<meta name="apple-mobile-web-app-title" content="">
<meta name="environment" content="pwcm7">
<meta name="id" content="17615441">
<link rel="canonical" href="https://www.milfordmirror.com/sports/article/2022-Green-Bay-Packers-Roster-17615441.php" />
<meta name="robots" content="max-image-preview:large">
                                            <meta name="author" content="">
        <meta name="author.name" content="" />
        <meta name="author.title" content="" />
        <meta name="description" content="Head Coach: Matt LaFleur . . . . . . . . . . . . . . . . ... . . . . . ...."/>
    <meta name="date.release" content="2022-11-28 15:12:38" />
    <meta name="time.release" content="2022-11-28 15:12:38" />
    <meta name="sections" content="Sports" />
            <meta name="subject" content="Matt LaFleur, Aaron Rodgers, Randall Cobb WR, Justin Hollins LB, Jordan Love QB, Ramiz Ahmed K, Danny Etling QB, Thomas LB, Rashan Gary LB, Jonathan Garvin LB, Isaiah McDuffie LB, Christian Watson WR, Micah Abernathy SAF, Johnathan Abram SAF, Rudy Ford SAF, Adrian Amos SAF, Corey Ballentine CB, Kiondre Thomas CB, Eric Stokes CB, Shemar Jean-Charles CB, Jaire Alexander CB, Rasul Douglas CB, Sammy Watkins, Pat O'Donnell P, Zach Tom OL, Samori Toure WR, Aaron Jones RB, Washburn, Tyler Goodson RB, Eric Wilson, Patrick Taylor, AJ Dillon RB, Luke Tenuta T, Josiah Deguara TE, Robert Tonyan TE, Krys Barnes, Jack Coco LS, Tim Ward, Jon Runyan G, Dede Westbrook, Travis Fulgham WR, Juwann Winfree WR, Jarran Reed DT, Devonte Wyatt DT, Jack Heflin DT, Chris Slayton DT, Jonathan Ford, Preston Smith, Dean Lowry DE 6, Kenny Clark, David Bakhtiari T, Sean Rhyan T, Caleb Jones T 6, Colorado, Georgia, Miami, FL, Nevada, Iowa, Michigan, Old Dominion, South Carolina, Cincinnati, Clemson, California, Kentucky, Tennessee, West Virginia, Auburn, Louisville, Maryland, Memphis, Oregon, Wake Forest, North Texas, Oklahoma, Nebraska, Romeo Doubs, Alabama, T.J., Syracuse, Indiana, Minnesota, Utah State, Green Bay Packers, Quay Walker LB, Dallin Leavitt SAF, Mason Crosby K, Mississippi State, UCLA, Georgia Tech, North Dakota State, Iowa State, Penn State, Tipa Galeai LB, Kansas State, Appalachian State, Innis Gaines SAF, Tariq Carpenter SAF, Darnell Savage SAF, Virginia Tech, Allen Lazard, LSU, Boston College, Indiana State, UTEP, TCU, Tyler Davis TE, Kingsley Enagbare, Slaton DT, Marcedes Lewis TE, Northwestern, Ohio State, DL, Rasheed Walker OL, Ole Miss, Royce Newman OL, Josh Myers OL, Elgton Jenkins G, Jake Hanson C, Nijman T, Member Choice Sports Option, Generic Sports, Christian Watson WR., Hamilton LB, Keisean Nixon CB" />
        <meta name="news_keywords" content="Matt LaFleur, Aaron Rodgers, Randall Cobb WR, Justin Hollins LB, Jordan Love QB, Ramiz Ahmed K, Danny Etling QB, Thomas LB, Rashan Gary LB, Jonathan Garvin LB, Isaiah McDuffie LB, Christian Watson WR, Micah Abernathy SAF, Johnathan Abram SAF, Rudy Ford SAF, Adrian Amos SAF, Corey Ballentine CB, Kiondre Thomas CB, Eric Stokes CB, Shemar Jean-Charles CB, Jaire Alexander CB, Rasul Douglas CB, Sammy Watkins, Pat O'Donnell P, Zach Tom OL, Samori Toure WR, Aaron Jones RB, Washburn, Tyler Goodson RB, Eric Wilson, Patrick Taylor, AJ Dillon RB, Luke Tenuta T, Josiah Deguara TE, Robert Tonyan TE, Krys Barnes, Jack Coco LS, Tim Ward, Jon Runyan G, Dede Westbrook, Travis Fulgham WR, Juwann Winfree WR, Jarran Reed DT, Devonte Wyatt DT, Jack Heflin DT, Chris Slayton DT, Jonathan Ford, Preston Smith, Dean Lowry DE 6, Kenny Clark, David Bakhtiari T, Sean Rhyan T, Caleb Jones T 6, Colorado, Georgia, Miami, FL, Nevada, Iowa, Michigan, Old Dominion, South Carolina, Cincinnati, Clemson, California, Kentucky, Tennessee, West Virginia, Auburn, Louisville, Maryland, Memphis, Oregon, Wake Forest, North Texas, Oklahoma, Nebraska, Romeo Doubs, Alabama, T.J., Syracuse, Indiana, Minnesota, Utah State, Green Bay Packers, Quay Walker LB, Dallin Leavitt SAF, Mason Crosby K, Mississippi State, UCLA, Georgia Tech, North Dakota State, Iowa State, Penn State, Tipa Galeai LB, Kansas State, Appalachian State, Innis Gaines SAF, Tariq Carpenter SAF, Darnell Savage SAF, Virginia Tech, Allen Lazard, LSU, Boston College, Indiana State, UTEP, TCU, Tyler Davis TE, Kingsley Enagbare, Slaton DT, Marcedes Lewis TE, Northwestern, Ohio State, DL, Rasheed Walker OL, Ole Miss, Royce Newman OL, Josh Myers OL, Elgton Jenkins G, Jake Hanson C, Nijman T, Member Choice Sports Option, Generic Sports, Christian Watson WR., Hamilton LB, Keisean Nixon CB" />
                <meta name="nlpOrganization" content="Utah State, Green Bay Packers, Quay Walker LB, Dallin Leavitt SAF, Mason Crosby K, Mississippi State, UCLA, Georgia Tech, North Dakota State, Iowa State, Penn State, Tipa Galeai LB, Kansas State, Appalachian State, Innis Gaines SAF, Tariq Carpenter SAF, Darnell Savage SAF, Virginia Tech, Allen Lazard, LSU, Boston College, Indiana State, UTEP, TCU, Tyler Davis TE, Kingsley Enagbare, Slaton DT, Marcedes Lewis TE, Northwestern, Ohio State, DL, Rasheed Walker OL, Ole Miss, Royce Newman OL, Josh Myers OL, Elgton Jenkins G, Jake Hanson C" />
                <meta name="nlpPerson" content="Matt LaFleur, Aaron Rodgers, Randall Cobb WR, Justin Hollins LB, Jordan Love QB, Ramiz Ahmed K, Danny Etling QB, Thomas LB, Rashan Gary LB, Jonathan Garvin LB, Isaiah McDuffie LB, Christian Watson WR, Micah Abernathy SAF, Johnathan Abram SAF, Rudy Ford SAF, Adrian Amos SAF, Corey Ballentine CB, Kiondre Thomas CB, Eric Stokes CB, Shemar Jean-Charles CB, Jaire Alexander CB, Rasul Douglas CB, Sammy Watkins, Pat O'Donnell P, Zach Tom OL, Samori Toure WR, Aaron Jones RB, Washburn, Tyler Goodson RB, Eric Wilson, Patrick Taylor, AJ Dillon RB, Luke Tenuta T, Josiah Deguara TE, Robert Tonyan TE, Krys Barnes, Jack Coco LS, Tim Ward, Jon Runyan G, Dede Westbrook, Travis Fulgham WR, Juwann Winfree WR, Jarran Reed DT, Devonte Wyatt DT, Jack Heflin DT, Chris Slayton DT, Jonathan Ford, Preston Smith, Dean Lowry DE 6, Kenny Clark, David Bakhtiari T, Sean Rhyan T, Caleb Jones T 6" />
                <meta name="nlpLocation" content="Colorado, Georgia, Miami, FL, Nevada, Iowa, Michigan, Old Dominion, South Carolina, Cincinnati, Clemson, California, Kentucky, Tennessee, West Virginia, Auburn, Louisville, Maryland, Memphis, Oregon, Wake Forest, North Texas, Oklahoma, Nebraska, Romeo Doubs, Alabama, T.J., Syracuse, Indiana, Minnesota" />
                <meta name="nlpConsumerGood" content="Nijman T" />
                        <meta name="nlpOther" content="Member Choice Sports Option, Generic Sports, Christian Watson WR., Hamilton LB, Keisean Nixon CB" />
                            <meta name="nlpCategories" content="%2FSports%2FTeam+Sports%2FAmerican+Football,%2FNews%2FSports+News" />
    <!-- e hearst/article/common/meta_tags.tpl -->    <!-- hearst/article/common/opengraph.tpl -->
<meta property="fb:admins" content="100006394927810"/><meta property="fb:app_id" content="322056085100167"/><meta property="fb:pages" content="105702905593" /><meta property="fb:pages" content="307851324523" /><meta property="fb:pages" content="12852567813" /><meta property="fb:pages" content="480760515417232" /><meta property="fb:pages" content="288240529145" /><meta property="fb:pages" content="316774245761" /><meta property="fb:pages" content="984197758297116" /><meta property="fb:pages" content="7457442370" /><meta property="fb:pages" content="207033189701" /><meta property="fb:pages" content="207346283795" /><meta property="fb:pages" content="222959748728" /><meta property="fb:pages" content="207042068180" /><meta property="fb:pages" content="72983690774" /><meta property="fb:pages" content="339413234035" /><meta property="fb:pages" content="343689323559" /><meta property="fb:pages" content="345828366626" /><meta property="fb:pages" content="234821559861394" /><meta property="fb:pages" content="335699426867" /><meta property="fb:pages" content="10150105039485602" /><meta property="fb:pages" content="338983127562" /><meta property="fb:pages" content="364516539001" /><meta property="fb:pages" content="337922332042" /><meta property="fb:pages" content="115637335153191" /><meta property="fb:pages" content="372011535931" /><meta property="fb:pages" content="333376634908" /><meta property="fb:pages" content="127590790608884" /><meta property="fb:pages" content="141923885872653" /><meta property="fb:pages" content="655037391286291" /><meta property="fb:pages" content="320774811368833" /><meta property="fb:pages" content="1740489152861748" /><meta property="fb:pages" content="469700473093040" /><meta property="fb:pages" content="386754203367" /><meta property="fb:pages" content="556449374478585" /><meta property="fb:pages" content="340999853450" /><meta property="fb:pages" content="350771491032" /><meta property="fb:pages" content="1120648627959218" /><meta property="fb:pages" content="342017778245" /><meta property="fb:pages" content="338463361591" /><meta property="fb:pages" content="138772706196968" /><meta property="fb:pages" content="1641688532739111" /><meta property="fb:pages" content="326312697536" /><meta property="fb:pages" content="353120110016" /><meta property="fb:pages" content="343366744658" /><meta property="fb:pages" content="335009494554" /><meta property="fb:pages" content="347261603104" /><meta property="fb:pages" content="350924013892" /><meta property="fb:pages" content="257724773860" /><meta property="fb:pages" content="361203926417" /><meta property="fb:pages" content="367174215398" /><meta property="fb:pages" content="284154645394" /><meta property="fb:pages" content="334501182354" /><meta property="fb:pages" content="350279743224" /><meta property="fb:pages" content="154340691263654" /><meta property="fb:pages" content="147848678611852" /><meta property="fb:pages" content="361381078011" /><meta property="fb:pages" content="362831597677" /><meta property="fb:pages" content="10150095255780118" /><meta name="og:datePublished" content="2022-11-28 15:10:10"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="2022 Green Bay Packers Roster"/><meta property="og:description" content="Head Coach: Matt LaFleur . . . . . . . . . . . . . . . . ... . . . . . ...."/><meta property="og:url" content="https://www.milfordmirror.com/sports/article/2022-Green-Bay-Packers-Roster-17615441.php"/><meta property="og:site_name" content="Milford Mirror"/><meta property="og:image" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg"/><meta property="article:published_time" content="2022-11-28 15:10:10" /><meta property="article:modified_time" content="2022-11-28 15:12:40" /><meta property="article:author" content=""/><meta property="article:section" content="Sports" /><meta property="article:tag" content="Matt LaFleur" /><meta property="article:tag" content="Aaron Rodgers" /><meta property="article:tag" content="Randall Cobb WR" /><meta property="article:tag" content="Justin Hollins LB" /><meta property="article:tag" content="Jordan Love QB" /><meta property="article:tag" content="Ramiz Ahmed K" /><meta property="article:tag" content="Danny Etling QB" /><meta property="article:tag" content="Thomas LB" /><meta property="article:tag" content="Rashan Gary LB" /><meta property="article:tag" content="Jonathan Garvin LB" /><meta property="article:tag" content="Isaiah McDuffie LB" /><meta property="article:tag" content="Christian Watson WR" /><meta property="article:tag" content="Micah Abernathy SAF" /><meta property="article:tag" content="Johnathan Abram SAF" /><meta property="article:tag" content="Rudy Ford SAF" /><meta property="article:tag" content="Adrian Amos SAF" /><meta property="article:tag" content="Corey Ballentine CB" /><meta property="article:tag" content="Kiondre Thomas CB" /><meta property="article:tag" content="Eric Stokes CB" /><meta property="article:tag" content="Shemar Jean-Charles CB" /><meta property="article:tag" content="Jaire Alexander CB" /><meta property="article:tag" content="Rasul Douglas CB" /><meta property="article:tag" content="Sammy Watkins" /><meta property="article:tag" content="Pat O&#039;Donnell P" /><meta property="article:tag" content="Zach Tom OL" /><meta property="article:tag" content="Samori Toure WR" /><meta property="article:tag" content="Aaron Jones RB" /><meta property="article:tag" content="Washburn" /><meta property="article:tag" content="Tyler Goodson RB" /><meta property="article:tag" content="Eric Wilson" /><meta property="article:tag" content="Patrick Taylor" /><meta property="article:tag" content="AJ Dillon RB" /><meta property="article:tag" content="Luke Tenuta T" /><meta property="article:tag" content="Josiah Deguara TE" /><meta property="article:tag" content="Robert Tonyan TE" /><meta property="article:tag" content="Krys Barnes" /><meta property="article:tag" content="Jack Coco LS" /><meta property="article:tag" content="Tim Ward" /><meta property="article:tag" content="Jon Runyan G" /><meta property="article:tag" content="Dede Westbrook" /><meta property="article:tag" content="Travis Fulgham WR" /><meta property="article:tag" content="Juwann Winfree WR" /><meta property="article:tag" content="Jarran Reed DT" /><meta property="article:tag" content="Devonte Wyatt DT" /><meta property="article:tag" content="Jack Heflin DT" /><meta property="article:tag" content="Chris Slayton DT" /><meta property="article:tag" content="Jonathan Ford" /><meta property="article:tag" content="Preston Smith" /><meta property="article:tag" content="Dean Lowry DE 6" /><meta property="article:tag" content="Kenny Clark" /><meta property="article:tag" content="David Bakhtiari T" /><meta property="article:tag" content="Sean Rhyan T" /><meta property="article:tag" content="Caleb Jones T 6" /><meta property="article:tag" content="Colorado" /><meta property="article:tag" content="Georgia" /><meta property="article:tag" content="Miami" /><meta property="article:tag" content="FL" /><meta property="article:tag" content="Nevada" /><meta property="article:tag" content="Iowa" /><meta property="article:tag" content="Michigan" /><meta property="article:tag" content="Old Dominion" /><meta property="article:tag" content="South Carolina" /><meta property="article:tag" content="Cincinnati" /><meta property="article:tag" content="Clemson" /><meta property="article:tag" content="California" /><meta property="article:tag" content="Kentucky" /><meta property="article:tag" content="Tennessee" /><meta property="article:tag" content="West Virginia" /><meta property="article:tag" content="Auburn" /><meta property="article:tag" content="Louisville" /><meta property="article:tag" content="Maryland" /><meta property="article:tag" content="Memphis" /><meta property="article:tag" content="Oregon" /><meta property="article:tag" content="Wake Forest" /><meta property="article:tag" content="North Texas" /><meta property="article:tag" content="Oklahoma" /><meta property="article:tag" content="Nebraska" /><meta property="article:tag" content="Romeo Doubs" /><meta property="article:tag" content="Alabama" /><meta property="article:tag" content="T.J." /><meta property="article:tag" content="Syracuse" /><meta property="article:tag" content="Indiana" /><meta property="article:tag" content="Minnesota" /><meta property="article:tag" content="Utah State" /><meta property="article:tag" content="Green Bay Packers" /><meta property="article:tag" content="Quay Walker LB" /><meta property="article:tag" content="Dallin Leavitt SAF" /><meta property="article:tag" content="Mason Crosby K" /><meta property="article:tag" content="Mississippi State" /><meta property="article:tag" content="UCLA" /><meta property="article:tag" content="Georgia Tech" /><meta property="article:tag" content="North Dakota State" /><meta property="article:tag" content="Iowa State" /><meta property="article:tag" content="Penn State" /><meta property="article:tag" content="Tipa Galeai LB" /><meta property="article:tag" content="Kansas State" /><meta property="article:tag" content="Appalachian State" /><meta property="article:tag" content="Innis Gaines SAF" /><meta property="article:tag" content="Tariq Carpenter SAF" /><meta property="article:tag" content="Darnell Savage SAF" /><meta property="article:tag" content="Virginia Tech" /><meta property="article:tag" content="Allen Lazard" /><meta property="article:tag" content="LSU" /><meta property="article:tag" content="Boston College" /><meta property="article:tag" content="Indiana State" /><meta property="article:tag" content="UTEP" /><meta property="article:tag" content="TCU" /><meta property="article:tag" content="Tyler Davis TE" /><meta property="article:tag" content="Kingsley Enagbare" /><meta property="article:tag" content="Slaton DT" /><meta property="article:tag" content="Marcedes Lewis TE" /><meta property="article:tag" content="Northwestern" /><meta property="article:tag" content="Ohio State" /><meta property="article:tag" content="DL" /><meta property="article:tag" content="Rasheed Walker OL" /><meta property="article:tag" content="Ole Miss" /><meta property="article:tag" content="Royce Newman OL" /><meta property="article:tag" content="Josh Myers OL" /><meta property="article:tag" content="Elgton Jenkins G" /><meta property="article:tag" content="Jake Hanson C" /><meta property="article:tag" content="Nijman T" /><meta property="article:tag" content="Member Choice Sports Option" /><meta property="article:tag" content="Generic Sports" /><meta property="article:tag" content="Christian Watson WR." /><meta property="article:tag" content="Hamilton LB" /><meta property="article:tag" content="Keisean Nixon CB" />
<!-- e hearst/article/common/opengraph.tpl -->    <!-- hearst/article/common/twittercard.tpl -->

<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:image" content="https://www.milfordmirror.com/img/pages/article/opengraph_default.jpg"/>
<meta name="twitter:description" content="Head Coach: Matt LaFleur . . . . . . . . . . . . . . . . ... . . . . . ...."/>
<meta name="twitter:title" content="2022 Green Bay Packers Roster"/>
<meta name="twitter:site" content="@milfordmirror" />
<!-- e hearst/article/common/twittercard.tpl -->    <!-- hearst/article/common/analytics.tpl -->
<script>var omni_channelPath = "Sports";var omni_title = "2022 Green Bay Packers Roster";var omni_bizObjectId = "17615441";var omni_className = "article";var omni_publicationDate = "2022-11-28 15:10:10";var omni_sourceSite ="ap";var omni_authorName = "";var omni_authorTitle = "";var omni_premiumStatus = "free";var omni_premiumEndDate = "";var omni_originalSource = "AP";var omni_pageNumber = "0";var omni_breakingNewsFlag = "0";var omni_localNewsFlag = "0";var omni_isListView = "0";var omni_paywallSite = "0";var omni_displayTemplate = "dynamic_two_column";</script>
<!-- e hearst/article/common/analytics.tpl -->    <!-- hearst/article/common/schema_NewsArticle.tpl -->

<script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@id":"https:\/\/www.milfordmirror.com\/sports\/article\/2022-Green-Bay-Packers-Roster-17615441.php"},"headline":"2022 Green Bay Packers Roster","articleBody":"No. Player Pos Ht Wt Born Exp College 2 Mason Crosby K 6-1 207 09-03-1984 15 Colorado 6 Dallin Leavitt SAF 5-10 195 08-08-1994 4 Utah State 7 Quay Walker LB 6-4 241 05-08-2000 0 Georgia 9 Christian Watson WR 6-5 208 05-12-1999 0 North Dakota State 10 Jordan Love QB 6-4 219 11-02-1998 2 Utah State 11 Sammy Watkins WR 6-1 211 06-14-1993 8 Clemson 12 Aaron Rodgers QB 6-2 225 12-02-1983 17 California 13 Allen Lazard WR 6-5 227 12-11-1995 4 Iowa State 16 Pat O'Donnell P 6-4 220 02-22-1991 8 Miami (FL) 17 Ramiz Ahmed K 5-11 193 07-27-1995 2 Nevada 18 Randall Cobb WR 5-10 195 08-22-1990 11 Kentucky 19 Danny Etling QB 6-3 222 07-22-1994 4 LSU 20 Rudy Ford SAF 6-0 200 11-01-1994 5 Auburn 21 Eric Stokes CB 6-0 194 03-01-1999 1 Georgia 22 Shemar Jean-Charles CB 5-10 184 06-20-1998 1 Appalachian State 23 Jaire Alexander CB 5-10 196 02-09-1997 4 Louisville 24 Tariq Carpenter SAF 6-3 230 12-28-1998 0 Georgia Tech 25 Keisean Nixon CB 5-10 200 06-22-1997 3 South Carolina 26 Darnell Savage SAF 5-11 198 07-30-1997 3 Maryland 27 Patrick Taylor RB 6-2 217 04-29-1998 2 Memphis 28 AJ Dillon RB 6-0 247 05-02-1998 2 Boston College 29 Rasul Douglas CB 6-2 209 08-29-1995 5 West Virginia 31 Adrian Amos SAF 6-0 214 04-29-1993 7 Penn State 33 Aaron Jones RB 5-9 208 12-02-1994 5 UTEP 34 Micah Abernathy SAF 6-0 195 02-10-1997 3 Tennessee 35 Corey Ballentine CB 5-11 196 04-13-1996 3 Washburn 38 Innis Gaines SAF 6-1 202 08-29-1998 2 TCU 39 Tyler Goodson RB 5-9 197 11-10-2000 0 Iowa 40 Tipa Galeai LB 6-5 229 02-26-1997 2 Utah State 43 Kiondre Thomas CB 6-0 186 02-07-1998 1 Kansas State 44 Johnathan Abram SAF 5-11 205 10-25-1996 3 Mississippi State 45 Eric Wilson LB 6-1 230 09-26-1994 5 Cincinnati 47 Justin Hollins LB 6-5 248 01-15-1996 3 Oregon 48 DQ Thomas LB 6-2 216 12-04-1998 0 Middle Tennessee 50 Zach Tom OL 6-4 304 03-26-1999 0 Wake Forest 51 Krys Barnes LB 6-2 229 04-02-1998 2 UCLA 52 Rashan Gary LB 6-5 277 12-03-1997 3 Michigan 53 Jonathan Garvin LB 6-4 257 07-28-1999 2 Miami (FL) 54 La'Darius Hamilton LB 6-2 261 01-18-1998 2 North Texas 55 Kingsley Enagbare LB 6-4 258 01-18-2000 0 South Carolina 56 Jack Coco LS 6-2 248 10-09-1998 0 Georgia Tech 57 Tim Ward LB 6-6 255 08-11-1997 3 Old Dominion 58 Isaiah McDuffie LB 6-1 227 07-21-1999 1 Boston College 59 De'Vondre Campbell LB 6-3 232 07-01-1993 6 Minnesota 63 Rasheed Walker OL 6-6 324 02-13-2000 0 Penn State 67 Jake Hanson C 6-4 296 04-29-1997 2 Oregon 69 David Bakhtiari T 6-4 310 09-30-1991 9 Colorado 70 Royce Newman OL 6-5 310 08-17-1997 1 Ole Miss 71 Josh Myers OL 6-5 310 07-16-1998 1 Ohio State 72 Caleb Jones T 6-9 370 02-10-1999 0 Indiana 73 Yoshuah Nijman T 6-7 314 01-02-1996 3 Virginia Tech 74 Elgton Jenkins G 6-5 311 12-26-1995 3 Mississippi State 75 Sean Rhyan T 6-5 321 09-15-2000 0 UCLA 76 Jon Runyan G 6-4 307 08-08-1997 2 Michigan 78 Luke Tenuta T 6-8 319 09-01-1999 0 Virginia Tech 80 Dede Westbrook WR 6-0 178 11-21-1993 5 Oklahoma 81 Josiah Deguara TE 6-2 238 02-14-1997 2 Cincinnati 83 Samori Toure WR 6-3 191 03-24-1998 0 Nebraska 84 Tyler Davis TE 6-4 252 04-02-1997 2 Georgia Tech 85 Robert Tonyan TE 6-5 240 04-30-1994 5 Indiana State 86 Travis Fulgham WR 6-2 211 09-13-1995 3 Old Dominion 87 Romeo Doubs WR 6-2 204 04-13-2000 0 Nevada 88 Juwann Winfree WR 6-1 210 09-04-1996 3 Colorado 89 Marcedes Lewis TE 6-6 267 05-19-1984 16 UCLA 90 Jarran Reed DT 6-3 307 12-16-1992 6 Alabama 91 Preston Smith LB 6-5 265 11-17-1992 7 Mississippi State 93 T.J. Slaton DT 6-4 330 10-03-1997 1 Florida 94 Dean Lowry DE 6-6 296 06-09-1994 6 Northwestern 95 Devonte Wyatt DT 6-3 304 03-31-1998 0 Georgia 96 Jack Heflin DT 6-3 304 03-08-1998 1 Iowa 97 Kenny Clark DL 6-3 314 10-04-1995 6 UCLA 98 Chris Slayton DT 6-4 307 08-01-1996 3 Syracuse 99 Jonathan Ford DL 6-5 338 09-29-1999 0 Miami (FL)","datePublished":"2022-11-28T15:10:10Z","dateModified":"2022-11-28T15:12:40Z","author":[{"@type":"Person","name":"","jobTitle":""}],"publisher":{"@type":"Organization","name":"Associated Press","logo":{"@type":"ImageObject","url":"https:\/\/www.MilfordMirror.com\/img\/ldjson_logo.png","width":600,"height":60},"sameAs":["http:\/\/facebook.com\/milfordmirror","http:\/\/twitter.com\/milfordmirror"]},"description":"Head Coach: Matt LaFleur . . . . . . . . . . . . . . . . ... . . . . . ...."}
</script>
<!-- e hearst/article/common/schema_NewsArticle.tpl -->        <!-- hearst/common/third_party_assets.tpl -->
                    <!-- hmb:juice Juice -->
        <script type="text/javascript">
            
                var startRevWorker = function() {
                    if (window.articleShowLISTQueue) {
                        while (window.articleShowLISTQueue.length > 0) {
                            var showListEntry = articleShowLISTQueue.shift();
                            window.aps.showLIST([showListEntry]);
                        }
                    }
                    if (window.placeAdQueue) {
                        while (window.placeAdQueue.length > 0) {
                            var placeAdEntry = placeAdQueue.shift();
                            window.aps.placeAd([placeAdEntry]);
                        }
                    }
                    if (window.slideshowShowLISTQueue) {
                        while (window.slideshowShowLISTQueue.length > 0) {
                            var ads = window.slideshowShowLISTQueue.shift();
                            window.aps.showLIST(ads);
                        }
                    }
                    window.juiceloaded = true;
                }
            
        </script>

        <!-- ENG-10074 If AB Test on Seattle we turn off Juice in order to use HTL code -->
                    <script  src="https://aps.hearstnp.com/Scripts/loadAds.js?v=1.3.3.5" type="text/javascript" id="adPositionManagerScriptTag"></script>
            
    <!-- hmb:ensighten Ensighten  -->
    <!-- hearst/ensighten/ensighten.tpl -->
<!-- hmb:ensighten Ensighten script -->
<!-- Hearst analytics: Ensighten -->
<script src="https://tm.hdmtools.com/hearst/news/Bootstrap.js"></script>
<!-- End Hearst analytics: Ensighten -->
<!-- e ensighten.tpl -->                    <!-- blueconic -->
        <script src="https://y752.milfordmirror.com/script.js" async></script>
            
    <!-- hmb:taboola Taboola  -->
                            
                            
                <script type="text/javascript">
                    
                    (function () {
                        window._taboolaNetworkMode = true;
                        
                        window._taboola = window._taboola || [];
                        window._taboolaHDNPageLabel = window._taboolaHDNPageLabel || 'article';
                        var tobj = {};
                        tobj[window._taboolaHDNPageLabel] = 'auto';
                        window._taboola.push(tobj);
                        !function (e, f, u, i) {
                            if (!document.getElementById(i)){
                                e.async = 1;
                                e.src = u;
                                e.id = i;
                                f.parentNode.insertBefore(e, f);
                            }
                        }(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/hearstlocalnews-network/loader.js', 'tb_loader_script');
                        if(window.performance && typeof window.performance.mark == 'function') {
                            window.performance.mark('tbl_ic');
                        }
                    })();
                </script>
                
                                <!-- e hearst/common/third_party_assets.tpl -->
    <link rel="shortcut icon" href="/favicon.ico">
    <link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon.png">
    <link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
    <link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
    <link rel="apple-touch-icon-precomposed" sizes="128x128" href="/apple-touch-icon-128x128.png">
            <!-- Hotfix Freeform (All Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.93530 -->
<!-- ENG-3363 -->
<style>
  .thumbnailListAuthor.one .thumbnailListAuthor--wrapper { margin: 0; }
  @media (min-width: 768px) { .thumbnailListAuthor.two .thumbnailListAuthor--wrapper { margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--items { justify-content: space-between; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--item { flex: 0 0 48%; margin: 0; } }
  @media (min-width: 928px) { .thumbnailListAuthor.two .thumbnailListAuthor--spacer { display: none; } }
  @media (min-width: 928px) { .thumbnailListAuthor.three .thumbnailListAuthor--wrapper { margin: 0; } }
</style>
<!-- ENG-3834 -->
<style>
  .alert{background-color:#000;bottom:0;box-sizing:border-box;color:#fff;font-family:Helvetica,sans-serif;font-size:16px;font-weight:600;left:50%;line-height:1.25;overflow:hidden;padding:10px;position:fixed;transform:translateX(-50%);width:100vw;z-index:5000000}.alert .close{border-radius:8px;color:#fff;display:block;position:absolute;right:10px;height:16px;overflow:hidden;top:10px;width:16px}.alert .close::after{background-color:#fff;content:'';display:block;height:2px;left:-6px;position:relative;top:4px;transform:rotate(-45deg);width:30px}.alert .close::before{background-color:#fff;content:'';display:block;height:2px;left:-5px;position:relative;top:9px;transform:rotate(45deg);width:30px}.alert>div{box-sizing:border-box;max-width:1200px;margin:0 auto;position:relative;padding-right:34px}
</style>
<script>
  document.addEventListener('DOMContentLoaded', function() {
    if (/MSIE \d|Trident.*rv:/.test(navigator.userAgent)) {var site=HDN.domain,name=site.charAt(0).toUpperCase()+site.slice(1),section=document.createElement("section"),close=document.createElement("a");close.className="close",close.href="#",close.addEventListener("click",function(e){e.stopPropagation(),e.preventDefault(),e.target.parentElement.style.display="none"});var HTML="<div>Thank you for visiting "+name+". You are using an older browser that may impact your reading experience. For the best experience, we recommend you use Chrome, Safari, Firefox, or Edge.</div>";section.className="alert",section.id="warning",section.innerHTML=HTML,section.appendChild(close),document.getElementsByTagName("body")[0].appendChild(section);}
  }, false);
</script>
<!-- e ENG-3834 -->
<!--  Start ENG-8221 -->
<style>
@media (max-width:768px) {   
  .articleHeader:not(.heroleft):not(.herotextabove):not(.herocenter) .articleHeader--timestamp {     
    bottom: 0px !important;     
    margin-left: 0px !important;     
    position: relative;    
  }
}</style>
        <!-- Hotfix Freeform (Local Dynamic Two-Column) -->
        <!-- hearst/item/standalone.tpl -->
<!-- mid:freeform.97469 -->
<!-- ENG-10491 -->
<style>
  .badge:not(.shopping):not(.sponsored-content):not(.paidad-content):before, 
  section.fourPack-breaking .fourPack--item .badge::before, 
  section.centerpiece .centerpiece-tab-primary.density>div:last-child .centerpiece-tab 
  .badge::before {
    display: none;
  }
  .thumbnail-list a.hideKicker, 
  .centerpiece div.hideKicker, 
  .dynamicSpotlight div.hideKicker, 
  .thumbnail-list div.hideKicker, 
  .thumbnail-list span.hideKicker,
  .dynamicSpotlight span.hideKicker {
    display: inherit;
  }
  .dynamicSpotlight div.hideKicker, 
  .dynamicSpotlight span.hideKicker {
    display: inline-block;
  }
  .centerpiece .badgeInline p.bullet span {
    display: none;
  }
  .centerpiece:not(.density) div.centerpiece-tab--main-kicker.hideKicker {
    display: block;
  }
  .thumbnail-list--item-header.badge.shopping .hideKicker > a, .thumbnail-list--item-header.badge.shopping .hideKicker > span {
    display: none;
  }
</style>
                    </head>
<!-- e hearst/article/headerMain.tpl -->    <body data-location="sports"  class="two-column">
                                                <!-- design/article/dynamic_two_column.tpl -->
    <!-- hearst/article/types/dynamic_two_column.tpl -->


<div id="zoneTop" class="zone full innerGrid" data-tb-region="zoneAboveMasthead"></div><!-- hearst/common/siteBranding.tpl -->
    <header class="pageHeader standard" data-stage="0">
        <div class="pageHeader--progress"><div class="pageHeader--progress-bar" id="progress"></div></div>    <div class="pageHeader--skipLink-wrapper">
        <a href="#content" class="pageHeader--skipLink" aria-label="Skip to main content">Skip to main content</a>
    </div>
    <div class="pageHeader--wrapper lock">
        <button id="navToggle" class="pageHeader--menuButton navToggle" role="button" tabindex="0" aria-expanded="false" aria-label="navigation"></button>                <a id="mastheadLogo" href="/" tabindex="0">Milford Mirror Homepage<span  class="pageHeader--logo mastheadLogo fade show hdn-analytics" role="img" aria-label="Milford Mirror Homepage - Site Logo" data-hdn-analytics="visit|masthead|navigation|0"></span></a>
                    <div id="titleBar" class="pageHeader--titleBar titleBar fade show hidden">
                                    <div class="pageHeader--titleBar-subsection">Currently Reading</div>
                    <div class="pageHeader--titleBar-title">2022 Green Bay Packers Roster</div>
                            </div>
                            <div id="nextStory" class="pageHeader--nextStory nextStory fade show hidden"></div>
                            <ul class="pageHeader--links fade show">
                                                                                                                                        <li id="subscription" class="pageHeader--links-nonsub subscribeButton fade show hidden">
                                <a class="visible-xs-f subscribe" href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=button&ipid=wcm" target="_blank">Subscribe</a>
                                <a class="hidden-xs button" href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=button&ipid=wcm" target="_blank">Subscribe</a>
                            </li>
                                                                                                <li id="eEdition" class="pageHeader--links-sub eEdition fade show hidden"><a href="/e-edition">e-Edition</a></li>
                                                                                                                                        <!-- hearst/common/signin.tpl -->
<li class="treg-is-gigya gigya_menu ">
    <div class="gya-title expandable treg-conditional treg-not-logged-in">
        <a class="signIn featureSignIn" tabindex="0" role="button">Sign In</a>
    </div>
    <div class="gya-title expandable treg-conditional treg-logged-in" aria-controls="treg-login-widget" role="button"><span></span></div>
    <div class="gya-content expandable" id="treg-login-widget">
        <div class="treg-gya-login-widget"></div>
    </div>
</li>
<!-- e hearst/common/signin.tpl -->                <button class="pageHeader--searchButton searchToggle" aria-expanded="false" tabindex="0" aria-label="searchToggle" aria-controls="searchField-aria"></button>            </ul>
                            <div class="pageHeader--search searchField" id="searchField-aria">
                
                <form class="pageHeader--search-form" action="/search/" method="get">
                    <input type="hidden" name="action" value="search" />
                    <input type="hidden" name="firstRequest" value="1" />
                    <input type="hidden" name="searchindex" value="solr" />
                    <div class="fieldset">
                        <input class="pageHeader--search-input" id="search" name="query" type="text" value="" placeholder="Search" aria-label="search" />
                        <button class="searchButton btn" value="" name="search" type="submit" aria-label="search"></button>
                    </div>
                </form>
            </div>
            </div>
                                    
        <!-- hearst/home/HNavigation.tpl -->
<!-- hearst/home/navigation.tpl -->
         <!-- hearst/common/siteNavigation.tpl -->
<nav id="navigation" class="navigation"><div class="navigation--wrapper lock"><div class="navigation--menu"><ul class="hidden-sm hidden-md hidden-lg hidden-xl"><li class="single" data-length="1" data-index="1"><a href="/puzzles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="6062" data-hdn-analytics="visit|Puzzles|navigation-ard|1">Puzzles</a></li><li class="parent topLevel" data-length="6" data-index="0"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4941" data-hdn-analytics="visit|home|navigation-ard|2">home</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 132px"><li class="child"><a  href="https://link.milfordmirror.com/join/signup-mm" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5806" data-hdn-analytics="visit|home-Sign Up for Newsletters|navigation-ard|1">Sign Up for Newsletters</a></li><li class="child"><a  href="https://hearstmediact.newsbank.com/home" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4949" data-hdn-analytics="visit|home-Print Archives|navigation-ard|2">Print Archives</a></li><li class="child"><a  href="https://subscription.hearstmediact.com/checkout/693/1637?siteid=CT_MM&origin=hamburger&ipid=wcm" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4952" data-hdn-analytics="visit|home-Subscribe|navigation-ard|3">Subscribe</a></li><li class="child"><a  href="/news-submission-guidelines/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4944" data-hdn-analytics="visit|home-Submission Guidelines|navigation-ard|4">Submission Guidelines</a></li><li class="child"><a  href="/submissions/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4987" data-hdn-analytics="visit|home-Submissions|navigation-ard|5">Submissions</a></li></ul></li><li class="parent topLevel" data-length="9" data-index="2"><span role="heading" aria-level="2"><a  href="/news/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4997" data-hdn-analytics="visit|News|navigation-ard|3">News</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 176px"><li class="child"><a  href="/politics-elections/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4990" data-hdn-analytics="visit|News-Politics & Elections|navigation-ard|1">Politics & Elections</a></li><li class="child"><a  href="/news/town-government/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4991" data-hdn-analytics="visit|News-Town Government|navigation-ard|2">Town Government</a></li><li class="child"><a  href="/news/community/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4992" data-hdn-analytics="visit|News-Community|navigation-ard|3">Community</a></li><li class="child"><a  href="/news/education/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4994" data-hdn-analytics="visit|News-Education|navigation-ard|4">Education</a></li><li class="child"><a  href="/news/police-fire/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4995" data-hdn-analytics="visit|News-Police & Fire|navigation-ard|5">Police & Fire</a></li><li class="child"><a  href="/news/connecticut/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4998" data-hdn-analytics="visit|News-Connecticut|navigation-ard|6">Connecticut</a></li><li class="child"><a  href="/cannabis/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="6085" data-hdn-analytics="visit|News-Cannabis|navigation-ard|7">Cannabis</a></li><li class="child"><a  href="/opinion/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5812" data-hdn-analytics="visit|News-Opinion|navigation-ard|8">Opinion</a></li></ul></li><li class="single" data-length="1" data-index="3"><a href="/business/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4977" data-hdn-analytics="visit|Business|navigation-ard|4">Business</a></li><li class="single" data-length="1" data-index="4"><a href="https://www.legacy.com/obituaries/milfordmirror/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4979" data-hdn-analytics="visit|Obituaries|navigation-ard|5">Obituaries</a></li><li class="parent topLevel" data-length="3" data-index="5"><span role="heading" aria-level="2"><a  href="/sports/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4986" data-hdn-analytics="visit|Sports|navigation-ard|6">Sports</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/uconn/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5833" data-hdn-analytics="visit|Sports-UConn|navigation-ard|1">UConn</a></li><li class="child"><a  href="/sports/high-school-sports/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4985" data-hdn-analytics="visit|Sports-High School Sports|navigation-ard|2">High School Sports</a></li></ul></li><li class="parent topLevel" data-length="3" data-index="6"><span role="heading" aria-level="2"><a  href="/living/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5799" data-hdn-analytics="visit|Living|navigation-ard|7">Living</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/food/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5800" data-hdn-analytics="visit|Living-Food|navigation-ard|1">Food</a></li><li class="child"><a  href="/homegarden/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="5354" data-hdn-analytics="visit|Living-Home and Garden|navigation-ard|2">Home and Garden</a></li></ul></li><li class="single" data-length="1" data-index="7"><a href="/entertainment/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4996" data-hdn-analytics="visit|Entertainment|navigation-ard|8">Entertainment</a></li><li class="parent topLevel" data-length="6" data-index="8"><span role="heading" aria-level="2"><a  href="/faq/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="4948" data-hdn-analytics="visit|Help|navigation-ard|9">Help</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 132px"><li class="child"><a  href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CMM" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4947" data-hdn-analytics="visit|Help-Delivery Problems|navigation-ard|1">Delivery Problems</a></li><li class="child"><a  href="/about-us/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4945" data-hdn-analytics="visit|Help-About Us|navigation-ard|2">About Us</a></li><li class="child"><a  href="/contact/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4946" data-hdn-analytics="visit|Help-Contact Us|navigation-ard|3">Contact Us</a></li><li class="child"><a  href="/privacy/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4943" data-hdn-analytics="visit|Help-Privacy Notice|navigation-ard|4">Privacy Notice</a></li><li class="child"><a  href="/tos/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="4942" data-hdn-analytics="visit|Help-Terms of Use|navigation-ard|5">Terms of Use</a></li></ul></li><li class="single" data-length="1" data-index="9"><a href="/shopping/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="6110" data-hdn-analytics="visit|Shopping|navigation-ard|10">Shopping</a></li><li class="parent topLevel" data-length="2" data-index="10"><span role="heading" aria-level="2"><a  href="/sponsoredarticles/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5716" data-hdn-analytics="visit|Advertising Features|navigation-ard|11">Advertising Features</a><span class="toggle navigation--item-glyph" aria-expanded="false" tabindex="0" aria-label="navigation--subMenu"></span></a></span><ul class="navigation--subMenu" id="navigation--subMenu" data-collapsed="true" style="--n: 44px"><li class="child"><a  href="/events-calendar/" class="navigation--item navigation--subMenu-item hdn-analytics" data-naveid="6007" data-hdn-analytics="visit|Advertising Features-Events|navigation-ard|1">Events</a></li></ul></li><li class="single" data-length="1" data-index="11"><a href="http://connecticut.ipublishmarketplace.com/connecticut-marketplace/" class="navigation--item navigation--menu-item hdn-analytics" data-naveid="5002" data-hdn-analytics="visit|Classifieds|navigation-ard|1">Classifieds</a></li></ul></div></div><span class="rule"></span><div id="navToggle__page" class="navTogglePage"></div></nav>
<!-- e hearst/common/siteNavigation.tpl -->
<!-- e hearst/home/navigation.tpl --> <!-- e hearst/home/HNavigation.tpl -->    </header>

<!-- e hearst/common/siteBranding.tpl --> <main><section id="topZone" class="zone topZone"><!-- src/business/widgets/hearst/collection/widget.tpl -->

    <div class="hide-rss-link hdnce-e hdnce-collection-111519-dynamic_ribbon_articles"><!-- hearst/collections/dynamic_ribbon_articles.tpl -->
<!-- collection.dynamic_ribbon_articles.111519 -->
    <!-- design/collection/dynamic_ribbon_articles/single_zone.tpl -->
                                                                                                                                                <div class="articleRibbon" aria-label="carousel" role="region" data-component="collection" data-type="ribbon" data-collection-id="111519" data-collection-title="D- MM Article Ribbon Sports" data-type="list">
        <button class="articleRibbon--nav-btn articleRibbon--nav-prev fade" data-delta="-1" aria-label="Previous"></button>
        <div class="articleRibbon--wrapper">
            <ul class="articleRibbon--list">
                <div class="scrollSpacer"></div>
                                <div class="articleRibbon--list-wrapper" style="flex: 1 0 2200px;">
                    <span class="articleRibbon--list-title" role="heading" aria-level="2"><span class="articleRibbon--list-label"><!-- widgets/hearst/moduleHeader/widget.tpl -->
                                            <h2 role="heading" aria-level="2">Recommended</h2>
                        <!-- e widgets/hearst/moduleHeader/widget.tpl --></span></span>                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php" data-hdn-analytics="visit-from-img|article-17310688|-111519|1">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio1x1_100.jpg" alt="Members of the Milford Little League softball team celebrate after defeating Wallingford 9-4 Saturday for the program's fourth-straight state championship. Milford will represent Connecticut in the Little League World Series New England Regional at the A. Bartlett Giamatti Little League Leadership Training Center in Bristol. Milford opens play against Rhode Island Saturday at 4 p.m. on ESPN+.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php" data-hdn-analytics="visit|article-17310688|-111519|1" data-epe-inst="s:0;t:75" data-epe-title="1">Milford Little League softball wins 4th straight state title</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php" data-hdn-analytics="visit-from-img|article-17207808|-111519|2">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio1x1_100.jpg" alt="Lauren Vitti, Kelly Jones, Amanda Umbricht and Carys Cook broke the school record in the 4x800 at the SCC Championships.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php" data-hdn-analytics="visit|article-17207808|-111519|2" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton seventh at SCC track, relay sets record</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php" data-hdn-analytics="visit-from-img|article-17181447|-111519|3">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio1x1_100.jpg" alt="Katherine Baisley, Bria Colangelo, Emma Hoffman, Lauren Vitti, Katerina Koutouvides, Carys Cook and Kelly Jones medaled for Lauralton Hall at the SCC East Sectional meet.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php" data-hdn-analytics="visit|article-17181447|-111519|3" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton fifth at SCC East Sectional meet</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php" data-hdn-analytics="visit-from-img|article-17176456|-111519|4">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio1x1_100.jpg" alt="Foran improved to 9-8 with its win against previously unbeaten Amity.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php" data-hdn-analytics="visit|article-17176456|-111519|4" data-epe-inst="s:0;t:75" data-epe-title="1">HS update: Foran baseball upends No. 1 Amity</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php" data-hdn-analytics="visit-from-img|article-17172989|-111519|5">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio1x1_100.jpg" alt="Law’s Mike Merchant is safe at the plate as Hand catcher Connor Powell tags him too late.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php" data-hdn-analytics="visit|article-17172989|-111519|5" data-epe-inst="s:0;t:75" data-epe-title="1">Law edges Hand in high-scoring SCC tilt</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php" data-hdn-analytics="visit-from-img|article-17172988|-111519|6">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio1x1_100.jpg" alt="Lucia Pino is closing in on becoming the career wins leader at Law before going to Bryant University.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php" data-hdn-analytics="visit|article-17172988|-111519|6" data-epe-inst="s:0;t:75" data-epe-title="1">Lucia Pino closing in on Law record for wins</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php" data-hdn-analytics="visit-from-img|article-17170770|-111519|7">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio1x1_100.jpg" alt="Lauralton Hall's track team celebrates winning SCC Housatonic Division championship.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php" data-hdn-analytics="visit|article-17170770|-111519|7" data-epe-inst="s:0;t:75" data-epe-title="1">Lauralton track wins Housatonic Division</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php" data-hdn-analytics="visit-from-img|article-17162949|-111519|8">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio1x1_100.jpg" alt="Arezoo Ghazagh, Quincy Ercanbrack and Katharine Harrison captain the Foran girls track team.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php" data-hdn-analytics="visit|article-17162949|-111519|8" data-epe-inst="s:0;t:75" data-epe-title="1">Foran aided by newcomers, strong leadership</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php" data-hdn-analytics="visit-from-img|article-17147665|-111519|9">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio1x1_100.jpg" alt="McKenna Sharpe, Sydney Simpson, McKenzie Powers, Shelby Green and Lauren Davis captain Law girls track team.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php" data-hdn-analytics="visit|article-17147665|-111519|9" data-epe-inst="s:0;t:75" data-epe-title="1">Law track making its mark in early going of season</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                                                    <!-- hearst/collections/dynamic_ribbon_articles_body.tpl -->
<li class="articleRibbon--list-item">
            <div class="articleRibbon--item-img">
            <a class="hdn-analytics "  href="/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php" data-hdn-analytics="visit-from-img|article-17128086|-111519|10">
                <picture>
                    <source srcset="https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio1x1_100.jpg 1x, https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio1x1_200.jpg 2x" media="(min-width: 48rem)">
                    <img src="https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio1x1_100.jpg" alt="Foran and Jonathan Law catchers and captains Kendall LaMorte and Nicolina Salanto have high hopes for their softball teams.">
                </picture>
            </a>
        </div>
        <a class="articleRibbon--item-headline hdn-analytics " role="heading" aria-level="3"  href="/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php" data-hdn-analytics="visit|article-17128086|-111519|10" data-epe-inst="s:0;t:75" data-epe-title="1">Foran, Law aiming to further success this postseason</a></li>
<!-- e hearst/collections/dynamic_ribbon_articles_body.tpl -->                                    </div>
                <div class="scrollSpacer"></div>
            </ul>
        </div>
        <button class="articleRibbon--nav-btn articleRibbon--nav-next fade show " data-delta="1" aria-label="Next"></button>
    </div>
        <script type="text/javascript">
        var nextStory = [
                                                            {
                    "id": 17310688,
                    "headline": "Milford Little League softball wins 4th straight...",
                    "url": "/sports/article/Milford-Little-League-softball-wins-4th-straight-17310688.php",
                    "image": "https://s.hdnux.com/photos/01/26/50/44/22710538/4/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17207808,
                    "headline": "Lauralton seventh at SCC track, relay sets record",
                    "url": "/sports/article/Lauralton-seventh-at-SCC-track-relay-sets-record-17207808.php",
                    "image": "https://s.hdnux.com/photos/01/25/76/70/22539802/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17181447,
                    "headline": "Lauralton fifth at SCC East Sectional meet",
                    "url": "/sports/article/Lauralton-fifth-at-SCC-East-Sectional-meet-17181447.php",
                    "image": "https://s.hdnux.com/photos/01/25/63/07/22491618/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17176456,
                    "headline": "HS update: Foran baseball upends No. 1 Amity",
                    "url": "/sports/article/HS-update-Foran-baseball-upends-No-1-Amity-17176456.php",
                    "image": "https://s.hdnux.com/photos/01/25/61/15/22483835/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17172989,
                    "headline": "Law edges Hand in high-scoring SCC tilt",
                    "url": "/sports/article/Law-edges-Hand-in-high-scoring-SCC-tilt-17172989.php",
                    "image": "https://s.hdnux.com/photos/01/25/57/37/22476761/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17172988,
                    "headline": "Lucia Pino closing in on Law record for wins",
                    "url": "/sports/article/Lucia-Pino-closing-in-on-Law-record-for-wins-17172988.php",
                    "image": "https://s.hdnux.com/photos/01/25/57/37/22476760/8/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17170770,
                    "headline": "Lauralton track wins Housatonic Division",
                    "url": "/sports/article/Lauralton-track-wins-Housatonic-Division-17170770.php",
                    "image": "https://s.hdnux.com/photos/01/25/56/54/22473489/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17162949,
                    "headline": "Foran aided by newcomers, strong leadership",
                    "url": "/sports/article/Foran-aided-by-newcomers-strong-leadership-17162949.php",
                    "image": "https://s.hdnux.com/photos/01/25/53/53/22461156/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17147665,
                    "headline": "Law track making its mark in early going of season",
                    "url": "/sports/article/Law-track-making-its-mark-in-early-going-of-season-17147665.php",
                    "image": "https://s.hdnux.com/photos/01/25/45/66/22437278/5/ratio3x2_100.jpg"
                },                                                            {
                    "id": 17128086,
                    "headline": "Foran, Law aiming to further success this postseason",
                    "url": "/sports/article/Foran-Law-aiming-to-further-success-this-17128086.php",
                    "image": "https://s.hdnux.com/photos/01/25/36/52/22407860/5/ratio3x2_100.jpg"
                }                    ];
    </script>
<!-- e design/collection/dynamic_ribbon_articles/single_zone.tpl --><!-- e hearst/collections/dynamic_ribbon_articles.tpl -->
</div><!-- e src/business/widgets/hearst/collection/widget.tpl --></section> <div class="belowMastheadWrapper"></div> <section id="content" class="article" data-type="dtc"><!-- hearst/article/articleHeader.tpl -->
            
    <header class="article--header articleHeader"><div class="articleHeader--breadcrumbs"><a class="articleHeader--breadcrumbs-item" href="https://www.milfordmirror.com/sports/">Sports</a></div><h1 class="articleHeader--headline" aria-labelledby="">2022 Green Bay Packers Roster</h1><div class="articleHeader--subHead"><div class="articleHeader--byline"></div><div class="articleHeader--timestamp"><time class="articleHeader--timestamp-pubdate " datetime="2022-11-28 15:12:38">Nov. 28, 2022</time></div><div class="articleHeader--shareTools"><!-- hearst/common/shareTools.tpl -->
    
<div class="share-list comments">
    <a class="share-facebook" data-shareNetwork="facebook">Facebook</a>
    <a class="share-twitter" data-shareNetwork="twitter">Twitter</a>
    <a class="share-email" data-shareNetwork="email">Email</a>
            <div class="pipe"></div>
                    
                            <a class="share-comments" data-shareNetwork="comments" href="https://www.milfordmirror.com/sports/articleComments/2022-Green-Bay-Packers-Roster-17615441.php" onclick="document.location.href = document.location.href.replace('/article/','/articleComments/').replace('/slideshow/','/slideshowComments/'); return false;">Comments</a>
        <span class="share-count"></span>
    </div>
<!-- e hearst/common/shareTools.tpl --></div></div></header>
<!-- e hearst/article/articleHeader.tpl --><!-- hearst/common/chapterNavigation.tpl -->
        <!-- e hearst/common/chapterNavigation.tpl --><article class="article--content"><section id="articleTop" class="article--content-zone top"></section>            <table xmlns="http://www.w3.org/2005/Atom" xmlns:apcm="http://ap.org/schemas/03/2005/apcm" xmlns:apnm="http://ap.org/schemas/03/2005/apnm" xmlns:o="http://w3.org/ns/odrl/2/">
<thead><tr>
<th class="headline-col-jersey-number">No.</th>
<th class="headline-col-name">Player</th>
<th class="headline-col-position">Pos</th>
<th class="headline-col-height">Ht</th>
<th class="headline-col-weight">Wt</th>
<th class="headline-col-born">Born</th>
<th class="headline-col-experience">Exp</th>
<th class="headline-col-college">College</th>
</tr></thead>
<tbody>
<tr>
<td class="col-jersey-number">2</td>
<td class="col-name">Mason Crosby</td>
<td class="col-position">K</td>
<td class="col-height">6-1</td>
<td class="col-weight">207</td>
<td class="col-born">09-03-1984</td>
<td class="col-experience">15</td>
<td class="col-college">Colorado</td>
</tr>
<tr>
<td class="col-jersey-number">6</td>
<td class="col-name">Dallin Leavitt</td>
<td class="col-position">SAF</td>
<td class="col-height">5-10</td>
<td class="col-weight">195</td>
<td class="col-born">08-08-1994</td>
<td class="col-experience">4</td>
<td class="col-college">Utah State</td>
</tr>
<tr>
<td class="col-jersey-number">7</td>
<td class="col-name">Quay Walker</td>
<td class="col-position">LB</td>
<td class="col-height">6-4</td>
<td class="col-weight">241</td>
<td class="col-born">05-08-2000</td>
<td class="col-experience">0</td>
<td class="col-college">Georgia</td>
</tr>
<tr>
<td class="col-jersey-number">9</td>
<td class="col-name">Christian Watson</td>
<td class="col-position">WR</td>
<td class="col-height">6-5</td>
<td class="col-weight">208</td>
<td class="col-born">05-12-1999</td>
<td class="col-experience">0</td>
<td class="col-college">North Dakota State</td>
</tr>
<tr>
<td class="col-jersey-number">10</td>
<td class="col-name">Jordan Love</td>
<td class="col-position">QB</td>
<td class="col-height">6-4</td>
<td class="col-weight">219</td>
<td class="col-born">11-02-1998</td>
<td class="col-experience">2</td>
<td class="col-college">Utah State</td>
</tr>
<tr>
<td class="col-jersey-number">11</td>
<td class="col-name">Sammy Watkins</td>
<td class="col-position">WR</td>
<td class="col-height">6-1</td>
<td class="col-weight">211</td>
<td class="col-born">06-14-1993</td>
<td class="col-experience">8</td>
<td class="col-college">Clemson</td>
</tr>
<tr>
<td class="col-jersey-number">12</td>
<td class="col-name">Aaron Rodgers</td>
<td class="col-position">QB</td>
<td class="col-height">6-2</td>
<td class="col-weight">225</td>
<td class="col-born">12-02-1983</td>
<td class="col-experience">17</td>
<td class="col-college">California</td>
</tr>
<tr>
<td class="col-jersey-number">13</td>
<td class="col-name">Allen Lazard</td>
<td class="col-position">WR</td>
<td class="col-height">6-5</td>
<td class="col-weight">227</td>
<td class="col-born">12-11-1995</td>
<td class="col-experience">4</td>
<td class="col-college">Iowa State</td>
</tr>
<tr>
<td class="col-jersey-number">16</td>
<td class="col-name">Pat O'Donnell</td>
<td class="col-position">P</td>
<td class="col-height">6-4</td>
<td class="col-weight">220</td>
<td class="col-born">02-22-1991</td>
<td class="col-experience">8</td>
<td class="col-college">Miami (FL)</td>
</tr>
<tr>
<td class="col-jersey-number">17</td>
<td class="col-name">Ramiz Ahmed</td>
<td class="col-position">K</td>
<td class="col-height">5-11</td>
<td class="col-weight">193</td>
<td class="col-born">07-27-1995</td>
<td class="col-experience">2</td>
<td class="col-college">Nevada</td>
</tr>
<tr>
<td class="col-jersey-number">18</td>
<td class="col-name">Randall Cobb</td>
<td class="col-position">WR</td>
<td class="col-height">5-10</td>
<td class="col-weight">195</td>
<td class="col-born">08-22-1990</td>
<td class="col-experience">11</td>
<td class="col-college">Kentucky</td>
</tr>
<tr>
<td class="col-jersey-number">19</td>
<td class="col-name">Danny Etling</td>
<td class="col-position">QB</td>
<td class="col-height">6-3</td>
<td class="col-weight">222</td>
<td class="col-born">07-22-1994</td>
<td class="col-experience">4</td>
<td class="col-college">LSU</td>
</tr>
<tr>
<td class="col-jersey-number">20</td>
<td class="col-name">Rudy Ford</td>
<td class="col-position">SAF</td>
<td class="col-height">6-0</td>
<td class="col-weight">200</td>
<td class="col-born">11-01-1994</td>
<td class="col-experience">5</td>
<td class="col-college">Auburn</td>
</tr>
<tr>
<td class="col-jersey-number">21</td>
<td class="col-name">Eric Stokes</td>
<td class="col-position">CB</td>
<td class="col-height">6-0</td>
<td class="col-weight">194</td>
<td class="col-born">03-01-1999</td>
<td class="col-experience">1</td>
<td class="col-college">Georgia</td>
</tr>
<tr>
<td class="col-jersey-number">22</td>
<td class="col-name">Shemar Jean-Charles</td>
<td class="col-position">CB</td>
<td class="col-height">5-10</td>
<td class="col-weight">184</td>
<td class="col-born">06-20-1998</td>
<td class="col-experience">1</td>
<td class="col-college">Appalachian State</td>
</tr>
<tr>
<td class="col-jersey-number">23</td>
<td class="col-name">Jaire Alexander</td>
<td class="col-position">CB</td>
<td class="col-height">5-10</td>
<td class="col-weight">196</td>
<td class="col-born">02-09-1997</td>
<td class="col-experience">4</td>
<td class="col-college">Louisville</td>
</tr>
<tr>
<td class="col-jersey-number">24</td>
<td class="col-name">Tariq Carpenter</td>
<td class="col-position">SAF</td>
<td class="col-height">6-3</td>
<td class="col-weight">230</td>
<td class="col-born">12-28-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Georgia Tech</td>
</tr>
<tr>
<td class="col-jersey-number">25</td>
<td class="col-name">Keisean Nixon</td>
<td class="col-position">CB</td>
<td class="col-height">5-10</td>
<td class="col-weight">200</td>
<td class="col-born">06-22-1997</td>
<td class="col-experience">3</td>
<td class="col-college">South Carolina</td>
</tr>
<tr>
<td class="col-jersey-number">26</td>
<td class="col-name">Darnell Savage</td>
<td class="col-position">SAF</td>
<td class="col-height">5-11</td>
<td class="col-weight">198</td>
<td class="col-born">07-30-1997</td>
<td class="col-experience">3</td>
<td class="col-college">Maryland</td>
</tr>
<tr>
<td class="col-jersey-number">27</td>
<td class="col-name">Patrick Taylor</td>
<td class="col-position">RB</td>
<td class="col-height">6-2</td>
<td class="col-weight">217</td>
<td class="col-born">04-29-1998</td>
<td class="col-experience">2</td>
<td class="col-college">Memphis</td>
</tr>
<tr>
<td class="col-jersey-number">28</td>
<td class="col-name">AJ Dillon</td>
<td class="col-position">RB</td>
<td class="col-height">6-0</td>
<td class="col-weight">247</td>
<td class="col-born">05-02-1998</td>
<td class="col-experience">2</td>
<td class="col-college">Boston College</td>
</tr>
<tr>
<td class="col-jersey-number">29</td>
<td class="col-name">Rasul Douglas</td>
<td class="col-position">CB</td>
<td class="col-height">6-2</td>
<td class="col-weight">209</td>
<td class="col-born">08-29-1995</td>
<td class="col-experience">5</td>
<td class="col-college">West Virginia</td>
</tr>
<tr>
<td class="col-jersey-number">31</td>
<td class="col-name">Adrian Amos</td>
<td class="col-position">SAF</td>
<td class="col-height">6-0</td>
<td class="col-weight">214</td>
<td class="col-born">04-29-1993</td>
<td class="col-experience">7</td>
<td class="col-college">Penn State</td>
</tr>
<tr>
<td class="col-jersey-number">33</td>
<td class="col-name">Aaron Jones</td>
<td class="col-position">RB</td>
<td class="col-height">5-9</td>
<td class="col-weight">208</td>
<td class="col-born">12-02-1994</td>
<td class="col-experience">5</td>
<td class="col-college">UTEP</td>
</tr>
<tr>
<td class="col-jersey-number">34</td>
<td class="col-name">Micah Abernathy</td>
<td class="col-position">SAF</td>
<td class="col-height">6-0</td>
<td class="col-weight">195</td>
<td class="col-born">02-10-1997</td>
<td class="col-experience">3</td>
<td class="col-college">Tennessee</td>
</tr>
<tr>
<td class="col-jersey-number">35</td>
<td class="col-name">Corey Ballentine</td>
<td class="col-position">CB</td>
<td class="col-height">5-11</td>
<td class="col-weight">196</td>
<td class="col-born">04-13-1996</td>
<td class="col-experience">3</td>
<td class="col-college">Washburn</td>
</tr>
<tr>
<td class="col-jersey-number">38</td>
<td class="col-name">Innis Gaines</td>
<td class="col-position">SAF</td>
<td class="col-height">6-1</td>
<td class="col-weight">202</td>
<td class="col-born">08-29-1998</td>
<td class="col-experience">2</td>
<td class="col-college">TCU</td>
</tr>
<tr>
<td class="col-jersey-number">39</td>
<td class="col-name">Tyler Goodson</td>
<td class="col-position">RB</td>
<td class="col-height">5-9</td>
<td class="col-weight">197</td>
<td class="col-born">11-10-2000</td>
<td class="col-experience">0</td>
<td class="col-college">Iowa</td>
</tr>
<tr>
<td class="col-jersey-number">40</td>
<td class="col-name">Tipa Galeai</td>
<td class="col-position">LB</td>
<td class="col-height">6-5</td>
<td class="col-weight">229</td>
<td class="col-born">02-26-1997</td>
<td class="col-experience">2</td>
<td class="col-college">Utah State</td>
</tr>
<tr>
<td class="col-jersey-number">43</td>
<td class="col-name">Kiondre Thomas</td>
<td class="col-position">CB</td>
<td class="col-height">6-0</td>
<td class="col-weight">186</td>
<td class="col-born">02-07-1998</td>
<td class="col-experience">1</td>
<td class="col-college">Kansas State</td>
</tr>
<tr>
<td class="col-jersey-number">44</td>
<td class="col-name">Johnathan Abram</td>
<td class="col-position">SAF</td>
<td class="col-height">5-11</td>
<td class="col-weight">205</td>
<td class="col-born">10-25-1996</td>
<td class="col-experience">3</td>
<td class="col-college">Mississippi State</td>
</tr>
<tr>
<td class="col-jersey-number">45</td>
<td class="col-name">Eric Wilson</td>
<td class="col-position">LB</td>
<td class="col-height">6-1</td>
<td class="col-weight">230</td>
<td class="col-born">09-26-1994</td>
<td class="col-experience">5</td>
<td class="col-college">Cincinnati</td>
</tr>
<tr>
<td class="col-jersey-number">47</td>
<td class="col-name">Justin Hollins</td>
<td class="col-position">LB</td>
<td class="col-height">6-5</td>
<td class="col-weight">248</td>
<td class="col-born">01-15-1996</td>
<td class="col-experience">3</td>
<td class="col-college">Oregon</td>
</tr>
<tr>
<td class="col-jersey-number">48</td>
<td class="col-name">DQ Thomas</td>
<td class="col-position">LB</td>
<td class="col-height">6-2</td>
<td class="col-weight">216</td>
<td class="col-born">12-04-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Middle Tennessee</td>
</tr>
<tr>
<td class="col-jersey-number">50</td>
<td class="col-name">Zach Tom</td>
<td class="col-position">OL</td>
<td class="col-height">6-4</td>
<td class="col-weight">304</td>
<td class="col-born">03-26-1999</td>
<td class="col-experience">0</td>
<td class="col-college">Wake Forest</td>
</tr>
<tr>
<td class="col-jersey-number">51</td>
<td class="col-name">Krys Barnes</td>
<td class="col-position">LB</td>
<td class="col-height">6-2</td>
<td class="col-weight">229</td>
<td class="col-born">04-02-1998</td>
<td class="col-experience">2</td>
<td class="col-college">UCLA</td>
</tr>
<tr>
<td class="col-jersey-number">52</td>
<td class="col-name">Rashan Gary</td>
<td class="col-position">LB</td>
<td class="col-height">6-5</td>
<td class="col-weight">277</td>
<td class="col-born">12-03-1997</td>
<td class="col-experience">3</td>
<td class="col-college">Michigan</td>
</tr>
<tr>
<td class="col-jersey-number">53</td>
<td class="col-name">Jonathan Garvin</td>
<td class="col-position">LB</td>
<td class="col-height">6-4</td>
<td class="col-weight">257</td>
<td class="col-born">07-28-1999</td>
<td class="col-experience">2</td>
<td class="col-college">Miami (FL)</td>
</tr>
<tr>
<td class="col-jersey-number">54</td>
<td class="col-name">La'Darius Hamilton</td>
<td class="col-position">LB</td>
<td class="col-height">6-2</td>
<td class="col-weight">261</td>
<td class="col-born">01-18-1998</td>
<td class="col-experience">2</td>
<td class="col-college">North Texas</td>
</tr>
<tr>
<td class="col-jersey-number">55</td>
<td class="col-name">Kingsley Enagbare</td>
<td class="col-position">LB</td>
<td class="col-height">6-4</td>
<td class="col-weight">258</td>
<td class="col-born">01-18-2000</td>
<td class="col-experience">0</td>
<td class="col-college">South Carolina</td>
</tr>
<tr>
<td class="col-jersey-number">56</td>
<td class="col-name">Jack Coco</td>
<td class="col-position">LS</td>
<td class="col-height">6-2</td>
<td class="col-weight">248</td>
<td class="col-born">10-09-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Georgia Tech</td>
</tr>
<tr>
<td class="col-jersey-number">57</td>
<td class="col-name">Tim Ward</td>
<td class="col-position">LB</td>
<td class="col-height">6-6</td>
<td class="col-weight">255</td>
<td class="col-born">08-11-1997</td>
<td class="col-experience">3</td>
<td class="col-college">Old Dominion</td>
</tr>
<tr>
<td class="col-jersey-number">58</td>
<td class="col-name">Isaiah McDuffie</td>
<td class="col-position">LB</td>
<td class="col-height">6-1</td>
<td class="col-weight">227</td>
<td class="col-born">07-21-1999</td>
<td class="col-experience">1</td>
<td class="col-college">Boston College</td>
</tr>
<tr>
<td class="col-jersey-number">59</td>
<td class="col-name">De'Vondre Campbell</td>
<td class="col-position">LB</td>
<td class="col-height">6-3</td>
<td class="col-weight">232</td>
<td class="col-born">07-01-1993</td>
<td class="col-experience">6</td>
<td class="col-college">Minnesota</td>
</tr>
<tr>
<td class="col-jersey-number">63</td>
<td class="col-name">Rasheed Walker</td>
<td class="col-position">OL</td>
<td class="col-height">6-6</td>
<td class="col-weight">324</td>
<td class="col-born">02-13-2000</td>
<td class="col-experience">0</td>
<td class="col-college">Penn State</td>
</tr>
<tr>
<td class="col-jersey-number">67</td>
<td class="col-name">Jake Hanson</td>
<td class="col-position">C</td>
<td class="col-height">6-4</td>
<td class="col-weight">296</td>
<td class="col-born">04-29-1997</td>
<td class="col-experience">2</td>
<td class="col-college">Oregon</td>
</tr>
<tr>
<td class="col-jersey-number">69</td>
<td class="col-name">David Bakhtiari</td>
<td class="col-position">T</td>
<td class="col-height">6-4</td>
<td class="col-weight">310</td>
<td class="col-born">09-30-1991</td>
<td class="col-experience">9</td>
<td class="col-college">Colorado</td>
</tr>
<tr>
<td class="col-jersey-number">70</td>
<td class="col-name">Royce Newman</td>
<td class="col-position">OL</td>
<td class="col-height">6-5</td>
<td class="col-weight">310</td>
<td class="col-born">08-17-1997</td>
<td class="col-experience">1</td>
<td class="col-college">Ole Miss</td>
</tr>
<tr>
<td class="col-jersey-number">71</td>
<td class="col-name">Josh Myers</td>
<td class="col-position">OL</td>
<td class="col-height">6-5</td>
<td class="col-weight">310</td>
<td class="col-born">07-16-1998</td>
<td class="col-experience">1</td>
<td class="col-college">Ohio State</td>
</tr>
<tr>
<td class="col-jersey-number">72</td>
<td class="col-name">Caleb Jones</td>
<td class="col-position">T</td>
<td class="col-height">6-9</td>
<td class="col-weight">370</td>
<td class="col-born">02-10-1999</td>
<td class="col-experience">0</td>
<td class="col-college">Indiana</td>
</tr>
<tr>
<td class="col-jersey-number">73</td>
<td class="col-name">Yoshuah Nijman</td>
<td class="col-position">T</td>
<td class="col-height">6-7</td>
<td class="col-weight">314</td>
<td class="col-born">01-02-1996</td>
<td class="col-experience">3</td>
<td class="col-college">Virginia Tech</td>
</tr>
<tr>
<td class="col-jersey-number">74</td>
<td class="col-name">Elgton Jenkins</td>
<td class="col-position">G</td>
<td class="col-height">6-5</td>
<td class="col-weight">311</td>
<td class="col-born">12-26-1995</td>
<td class="col-experience">3</td>
<td class="col-college">Mississippi State</td>
</tr>
<tr>
<td class="col-jersey-number">75</td>
<td class="col-name">Sean Rhyan</td>
<td class="col-position">T</td>
<td class="col-height">6-5</td>
<td class="col-weight">321</td>
<td class="col-born">09-15-2000</td>
<td class="col-experience">0</td>
<td class="col-college">UCLA</td>
</tr>
<tr>
<td class="col-jersey-number">76</td>
<td class="col-name">Jon Runyan</td>
<td class="col-position">G</td>
<td class="col-height">6-4</td>
<td class="col-weight">307</td>
<td class="col-born">08-08-1997</td>
<td class="col-experience">2</td>
<td class="col-college">Michigan</td>
</tr>
<tr>
<td class="col-jersey-number">78</td>
<td class="col-name">Luke Tenuta</td>
<td class="col-position">T</td>
<td class="col-height">6-8</td>
<td class="col-weight">319</td>
<td class="col-born">09-01-1999</td>
<td class="col-experience">0</td>
<td class="col-college">Virginia Tech</td>
</tr>
<tr>
<td class="col-jersey-number">80</td>
<td class="col-name">Dede Westbrook</td>
<td class="col-position">WR</td>
<td class="col-height">6-0</td>
<td class="col-weight">178</td>
<td class="col-born">11-21-1993</td>
<td class="col-experience">5</td>
<td class="col-college">Oklahoma</td>
</tr>
<tr>
<td class="col-jersey-number">81</td>
<td class="col-name">Josiah Deguara</td>
<td class="col-position">TE</td>
<td class="col-height">6-2</td>
<td class="col-weight">238</td>
<td class="col-born">02-14-1997</td>
<td class="col-experience">2</td>
<td class="col-college">Cincinnati</td>
</tr>
<tr>
<td class="col-jersey-number">83</td>
<td class="col-name">Samori Toure</td>
<td class="col-position">WR</td>
<td class="col-height">6-3</td>
<td class="col-weight">191</td>
<td class="col-born">03-24-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Nebraska</td>
</tr>
<tr>
<td class="col-jersey-number">84</td>
<td class="col-name">Tyler Davis</td>
<td class="col-position">TE</td>
<td class="col-height">6-4</td>
<td class="col-weight">252</td>
<td class="col-born">04-02-1997</td>
<td class="col-experience">2</td>
<td class="col-college">Georgia Tech</td>
</tr>
<tr>
<td class="col-jersey-number">85</td>
<td class="col-name">Robert Tonyan</td>
<td class="col-position">TE</td>
<td class="col-height">6-5</td>
<td class="col-weight">240</td>
<td class="col-born">04-30-1994</td>
<td class="col-experience">5</td>
<td class="col-college">Indiana State</td>
</tr>
<tr>
<td class="col-jersey-number">86</td>
<td class="col-name">Travis Fulgham</td>
<td class="col-position">WR</td>
<td class="col-height">6-2</td>
<td class="col-weight">211</td>
<td class="col-born">09-13-1995</td>
<td class="col-experience">3</td>
<td class="col-college">Old Dominion</td>
</tr>
<tr>
<td class="col-jersey-number">87</td>
<td class="col-name">Romeo Doubs</td>
<td class="col-position">WR</td>
<td class="col-height">6-2</td>
<td class="col-weight">204</td>
<td class="col-born">04-13-2000</td>
<td class="col-experience">0</td>
<td class="col-college">Nevada</td>
</tr>
<tr>
<td class="col-jersey-number">88</td>
<td class="col-name">Juwann Winfree</td>
<td class="col-position">WR</td>
<td class="col-height">6-1</td>
<td class="col-weight">210</td>
<td class="col-born">09-04-1996</td>
<td class="col-experience">3</td>
<td class="col-college">Colorado</td>
</tr>
<tr>
<td class="col-jersey-number">89</td>
<td class="col-name">Marcedes Lewis</td>
<td class="col-position">TE</td>
<td class="col-height">6-6</td>
<td class="col-weight">267</td>
<td class="col-born">05-19-1984</td>
<td class="col-experience">16</td>
<td class="col-college">UCLA</td>
</tr>
<tr>
<td class="col-jersey-number">90</td>
<td class="col-name">Jarran Reed</td>
<td class="col-position">DT</td>
<td class="col-height">6-3</td>
<td class="col-weight">307</td>
<td class="col-born">12-16-1992</td>
<td class="col-experience">6</td>
<td class="col-college">Alabama</td>
</tr>
<tr>
<td class="col-jersey-number">91</td>
<td class="col-name">Preston Smith</td>
<td class="col-position">LB</td>
<td class="col-height">6-5</td>
<td class="col-weight">265</td>
<td class="col-born">11-17-1992</td>
<td class="col-experience">7</td>
<td class="col-college">Mississippi State</td>
</tr>
<tr>
<td class="col-jersey-number">93</td>
<td class="col-name">T.J. Slaton</td>
<td class="col-position">DT</td>
<td class="col-height">6-4</td>
<td class="col-weight">330</td>
<td class="col-born">10-03-1997</td>
<td class="col-experience">1</td>
<td class="col-college">Florida</td>
</tr>
<tr>
<td class="col-jersey-number">94</td>
<td class="col-name">Dean Lowry</td>
<td class="col-position">DE</td>
<td class="col-height">6-6</td>
<td class="col-weight">296</td>
<td class="col-born">06-09-1994</td>
<td class="col-experience">6</td>
<td class="col-college">Northwestern</td>
</tr>
<tr>
<td class="col-jersey-number">95</td>
<td class="col-name">Devonte Wyatt</td>
<td class="col-position">DT</td>
<td class="col-height">6-3</td>
<td class="col-weight">304</td>
<td class="col-born">03-31-1998</td>
<td class="col-experience">0</td>
<td class="col-college">Georgia</td>
</tr>
<tr>
<td class="col-jersey-number">96</td>
<td class="col-name">Jack Heflin</td>
<td class="col-position">DT</td>
<td class="col-height">6-3</td>
<td class="col-weight">304</td>
<td class="col-born">03-08-1998</td>
<td class="col-experience">1</td>
<td class="col-college">Iowa</td>
</tr>
<tr>
<td class="col-jersey-number">97</td>
<td class="col-name">Kenny Clark</td>
<td class="col-position">DL</td>
<td class="col-height">6-3</td>
<td class="col-weight">314</td>
<td class="col-born">10-04-1995</td>
<td class="col-experience">6</td>
<td class="col-college">UCLA</td>
</tr>
<tr>
<td class="col-jersey-number">98</td>
<td class="col-name">Chris Slayton</td>
<td class="col-position">DT</td>
<td class="col-height">6-4</td>
<td class="col-weight">307</td>
<td class="col-born">08-01-1996</td>
<td class="col-experience">3</td>
<td class="col-college">Syracuse</td>
</tr>
<tr>
<td class="col-jersey-number">99</td>
<td class="col-name">Jonathan Ford</td>
<td class="col-position">DL</td>
<td class="col-height">6-5</td>
<td class="col-weight">338</td>
<td class="col-born">09-29-1999</td>
<td class="col-experience">0</td>
<td class="col-college">Miami (FL)</td>
</tr>
</tbody>
</table>
        <!-- hearst/article/content/relatedStories.tpl -->
    <section class="relatedStories" data-progressive="true"><div class="relatedStories--title articleModule"><div class="articleModule--title h4" role="heading" aria-level="2">More for you</div></div><ul class="relatedStories--list" data-total="2"><li class="relatedStories--item" data-number="1"><div class="slide" data-number="1"><a href="https://www.milfordmirror.com/sports/uconn-womens-basketball/article/UConn-women-s-basketball-s-Aaliyah-Edwards-MVP-17614355.php" class="hdn-analytics"data-hdn-analytics="related_stories|article-17614355|article-17615441|1"><div class="slide--headline"><div class="slide--headline-title">UConn's Aaliyah Edwards has MVP performance in Portland</div></div><div class="slide--image fullBleed"><picture class="deferred threeTwo" data-progressive="true" data-component="picture"><source data-srcset="https://s.hdnux.com/photos/01/30/42/71/23211618/3/ratio3x2_350.jpg 1x, https://s.hdnux.com/photos/01/30/42/71/23211618/3/ratio3x2_700.jpg 2x"><img data-src="https://s.hdnux.com/photos/01/30/42/71/23211618/3/ratio3x2_700.jpg" alt=""></picture></div></a></div></li><li class="relatedStories--item noImage" data-number="2"><div class="slide noImage" data-number="2"><a href="https://www.milfordmirror.com/sports/uconn-mens-basketball/article/UConn-Iowa-State-Phil-Knight-Invitational-17614425.php" class="hdn-analytics"data-hdn-analytics="related_stories|article-17614425|article-17615441|2"><div class="slide--headline"><div class="slide--headline-title">UConn men top Iowa State to win Phil Knight Invitational</div></div><span class="relatedStories--item-default-photo"><img class="relatedStories--item-default-photo-image" role="img" src="/img/default_3x2.jpg" alt=""/></span></a></div></li></ul></section>
     <!-- e hearst/article/content/relatedStories.tpl -->    <!-- hearst/article/content/embed.tpl -->
<section class="article--content-embed inline-iframe" data-eid="item-96892">
                        <script id="hst-exco-player-code">

  // Set article player ID as default
  var playerId = '93066811-0534-4a7d-848c-7844b68ad1e1';

  if (!HDN || !HDN.dataLayer || !HDN.dataLayer.content || HDN.dataLayer.content.objectType !== 'article') {
    // This is not an article, set non-article player ID
    playerId = 'b9b6399a-2338-4244-bd61-744cfa75ecac';
  }

  (function (d, id) {

    var div = document.createElement('div');
    div.id = id;
    div.classList.add('hst-exco-player');
    var script = document.getElementById('hst-exco-player-code');
    script.parentElement.insertBefore(div, script);

    var js, fjs = d.getElementsByTagName('script')[0];
    js = d.createElement('script');
    js.id = 'exco';
    js.dataset.src = 'https://player.ex.co/player/' + id;
    fjs.parentNode.insertBefore(js, fjs);
  }(document, playerId));
</script>

            </section>
<!-- e hearst/article/content/embed.tpl --><section id="articleBottom" class="article--content-zone bottom"></section></article><!-- hearst/article/articleAside.tpl -->
<aside class="article--aside slideshow--aside">
    <aside id="zoneD" class="zone">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85203 -->
    <div class="hst-freeform hdnce-e hdnce-item-85203">
                <script type="text/javascript" id="taboola-right-rail-script-id">
(function () {
    window._taboolaRRI = window._taboolaRRI || 0;
    window._taboolaRRI++;
    var e = document.documentElement;
    var g = document.getElementsByTagName('body')[0];
    var w = window.innerWidth||e.clientWidth||g.clientWidth;
    if ( (w >= 768 && window._taboolaRRI === 1) || (w < 768 && window._taboolaRRI === 2) ){
        var c = 'taboola-right-rail-thumbnails';
        var p = 'Right Rail Thumbnails';
        var m = 'rr';
        try {
            if (window._taboolaNetworkMode) {
                c = c + '---redesign';
                p = p + ' - Redesign';
                if (HDN.dataLayer.content.objectType  === 'article') {
                    m = 'f';
                if (HDN.dataLayer.presentation.infiniteScrollEnabled && (window.infiniteScroll && window.infiniteScroll.length > 0) && HDN.dataLayer.content.objectId && window.Article.isSensitive !== true && (Object.hasOwnProperty.call(HDN, 'activeABTest') && HDN.activeABTest === 'ENG9746')) {
                    p = 'Right Rail Thumbnails';
                    m = '1x8-rr';
                }
                }
            }
        } catch (e) {}
        var d = document.createElement('div');
        d.id = c;
        var s = document.getElementById('taboola-right-rail-script-id');
        s.parentNode.insertBefore(d, s);
        window._taboola = window._taboola || [];
        _taboola.push({
            mode: 'thumbnails-' + m,
            container: c,
            placement: p,
            target_type: 'mix'
        });
    }
})();
</script>
    </div>
            </aside>
    <aside id="zoneC" class="zone">
    
<!-- hearst/home/mostPopular.tpl -->

    <div class="mostPopular">
        <h2 class="collectionHeader" role="heading" aria-level="2">Most Popular</h2>
                                                <ol class="mostPopular--list">
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Bin-100-Restaurant-in-business-for-15-years-17610550.php" title="Milford restaurant marks 15 years in a spot picked for sibling proximity" data-hdn-analytics="visit|article-17610550|most_popular|0">Milford restaurant marks 15 years in a spot picked for sibling proximity</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/politics/article/As-CT-lawmakers-consider-more-funding-for-heating-17610315.php" title="Number of CT families seeking fuel assistance 'just unbelievable'" data-hdn-analytics="visit|article-17610315|most_popular|1">Number of CT families seeking fuel assistance 'just unbelievable'</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/politics/article/ct-lawmakers-set-to-extend-gas-tax-holiday-17610013.php" title="From the gas tax to 'hero' pay, here's what to know about Monday's special legislative session in CT" data-hdn-analytics="visit|article-17610013|most_popular|2">From the gas tax to 'hero' pay, here's what to know about Monday's special legislative session in CT</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Interstate-95-closed-West-Haven-Milford-crashes-17611955.php" title="Two killed in overnight crashes on Interstate 95, state police say." data-hdn-analytics="visit|article-17611955|most_popular|3">Two killed in overnight crashes on Interstate 95, state police say.</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/shopping/article/shark-stick-vacuum-cyber-monday-17611277.php" title="The Shark Vertex Cordless Stick Vacuum is a whopping $150 off at Walmart" data-hdn-analytics="visit|article-17611277|most_popular|4">The Shark Vertex Cordless Stick Vacuum is a whopping $150 off at Walmart</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Connecticut-jurist-remembered-for-dignity-honesty-17607007.php" title="Connecticut Superior Court judge remembered for dignity, honesty" data-hdn-analytics="visit|article-17607007|most_popular|5">Connecticut Superior Court judge remembered for dignity, honesty</a>
                                                    </li>
                                                                    <li class="mostPopular--list-item" role="heading" aria-level="3">
                            
                            <a class="mostPopular--list-title hdn-analytics" href="/news/article/Milford-native-uses-her-love-of-art-as-a-form-of-17604003.php" title="Milford native uses her love of art as therapy" data-hdn-analytics="visit|article-17604003|most_popular|6">Milford native uses her love of art as therapy</a>
                                                    </li>
                                    </ol>
                        </div>
<!--e hearst/home/mostPopular.tpl --></aside>
</aside>
<!-- e hearst/article/articleAside.tpl --><!-- hearst/article/articleFooter.tpl -->
<footer class="article--footer"><!-- hearst/common/author_body.tpl -->
     
        <div class="articleFooter">
                                <div class="articleFooter--author noImage">
                <div class="articleFooter--author-label">Written By </div>                    <div class="articleFooter--author-name"></div>
                </div>
                    </div>
<!-- e hearst/common/author_body.tpl --><section class="article--comments"><button id="commentsButton" data-link="https://www.milfordmirror.com/sports/articleComments/2022-Green-Bay-Packers-Roster-17615441.php" onclick="document.location.href = 'https://www.milfordmirror.com/sports/articleComments/2022-Green-Bay-Packers-Roster-17615441.php'; return false;">View Comments</button></section></footer>
<!-- e hearst/article/articleFooter.tpl --></section><section id="bottomZone" class="zone bottomZone lock">    
                        <!-- business/templates/design/item/default.tpl -->
    <!-- mid:freeform.85204 -->
    <div class="hst-freeform hdnce-e hdnce-item-85204">
                <script type="text/javascript" id="taboola-feed-script-id">
(function () {
    var c = 'taboola-below-article-thumbnails';
    var p = 'Below Article Thumbnails';
    try {
        if (window._taboolaNetworkMode) {
            var e = document.documentElement;
            var g = document.getElementsByTagName('body')[0];
            var w = window.innerWidth||e.clientWidth||g.clientWidth;
            if (w < 768) {
                c = 'taboola-mobile-below-article-feed---redesign';
                p = 'Mobile Below Article Feed - Redesign';
            } else {
                c = 'taboola-below-article-feed---redesign';
                p = 'Below Article Feed - Redesign';
            }
        }
    } catch (e) {}
    var d = document.createElement('div');
    d.id = c;
    var s = document.getElementById('taboola-feed-script-id');
    s.parentNode.insertBefore(d, s);
    window._taboola = window._taboola || [];
    window._taboola.push({
        mode: 'thumbnails-a',
        container: c,
        placement: p,
        target_type: 'mix'
    });
})();
</script>
    </div>
            <div class="taboola-skip-wrapper"><div id="taboola-skip"></div></div></section></main><!-- hearst/common/siteFooter.tpl -->
    <footer class="pageFooter">
    <div class="lock">
        <div class="pageFooter--wrapper">
            <div class="pageFooter--left">
                <a href="/">
                    <img class="pageFooter--left-logo" src="/img/logos/black/logo.svg" alt="Milford Mirror Homepage - Site Logo">
                </a>
                <ul class="pageFooter--left-social">
                    <li class="facebook"><a href="http://facebook.com/milfordmirror" aria-label="facebook"></a></li>                    <li class="twitter"><a href="http://twitter.com/milfordmirror" aria-label="twitter"></a></li>                                                        </ul>
            </div>
            <div class="pageFooter--right">
                <div class="pageFooter--right-topLine">
                    <a href="#content" class="return"><span class="full">Return to</span> Top</a>
                </div>
                <div class="pageFooter--right-links">
                    
                    <!-- hearst/item/standalone.tpl -->
<div class="hdnce-e hdnce-item-97493"><!-- mid:freeform.97493 -->
<style>
@media (min-width: 768px) {
  .pageFooter--right-links .wrapper > li:nth-child(2) {
    box-sizing: border-box;
    padding-left: 50px;
  }
}
</style>
<ul class="wrapper" role="presentation">
  <li>
<div class="title" role="heading" aria-level="2">About</div>
    <ul class="section" role="presentation">
      <li><a href="/home/article/How-Hearst-Newspapers-is-delivering-information-15678014.php">Newspaper Delivery Safety Procedures</a></li>
      <li><a href="/privacy/">Privacy Notice</a></li>
      <li><a href="/privacy/#additionalinformationforcaliforniaresidents">Your California Privacy Rights</a></li>
      <li><a href="/privacy/#interestbasedads">Interest Based Ads</a></li>
      <li><a href="/tos/">Terms of Use</a></li>
      <li><a href="https://eevd.fa.us6.oraclecloud.com/hcmUI/CandidateExperience/en/sites/CX_11004">Careers</a></li>
      <li><a href="https://hearstmediact.com/">Advertising</a></li>
    </ul>
  </li>
  <li>
<div class="title" role="heading" aria-level="2">Contact</div>
    <ul class="section" role="presentation">
      <li><a href="/contact/">Contact Us</a></li>
      <li><a href="/help/">FAQ's</a></li>
      <li><a href="https://subscription.hearstmediact.com/eEdition?siteID=CT_MM">E-Edition</a></li>
      <li><a href="/submissions/">Submissions</a></li>
    </ul>
  </li>
  <li>
<div class="title" role="heading" aria-level="2">Connect</div>
    <ul class="section" role="presentation">
      <li><a href="https://subscription.hearstmediact.com/checkout/700/1482?siteid=CT_MM&amp;origin=subserv&amp;ipid=footer">Subscribe Today</a></li>
      <li><a href="https://www.facebook.com/milfordmirror">Facebook</a></li>
      <li><a href="https://twitter.com/milfordmirror">Twitter</a></li>
    </ul>
  </li>
  <li>
</li>
</ul>
</div><!-- / hdnce-e -->                </div>
            </div>
        </div>
        <div class="pageFooter--branding">
            <img class="pageFooter--branding-logo" src="/img/core/hearst_newspapers_logo.svg" alt="HEARST newspapers logo" />
            <span class="pageFooter--branding-copyright">&copy;2022 Hearst</span>
        </div>
    </div>
                        <!-- hearst/common/spotImFooterJS.tpl -->
<script>
                                
        if ( document.readyState === "complete" || (document.readyState !== "loading" && !document.documentElement.doScroll)) {
            if (HDN && HDN.hasOwnProperty('spotim')) {
                HDN.spotim.commentCount(undefined,undefined,1);
            }
        } else {
            document.addEventListener("DOMContentLoaded", function() { 
                        if (HDN && HDN.hasOwnProperty('spotim')) {
                            HDN.spotim.commentCount(undefined,undefined,1);
                        }
                    });
        }
    
</script>
<!-- e hearst/common/spotImFooterJS.tpl -->
                            
                <script type="text/javascript">
                    window._taboola = window._taboola || [];
                    _taboola.push({flush: true});
                </script>
            
                    </footer>
<!-- e hearst/common/siteFooter.tpl -->
<!-- e hearst/article/types/dynamic_two_column.tpl --><!-- e design/article/dynamic_two_column.tpl -->                            </body>
</html>
<!-- e hearst/article/articleMain.tpl --><!-- e hearst/article/article_main.tpl -->