<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge" />
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Milford’s taxes will go down fourth year in a row &#8211; Milford Mirror</title>

<!-- This site is optimized with the Yoast SEO Premium plugin v2.3.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="The City of Milford’s taxes will go down slightly for the fourth year in a row, but while Democrats raved about that news, two Republican aldermen voted ag"/>
<link rel="canonical" href="https://www.milfordmirror.com/138632/milfords-taxes-will-go-down-fourth-year-in-a-row/" />
<link rel="publisher" href="https://plus.google.com/+MilfordMirror/po"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Milford’s taxes will go down fourth year in a row | Milford Mirror" />
<meta property="og:description" content="The City of Milford’s taxes will go down slightly for the fourth year in a row, but while Democrats raved about that news, two Republican aldermen voted ag" />
<meta property="og:url" content="https://www.milfordmirror.com/138632/milfords-taxes-will-go-down-fourth-year-in-a-row/" />
<meta property="og:site_name" content="Milford Mirror" />
<meta property="article:publisher" content="https://www.facebook.com/MilfordMirror" />
<meta property="article:tag" content="aldermen approve 2019-20 budget" />
<meta property="article:tag" content="City of Milford budget" />
<meta property="article:tag" content="Milford budget" />
<meta property="article:tag" content="what is Milford&#039;s tax rate" />
<meta property="article:section" content="Lead News" />
<meta property="article:published_time" content="2019-05-16T08:55:44+00:00" />
<meta property="article:modified_time" content="2019-05-16T09:09:05+00:00" />
<meta property="og:updated_time" content="2019-05-16T09:09:05+00:00" />
<meta property="og:image" content="https://www.milfordmirror.com/wp-content/uploads/sites/34/2017/10/city-hall.jpg" />
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:description" content="The City of Milford’s taxes will go down slightly for the fourth year in a row, but while Democrats raved about that news, two Republican aldermen voted ag"/>
<meta name="twitter:title" content="Milford’s taxes will go down fourth year in a row | Milford Mirror"/>
<meta name="twitter:site" content="@mifordmirror"/>
<meta name="twitter:domain" content="Milford Mirror"/>
<meta name="twitter:image:src" content="https://www.milfordmirror.com/wp-content/uploads/sites/34/2017/10/city-hall.jpg"/>
<meta name="twitter:creator" content="@mifordmirror"/>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//platform.linkedin.com' />
<link rel='dns-prefetch' href='//www.milfordmirror.com' />
<link rel='dns-prefetch' href='//ssl.p.jwpcdn.com' />
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//cdn.datatables.net' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Milford Mirror &raquo; Feed" href="https://www.milfordmirror.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Milford Mirror &raquo; Comments Feed" href="https://www.milfordmirror.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Milford Mirror &raquo; iCal Feed" href="https://www.milfordmirror.com/events/?ical=1" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.milfordmirror.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.10"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tfg_style-css'  href='https://www.milfordmirror.com/wp-content/plugins/twitter-facebook-google-plusone-share/tfg_style.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='generate-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans:300|Istok+Web:700' type='text/css' media='all' />
<link rel='stylesheet' id='cpsh-shortcodes-css'  href='https://www.milfordmirror.com/wp-content/plugins/column-shortcodes//assets/css/shortcodes.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='advpsStyleSheet-css'  href='https://www.milfordmirror.com/wp-content/plugins/advanced-post-slider/advps-style.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-datatables-css'  href='https://cdn.datatables.net/1.10.16/css/jquery.dataTables.min.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-buttons-css'  href='https://cdn.datatables.net/buttons/1.4.2/css/buttons.dataTables.min.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-select-css'  href='https://cdn.datatables.net/select/1.2.3/css/select.dataTables.min.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedheader-css'  href='https://cdn.datatables.net/fixedheader/3.1.3/css/fixedHeader.dataTables.min.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedcolumns-css'  href='https://cdn.datatables.net/fixedcolumns/3.2.3/css/fixedColumns.dataTables.min.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-responsive-css'  href='https://cdn.datatables.net/responsive/2.2.0/css/responsive.dataTables.min.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-grid-css'  href='https://www.milfordmirror.com/wp-content/themes/generatepress/css/unsemantic-grid.min.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-css'  href='https://www.milfordmirror.com/wp-content/themes/generatepress/style.min.css?ver=2.2.1' type='text/css' media='all' />
<style id='generate-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='generate-mobile-style-css'  href='https://www.milfordmirror.com/wp-content/themes/generatepress/css/mobile.min.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='generate-child-css'  href='https://www.milfordmirror.com/wp-content/themes/milford-generatepress/style.css?ver=1548771665' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=2.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='sailthru-subscribe-widget-styles-css'  href='https://www.milfordmirror.com/wp-content/plugins/sailthru-widget/css/widget.subscribe.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='generate-blog-css'  href='https://www.milfordmirror.com/wp-content/plugins/gp-premium/blog/functions/css/style-min.css?ver=1.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='generate-secondary-nav-css'  href='https://www.milfordmirror.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style.min.css?ver=1.5.6' type='text/css' media='all' />
<style id='generate-secondary-nav-inline-css' type='text/css'>
.secondary-navigation{background-color:#067299;}.secondary-navigation .main-nav ul li a,.secondary-navigation .menu-toggle{color:#ffffff;font-family:"Open Sans", sans-serif;font-size:12px;padding-left:18px;padding-right:18px;line-height:30px;}button.secondary-menu-toggle:hover,button.secondary-menu-toggle:focus{color:#ffffff;}.widget-area .secondary-navigation{margin-bottom:20px;}.secondary-navigation ul ul{background-color:#303030;top:auto;}.secondary-navigation .main-nav ul ul li a{color:#ffffff;font-size:11px;padding-left:18px;padding-right:18px;}.secondary-navigation .menu-item-has-children .dropdown-menu-toggle{padding-right:18px;}.secondary-navigation .main-nav ul li > a:hover,.secondary-navigation .main-nav ul li > a:focus,.secondary-navigation .main-nav ul li.sfHover > a{color:#ffffff;background-color:#303030;}.secondary-navigation .main-nav ul ul li > a:hover,.secondary-navigation .main-nav ul ul li > a:focus,.secondary-navigation .main-nav ul ul li.sfHover > a{color:#ffffff;background-color:#474747;}.secondary-navigation .main-nav ul li[class*="current-menu-"] > a, .secondary-navigation .main-nav ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul li[class*="current-menu-"].sfHover > a{color:#222222;background-color:#ffffff;}.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a,.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul ul li[class*="current-menu-"].sfHover > a{color:#ffffff;background-color:#474747;}
</style>
<link rel='stylesheet' id='generate-secondary-nav-mobile-css'  href='https://www.milfordmirror.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/mobile.min.css?ver=1.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='generate-sliiide-css'  href='https://www.milfordmirror.com/wp-content/plugins/gp-premium/menu-plus/functions/css/sliiide.min.css?ver=1.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='https://www.milfordmirror.com/wp-content/plugins/youtube-embed-plus-pro/styles/ytprefs.min.css?ver=4.9.10' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='__disptype__-css'  href='https://www.milfordmirror.com/wp-content/plugins/youtube-embed-plus-pro/scripts/lity.min.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='animate-css'  href='https://www.milfordmirror.com/wp-content/plugins/bbpowerpack/assets/css/animate.min.css?ver=3.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.milfordmirror.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>
/* <![CDATA[ */
var tribe_events_linked_posts = {"post_types":{"tribe_venue":"venue","tribe_organizer":"organizer"}};
var _EPYT_ = {"ajaxurl":"https:\/\/www.milfordmirror.com\/wp-admin\/admin-ajax.php","security":"dc2edb5dec","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.milfordmirror.com\/wp-content\/plugins\/youtube-embed-plus-pro\/scripts\/","epresponsiveselector":"[\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"11.8.4","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","stopMobileBuffer":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://ssl.p.jwpcdn.com/6/12/jwplayer.js?ver=4.9.10'></script>
<script type='text/javascript' src='//ak.sail-horizon.com/spm/spm.v1.min.js?ver=4.9.10'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tag = {"options":{"customerId":"e543352120f12dabe1cb022eaa5daf6f"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/sailthru-widget/js/tag.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/advanced-post-slider/js/advps.frnt.script.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/advanced-post-slider/bxslider/jquery.bxslider.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://cdn.datatables.net/1.10.16/js/jquery.dataTables.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://cdn.datatables.net/buttons/1.4.2/js/dataTables.buttons.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.4.2/js/buttons.colVis.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.4.2/js/buttons.print.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/pdfmake/0.1.32/pdfmake.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/pdfmake/0.1.32/vfs_fonts.js?ver=4.9.10'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/jszip/3.1.3/jszip.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.4.2/js/buttons.html5.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://cdn.datatables.net/select/1.2.3/js/dataTables.select.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://cdn.datatables.net/fixedheader/3.1.3/js/dataTables.fixedHeader.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://cdn.datatables.net/fixedcolumns/3.2.3/js/dataTables.fixedColumns.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://cdn.datatables.net/responsive/2.2.0/js/dataTables.responsive.min.js?ver=4.9.10'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var igsv_plugin_vars = {"lang_dir":"https:\/\/www.milfordmirror.com\/wp-content\/plugins\/inline-google-spreadsheet-viewer\/languages","datatables_classes":".igsv-table:not(.no-datatables)","datatables_defaults_object":{"dom":"B<'clear'>lfrtip","buttons":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-datatables.js?ver=4.9.10'></script>
<script type='text/javascript' src='//www.google.com/jsapi?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-gvizcharts.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/sailthru-widget/js/widget.subscribe.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/advanced-iframe/js/ai.js?ver=626026'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/youtube-embed-plus-pro/scripts/lity.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/youtube-embed-plus-pro/scripts/ytprefs.min.js?ver=4.9.10'></script>
<link rel='https://api.w.org/' href='https://www.milfordmirror.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.milfordmirror.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.milfordmirror.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.10" />
<link rel='shortlink' href='https://www.milfordmirror.com/?p=138632' />
<link rel="alternate" type="application/json+oembed" href="https://www.milfordmirror.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.milfordmirror.com%2F138632%2Fmilfords-taxes-will-go-down-fourth-year-in-a-row%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.milfordmirror.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.milfordmirror.com%2F138632%2Fmilfords-taxes-will-go-down-fourth-year-in-a-row%2F&#038;format=xml" />
<!-- Hearst analytics: Ensighten -->
<script type="text/javascript">
  (function(e) { 
    var t = '//nexus.ensighten.com/hearst/news/Bootstrap.js'; 
    if (e.cookie.indexOf("nsghtn") > -1) {
      if(e.cookie.indexOf("nsghtn=test-dev") > -1) {
      console.log("Ensighten :: Test-Dev"); t = "//nexus-test.ensighten.com/hearst/news-dev/Bootstrap.js";
      } else if(e.cookie.indexOf("nsghtn=test") > -1) {
      console.log("Ensighten :: Test"); t = "//nexus-test.ensighten.com/hearst/news/Bootstrap.js";
      } else if(e.cookie.indexOf("nsghtn=dev") > -1) {
      console.log("Ensighten :: Dev"); t = "//nexus.ensighten.com/hearst/news-dev/Bootstrap.js";
      } 
    }
    e.write("<scr"+"ipt src='"+e.location.protocol+t+"'></"+"scr"+"ipt>");
  })(document); 
</script>
<!-- End Hearst analytics: Ensighten --><script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script>

<!-- BEGIN Sailthru Horizon Meta Information -->
<meta name="sailthru.date" content="2019-05-16 08:55:44" />
<meta name="sailthru.title" content="Milford’s taxes will go down fourth year in a row" />
<meta name="sailthru.author" content="Jill Dion" />
<meta name="sailthru.description" content="The City of Milford’s taxes will go down slightly for the fourth year in a row, but while Democrats raved about that news, two Republican aldermen voted against the city’s 2019-20 budget, saying taxes could have gone down more. The city’s 2019-20 $216.55 million budget was adopted Wednesday night with a vote of 12 to 2, meaning that Milford’s tax ... &lt;a title=&quot;Milford’s taxes will go down fourth year in a row&quot; class=&quot;read-more&quot; href=&quot;https://www.milfordmirror.com/138632/milfords-taxes-will-go-down-fourth-year-in-a-row/&quot;&gt;read more&lt;/a&gt;" />
<meta name="sailthru.image.full" content="https://www.milfordmirror.com/wp-content/uploads/sites/34/2017/10/city-hall.jpg" />
<meta name="sailthru.image.thumb" content="https://www.milfordmirror.com/wp-content/uploads/sites/34/2017/10/city-hall.jpg" />
<!-- END Sailthru Horizon Meta Information -->



<!-- Facebook Like Thumbnail -->
<link rel="image_src" href="https://www.milfordmirror.com/wp-content/uploads/sites/34/2017/10/city-hall.jpg" />
<!-- End Facebook Like Thumbnail -->

		<style>
		form[class*="fl-builder-pp-"] .fl-lightbox-header h1:before {
			content: "PowerPack ";
			position: relative;
			display: inline-block;
			margin-right: 5px;
		}
		</style>
		<meta property="fb:app_id" content=""/><link rel="alternate" type="application/rss+xml" title="Milford Mirror GeoRSS-Feed" href="https://www.milfordmirror.com/wp-content/plugins/leaflet-maps-marker/leaflet-georss.php?layer=all" />
<style type='text/css' id='Responsive_Column_Widgets_1.2.7' >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</style>
<style type="text/css" id="style_custom_responsive_column_widgets_e74118aae87243085613c65b874dfb51">.responsive_column_widgets { display: inline-block; width: 100%; }</style>
<style type='text/css' class='style_responsive_column_widgets_e74118aae87243085613c65b874dfb51'>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</style><meta name="viewport" content="width=device-width, initial-scale=1"><script type="text/javascript">var sailthru_vars = {"ajaxurl":"https:\/\/www.milfordmirror.com\/wp-admin\/admin-ajax.php"}</script><a href="https://plus.google.com/+MilfordMirror" rel="publisher" />

 <script type="text/javascript" id="adPositionManagerScriptTag" src="https://aps.hearstnp.com/Scripts/loadAds.js"></script>		<style type="text/css" id="wp-custom-css">
			
.gdpr-preferences /* ,.gdpr-buttons */{display:none !important}


.gdpr-content a{color:#00ccff !important}

/* @media screen and (max-width: 840px) {
 .centermobile {
    margin: 0 auto;
    padding-bottom: 15px;
    padding-top: 15px;
    display: block;
    width: 50%;
}
} */

/*Sailthru stuff */

.sailthru-signup-widget{padding:15px 0; border-top:3px solid #008abc;border-bottom:1px solid #ccc;
}

.sailthru-signup-widget .checkbox label {
    display: block;
    margin-bottom: 10px;
    font-weight: 600;
}		</style>
	</head>

<body data-rsssl=1 class="post-template-default single single-post postid-138632 single-format-standard wp-custom-logo post-image-above-header post-image-aligned-center secondary-nav-above-header secondary-nav-aligned-center slideout-enabled slideout-mobile sticky-menu-fade tribe-bar-is-disabled right-sidebar nav-below-header fluid-header one-container active-footer-widgets-4 nav-search-enabled nav-aligned-center header-aligned-center dropdown-hover featured-image-active" itemtype="https://schema.org/Blog" itemscope>

	<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>		<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="secondary-navigation" class="secondary-navigation">
			<div class="inside-navigation grid-container grid-parent">
								<button class="menu-toggle secondary-menu-toggle">
										<span class="mobile-menu">Menu</span>
				</button>
				<div class="main-nav"><ul id="menu-top-menu" class=" secondary-menu sf-menu"><li id="menu-item-27092" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27092"><a href="https://milfordmirror.com/">Home</a></li>
<li id="menu-item-28378" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-28378"><a target="_blank" href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CMM">Subscribe<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-28381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28381"><a target="_blank" href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CMM">Delivery Problems</a></li>
</ul>
</li>
<li id="menu-item-138647" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-138647"><a href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CMM">MyAccount</a></li>
<li id="menu-item-28427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28427"><a target="_blank" href="http://milfordmirror.ct.newsmemory.com/">E-Edition</a></li>
<li id="menu-item-28379" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28379"><a target="_blank" href="http://milfordmirror.ct.newsmemory.com/marketplace.php">Today&#8217;s Print Ads</a></li>
<li id="menu-item-28380" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-28380"><a href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CMM">Print Edition<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-135592" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135592"><a href="https://hearstmediact.newsbank.com/home">Print Archives</a></li>
</ul>
</li>
<li id="menu-item-28382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28382"><a target="_blank" href="https://hearstmediact.com/">Advertise</a></li>
<li id="menu-item-28465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-28465"><a href="https://www.milfordmirror.com/help/">Help<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-28479" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28479"><a href="https://www.milfordmirror.com/about-us/">About Us</a></li>
	<li id="menu-item-28480" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28480"><a href="https://www.milfordmirror.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-135588" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135588"><a href="https://www.milfordmirror.com/privacy-notice/">Privacy Notice</a></li>
	<li id="menu-item-135587" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135587"><a href="https://www.milfordmirror.com/terms-of-use/">Terms of Use</a></li>
</ul>
</li>
<li id="menu-item-135435" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135435"><a href="mailto:legals@heartmediact.com">Submit Paid Legal Notice</a></li>
</ul></div>			</div><!-- .inside-navigation -->
		</nav><!-- #secondary-navigation -->
				<header id="masthead" class="site-header" itemtype="https://schema.org/WPHeader" itemscope>
			<div class="inside-header">
				<div class="site-logo">
				<a href="https://www.milfordmirror.com/" title="Milford Mirror" rel="home">
					<img  class="header-image" alt="Milford Mirror" src="https://www.milfordmirror.com/wp-content/uploads/sites/34/2019/01/milford_mirror_banner-FINAL-jk.png" title="Milford Mirror" srcset="https://www.milfordmirror.com/wp-content/uploads/sites/34/2019/01/milford_mirror_banner-FINAL-jk.png 1x, https://www.milfordmirror.com/wp-content/uploads/sites/34/2019/01/milford_mirror_banner-FINAL-jk.png 2x" width="400" height="85" />
				</a>
			</div>			</div><!-- .inside-header -->
		</header><!-- #masthead -->
				<nav id="site-navigation" class="main-navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope>
			<div class="inside-navigation">
				<form method="get" class="search-form navigation-search" action="https://www.milfordmirror.com/">
				<input type="search" class="search-field" value="" name="s" title="Search" />
			</form>		<div class="mobile-bar-items">
						<span class="search-item" title="Search">
				<a href="#">
					<span class="screen-reader-text">Search</span>
				</a>
			</span>
		</div><!-- .mobile-bar-items -->
						<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
										<span class="mobile-menu">Menu</span>
				</button>
				<div id="primary-menu" class="main-nav"><ul id="menu-navigation" class=" menu sf-menu"><li id="menu-item-28349" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-28349"><a href="https://www.milfordmirror.com/category/news/">News<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-28424" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-28424"><a href="https://www.milfordmirror.com/category/news/">Latest Milford News</a></li>
	<li id="menu-item-28351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28351"><a href="https://www.milfordmirror.com/category/news/police-fire/">Police &#038; Fire</a></li>
	<li id="menu-item-28356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28356"><a href="https://www.milfordmirror.com/category/news/schools/">Schools</a></li>
	<li id="menu-item-28705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28705"><a href="https://www.milfordmirror.com/category/news/business/">Business</a></li>
	<li id="menu-item-47495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47495"><a href="https://www.milfordmirror.com/category/news/community/">Community</a></li>
	<li id="menu-item-47497" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47497"><a href="https://www.milfordmirror.com/category/news/people/">People</a></li>
	<li id="menu-item-47496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47496"><a href="https://www.milfordmirror.com/category/news/entertainment/">Entertainment</a></li>
	<li id="menu-item-47498" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47498"><a href="https://www.milfordmirror.com/category/news/town-government/">Town Government</a></li>
	<li id="menu-item-47499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47499"><a href="https://www.milfordmirror.com/category/politics-elections/">Politics &#038; Elections</a></li>
	<li id="menu-item-63858" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63858"><a href="https://www.milfordmirror.com/category/news/regional/">Regional</a></li>
	<li id="menu-item-28230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28230"><a target="_blank" href="http://www.hersamacorn.com/print-archives/">Print Archives</a></li>
	<li id="menu-item-28467" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28467"><a href="https://www.milfordmirror.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-27177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-27177"><a href="https://www.milfordmirror.com/category/sports/">Sports<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-27073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27073"><a href="https://www.milfordmirror.com/category/sports/high-school-sports/">High School Sports</a></li>
	<li id="menu-item-27077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27077"><a href="https://www.milfordmirror.com/category/sports/sports-features/">Sports Features</a></li>
	<li id="menu-item-27078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27078"><a href="https://www.milfordmirror.com/category/sports/youth-sports/">Youth Sports</a></li>
	<li id="menu-item-27075" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27075"><a href="https://www.milfordmirror.com/category/sports/recreational-sports/">Recreational Sports</a></li>
	<li id="menu-item-27074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27074"><a href="https://www.milfordmirror.com/category/sports/other-sports/">Other Sports</a></li>
	<li id="menu-item-27151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27151"><a href="https://www.milfordmirror.com/submissions/">Submissions</a></li>
</ul>
</li>
<li id="menu-item-135586" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-135586"><a target="_blank" href="https://www.legacy.com/obituaries/milfordmirror/">Obituaries<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-135591" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135591"><a target="_blank" href="https://www.legacy.com/obituaries/milfordmirror/">Latest Obituaries</a></li>
	<li id="menu-item-135508" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-135508"><a href="https://www.milfordmirror.com/category/obituaries/">Obituaries Prior to 2019</a></li>
	<li id="menu-item-27098" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27098"><a target="_blank" href="https://hearstctads.com/connecticut-adportal/obits/">Submit an Obituary</a></li>
</ul>
</li>
<li id="menu-item-27068" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-27068"><a href="https://www.milfordmirror.com/category/opinion/">Opinion<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-27179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27179"><a href="https://www.milfordmirror.com/category/opinion/editorial/">Editorial</a></li>
	<li id="menu-item-27180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27180"><a href="https://www.milfordmirror.com/category/opinion/letters/">Letters</a></li>
	<li id="menu-item-27178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27178"><a href="https://www.milfordmirror.com/category/opinion/columns/">Columns</a></li>
	<li id="menu-item-46392" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46392"><a href="https://www.milfordmirror.com/category/al-columns/al-did-i-say-that/">DId I Say That?</a></li>
	<li id="menu-item-27161" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27161"><a href="https://www.milfordmirror.com/cartoon-gallery/">Cartoon Gallery</a></li>
</ul>
</li>
<li id="menu-item-27061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27061"><a href="https://www.milfordmirror.com/category/calendar/">Calendar</a></li>
<li id="menu-item-27062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27062"><a href="https://www.milfordmirror.com/category/news/community/">Community</a></li>
<li id="menu-item-46403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46403"><a href="https://www.milfordmirror.com/category/al-features/">Arts Features<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-136371" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136371"><a href="https://www.milfordmirror.com/category/al-features/qas/">Q&#038;As</a></li>
	<li id="menu-item-46389" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46389"><a href="https://www.milfordmirror.com/category/al-columns/">Columns<span role="presentation" class="dropdown-menu-toggle"></span></a>
	<ul class="sub-menu">
		<li id="menu-item-136368" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136368"><a href="https://www.milfordmirror.com/category/al-columns/binge-and-repeat-al-columns/">Binge and Repeat</a></li>
		<li id="menu-item-136378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136378"><a href="https://www.milfordmirror.com/category/al-columns/al-the-conscious-cook/">Conscious Cook</a></li>
		<li id="menu-item-46391" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46391"><a href="https://www.milfordmirror.com/category/al-columns/al-curtain-call/">Curtain Call</a></li>
		<li id="menu-item-136369" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136369"><a href="https://www.milfordmirror.com/category/al-columns/al-did-i-say-that/">DId I Say That?</a></li>
		<li id="menu-item-136370" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136370"><a href="https://www.milfordmirror.com/category/al-columns/kneads-cravings/">Kneads &#038; Cravings</a></li>
		<li id="menu-item-46401" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46401"><a href="https://www.milfordmirror.com/category/al-columns/al-tv-movie-menu/">Movie Menu</a></li>
		<li id="menu-item-46400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46400"><a href="https://www.milfordmirror.com/category/al-columns/al-the-reel-dad/">Reel Dad</a></li>
		<li id="menu-item-46398" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46398"><a href="https://www.milfordmirror.com/category/al-columns/al-taking-a-hike/">Taking a Hike</a></li>
		<li id="menu-item-46393" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46393"><a href="https://www.milfordmirror.com/category/al-columns/al-drive/">Test Drive</a></li>
	</ul>
</li>
	<li id="menu-item-136372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-136372"><a href="https://www.milfordmirror.com/category/al-listings/">Arts Listings<span role="presentation" class="dropdown-menu-toggle"></span></a>
	<ul class="sub-menu">
		<li id="menu-item-136373" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136373"><a href="https://www.milfordmirror.com/category/al-listings/bill-of-fairs/">Bill of Fairs</a></li>
		<li id="menu-item-136374" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136374"><a href="https://www.milfordmirror.com/category/al-listings/kids-stuff/">Kids Stuff</a></li>
		<li id="menu-item-136375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136375"><a href="https://www.milfordmirror.com/category/al-listings/lively-arts/">Lively Arts</a></li>
		<li id="menu-item-136376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136376"><a href="https://www.milfordmirror.com/category/al-listings/on-exhibit/">On Exhibit</a></li>
		<li id="menu-item-136377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136377"><a href="https://www.milfordmirror.com/category/al-listings/on-stage/">On Stage</a></li>
		<li id="menu-item-136380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136380"><a href="https://www.milfordmirror.com/category/al-listings/something-new/">Something New</a></li>
		<li id="menu-item-136381" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136381"><a href="https://www.milfordmirror.com/category/al-listings/sound-of-music/">Sound of Music</a></li>
		<li id="menu-item-136379" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136379"><a href="https://www.milfordmirror.com/category/al-upcoming-arts-leisure/">Weekend</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-28706" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28706"><a target="_blank" href="http://connecticut.ipublishmarketplace.com/connecticut-marketplace/">Classifieds</a></li>
<li id="menu-item-27091" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27091"><a target="_blank" href="https://thehomemonthly.com/">HOME Monthly</a></li>
<li class="search-item" title="Search"><a href="#"><span class="screen-reader-text">Search</span></a></li></ul></div>			</div><!-- .inside-navigation -->
		</nav><!-- #site-navigation -->
		
	<div id="page" class="hfeed site grid-container container grid-parent">
		<div id="content" class="site-content">
			
	<div id="primary" class="content-area grid-parent mobile-grid-100 grid-60 tablet-grid-60">
		<main id="main" class="site-main">
			
<article id="post-138632" class="post-138632 post type-post status-publish format-standard has-post-thumbnail hentry category-lead-news category-news tag-aldermen-approve-2019-20-budget tag-city-of-milford-budget tag-milford-budget tag-what-is-milfords-tax-rate no-featured-image-padding" itemtype='https://schema.org/CreativeWork' itemscope='itemscope'>
	<div class="inside-article">
		<div class="featured-image  page-header-image-single ">
			<img width="720" height="477" src="https://www.milfordmirror.com/wp-content/uploads/sites/34/2017/10/city-hall.jpg" class="attachment-960x600 size-960x600" alt="" itemprop="image" srcset="https://www.milfordmirror.com/wp-content/uploads/sites/34/2017/10/city-hall.jpg 720w, https://www.milfordmirror.com/wp-content/uploads/sites/34/2017/10/city-hall-300x199.jpg 300w" sizes="(max-width: 720px) 100vw, 720px" />
		</div>		
		<header class="entry-header">
										<h1 class="entry-title" itemprop="headline">Milford’s taxes will go down fourth year in a row</h1><h3 class="subtitle"></h3>
									<div class="entry-meta">
				<span class="posted-on"><a href="https://www.milfordmirror.com/138632/milfords-taxes-will-go-down-fourth-year-in-a-row/" title="8:55 am" rel="bookmark"><time class="updated" datetime="2019-05-16T09:09:05+00:00" itemprop="dateModified">May 16, 2019</time><time class="entry-date published" datetime="2019-05-16T08:55:44+00:00" itemprop="datePublished">May 16, 2019</time></a></span> <span class="byline"><span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope>by <a class="url fn n" href="https://www.milfordmirror.com/author/jdion/" title="View all posts by Jill Dion" rel="author" itemprop="url"><span class="author-name" itemprop="name">Jill Dion</span></a></span></span>			</div><!-- .entry-meta -->
				</header><!-- .entry-header -->
		
				<div class="entry-content" itemprop="text">
			<p class="p1">The City of Milford’s taxes will go down slightly for the fourth year in a row, but while Democrats raved about that news, two Republican aldermen voted against the city’s 2019-20 budget, saying taxes could have gone down more.</p>
<p class="p1">The city’s 2019-20 $216.55 million budget was adopted Wednesday night with a vote of 12 to 2, meaning that Milford’s tax rate will drop in 2019-20 by .03 mills, from the current 27.74 mills to 27.71 mills.</p>
<p class="p1">With that .11 percent tax reduction, residents with a typical home with a market value of $311,070 will see a tax cut of about $7.</p>
<p class="p1">“This is the fourth tax cut in a row, back to back to back,” Mayor Ben Blake said, calling it “historic and unprecedented.”</p>
<p class="p1">But Republican Aldermen Anthony Giannattasio and Ray Vitali disagreed with several new positions included in the budget, and the mayor upping his assistant’s salary by about $20,000, so they voted against the spending plan.</p>
<p class="p1">The salary for the mayor’s assistant goes from $70,328 to $91,147 in the 2019-20 budget, and that drew the most dissension from Republicans on the board.</p>
<p class="p1"><a href="https://www.milfordmirror.com/94060/former-alderman-tapped-as-mayors-assistant/">Justin Rosen</a> took over the position formerly held by Steve Fournier in January. But while Fournier was a mayoral assistant, Blake said Rosen was hired as his chief of staff, and the job has increased responsibilities than it had under Fournier.</p>
<p class="p1">The mayor said the job was largely handling constituent matters before, such as fielding calls from residents with complaints or concerns, and now the job is more focused on liaison work with departments and city boards and commissions.</p>
<p class="p1">Blake argued that the position as it is described now “demands a higher level of skill than we previously had in that position.”</p>
<p class="p1">Rosen, a former city alderman, previously worked for the Connecticut General Assembly as a legislative aide, clerk of the Banks Committee and policy analyst for a former Speaker of the House, and he worked for the American College of Surgeons as an advocate on the state level and a lobbyist on the federal level.</p>
<p class="p1">While Democrats agreed the job has been elevated and merits the higher pay, Giannattasio argued that the mayor implemented a spending freeze in recent months, and he said it’s not fair that departments have to hold the line on spending while the mayor ups the pay for this position.</p>
<p class="p1">“I think you have to lead by example,” Giannattasio said. “This is not Washington. We do not have chiefs of staff.”</p>
<p class="p1">Giannattasio called the job a “manufactured political position.”</p>
<p class="p1">The Republicans’ effort to lower the chief of staff pay failed, as did attempts to make cuts elsewhere, including a new human resources assistant, a new construction project manager in the public works department, and some funding in the street lighting account.</p>
<p class="p1">Giannattasio also had an issue with the mayor transferring $9 million from the city’s undesignated account to keep taxes from rising, which he said is $4 million more than was transferred last year. But the mayor said Milford has been ending its fiscal year with a healthy surplus, and that it’s right to return that to the taxpayers.</p>
<p class="p1">The aldermen didn’t squabble over the Board of Education budget, which in the past has been a point of contention. Republicans and Democrats quickly and unanimously approved the school board’s request of $95.08 million, which marks an increase of 1.89% over the current year’s budget.</p>
<p class="p1">The total budget plan adopted Wednesday night calls for spending $216.55 million, an increase of $6.36 million, or 3% over the current year’s $210.19 million. While costs increase, the mayor has said a very healthy grand list has helped keep taxes stable.</p>
<p class="p1">There were a number of technical changes to the budget Wednesday night, including to funds expected from the state. The mayor said anticipated revenue from the state is based on a “best guess,” since the state hasn’t adopted its budget yet.</p>
<div id="wpdevar_comment_2" style="width:100%;text-align:left;">
		<span style="padding: 10px;font-size:16px;font-family:Arial,Helvetica Neue,Helvetica,sans-serif;color:#000000;">Facebook Comments</span>
		<div class="fb-comments" data-href="https://www.milfordmirror.com/138632/milfords-taxes-will-go-down-fourth-year-in-a-row/" data-order-by="social" data-numposts="10" data-width="100%" style="display:block;"></div></div><style>#wpdevar_comment_2 span,#wpdevar_comment_2 iframe{width:100% !important;}</style>					</div><!-- .entry-content -->
		
					<footer class="entry-meta">
				<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.milfordmirror.com/category/lead-news/" rel="category tag">Lead News</a>, <a href="https://www.milfordmirror.com/category/news/" rel="category tag">News</a></span><span class="tags-links"><span class="screen-reader-text">Tags </span><a href="https://www.milfordmirror.com/tag/aldermen-approve-2019-20-budget/" rel="tag">aldermen approve 2019-20 budget</a>, <a href="https://www.milfordmirror.com/tag/city-of-milford-budget/" rel="tag">City of Milford budget</a>, <a href="https://www.milfordmirror.com/tag/milford-budget/" rel="tag">Milford budget</a>, <a href="https://www.milfordmirror.com/tag/what-is-milfords-tax-rate/" rel="tag">what is Milford's tax rate</a></span>		<nav id="nav-below" class="post-navigation">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.milfordmirror.com/138629/baseball-foran-gets-back-on-track-with-win-over-law/" rel="prev">Baseball: Foran gets back on track with win over Law</a></span></div><div class="nav-next"><span class="next" title="Next"><a href="https://www.milfordmirror.com/138555/art-of-being-a-girl-carriage-barn-exhibition-celebrates-the-essence-of-female-power/" rel="next">Art of Being a Girl: Carriage Barn exhibition celebrates the essence of female power</a></span></div>		</nav><!-- #nav-below -->
					</footer><!-- .entry-meta -->
					</div><!-- .inside-article -->
</article><!-- #post-## -->
		</main><!-- #main -->
	</div><!-- #primary -->

	<div id="right-sidebar" class="widget-area grid-40 tablet-grid-40 grid-parent sidebar" itemtype="https://schema.org/WPSidebar" itemscope>
	<div class="inside-right-sidebar">
		<aside id="custom_html-8" class="widget_text widget-odd widget-first widget-1 widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><div class="centermobile" style="padding-bottom:15px;padding-top:20px;">
<!-- Begin Hearst Ad -->
	<div id="A300">
		<script type="text/javascript">/*<![CDATA[*/hearstPlaceAd("A300");/*]]>*/</script>
	</div> 
<!-- End Hearst Ad -->
</div></div></aside><aside id="custom_html-9" class="widget_text widget-even widget-2 widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><div class="centermobile" style="padding-bottom:15px;padding-top:15px;">
<!-- Begin Hearst Ad -->
	<div id="B300">
		<script type="text/javascript">/*<![CDATA[*/hearstPlaceAd("B300");/*]]>*/</script>
	</div> 
<!-- End Hearst Ad -->
</div></div></aside><aside id="sailthru-subscribe-id-2" class="widget-odd widget-3 widget inner-padding Sailthru_Subscribe">	<div class="sailthru-signup-widget">
		<span class="sailthru-signup-widget-close"><a href="#sailthru-signup-widget">Close</a></span>
		<div class="sailthru_form">

			<h2 class="widget-title">Sign up for our Online Today email newsletter</h2>
			<div class="success" hidden="hidden">Thank you for subscribing!</div>

			<form method="post" action="#" class="sailthru-add-subscriber-form" id="sailthru-subscribe-id-2">

				<div class="sailthru-add-subscriber-errors"></div>

				<div class="sailthru_form_input form-group">
					<label class="sailthru-widget-label">Email</label>
					<input type="text" name="email" value="" class="form-control sailthru_email" />
				</div>

				<div class="sailthru_form_input form-group"><label for="custom_firstname">First Name</label><input  type="text" name="custom_firstname" id="sailthru_firstname_id"  class="form-control"/></div><div class="sailthru_form_input form-group"><label for="custom_lastname">Last Name</label><input  type="text" name="custom_lastname" id="sailthru_lastname_id"  class="form-control"/></div><div class="sailthru_form_input form-group"><div class="checkbox"><label for="custom_mailchimp_mm_notifications_you_would_like_to_receive">Select the notifications that you would like to receive:</label><input type="checkbox" name="custom_mailchimp_mm_notifications_you_would_like_to_receive[]" value="News Alerts"   > News Alerts<input type="checkbox" name="custom_mailchimp_mm_notifications_you_would_like_to_receive[]" value="Online Today"   > Online Today</div></div>				<input type="hidden" name="sailthru_nonce" value="e5f7f3f0fb" />
				<input type="hidden" name="sailthru_email_list" value="MM_Email_Master" />
				<input type="hidden" name="action" value="add_subscriber" />
				<input type="hidden" name="source" value="sidebar" />
				<input type="hidden" name="lo_event_name" value="wp_mm_signup" />

				<span class="input-group-btn">
					<button class="btn btn-reverse" type="submit">
						Submit
					</button>
				</span>
		</form>
	</div>
</div>
</aside><style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<aside id="rpwe_widget-3" class="widget-even widget-4 widget inner-padding rpwe_widget recent-posts-extended"><h2 class="widget-title">LATEST OPINION</h2><div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.milfordmirror.com/138424/man-camping-on-green-shows-complexity-of-homeless-situation/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.milfordmirror.com/wp-content/uploads/sites/34/2015/12/Letter-to-the-EditorNEW-90x35.jpg" alt="Man camping on green shows complexity of homeless situation"></a><h3 class="rpwe-title"><a href="https://www.milfordmirror.com/138424/man-camping-on-green-shows-complexity-of-homeless-situation/" title="Permalink to Man camping on green shows complexity of homeless situation" rel="bookmark">Man camping on green shows complexity of homeless situation</a></h3><time class="rpwe-time published" datetime="2019-05-10T12:43:35+00:00">May 10, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.milfordmirror.com/138240/walshs-wonderings-unsubscribing/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.milfordmirror.com/wp-content/uploads/sites/34/2016/09/Walshs-Wonderings-COLOR-new-90x35.jpg" alt="Walsh&#8217;s Wonderings — Unsubscribing"></a><h3 class="rpwe-title"><a href="https://www.milfordmirror.com/138240/walshs-wonderings-unsubscribing/" title="Permalink to Walsh&#8217;s Wonderings — Unsubscribing" rel="bookmark">Walsh&#8217;s Wonderings — Unsubscribing</a></h3><time class="rpwe-time published" datetime="2019-05-09T07:00:33+00:00">May 9, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.milfordmirror.com/138195/letter-voters-should-hold-candidates-accountable/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.milfordmirror.com/wp-content/uploads/sites/34/2015/12/Letter-to-the-EditorNEW-90x35.jpg" alt="LETTER: Voters should hold candidates accountable"></a><h3 class="rpwe-title"><a href="https://www.milfordmirror.com/138195/letter-voters-should-hold-candidates-accountable/" title="Permalink to LETTER: Voters should hold candidates accountable" rel="bookmark">LETTER: Voters should hold candidates accountable</a></h3><time class="rpwe-time published" datetime="2019-05-06T13:21:47+00:00">May 6, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.milfordmirror.com/137778/walshs-wonderings-lost-pleasures/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.milfordmirror.com/wp-content/uploads/sites/34/2016/09/Walshs-Wonderings-COLOR-new-90x35.jpg" alt="Walsh&#8217;s Wonderings — Lost pleasures"></a><h3 class="rpwe-title"><a href="https://www.milfordmirror.com/137778/walshs-wonderings-lost-pleasures/" title="Permalink to Walsh&#8217;s Wonderings — Lost pleasures" rel="bookmark">Walsh&#8217;s Wonderings — Lost pleasures</a></h3><time class="rpwe-time published" datetime="2019-04-25T07:00:21+00:00">April 25, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.milfordmirror.com/137568/letter-age-raised-to-purchase-tobacco-products/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.milfordmirror.com/wp-content/uploads/sites/34/2015/12/Letter-to-the-EditorNEW-90x35.jpg" alt="Letter — Age raised to purchase tobacco products"></a><h3 class="rpwe-title"><a href="https://www.milfordmirror.com/137568/letter-age-raised-to-purchase-tobacco-products/" title="Permalink to Letter — Age raised to purchase tobacco products" rel="bookmark">Letter — Age raised to purchase tobacco products</a></h3><time class="rpwe-time published" datetime="2019-04-16T10:00:50+00:00">April 16, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.milfordmirror.com/137293/walshs-wonderings-winter-bodies-in-summer-clothes/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.milfordmirror.com/wp-content/uploads/sites/34/2016/09/Walshs-Wonderings-COLOR-new-90x35.jpg" alt="Walsh&#8217;s Wonderings — Winter bodies in summer clothes"></a><h3 class="rpwe-title"><a href="https://www.milfordmirror.com/137293/walshs-wonderings-winter-bodies-in-summer-clothes/" title="Permalink to Walsh&#8217;s Wonderings — Winter bodies in summer clothes" rel="bookmark">Walsh&#8217;s Wonderings — Winter bodies in summer clothes</a></h3><time class="rpwe-time published" datetime="2019-04-11T07:01:38+00:00">April 11, 2019</time></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></aside><aside id="custom_html-10" class="widget_text widget-odd widget-5 widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><div class="centermobile" style="padding-bottom:15px;padding-top:15px;">
<!-- Begin Hearst Ad -->
	<div id="S300">
		<script type="text/javascript">/*<![CDATA[*/hearstPlaceAd("S300");/*]]>*/</script>
	</div>
<!-- End Hearst Ad -->
</div></div></aside><aside id="execphp-11" class="widget-even widget-6 widget inner-padding widget_execphp"><h2 class="widget-title">Latest Tweets</h2>			<div class="execphpwidget">            <a class="twitter-timeline"  href="https://twitter.com/Milfordmirror" data-widget-id="654694617955221504">Tweets by @Milfordmirror</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
          <br></div>
		</aside><aside id="text-4" class="widget-odd widget-last widget-7 widget inner-padding widget_text">			<div class="textwidget"><div class="centermobile" style="padding-bottom:0px;padding-top:0px;"><a href="http://feeds.feedburner.com/MilfordMirrorNews" target="_blank"><img class="alignleft size-full wp-image-24531" style="margin-right: 10px;" alt="news-rss" src="https://hersamacorn.com/img/news-rss.jpg" width="145" height="30" /></a>
</div>
<div class="centermobile" style="padding-bottom:0px;padding-top:0px;">
<a href="http://feeds.feedburner.com/MilfordMirrorSports" target="_blank"><img alt="sports-rss" src="https://hersamacorn.com/img/sports-rss.jpg" width="145" height="30" /></a>
</div></div>
		</aside>	</div><!-- .inside-right-sidebar -->
</div><!-- #secondary -->

	</div><!-- #content -->
</div><!-- #page -->


<div class="site-footer">
				<div id="footer-widgets" class="site footer-widgets">
				<div class="footer-widgets-container grid-container grid-parent">
					<div class="inside-footer-widgets">
							<div class="footer-widget-1 grid-parent grid-25 tablet-grid-50 mobile-grid-100">
		<aside id="text-6" class="widget-odd widget-last widget-first widget-1 widget inner-padding widget_text">			<div class="textwidget"><p><a href="https://milfordmirror.com"><img src="https://www.milfordmirror.com/wp-content/uploads/sites/34/2019/01/mm-f-150x150.png" alt="Milford Mirrror" width="150" height="150" class="alignleft size-thumbnail wp-image-135512" /></a></p>
</div>
		</aside>	</div>
		<div class="footer-widget-2 grid-parent grid-25 tablet-grid-50 mobile-grid-100">
		<aside id="custom_html-3" class="widget_text widget-odd widget-last widget-first widget-1 widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><ul>
 	<li><a href="https://www.darientimes.com" target="_blank" rel="noreferrer noopener">Darien Times</a></li>
 	<li><a href="https://www.milfordmirror.com" target="_blank" rel="noreferrer noopener">Milford Mirror</a></li>
 	<li><a href="https://www.ncadvertiser.com" target="_blank" rel="noreferrer noopener">New Canaan Advertiser</a></li>
 	<li><a href="https://www.theridgefieldpress.com" target="_blank" rel="noreferrer noopener">Ridgefield Press</a></li>
 	<li><a href="https://www.sheltonherald.com" target="_blank" rel="noreferrer noopener">Shelton Herald</a></li>
 	<li><a href="http://www.trumbulltimes.com" target="_blank" rel="noreferrer noopener">Trumbull Times </a></li>
 	<li><a href="http://www.wiltonbulletin.com" target="_blank" rel="noreferrer noopener">Wilton Bulletin </a></li>
</ul></div></aside>	</div>
		<div class="footer-widget-3 grid-parent grid-25 tablet-grid-50 mobile-grid-100">
		<aside id="custom_html-4" class="widget_text widget-odd widget-last widget-first widget-1 widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><ul>
	<li><a href="https://hearstmediact.com/" target="_blank" rel="noreferrer noopener">Advertise</a></li>
	<li><a href="http://connecticut.ipublishmarketplace.com/connecticut-marketplace/#_ga=2.56015723.1136683387.1547164258-1114500202.1525449009" target="_blank" rel="noreferrer noopener">Classifieds</a></li>
		<li> <span style="font-size:11px">For Article Re-Prints Call 203-333-6688</span></li>	
	<li><a href="https://hrstiservices.dticloud.com/hrst-est-cmdb1_cmo/subscriber/web/signin.html?siteId=CMM" target="_blank" rel="noreferrer noopener">Subscriptions</a></li>
</ul></div></aside>	</div>
		<div class="footer-widget-4 grid-parent grid-25 tablet-grid-50 mobile-grid-100">
		<aside id="custom_html-5" class="widget_text widget-odd widget-last widget-first widget-1 widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><ul>
	<li><a href="http://twitter.com/milfordmirror" target="_blank" rel="noreferrer noopener">Follow Us on Twitter</a></li>
	<li><a href="http://facebook.com/milfordmirror">Like Us on Facebook</a></li>
	<li><a href="https://www.milfordmirror.com/contact-us/">Contact The Milford Mirror</a></li>
	<li><a href="https://milfordmirror.com/submit/">Submissions</a></li>
	<li><a href="mailto:legals@hearstmediact.com" target="_blank" rel="noopener">Submit Legal Notice</a></li>
	<li><a href="https://www.milfordmirror.com/privacy-notice">Privacy Notice</a></li>
<li><a href="https://www.milfordmirror.com/privacy-notice/#interestbasedads">Interest Based Ads</a></li>
<li><a href="https://www.milfordmirror.com/terms-of-use/">Terms of Use</a></li>
<li><a href="https://www.milfordmirror.com/privacy-notice/#additionalinformationforcaliforniaresidents">Your California Privacy Rights</a></li>
</ul></div></aside>	</div>
						</div>
				</div>
			</div>
				<footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope>
			<div class="inside-site-info grid-container grid-parent">
								<div class="copyright-bar">
					&copy; Copyright 2019 Hearst Media Services Connecticut, LLC				</div>
			</div>
		</footer><!-- .site-info -->
		</div><!-- .site-footer -->

	<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="generate-slideout-menu" class="main-navigation slideout-navigation">
		<div class="inside-navigation grid-container grid-parent">
			<div class="main-nav"><ul id="menu-navigation-1" class=" slideout-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-28349"><a href="https://www.milfordmirror.com/category/news/">News<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-28424"><a href="https://www.milfordmirror.com/category/news/">Latest Milford News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28351"><a href="https://www.milfordmirror.com/category/news/police-fire/">Police &#038; Fire</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28356"><a href="https://www.milfordmirror.com/category/news/schools/">Schools</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28705"><a href="https://www.milfordmirror.com/category/news/business/">Business</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47495"><a href="https://www.milfordmirror.com/category/news/community/">Community</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47497"><a href="https://www.milfordmirror.com/category/news/people/">People</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47496"><a href="https://www.milfordmirror.com/category/news/entertainment/">Entertainment</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47498"><a href="https://www.milfordmirror.com/category/news/town-government/">Town Government</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47499"><a href="https://www.milfordmirror.com/category/politics-elections/">Politics &#038; Elections</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63858"><a href="https://www.milfordmirror.com/category/news/regional/">Regional</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28230"><a target="_blank" href="http://www.hersamacorn.com/print-archives/">Print Archives</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28467"><a href="https://www.milfordmirror.com/submissions/">Submissions</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-27177"><a href="https://www.milfordmirror.com/category/sports/">Sports<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27073"><a href="https://www.milfordmirror.com/category/sports/high-school-sports/">High School Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27077"><a href="https://www.milfordmirror.com/category/sports/sports-features/">Sports Features</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27078"><a href="https://www.milfordmirror.com/category/sports/youth-sports/">Youth Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27075"><a href="https://www.milfordmirror.com/category/sports/recreational-sports/">Recreational Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27074"><a href="https://www.milfordmirror.com/category/sports/other-sports/">Other Sports</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27151"><a href="https://www.milfordmirror.com/submissions/">Submissions</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-135586"><a target="_blank" href="https://www.legacy.com/obituaries/milfordmirror/">Obituaries<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-135591"><a target="_blank" href="https://www.legacy.com/obituaries/milfordmirror/">Latest Obituaries</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-135508"><a href="https://www.milfordmirror.com/category/obituaries/">Obituaries Prior to 2019</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27098"><a target="_blank" href="https://hearstctads.com/connecticut-adportal/obits/">Submit an Obituary</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-27068"><a href="https://www.milfordmirror.com/category/opinion/">Opinion<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27179"><a href="https://www.milfordmirror.com/category/opinion/editorial/">Editorial</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27180"><a href="https://www.milfordmirror.com/category/opinion/letters/">Letters</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27178"><a href="https://www.milfordmirror.com/category/opinion/columns/">Columns</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46392"><a href="https://www.milfordmirror.com/category/al-columns/al-did-i-say-that/">DId I Say That?</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27161"><a href="https://www.milfordmirror.com/cartoon-gallery/">Cartoon Gallery</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27061"><a href="https://www.milfordmirror.com/category/calendar/">Calendar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27062"><a href="https://www.milfordmirror.com/category/news/community/">Community</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46403"><a href="https://www.milfordmirror.com/category/al-features/">Arts Features<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136371"><a href="https://www.milfordmirror.com/category/al-features/qas/">Q&#038;As</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46389"><a href="https://www.milfordmirror.com/category/al-columns/">Columns<span role="presentation" class="dropdown-menu-toggle"></span></a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136368"><a href="https://www.milfordmirror.com/category/al-columns/binge-and-repeat-al-columns/">Binge and Repeat</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136378"><a href="https://www.milfordmirror.com/category/al-columns/al-the-conscious-cook/">Conscious Cook</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46391"><a href="https://www.milfordmirror.com/category/al-columns/al-curtain-call/">Curtain Call</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136369"><a href="https://www.milfordmirror.com/category/al-columns/al-did-i-say-that/">DId I Say That?</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136370"><a href="https://www.milfordmirror.com/category/al-columns/kneads-cravings/">Kneads &#038; Cravings</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46401"><a href="https://www.milfordmirror.com/category/al-columns/al-tv-movie-menu/">Movie Menu</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46400"><a href="https://www.milfordmirror.com/category/al-columns/al-the-reel-dad/">Reel Dad</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46398"><a href="https://www.milfordmirror.com/category/al-columns/al-taking-a-hike/">Taking a Hike</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46393"><a href="https://www.milfordmirror.com/category/al-columns/al-drive/">Test Drive</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-136372"><a href="https://www.milfordmirror.com/category/al-listings/">Arts Listings<span role="presentation" class="dropdown-menu-toggle"></span></a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136373"><a href="https://www.milfordmirror.com/category/al-listings/bill-of-fairs/">Bill of Fairs</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136374"><a href="https://www.milfordmirror.com/category/al-listings/kids-stuff/">Kids Stuff</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136375"><a href="https://www.milfordmirror.com/category/al-listings/lively-arts/">Lively Arts</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136376"><a href="https://www.milfordmirror.com/category/al-listings/on-exhibit/">On Exhibit</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136377"><a href="https://www.milfordmirror.com/category/al-listings/on-stage/">On Stage</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136380"><a href="https://www.milfordmirror.com/category/al-listings/something-new/">Something New</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136381"><a href="https://www.milfordmirror.com/category/al-listings/sound-of-music/">Sound of Music</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136379"><a href="https://www.milfordmirror.com/category/al-upcoming-arts-leisure/">Weekend</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28706"><a target="_blank" href="http://connecticut.ipublishmarketplace.com/connecticut-marketplace/">Classifieds</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27091"><a target="_blank" href="https://thehomemonthly.com/">HOME Monthly</a></li>
</ul></div>					</div><!-- .inside-navigation -->
	</nav><!-- #site-navigation -->
	<div class="slideout-overlay" style="display: none;"></div>
	<script type="text/javascript">if(window.aiModifyParent) {aiModifyParent();}</script>        <div id="fb-root"></div>
        <script>(function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) return;
          js = d.createElement(s); js.id = id;
          js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=&version=v2.3";
          fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script>	
    <style>.fa{font-family: FontAwesome !important;}</style><link rel='stylesheet' id='dashicons-css'  href='https://www.milfordmirror.com/wp-includes/css/dashicons.min.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.milfordmirror.com/wp-includes/js/thickbox/thickbox.css?ver=4.9.10' type='text/css' media='all' />
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://platform.linkedin.com/in.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sliiide.min.js?ver=1.5.6'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201920'></script>
<!--[if lte IE 11]>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/themes/generatepress/js/classList.min.js?ver=2.2.1'></script>
<![endif]-->
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/themes/generatepress/js/menu.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/themes/generatepress/js/a11y.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/themes/generatepress/js/navigation-search.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-content/plugins/youtube-embed-plus-pro/scripts/fitvids.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-includes/js/wp-embed.min.js?ver=4.9.10'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.milfordmirror.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.milfordmirror.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>

</body>
</html>
